On 06/02/17 17:45, Laszlo Ersek wrote:
> The patches can cause linker/loader breakage when old firmware is booted
> on new QEMU. However, that's no problem (it's nothing new), the next
> release of QEMU should bundle the new firmware binaries as always.
Dave made a good point (which I should have
Xtensa cores may have registers of types/sizes not supported by the
gdbstub accessors. Ignore writes to such registers and return zero on
read, but always return correct register size, so that gdb on the other
side is able to access all registers in the packet holding unsupported
registers in the m
On 02.06.2017 23:58, Laszlo Ersek wrote:
> On 06/02/17 16:35, Peter Maydell wrote:
>> We want the wide character functions from the ncurses header.
>> Unfortunately it doesn't provide them by default, but only
>> if either:
>> * NCURSES_WIDECHAR is defined (for ncurses 20111030 and up)
>> * _XOPE
On 2017-06-02 16:35, Peter Maydell wrote:
> diff --git a/configure b/configure
> index 0586ec9..6aca5d1 100755
> --- a/configure
> +++ b/configure
> @@ -3053,6 +3053,8 @@ int main(void) {
> EOF
>IFS=:
>for curses_inc in $curses_inc_list; do
> +# Make sure we get the wide character prot
On 03.06.2017 12:13, Rainer Müller wrote:
> On 2017-06-02 16:35, Peter Maydell wrote:
>> diff --git a/configure b/configure
>> index 0586ec9..6aca5d1 100755
>> --- a/configure
>> +++ b/configure
>> @@ -3053,6 +3053,8 @@ int main(void) {
>> EOF
>>IFS=:
>>for curses_inc in $curses_inc_list;
On Thu, Jun 1, 2017 at 7:27 PM, Fam Zheng wrote:
> On Sat, 04/22 10:43, Ashijeet Acharya wrote:
>> Introduce two new helper functions handle_alloc() and
>> vmdk_alloc_cluster_offset(). handle_alloc() helps to allocate multiple
>> clusters at once starting from a given offset on disk and performs C
On 05/22/17 16:23, Laszlo Ersek wrote:
> Keeping some context:
>
> On 05/12/17 23:00, Laszlo Ersek wrote:
>> On 04/30/17 07:35, Dongjiu Geng wrote:
> (68) In the code below, you are not taking an "OVMF header probe
> suppressor" into account.
>
> But, we have already planned to replace that quir
On Thu, Jun 01, 2017 at 08:51:58AM +0100, Felipe Franciosi wrote:
> This makes VMs bootable on spapr when using vhost-*-scsi.
This commit message needs more information: what previously prevented
vhost-*-scsi from working?
> Signed-off-by: Felipe Franciosi
> Signed-off-by: Mike Cui
> ---
> hw/
On 06/02/2017 07:20 PM, Laszlo Ersek wrote:
On 06/02/17 18:30, Michael S. Tsirkin wrote:
On Fri, Jun 02, 2017 at 05:45:21PM +0200, Laszlo Ersek wrote:
Hi,
this message is cross-posted to three lists (qemu, seabios, edk2). I'll
follow up with three patch series, one series for each project. I'l
On 06/03/17 11:43, Kamil Rytarowski wrote:
> On 02.06.2017 23:58, Laszlo Ersek wrote:
>> On 06/02/17 16:35, Peter Maydell wrote:
>>> We want the wide character functions from the ncurses header.
>>> Unfortunately it doesn't provide them by default, but only
>>> if either:
>>> * NCURSES_WIDECHAR is
On 03.06.2017 01:17, John Snow wrote:
On 06/02/2017 07:21 AM, Vladimir Sementsov-Ogievskiy wrote:
Add format driver handler, which should mark loaded read-only
bitmaps as 'IN_USE' in the image and unset read_only field in
corresponding BdrvDirtyBitmap's.
Signed-off-by: Vladimir Sementsov-Ogi
On 02.06.2017 21:46, John Snow wrote:
On 06/02/2017 05:45 AM, Vladimir Sementsov-Ogievskiy wrote:
02.06.2017 12:01, Vladimir Sementsov-Ogievskiy wrote:
02.06.2017 11:56, Vladimir Sementsov-Ogievskiy wrote:
02.06.2017 02:25, John Snow wrote:
On 06/01/2017 03:30 AM, Sementsov-Ogievskiy Vladi
On 03.06.2017 00:02, John Snow wrote:
On 06/02/2017 07:21 AM, Vladimir Sementsov-Ogievskiy wrote:
It will be needed in following commits for persistent bitmaps.
If bitmap is loaded from read-only storage (and we can't mark it
"in use" in this storage) corresponding BdrvDirtyBitmap should be
r
On 05/30/2017 09:30 AM, Vladimir Sementsov-Ogievskiy wrote:
> Move to modern errp scheme from just LOGging errors.
>
> Signed-off-by: Vladimir Sementsov-Ogievskiy
> ---
> nbd/server.c | 257
> ++-
> 1 file changed, 150 insertions(+), 107 d
On 05/30/2017 09:30 AM, Vladimir Sementsov-Ogievskiy wrote:
> Signed-off-by: Vladimir Sementsov-Ogievskiy
> ---
> nbd/server.c | 17 +
> 1 file changed, 9 insertions(+), 8 deletions(-)
>
>
> -if (nbd_co_send_reply(req, &reply, reply_data_len) < 0) {
> -error_setg(&
On 05/30/2017 09:30 AM, Vladimir Sementsov-Ogievskiy wrote:
> Use error_reportf_err instead of TRACE in case of fail.
>
> Signed-off-by: Vladimir Sementsov-Ogievskiy
> ---
> nbd/common.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/nbd/common.c b/nbd/common.c
> index
Quoting David Gibson (2017-06-02 02:29:50)
> Currently the sPAPRMachineState contains a of sPAPRConfigureConnector
"contains a list"?
> structures which store intermediate state for the ibm,configure-connector
> RTAS call.
>
> This was an attempt to separate this state from the core of the DRC s
Quoting David Gibson (2017-06-02 02:29:52)
> * 'connector_type' is easily derived from the 'index' property, so there's
>no point to it (it's also implicit in the QOM type of the DRC)
> * 'isolation-state', 'indicator-state' and 'allocation-state' are
>part of the transaction between qemu
Quoting David Gibson (2017-06-02 02:29:51)
> This function was used in generating the device tree. However, now that
> we have different QOM types for different DRC types we can easily store
> the information we need in the class structure and avoid this specialized
> lookup function.
>
> Signed-
Quoting David Gibson (2017-06-02 02:29:49)
> * Change names to something less ludicrously verbose
> * Now that we have QOM subclasses for the different DRC types, use a QOM
>typename instead of a PAPR type value parameter
>
> The latter allows removal of the get_type_shift() helper.
>
> Sig
Quoting David Gibson (2017-06-02 02:29:48)
> Currently we only have a single QOM type for all DRCs, but lots of
> places where we switch behaviour based on the DRC's PAPR defined type.
> This is a poor use of our existing type system.
>
> So, instead create QOM subclasses for each PAPR defined DRC
hmp_object_del() followed by a subsequent hmp_object_add() can trigger a
duplicate ID error if the previous object shared the same ID and was added
via the command-line. Please see patch 2/2 for more details.
This patchset fixes the issue in question and adds some general unit tests
for object cre
check-qom-proplist originally added tests for verifying that
object-creation helpers object_new_with_{props,propv} behaved in
similar fashion to the "traditional" method involving setting each
individual property separately after object creation rather than
via a single call.
Another similar "help
Currently objects specified on the command-line are only partially
cleaned up when 'object_del' is issued in either HMP or QMP: the
object itself is fully finalized, but the QemuOpts are not removed.
This results in the following behavior:
x86_64-softmmu/qemu-system-x86_64 -monitor stdio \
-
Quoting Markus Armbruster (2017-05-31 12:05:16)
> Markus Armbruster writes:
>
> > "Dr. David Alan Gilbert" writes:
> >
> >> I notice this pair of patches doesn't seem to have gone anywhere.
> >> WHile it's labelled as a monitor fix, it's all QOM stuff, so I don't
> >> think it should be going vi
25 matches
Mail list logo