This Patch provides the glue for the TPM_TIS(Qemu frontend) to Xen
stubdom vTPM domain that provides the actual TPM functionality. It
sends data and TPM commends with xen_vtpm_frontend. It is similar as
another two vTPM backens:
*vTPM passthrough backen Since QEMU 1.5.
*vTPM libtpms-based backe
Signed-off-by: Quan Xu
Reviewed-by: Eric Blake
---
configure| 14 ++
hmp.c| 2 ++
qapi-schema.json | 16 ++--
qemu-options.hx | 13 +++--
tpm.c| 7 ++-
5 files changed, 47 insertions(+), 5 deletions(-)
diff --git a/configure
This drvier transfers any request/repond between TPM xenstubdoms
driver and Xen vTPM stubdom, and facilitates communications between
Xen vTPM stubdom domain and vTPM xenstubdoms driver. It is a glue for
the TPM xenstubdoms driver and Xen stubdom vTPM domain that provides
the actual TPM functionalit
*INTRODUCTION*
The goal of virtual Trusted Platform Module (vTPM) is to provide a TPM
functionality to virtual machines (Fedora, Ubuntu, Redhat, Windows .etc). This
allows programs to interact with a TPM in a virtual machine the same way they
interact with a TPM on the physical system. Each virt
and rename it to tpm_util_is_selftest().
Signed-off-by: Quan Xu
Reviewed-by: Stefan Berger
---
hw/tpm/Makefile.objs | 2 +-
hw/tpm/tpm_passthrough.c | 13 +
hw/tpm/tpm_util.c| 39 +++
include/sysemu/tpm_backend
This patch adds infrastructure for xen front drivers living in qemu,
so drivers don't need to implement common stuff on their own. It's
mostly xenbus management stuff: some functions to access XenStore,
setting up XenStore watches, callbacks on device discovery and state
changes, and handle event
make sure QEMU machine class is initialized and QEMU has registered
Xen stubdom vTPM driver when call tpm_init()
Signed-off-by: Quan Xu
Reviewed-by: Stefan Berger
---
vl.c | 17 +++--
1 file changed, 11 insertions(+), 6 deletions(-)
diff --git a/vl.c b/vl.c
index 74c2681..7bc87f1 1
*INTRODUCTION*
The goal of virtual Trusted Platform Module (vTPM) is to provide a TPM
functionality to virtual machines (Fedora, Ubuntu, Redhat, Windows .etc). This
allows programs to interact with a TPM in a virtual machine the same way they
interact with a TPM on the physical system. Each virt
for some common part of xen frontend and backend, such as xendevs
queue and xenstore update functions.
Signed-off-by: Quan Xu
---
hw/display/xenfb.c | 4 +-
hw/xen/Makefile.objs | 2 +-
hw/xen/xen_backend.c | 353 ---
hw/xen/xen_pvdev.c
Am 17.05.2015 um 07:16 schrieb Peter Crosthwaite:
> There is no reason for device tree API to be built per-target.
> common-obj it. There is an extraneous inclusion of config.h that
> needs to be removed.
>
> Signed-off-by: Peter Crosthwaite
> ---
> Makefile.objs | 2 ++
> Makefile.target | 1
On Fri, May 15, 2015 at 9:15 PM, Andreas Färber wrote:
> Am 15.05.2015 um 08:36 schrieb Alistair Francis:
>> On Fri, May 15, 2015 at 4:32 PM, Peter Crosthwaite
>> wrote:
>>> On Thu, May 14, 2015 at 10:56 PM, Alistair Francis
>>> wrote:
On Fri, May 15, 2015 at 3:52 PM, Peter Crosthwaite
Public bug reported:
All of my vms are started with a simple script on the command line.
Starting with Qemu 2.3.0, the option "-vnc host:port,websocket" is no longer
working.
Previously if I said listen on Tor:17,websocket it would function
correctly. Now it's kicking an error:
qemu-system-
Someone has had a similar issue with the port portion of the display as
a string and not an integer (so it's looking in /etc/services etc):
http://stackoverflow.com/questions/23079017/servname-not-supported-for-
ai-socktype
--
You received this bug notification because you are a member of qemu-
I have more information about the bug. The host I'm running this on is
called "tor' (no, it has nothing to do with an onion router, its an old
nickname and something I've been calling my main dev host for years).
Its IP is 10.16.0.5. If I designate the command line option as "-vnc
tor:11,websock
Am 17.05.2015 um 14:26 schrieb Alistair Francis:
> On Fri, May 15, 2015 at 9:15 PM, Andreas Färber wrote:
>> Am 15.05.2015 um 08:36 schrieb Alistair Francis:
>>> On Fri, May 15, 2015 at 4:32 PM, Peter Crosthwaite
>>> wrote:
On Thu, May 14, 2015 at 10:56 PM, Alistair Francis
wrote:
Subject: [PATCH] keyboard: handle ps2 typing buffer overrun
Starting a linux guest with ps2 keyboard, if you type many times during leaving
grub and into linux kernel,then you can't use keyboard after linux
initialization finished.
Specally when you setup linux guest from iso file,you will type in
The monitor currently has one helper, mon_get_cpu() which will return
an env pointer. The target specific users of this API want an env, but
all the target agnostic users really just want the cpu pointer. These
users then need to use the target-specifically defined ENV_GET_CPU to
navigate back up t
Neither the monitor or disassembly core has a good reason to navigate from an
env pointer to a cpu pointer. Disas should not need env awarness at all, that
is removed in P2.
The monitor is trickier, the env is still needed by some #ifdef switched target
specific code but all common code only needs
disas does not need to access the CPU env for any reason. Change the
APIs to accept CPU pointers instead. Small change pattern needs to be
applied to all target translate.c. This brings us closer to making
disas.o a common-obj and less architecture specific in general.
Cc: Richard Henderson
Cc: P
On May 16, 2015, at 5:45 PM, Peter Maydell wrote:
> On 11 May 2015 at 16:18, Programmingkid wrote:
>> Adds any console that is available to the current emulator as a menu item
>> under the View menu.
>>
>> Signed-off-by: John Arbuckle
>
> Thanks; I think this version looks pretty good. A min
Add Machine menu to the Macintosh interface with pause
and resume menu items. These items can either pause or
resume execution of the guest operating system.
Signed-off-by: John Arbuckle
---
Remove createMachineMenu() function.
Minor space issues fixed.
Patch created on top of cocoa.next branch.
Add "Reset" and "Power Down" menu items to Machine menu.
Signed-off-by: John Arbuckle
---
Changed text "Qemu" to "QEMU".
Moved menu insertion code into main() function.
Changed powerDown menu item's name to powerDownQEMU.
Replaced qemu_system_reset_request() with qmp_system_reset(NULL).
ui/coc
On 17 May 2015 at 21:09, Programmingkid wrote:
> You know how there's a "Zoom To Fit" menu item. What if we added a
> mutually exclusive menu item called "Resize To Fit"? This menu item
> would instead adjust the host screen's resolution to match that of the
> guest screen's resolution. It can be
On May 17, 2015, at 5:37 PM, Peter Maydell wrote:
> On 17 May 2015 at 21:09, Programmingkid wrote:
>> You know how there's a "Zoom To Fit" menu item. What if we added a
>> mutually exclusive menu item called "Resize To Fit"? This menu item
>> would instead adjust the host screen's resolution to
On 17 May 2015 at 22:55, Programmingkid wrote:
> I think SDL solved this problem some how. I was using a fullscreen program
> that used
> SDL and it managed to change the resolution without messing up all the
> windows. So
> I think there is a way to solve this problem. Maybe someone out there m
Do we only support user interfaces in the english language, or are multiple
languages supported?
On Mon, May 18, 2015 at 1:12 AM, Andreas Färber wrote:
> Am 17.05.2015 um 14:26 schrieb Alistair Francis:
>> On Fri, May 15, 2015 at 9:15 PM, Andreas Färber wrote:
>>> Am 15.05.2015 um 08:36 schrieb Alistair Francis:
On Fri, May 15, 2015 at 4:32 PM, Peter Crosthwaite
wrote:
> On Th
Firstly this patch series tidies up some code and removes
a "xlnx." prefix.
Then it moves the Microblaze PVR registers to the end
of the CPUMBState to preserve them during reset. This
allows most of the operations on them to be moved from
the reset to the realise. Except for the machine specific
o
Fix up the incorrect indentation level in the helper_stackprot() function.
Signed-off-by: Alistair Francis
---
target-microblaze/op_helper.c | 10 +-
1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/target-microblaze/op_helper.c b/target-microblaze/op_helper.c
index a4c8
Move the Microblaze PVR registers to the end of the CPUMBState
and preserve them during reset. This is similar to what the
QEMU ARM model does with some of it's registers.
This allows the Microblaze PVR registers to only be set once
at realise instead of constantly at reset.
Signed-off-by: Alista
Microblaze stack protection is configurable and isn't always enabled.
This patch allows the stack protection to be disabled from the CPU
properties.
Signed-off-by: Alistair Francis
---
Changes since RFC:
- Move the cfg.stackproc check into translate.c
- Set the PVR register
target-microblaze/
Rename the "xlnx.base-vectors" string to "base-vectors" and
move the base_vectors variable into the cfg struct.
Signed-off-by: Alistair Francis
---
target-microblaze/cpu-qom.h |3 ++-
target-microblaze/cpu.c |4 ++--
target-microblaze/helper.c |8
3 files changed, 8 in
On Fri, 05/15 13:48, John Snow wrote:
>
>
> On 05/15/2015 01:26 AM, Fam Zheng wrote:
> > Adding "-d" option. The output goes to "tee" so it appears in your
> > console. Also, raise the verbosity of unnitest runner.
> >
> > When testing a topic branch, it's possible that a bug introduced by a
> >
Adding "-d" option. The output goes to "tee" so it appears in your
console. Also, raise the verbosity of unnitest runner.
When testing a topic branch, it's possible that a bug introduced by a
code change makes the python test case hang, with debug output, it is
much easier to locate the problem.
While testing the inline sh4a atomics patch for musl (see
http://www.openwall.com/lists/musl/2015/05/17/22) I noticed that
qemu-sh4 crashed on the instructions used for atomics, which are only
available in sh4a. Adding -cpu SH7785 made it work, but that got me
wondering what's happening when we don
Add Machine menu to the Macintosh interface with pause
and resume menu items. These items can either pause or
resume execution of the guest operating system.
Signed-off-by: John Arbuckle
---
Disable the Resume menu item initially.
ui/cocoa.m | 67 +
On 2015/5/15 20:45, Igor Mammedov wrote:
> On Thu, 7 May 2015 17:29:07 +0800
> Shannon Zhao wrote:
>
>> From: Shannon Zhao
>>
>> Add aml_interrupt() for describing device interrupt in resource template.
>> These can be used to generating DSDT table for ACPI on ARM.
>>
>> Signed-off-by: Shannon Z
On 2015/5/15 20:14, Igor Mammedov wrote:
> On Thu, 7 May 2015 16:51:31 +0100
> Peter Maydell wrote:
>
>> > On 7 May 2015 at 10:29, Shannon Zhao wrote:
>>> > > From: Shannon Zhao
>>> > >
>>> > > Add aml_interrupt() for describing device interrupt in resource
>>> > > template.
>>> > > These can
Am 18.05.2015 um 00:19 schrieb Programmingkid:
Do we only support user interfaces in the english language, or are multiple
languages supported?
Good question. Currently only the GTK user interface supports other
languages,
see 'po' directory with 6 translations.
I think that in the long run
On 2015/5/15 19:38, Dr. David Alan Gilbert wrote:
* zhanghailiang (zhang.zhanghaili...@huawei.com) wrote:
We can know if VM in destination should go into COLO mode by refer to
the info that has been migrated from PVM.
Signed-off-by: zhanghailiang
Signed-off-by: Yang Hongyang
Signed-off-by: La
On 2015/5/15 19:56, Dr. David Alan Gilbert wrote:
* zhanghailiang (zhang.zhanghaili...@huawei.com) wrote:
Introduce two new QEMUSizedBuffer APIs which will be used by COLO to buffer
VM state:
One is qsb_put_buffer(), which put the content of a given QEMUSizedBuffer
into QEMUFile, this is used to
On 2015/5/15 22:13, Igor Mammedov wrote:
> On Thu, 7 May 2015 17:29:22 +0800
> Shannon Zhao wrote:
>
>> From: Shannon Zhao
>>
>> Signed-off-by: Shannon Zhao
>> Signed-off-by: Shannon Zhao
>> ---
>> hw/acpi/aml-build.c | 18 ++
>> include/hw/acpi/aml-build.h | 1 +
>>
There are 2 Bug reports in the redhat bugzilla already.
https://bugzilla.redhat.com/show_bug.cgi?id=1210903
https://bugzilla.redhat.com/show_bug.cgi?id=1197592
i would say, we can close this bug here to avoid double work.
Cheers Tim
** Bug watch added: Red Hat Bugzilla #1210903
https://bugz
Eric Blake writes:
> On 05/16/2015 07:30 AM, Andreas Färber wrote:
>> Am 16.05.2015 um 00:24 schrieb Eric Blake:
>>> We require a C99 compiler, so let's use 'bool' instead of 'int'
>>> when dealing with boolean values. There are few enough clients
>>> to fix them all in one pass.
>>>
>>> Signed-
On (Tue) 14 Apr 2015 [18:03:31], Dr. David Alan Gilbert (git) wrote:
> From: "Dr. David Alan Gilbert"
>
> There are currently lots of pieces of incoming migration state scattered
> around,
next few patches don't move state into this new struct -- not sure if
you're doing that here, but would be
45 matches
Mail list logo