think ?
The Bug report is right, that the check should be
"(limit <= s->cmp)", as it's about the on-shot characteristic and not
the periodic characteristic (which earler version of the patch had).
I will provide a patch to fix this.
Axel
Peter,
Applied to target-arm.next, thanks. Sorry it took me so long to> get to this.
No worries. Thanks for picking up the changes, and I really appreciate
all the review feedback.
Axel
ly
slipped in my last patch iteration. Your changes look good to me.
Axel
and line options seem good enough.
What is the general feeling about having a more general system
emulation option when it comes to the "virt" machine, and a way
of resolving the usage (and security) conflict with the KVM
usecase.
Axel
here was ever an attempt to mainline this?
But it would avoid running into a command parameters hell for
customization options.
Axel
Alex,
It would also be worth updating ./docs/system/arm/virt.rst to document
this feature.
Good point. I will add this in the next iteration of the patch.
Until then, the proposed doc changes can be found here:
https://gitlab.com/axel-h/qemu/-/merge_requests/1/diffs
Axel
changing the name is worth the churn).
After this patch is merged, we have two UARTs, so the naming is
a bit more consistent. It's no longer a secure UART only. And
when adding even more UARTs in further customization, it's easier
to understand the order of the UARTs.
Axel
estions here that is non trivial? Othereise I would prefer to
look into this in a new patch-set, together with replacing the
PTIMER_POLICY_LEGACY.
Axel
in the appropriate place. Without the function then the
logic of "what is the IRQ line state given the current
device register state" ends up dispersed across the device
model code and potentially duplicated.
That bug is fixed for the next iteration of this patch set.
Axel
From: Axel Heider
Signed-off-by: Axel Heider
---
hw/timer/imx_epit.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/hw/timer/imx_epit.c b/hw/timer/imx_epit.c
index 5315d9633e..6af460946f 100644
--- a/hw/timer/imx_epit.c
+++ b/hw/timer/imx_epit.c
@@ -191,8
ssues/managing_issues.html#default-closing-pattern
I will change this to use "fix #1263" then. But the issue git closed already
from an earlier patch that got merged a few days ago.
Axel
mx_epit_freq(),
There will be an update of the whole patchset, so I will change
the name to imx_epit_freq(). That makes the name and signature in
sync. Note that the next commit in this patchset does more
refactoring anyway, so this is just a intermediate change that
is not really visible.
Axel
time then.
Axel
Signed-off-by: Axel Heider
---
qemu-options.hx | 30 +++---
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/qemu-options.hx b/qemu-options.hx
index e3f256fa72..ed91246114 100644
--- a/qemu-options.hx
+++ b/qemu-options.hx
@@ -244,15 +244,15 @@ DEF("
There is a difference between 'null' and 'none'. Add a sentence to
highlight this, so this does not get mixed up.
Signed-off-by: Axel Heider
---
qemu-options.hx | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/qemu-options.hx b/qemu-options.hx
index 83
Fix style to have a proper description of the parameter 'force-raw'.
Signed-off-by: Axel Heider
---
docs/system/generic-loader.rst | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/docs/system/generic-loader.rst b/docs/system/generic-loader.rst
index
Fix style to have a proper description of the parameter 'force-raw'.
Signed-off-by: Axel Heider
---
docs/system/generic-loader.rst | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/docs/system/generic-loader.rst b/docs/system/generic-loader.rst
index
Fix style to have a proper description of the parameter 'force-raw'.
Signed-off-by: Axel Heider
---
docs/system/generic-loader.rst | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/docs/system/generic-loader.rst b/docs/system/generic-loader.rst
index
Did you guys merge back the fix in:
http://lists.gnu.org/archive/html/qemu-devel/2011-11/msg01519.html
?
--
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/829455
Title:
user mode network stack - hostf
message they did so.
Kind Regards,
Axel
Hi list! I got a suggestion.
I first posted this to kvm, but they said its a qemu issue. Just have a
new host server which several guests, set up networking via bridges, and
wondered why it didn't work reliable. Surprise, Mac-Address Konflikt!
For now I just hard-set some other Mac-Adresses in
ase in ubuntu-server which the
hosts runs with.
Greetings, Axel Kittenberger
(I'm not subscribed to the list, so please CC me, if you have answers)
Hi Anthony,
On Thursday 29 March 2007 04:07, you wrote:
> Axel Zeuner wrote:
> > Hi Anthony,
> >
> > On Monday 26 March 2007 01:44, you wrote:
> >> Axel Zeuner wrote:
> >>> On Saturday 24 March 2007 21:15, Anthony Liguori wrote:
> >>>>
are explicit.
> Also, if a helper throws an exception it must be in helper.c to avoid
> clobbering CPU state before calling raise_exception.
Thank you for the clarification, I was wrong.
Kind regards
Axel
> Note that some targets use a different naming scheme. They use helper.c for
> regular code and op_helper.c for op.c-like code. IMHO this is a much better
> naming scheme.
>
> Paul
Hi Avi,
On Sunday 25 March 2007 15:40, Avi Kivity wrote:
> Axel Zeuner wrote:
> > A full featured converter (cvtasm) has a lot of dependencies: it has to
> > support all hosts (M) (with all assembler dialects M') and all targets N,
> > i.e. in the worst case one would end
Hi Anthony,
On Monday 26 March 2007 01:44, you wrote:
> Axel Zeuner wrote:
> > On Saturday 24 March 2007 21:15, Anthony Liguori wrote:
> >> The tricky thing I still can't figure out is how to get ASM_SOFTMMU
> >> working. The problem is GLUE(st, SUFFIX) function.
Hi Anthony,
On Monday 26 March 2007 01:46, you wrote:
> Axel Zeuner wrote:
> > On Saturday 24 March 2007 21:15, Anthony Liguori wrote:
> >> Axel Zeuner wrote:
> >>> Hi,
> >>
>
> > Furthermore I think one should move helper_pshufw() from
> >
On Saturday 24 March 2007 21:15, Anthony Liguori wrote:
> Axel Zeuner wrote:
> > Hi,
>
> Hi Axel,
>
> By adding some GCC4 fixes on top of your patch, I was able to get qemu
> for i386 (on i386) to compile and run. So far, I've only tested a win2k
> guest.
Hi Ant
Hi,
On Saturday 17 March 2007 10:51, Johannes Schindelin wrote:
> Hi,
>
> On Sat, 17 Mar 2007, axel wrote:
> > Why there exist two different blocks for COFF and ELF for x86/x86_64
> > hosts?
>
> Because COFF is used by Windows, and ELF by Linux, and they are
> subst
lso detect multiple returns in a function and one could try to
rewrite the opcode blocks replacing the multiple returns with jumps.
Why there exist two different blocks for COFF and ELF for x86/x86_64 hosts?
Axel
Index: dyngen.c
===
R
30 matches
Mail list logo