+-- On Tue, 31 Jan 2017, P J P wrote --+
| In SDHCI emulation, the 'Block Count Enable' bit of the Transfer Mode
| register is used to control 's->blkcnt' value. One, this bit is not
| relevant in single block transfers. Second, Transfer Mode register
| value could be set such that 's->blkcnt' woul
On 2017/1/31 18:19, Juan Quintela wrote:
"Dr. David Alan Gilbert" wrote:
* zhanghailiang (zhang.zhanghaili...@huawei.com) wrote:
There are several stages during loadvm/savevm process. In different stage,
migration incoming processes different types of sections.
We want to control these stages
On 2017/1/31 18:04, Dr. David Alan Gilbert wrote:
* zhanghailiang (zhang.zhanghaili...@huawei.com) wrote:
COLO's checkpoint process is based on migration process,
everytime we do checkpoint we will repeat the process of savevm and loadvm.
So we will call qemu_loadvm_section_start_full() repeate
On 2017/1/31 18:05, Dr. David Alan Gilbert wrote:
* zhanghailiang (zhang.zhanghaili...@huawei.com) wrote:
There are several stages during loadvm/savevm process. In different stage,
migration incoming processes different types of sections.
We want to control these stages more accuracy, it will be
Hi Laurent,
Thanks for the review.
Laurent Vivier writes:
> Le 25/01/2017 à 01:10, Pranith Kumar a écrit :
>> Adopted from a previous patch posting:
>> https://lists.gnu.org/archive/html/qemu-devel/2016-07/msg02079.html
>>
>> CC: Allan Wirth
>> CC: Peter Maydell
>> Signed-off-by: Pranith Kum
Markus Armbruster writes:
[...]
> === Structured values ===
>
> The dotted key convention messes with KEY syntax to permit structured
> values. Works, but the more conventional way to support structured
> values is a syntax for structured values.
>
> An obvious one is to use { KEY=VALUE, ...}
On Fri, Jan 27, 2017 at 12:07:27PM +, Dr. David Alan Gilbert wrote:
>* Chao Fan (fanc.f...@cn.fujitsu.com) wrote:
>> Hi all,
>>
>> This is a test for this RFC patch.
>>
>> Start vm as following:
>> cmdline="./x86_64-softmmu/qemu-system-x86_64 -m 2560 \
>> -drive if=none,file=/nfs/img/fedora.q
Fam Zheng writes:
> On Sat, 02/04 14:35, Markus Armbruster wrote:
>> Fam Zheng writes:
>>
>> > On Thu, 02/02 20:42, Markus Armbruster wrote:
>> >> === Comparison ===
>> >>
>> >> In my opinion, dotted keys are weird and ugly, but at least they don't
>> >> add to the quoting mess. Structured va
Is it possible to generate a PCIe burst of greater than 2dw for any MMIO.
I see we have limit of max 2dw operation for any MemoryRegion defined by
the max access size.
--Thanks
Power ISA 3.0 introduces a few quadruple precision floating point
instructions that support round-to-odd rounding mode. The
round-to-odd mode is explained as under:
Let Z be the intermediate arithmetic result or the operand of a convert
operation. If Z can be represented exactly in the target form
On Sun, 02/05 22:52, Max Reitz wrote:
> On 23.01.2017 13:30, Fam Zheng wrote:
> > qemu-io is a low level tool to read or modify guest visible data, which
> > implies the user knows very well what is being done. Allowing reading
> > from a locked image is harmless in most cases, so do it.
> >
> > S
[Expired for QEMU because there has been no activity for 60 days.]
** Changed in: qemu
Status: Incomplete => Expired
--
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/498417
Title:
cache=writeb
[Expired for QEMU because there has been no activity for 60 days.]
** Changed in: qemu
Status: Incomplete => Expired
--
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/584516
Title:
opensuse 11.
On 2017/2/4 2:24, Peter Maydell wrote:
> The functions vnc_has_job() and vnc_jobs_clear() are
> never used; remove them.
>
> Signed-off-by: Peter Maydell
> ---
>
> I last had a go at this five years ago:
> http://patchwork.ozlabs.org/patch/192335/
>
> Since then vnc_stop_worker_thread() got r
** Summary changed:
- qemu-img convert a overlay qcow2 image into a complete image
+ qemu-img convert a overlay qcow2 image into a entire image
** Description changed:
I have a base image file "base.qcow2" and a delta qcow2 image file
"delta.qcow2" whose backing file is "base.qcow2".
No
Hello Gerd,
Ping.
2017-01-23 17:09 GMT+08:00 Marc-André Lureau :
>
>
> On Sun, Jan 22, 2017 at 11:43 AM Li Qiang wrote:
>
>> From: Li Qiang
>>
>> In virtio_gpu_set_scanout function, when creating the 'rect'
>> its refcount is set to 2, by pixman_image_create_bits and
>> qemu_create_displaysurf
** Summary changed:
- qemu-img convert a delta qcow2 image into a complete image
+ qemu-img convert a overlay qcow2 image into a complete image
--
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1662050
Public bug reported:
I have a base image file "base.qcow2" and a delta qcow2 image file
"delta.qcow2" whose backing file is "base.qcow2".
Now I use qemu-img to convert "delta.qcow2" and will get a new image
file "new.qcow2" which is complete and equivalent to combination of
"base.qcow2" and "delt
On Fri, Feb 03, 2017 at 08:01:13PM -0200, Jose Ricardo Ziviani wrote:
> This set contains 4 new instructions
>
> xsrqpi[x] - VSX Scalar Round to Quad-Precision Integer
> xsrqpxp - VSX Scalar Round Quad-Precision to Double-Extended Precision
> xssqrtqp - VSX Scalar Square Root Quad-Precision
> xssu
On Fri, Feb 03, 2017 at 04:22:28PM +0800, Peter Xu wrote:
> A cleanup for vfio_iommu_map_notify(). Now we will fetch vaddr even if
> the operation is unmap, but it won't hurt much.
>
> One thing to mention is that we need the RCU read lock to protect the
> whole translation and map/unmap procedure
Hi Stefan,
I'm just back from Chinese New year's holiday.
>
> Subject: Re: [Qemu-devel] [PATCH v16 1/2] virtio-crypto: Add virtio crypto
> device specification
>
> On Wed, Jan 18, 2017 at 04:22:36PM +0800, Gonglei wrote:
> > The virtio crypto device is a virtual crypto device (ie. hardware
> >
>
> Subject: Re: [Qemu-devel] [PATCH v16 2/2] virtio-crypto: Add conformance
> clauses
>
> On Wed, Jan 18, 2017 at 04:22:37PM +0800, Gonglei wrote:
> > Add the conformance targets and clauses for
> > virtio-crypto device.
> >
> > Signed-off-by: Gonglei
> > ---
> > conformance.tex | 30 ++
Hi,
Your series seems to have some coding style problems. See output below for
more information:
Type: series
Subject: [Qemu-devel] [PULL 0/3] isa-cleanup queue 20170206
Message-id: 20170206013927.13693-1-da...@gibson.dropbear.id.au
=== TEST SCRIPT BEGIN ===
#!/bin/bash
BASE=base
n=1
total=$(gi
The m48t59 device supports both ISA and direct sysbus attached versions of
the device in the one .c file. This can be awkward for some embedded
machine types which need the sysbus M48T59, but don't want to pull in the
ISA bus code and its other dependencies.
Therefore, this patch splits out the c
At present, the core device model code for 8250-like serial ports
(serial.c) and the code for serial ports attached to ISA-style legacy IO
(serial-isa.c) are both controlled by the CONFIG_SERIAL variable.
There are lots and lots of embedded platforms that have 8250-like serial
ports but have never
On Fri, Feb 03, 2017 at 04:22:27PM +0800, Peter Xu wrote:
> We traces its range, but we don't know whether it's a MAP/UNMAP. Let's
> dump it as well.
>
> Acked-by: Alex Williamson
> Signed-off-by: Peter Xu
Reviewed-by: David Gibson
> ---
> hw/vfio/common.c | 3 ++-
> hw/vfio/trace-events
Currently, the code to handle the legacy ISA bus is always included in
qemu. However there are lots of platforms that don't include ISA legacy
devies, and quite a few that have never used ISA legacy devices at all.
This patch allows the ISA bus code to be disabled in the configuration for
platfor
The following changes since commit a951316b8a5c3c63254f20a826afeed940dd4cba:
Merge remote-tracking branch 'remotes/stefanha/tags/block-pull-request' into
staging (2017-02-03 14:41:49 +)
are available in the git repository at:
git://github.com/dgibson/qemu.git tags/isa-cleanup-20170206
On Thu, Feb 02, 2017 at 04:02:32PM +0100, Igor Mammedov wrote:
> Make cpu core hotunplug use the same (expected)
> unplug_request/unplug call flow like spapr memory unplug
> and mem/cpu unplug on x86.
>
> While doing it separate internal cpu core handling and
> machine wiring code and move machine
On Fri, Feb 03, 2017 at 11:29:37PM -0200, jos...@linux.vnet.ibm.com wrote:
> On Fri, Feb 03, 2017 at 02:11:31PM -0800, no-re...@patchew.org wrote:
> > Hi,
> >
> > Your series seems to have some coding style problems. See output below for
> > more information:
> >
> > Type: series
> > Subject: [Qe
On 23.01.2017 13:30, Fam Zheng wrote:
> v12: Fix test cases on old systems that doesn't have F_OFD_SETLK, such as RHEL
> 6. [Patchew]
> Trim the commit message of patch 15 to avoid bitrotting.
>
> v11: Move lock bytes from 1-2 to 0x10-0x12. [Daniel]
>
> v10: While we still don't have co
On 23.01.2017 13:30, Fam Zheng wrote:
> In this case we may open the source's backing image chain multiple
> times. Setting share flag means the new open won't try to acquire or
> check any lock, once we implement image locking.
>
> Signed-off-by: Fam Zheng
> ---
> blockdev.c | 3 +++
> 1 file c
On 23.01.2017 13:30, Fam Zheng wrote:
> Checking the status of an image when it is being used by guest is
> usually useful, and there is no risk of corrupting data, so don't let
> the upcoming image locking feature limit this use case.
>
> Signed-off-by: Fam Zheng
> ---
> qemu-img.c | 10 +++
On 23.01.2017 13:30, Fam Zheng wrote:
> qemu-io is a low level tool to read or modify guest visible data, which
> implies the user knows very well what is being done. Allowing reading
> from a locked image is harmless in most cases, so do it.
>
> Signed-off-by: Fam Zheng
> ---
> qemu-io.c | 2 ++
On 23.01.2017 13:30, Fam Zheng wrote:
> Signed-off-by: Fam Zheng
> ---
> include/block/block.h | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/include/block/block.h b/include/block/block.h
> index 8b0dcda..243839d 100644
> --- a/include/block/block.h
> +++ b/include/block/block.h
> @@
On 23.01.2017 13:30, Fam Zheng wrote:
> They are wrappers of POSIX fcntl "file private locking", with a
> convenient "try lock" wrapper implemented with F_OFD_GETLK.
>
> Signed-off-by: Fam Zheng
> ---
> include/qemu/osdep.h | 3 +++
> util/osdep.c | 48 ++
On 04.02.2017 10:51, Markus Armbruster wrote:
> "Richard W.M. Jones" writes:
>
>> On Thu, Feb 02, 2017 at 08:42:33PM +0100, Markus Armbruster wrote:
>>> There's also the -drive file=json:... syntax. It's a bad fit for
>>> QemuOpts, because QemuOpts and JSON fight for the comma. I'd show you
>>>
Le 03/02/2017 à 18:07, Paolo Bonzini a écrit :
> The function is not needed anymore now that migration is built on
> top of QIOChannel.
>
> Signed-off-by: Paolo Bonzini
> ---
> tests/test-vmstate.c | 11 ---
> 1 file changed, 11 deletions(-)
>
> diff --git a/tests/test-vmstate.c b/tests
Le 03/02/2017 à 19:59, Peter Maydell a écrit :
> In float64_to_uint64_round_to_zero() a typo meant that we were
> taking the uint64_t return value from float64_to_uint64() and
> putting it into an int64_t variable before returning it as
> uint64_t again. Use uint64_t instead of pointlessly casting
Le 03/02/2017 à 18:58, Peter Maydell a écrit :
> Our defacto coding style strongly prefers /* */ style comments
> over the single-line // style, and checkpatch enforces this,
> but we don't actually document this. Mention it in CODING_STYLE.
>
> Suggested-by: Thomas Huth
> Signed-off-by: Peter Ma
ello Frederic,
On 01/26/2017 10:47 AM, fred.kon...@greensocs.com wrote:
> From: KONRAD Frederic
>
> This introduces qemu-clk qom object.
>
> Signed-off-by: KONRAD Frederic
> ---
> Makefile.objs | 1 +
> include/qemu/qemu-clock.h | 40 +
> qemu-
Le 05/02/2017 à 00:05, Peter Maydell a écrit :
> Coverity doesn't like the code in load_symbols() which assumes
> it can use 'int' for a variable that might hold an offset into
> the guest ELF file, because in a 64-bit guest that could
> overflow. Guest binaries with 2GB sections aren't very likely
Drop the old SysBus init function and use instance_init
and an realize function
Signed-off-by: xiaoqiang zhao
---
hw/dma/sparc32_dma.c | 25 +++--
1 file changed, 15 insertions(+), 10 deletions(-)
diff --git a/hw/dma/sparc32_dma.c b/hw/dma/sparc32_dma.c
index 9d545e412e..ef4
Drop the old SysBus init function and use instance_init
Signed-off-by: xiaoqiang zhao
---
hw/dma/sun4m_iommu.c | 12 +---
1 file changed, 5 insertions(+), 7 deletions(-)
diff --git a/hw/dma/sun4m_iommu.c b/hw/dma/sun4m_iommu.c
index b3cbc54c23..335ef63cbc 100644
--- a/hw/dma/sun4m_iommu
Drop the old SysBus init function and use instance_init
Signed-off-by: xiaoqiang zhao
---
hw/misc/slavio_misc.c | 43 +--
1 file changed, 17 insertions(+), 26 deletions(-)
diff --git a/hw/misc/slavio_misc.c b/hw/misc/slavio_misc.c
index edd5de0702..e1a706
* split the old SysBus init function into an instance_init
and a Device realize function
* use DeviceClass::realize instead of SysBusDeviceClass::init
Signed-off-by: xiaoqiang zhao
---
hw/timer/m48t59.c | 35 ++-
1 file changed, 18 insertions(+), 17 deletions(-)
rename slavio_timer_init1 to slavio_timer_init and assign
it to slavio_timer_info.instance_init, then we drop the
SysBusDeviceClass::init
Signed-off-by: xiaoqiang zhao
---
hw/timer/slavio_timer.c | 12 +---
1 file changed, 5 insertions(+), 7 deletions(-)
diff --git a/hw/timer/slavio_tim
Drop the old SysBusDeviceClass::init and use instance_init
or DeviceClass::realize instead
Signed-off-by: xiaoqiang zhao
---
hw/sparc64/sun4u.c | 20 +---
1 file changed, 9 insertions(+), 11 deletions(-)
diff --git a/hw/sparc64/sun4u.c b/hw/sparc64/sun4u.c
index d1a6bca873..5182
assign DeviceClass::vmsd instead of using vmstate_register function
Signed-off-by: xiaoqiang zhao
---
hw/timer/m48t59.c | 26 --
1 file changed, 24 insertions(+), 2 deletions(-)
diff --git a/hw/timer/m48t59.c b/hw/timer/m48t59.c
index 39e425e950..6afcce4669 100644
--- a/
Rebased on the latest master.
This patch set aims for QOM'ifying code relate with sparc.
It is part of my QOM'ify work of qemu code base.
xiaoqiang zhao (9):
hw/misc: QOM'ify eccmemctl.c
hw/dma: QOM'ify sparc32_dma.c
hw/dma: QOM'ify sun4m_iommu.c
hw/misc: QOM'ify slavio_misc.c
hw/timer:
* Split the old SysBus init into an instance_init and a
DeviceClass::realize function
* Drop the old SysBus init function and use instance_init
Signed-off-by: xiaoqiang zhao
---
hw/misc/eccmemctl.c | 25 -
1 file changed, 16 insertions(+), 9 deletions(-)
diff --git a/h
Drop the old SysBusDeviceClass::init and use instance_init
or DeviceClass::realize instead
Signed-off-by: xiaoqiang zhao
---
hw/sparc/sun4m.c | 54 +++---
1 file changed, 19 insertions(+), 35 deletions(-)
diff --git a/hw/sparc/sun4m.c b/hw/sparc/s
From: Ben Warren
This allows pc_i440fx-based machines to add new devices such as
VM Generation ID directly to the sysbus.
Signed-off-by: Ben Warren
---
hw/i386/pc_piix.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/hw/i386/pc_piix.c b/hw/i386/pc_piix.c
index 9f102aa..c8ad99c 100644
---
From: Ben Warren
Also usable by upcoming VM Generation ID tests
Signed-off-by: Ben Warren
---
tests/acpi-utils.h | 75
tests/bios-tables-test.c | 72 +-
2 files changed, 76 insertions(+), 71 dele
From: Ben Warren
This patch set adds support for passing a GUID to Windows guests. It is a
re-implementation of previous patch sets written by Igor Mammedov et al, but
this time passing the GUID data as a fw_cfg blob.
This patch set has dependencies on new guest functionality, in particular the
From: Igor Mammedov
Add set-vm-generation-id command to set Virtual Machine
Generation ID counter.
QMP command example:
{ "execute": "set-vm-generation-id",
"arguments": {
"guid": "324e6eaf-d1d1-4bf6-bf41-b9bb6c91fb87"
}
}
HMP command example:
set-v
From: Igor Mammedov
Add commands to query Virtual Machine Generation ID counter.
QMP command example:
{ "execute": "query-vm-generation-id" }
HMP command example:
info vm-generation-id
Signed-off-by: Igor Mammedov
Reviewed-by: Eric Blake
Signed-off-by: Ben Warren
---
hmp-commands-i
From: Ben Warren
This allows them to be centrally initialized and destroyed
Signed-off-by: Ben Warren
---
hw/acpi/aml-build.c | 2 ++
include/hw/acpi/aml-build.h | 1 +
2 files changed, 3 insertions(+)
diff --git a/hw/acpi/aml-build.c b/hw/acpi/aml-build.c
index 03b6c6c..0f39eaf 10064
From: Ben Warren
The following tests are implemented:
* test that a GUID passed in by command line is propagated to the guest.
* test that changing the GUID at runtime via the monitor is reflected in
the guest.
* test that the "auto" argument to the GUID generates a different, and
correct GUI
From: Ben Warren
This implements the VM Generation ID feature by passing a 128-bit
GUID to the guest via a fw_cfg blob.
Any time the GUID changes, an ACPI notify event is sent to the guest
The user interface is a simple device with one parameter:
- guid (string, must be "auto" or in UUID format
From: Ben Warren
This adds to the existing 'add pointer' functionality in that it
instructs the guest (BIOS or UEFI) to not patch memory but to instead
write the changes back to QEMU via a writeable fw_cfg file.
Signed-off-by: Ben Warren
---
hw/acpi/aml-build.c | 2 +-
hw/acp
From: Ben Warren
This patch is based off an earlier version by
Gal Hammer (gham...@redhat.com)
Requirements section, ASCII diagrams and overall help
provided by Laszlo Ersek (ler...@redhat.com)
Signed-off-by: Gal Hammer
Signed-off-by: Ben Warren
---
docs/specs/vmgenid.txt | 239 +
From: Ben Warren
This is initially used to patch a 64-bit address into
the VM Generation ID SSDT
Signed-off-by: Ben Warren
---
hw/acpi/aml-build.c | 35 +++
include/hw/acpi/aml-build.h | 4
2 files changed, 39 insertions(+)
diff --git a/hw/acpi/am
2017-02-03 22:51 GMT+03:00 Dr. David Alan Gilbert :
> Ah well that is a bit better; you see now it's failing in kvm_**get**_msrs
> rather
> than put; so the question is which of the two changes made it survive
> kvm_put_msrs
>
> I'd hoped that the flags in (2) would have turned off the CPU flag a
64 matches
Mail list logo