You can improve your chances for people looking at your patches: don't
require them to go hunting for the parts! Use proper threading.
If you can't get git-send-email to work with gmail (unlike other gmail
users), get yourself an email address you can get to work.
Adding Suzuki Poulose.
Hi Suzuki,
On Fri, Apr 8, 2016 at 3:13 PM, Peter Maydell wrote:
> On 8 April 2016 at 07:21, Vijay Kilari wrote:
>> On Thu, Apr 7, 2016 at 5:15 PM, Peter Maydell
>> wrote:
>>> I'm told there are kernel patches in progress to get this sort
>>> of information in a maintain
iQQator writes:
> fix: http://patchwork.ozlabs.org/patch/603499/
This patch isn't correct. Quoting from its review:
ivshmem.o should only be linked when CONFIG_EVENTFD is set. pci.mak has
CONFIG_IVSHMEM=$(CONFIG_EVENTFD)
The compile error shown above indicates CONFIG_EVENTFD=y for make
Mostly there. Final note:
On Sun, Apr 10, 2016 at 01:47:32PM +0100, Alex Bligh wrote:
> diff --git a/doc/proto.md b/doc/proto.md
> index f117394..5005552 100644
> --- a/doc/proto.md
> +++ b/doc/proto.md
> @@ -195,6 +195,13 @@ request before sending the next one of the same type.
> The server MAY
On Tuesday 05 April 2016 22:50:51 Wouter Verhelst wrote:
> On Tue, Apr 05, 2016 at 08:14:01AM -0600, Eric Blake wrote:
> > On 04/05/2016 03:24 AM, Markus Pargmann wrote:
> >
> > >> +requested.
> > >> +
> > >> +The client SHOULD NOT read from an area that has both
> > >> +`NBD_STATE
On Tuesday 05 April 2016 15:50:16 Paolo Bonzini wrote:
>
> On 05/04/2016 11:24, Markus Pargmann wrote:
> > Also it is uncertain if these status bits may change over time through
> > reorganization of backend storage, for example holes may be removed in
> > the backend and so on. Is it safe to cach
Clearly late to the party,
On 08.04.2016 22:14, Paolo Bonzini wrote:
>
> On 08/04/2016 15:15, Markus Armbruster wrote:
>>> On the other hand, minimal usage of templates instead of some of the
>>> preprocessor gunk we have would be a very good thing IMNSHO. I am
>>> referring to the multiply incl
On 03/30/2016 11:07 PM, Max Reitz wrote:
On 30.03.2016 13:39, Alberto Garcia wrote:
On Tue 29 Mar 2016 05:51:22 PM CEST, Max Reitz wrote:
It sounds like the argument here, and in Max's thread on
query-block-node-tree, is that we DO have cases where order matters, and
so we need a way for the ho
On Mon, Apr 11, 2016 at 11:00:21AM +0800, Peter Xu wrote:
> Address Mask (AM) should be 6 bits long, not 7. (vt-d spec 6.5.2.3)
>
OMG I was wrong... Sorry please ignore this one.
-- peterx
On Fri, 8 Apr 2016 13:29:56 +0200
Igor Mammedov wrote:
> it returns a list of present/possible to hotplug CPU
> objects with a list of properties to use with
> device_add.
>
> in spapr case returned list would looks like:
> -> { "execute": "query-hotpluggable-cpus" }
> <- {"return": [
>
On Fri, 8 Apr 2016 13:29:55 +0200
Igor Mammedov wrote:
> it will allow mgmt to query present and hotpluggable
> CPU objects, it is required from a target platform that
> wish to support command to implement and set
> MachineClass.query_hotpluggable_cpus
> callback, which will return a list of p
From: Wen Congyang
Introduce a "xen-load-devices-state" QAPI command that can be used to
load the state of all devices, but not the RAM or the block devices of
the VM.
We only have hmp commands savevm/loadvm, and qmp commands
xen-save-devices-state.
We use this new command for COLO:
1. suspend
Changelog
v4:
1. Rebased to the lastest code
v3:
1. Addressed on David's commets, fix a bug
v2:
1. Rebased to the lastest code
2. Addressed on Eric's comments, fixed coding style
Wen Congyang (1):
Introduce "xen-load-devices-state"
migration/savevm.c | 36
Hi, Aviv,
On Sat, Apr 09, 2016 at 09:03:38PM +0300, Aviv B.D. wrote:
[...]
> +static int vtd_get_did_dev(IntelIOMMUState *s, uint8_t bus_num,
> uint8_t devfn, uint16_t * domain_id)
It seems that there are two lines above, however what I feel is that
this is a long line splitted by the email cli
https://patchwork.ozlabs.org/patch/602037/
Add debug macros to the code for easier debugging.
Signed-off-by: John Arbuckle
---
hw/input/hid.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/hw/input/hid.c b/hw/input/hid.c
index 329a27b..42ca592 100644
--- a/hw/input/hid.c
+++ b
https://patchwork.ozlabs.org/patch/602036/
Switches hid.c from PS/2 to QKeyCode support.
Signed-off-by: John Arbuckle
---
hw/input/hid.c | 270 ++---
1 file changed, 179 insertions(+), 91 deletions(-)
diff --git a/hw/input/hid.c b/hw/input/hi
Address Mask (AM) should be 6 bits long, not 7. (vt-d spec 6.5.2.3)
Signed-off-by: Peter Xu
---
hw/i386/intel_iommu_internal.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/hw/i386/intel_iommu_internal.h b/hw/i386/intel_iommu_internal.h
index e5f514c..db7da18 100644
--- a/h
https://patchwork.ozlabs.org/patch/602035/
Create an emum of all the USB HID keyboard values.
Signed-off-by: John Arbuckle
---
include/hw/input/usb-keys.h | 154
1 file changed, 154 insertions(+)
create mode 100644 include/hw/input/usb-keys.h
diff
https://patchwork.ozlabs.org/patch/602035/
This patchset switches from the PS/2 keycode to QKeyCode support in the hid.c
file.
John Arbuckle (3):
usb-keys.h: initial commit
hid.c: convert to QKeyCode
hid.c: Add debug support
hw/input/hid.c | 279 ++---
From: Sergey Fedorov
We don't take care of direct jumps when address mapping changes. Thus we
must be sure to generate direct jumps so that they always keep valid
even if address mapping changes. However we only allow to execute a TB
if it was generated from the pages which match with current map
From: Sergey Fedorov
Unify the code of this function with tb_jmp_remove_from_list(). Making
these functions similar improves their readability. Also this could be a
step towards making this function thread-safe.
Signed-off-by: Sergey Fedorov
Signed-off-by: Sergey Fedorov
Reviewed-by: Alex Benn
From: Sergey Fedorov
This series combines a set of patches which is meant to improve overall code
structure and readability of direct block chaining mechanism. The other point
is to make a step towards thread safety of TB chainig.
The series' tree can be found in a public git repository [1].
[1
From: Sergey Fedorov
In user mode, there's only a static address translation, TBs are always
invalidated properly and direct jumps are reset when mapping change.
Thus the destination address is always valid for direct jumps and
there's no need to restrict it to the pages the TB resides in.
Signe
From: Sergey Fedorov
Move the code for removing jumps to a TB out of tb_phys_invalidate() to
a separate static inline function tb_jmp_unlink(). This simplifies
tb_phys_invalidate() and improves code structure.
Signed-off-by: Sergey Fedorov
Signed-off-by: Sergey Fedorov
Reviewed-by: Alex Bennée
From: Sergey Fedorov
tb_jmp_remove() was only used to remove the TB from a list of all TBs
jumping to the same TB which is n-th jump destination of the given TB.
Put a comment briefly describing the function behavior and rename it to
better reflect its purpose.
Signed-off-by: Sergey Fedorov
Sig
From: Sergey Fedorov
Initialize TB's direct jump list data fields and reset the jumps before
tb_link_page() puts it into the physical hash table and the physical
page list. So TB is completely initialized before it becomes visible.
Signed-off-by: Sergey Fedorov
Signed-off-by: Sergey Fedorov
--
From: Sergey Fedorov
Signed-off-by: Sergey Fedorov
Signed-off-by: Sergey Fedorov
Reviewed-by: Alex Bennée
---
translate-all.c | 204
1 file changed, 101 insertions(+), 103 deletions(-)
diff --git a/translate-all.c b/translate-all.c
ind
From: Sergey Fedorov
The check is to make sure that another thread hasn't already done the
same while we were outside of tb_lock. Mention this in a comment.
Signed-off-by: Sergey Fedorov
Signed-off-by: Sergey Fedorov
---
Changes in v2:
* Typo fixed in the commit title
* Complete rewrite of
From: Sergey Fedorov
These fields do not contain pure pointers to a TranslationBlock
structure. So uintptr_t is the most appropriate type for them.
Also put an assert to assure that the two least significant bits of the
pointer are zero before assigning it to jmp_list_first.
Signed-off-by: Serge
From: Sergey Fedorov
Briefly describe in a comment how direct block chaining is done. It
should help in understanding of the following data fields.
Rename some fields in TranslationBlock and TCGContext structures to
better reflect their purpose (dropping excessive 'tb_' prefix in
TranslationBloc
fix: http://patchwork.ozlabs.org/patch/603499/
--
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1568589
Title:
Compile for os x host failed
Status in QEMU:
New
Bug description:
Hello QEMU,
I
Also for i386
LINK i386-softmmu/qemu-system-i386
Undefined symbols for architecture x86_64:
"_event_notifier_init_fd", referenced from:
_process_msg in ivshmem.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocatio
Host:
# uname -a
Darwin MacBook-Pro 15.4.0 Darwin Kernel Version 15.4.0: Fri Feb 26 22:08:05 PST
2016; root:xnu-3248.40.184~3/RELEASE_X86_64 x86_64
# ./configure
Configure: http://pastebin.com/L9ytLFDE
# make -v
GNU Make 3.81
Copyright (C) 2006 Free Software Foundation, Inc.
This is free softw
Public bug reported:
Hello QEMU,
I try compile qemu from git pulled by me today and have a troubles:
GEN trace/generated-helpers.c
CCaarch64-softmmu/trace/generated-helpers.o
LINK aarch64-softmmu/qemu-system-aarch64
Undefined symbols for architecture x86_64:
"_event_notifier_init_f
and how can i add a package to cygwin after the installation ? there is any
command line ? , i didn't find a way to add the python package so i
downloaded from internet like the traditional way , then an other error msg
dispalyed ERROR: "cc" either does not exist or does not work
so i add this cros
On Fri, Apr 01, 2016 at 04:38:28PM +0530, Jitendra Kolhe wrote:
> On 3/29/2016 5:58 PM, Michael S. Tsirkin wrote:
> > On Mon, Mar 28, 2016 at 09:46:05AM +0530, Jitendra Kolhe wrote:
> >> While measuring live migration performance for qemu/kvm guest, it
> >> was observed that the qemu doesn’t mainta
> On 10 Apr 2016, at 18:35, Michael S. Tsirkin wrote:
>
>> On Sun, Apr 10, 2016 at 06:14:49PM +0300, Dmitry Fleytman wrote:
>> From: Dmitry Fleytman
>>
>> Hello All,
>>
>> This is v4 of e1000e series.
>>
>> For convenience, the same patches are available at:
>> https://github.com/daynix/qem
On Sun, Apr 10, 2016 at 06:14:49PM +0300, Dmitry Fleytman wrote:
> From: Dmitry Fleytman
>
> Hello All,
>
> This is v4 of e1000e series.
>
> For convenience, the same patches are available at:
> https://github.com/daynix/qemu-e1000e/tree/e1000e-submit-v4
>
> Best regards,
> Dmitry.
>
> Change
On 2016年04月05日 16:17, Michael S. Tsirkin wrote:
On Tue, Apr 05, 2016 at 10:05:17AM +0800, Jason Wang wrote:
On 04/04/2016 03:25 AM, w...@redhat.com wrote:
From: Wei Xu
A new feature bit 'VIRTIO_NET_F_GUEST_RSC' is introduced to support WHQL
Receive-Segment-Offload test, this feature will c
From: Dmitry Fleytman
This patch extends the TX/RX packet abstractions with features that will
be used by the e1000e device implementation.
Changes are:
1. Support iovec lists for RX buffers
2. Deeper RX packets parsing
3. Loopback option for TX packets
4. Extended VLAN headers handling
From: Dmitry Fleytman
This patch drops "vmx" prefix from packet abstrations names
to emphasize the fact they are generic and not tied to any
specific network device.
These abstrations will be reused by e1000e emulation implementation
introduced by following patches so their names need generaliza
From: Dmitry Fleytman
To make this device and network packets
abstractions ready for IOMMU.
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
hw/net/net_tx_pkt.c | 16 +++-
hw/net/net_tx_pkt.h | 5 +++--
hw/net/vmxnet3.c| 51 ++
From: Dmitry Fleytman
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
hw/net/rtl8139.c | 5 -
include/net/eth.h | 8
2 files changed, 8 insertions(+), 5 deletions(-)
diff --git a/hw/net/rtl8139.c b/hw/net/rtl8139.c
index 1e5ec14..562c1fd 100644
--- a/hw/net/rtl813
From: Dmitry Fleytman
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
hw/net/e1000_regs.h | 345 +++-
1 file changed, 342 insertions(+), 3 deletions(-)
diff --git a/hw/net/e1000_regs.h b/hw/net/e1000_regs.h
index 1c40244..d62b3fa
From: Dmitry Fleytman
These macros will be used by future commits introducing
e1000e device emulation and by vmxnet3 tracing code.
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
include/net/net.h | 5 +
1 file changed, 5 insertions(+)
diff --git a/include/net/net.h b/incl
From: Dmitry Fleytman
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
hw/net/vmxnet3.c | 8
hw/net/vmxnet_debug.h | 3 ---
2 files changed, 4 insertions(+), 7 deletions(-)
diff --git a/hw/net/vmxnet3.c b/hw/net/vmxnet3.c
index 0a4db4d..26f6f90 100644
--- a/hw/net/
From: Dmitry Fleytman
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
hw/pci/pcie.c | 10 ++
include/hw/pci/pcie.h | 1 +
2 files changed, 11 insertions(+)
diff --git a/hw/pci/pcie.c b/hw/pci/pcie.c
index 24cfc3b..9599fde 100644
--- a/hw/pci/pcie.c
+++ b/hw/pci
From: Dmitry Fleytman
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
tests/Makefile | 3 +
tests/e1000e-test.c | 480
2 files changed, 483 insertions(+)
create mode 100644 tests/e1000e-test.c
diff --git a/tests/Makef
From: Dmitry Fleytman
Added support for PCIe CAP v1, while reusing some of the existing v2
infrastructure.
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
hw/pci/pcie.c | 84 --
include/hw/pci/pcie.h | 4 +++
includ
From: Dmitry Fleytman
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
include/net/checksum.h | 45 +
1 file changed, 45 insertions(+)
diff --git a/include/net/checksum.h b/include/net/checksum.h
index 7de1acb..dd8b4f6 100644
--- a/inc
From: Dmitry Fleytman
Hello All,
This is v4 of e1000e series.
For convenience, the same patches are available at:
https://github.com/daynix/qemu-e1000e/tree/e1000e-submit-v4
Best regards,
Dmitry.
Changes since v3:
1. Various code fixes as suggested by Jason and Michael
2. Rebased to the late
From: Dmitry Fleytman
Code that will be shared moved to a separate files.
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
MAINTAINERS| 5 +
hw/net/Makefile.objs | 2 +-
hw/net/e1000.c | 411 +++--
hw/net/e100
From: Dmitry Fleytman
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
hw/net/vmxnet3.c | 12 +---
1 file changed, 5 insertions(+), 7 deletions(-)
diff --git a/hw/net/vmxnet3.c b/hw/net/vmxnet3.c
index 093a71e..0a4db4d 100644
--- a/hw/net/vmxnet3.c
+++ b/hw/net/vmxnet3.c
From: Dmitry Fleytman
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
include/hw/pci/pci_regs.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/include/hw/pci/pci_regs.h b/include/hw/pci/pci_regs.h
index ba8cbe9..7a83142 100644
--- a/include/hw/pci/pci_regs.h
+++ b/include
From: Dmitry Fleytman
This function will be used by e1000e device code.
Signed-off-by: Dmitry Fleytman
Signed-off-by: Leonid Bloch
---
hw/pci/msix.c | 2 +-
include/hw/pci/msix.h | 1 +
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/hw/pci/msix.c b/hw/pci/msix.c
index b
Hi Jason,
See below...
> On 7 Apr 2016, at 10:24 AM, Jason Wang wrote:
[…]
>
+Device properties:
+
++-++-+
+| Propery name | Description| Type | Default |
++---
thanks stefan for your answer ,
i just download cygwin , mingw64 and msys2 and packages u mentioned , all
in c:/ , and i download qemu from source in c:/msys2/ , but when i run
./configure i got this error ERROR: Python not found. Use
--python=/path/to/python
[image: Images intégrées 1]
2016-04-1
It was tested on Windows & Linux hosts, on the later no obvious regressions
could be found. The guest was a Knoppix 7.6.0 live cd.
This is WIP and a RFC - it isn't meant to be upstreamed yet. The error_printf
are only for debugging and will be deleted in the final patch.
There are some comments
It was tested on Windows & Linux hosts, on the later no obvious regressions
could be found. The guest was a Knoppix 7.6.0 live cd.
This is WIP and a RFC - it isn't meant to be upstreamed yet. The error_printf
are only for debugging and will be deleted in the final patch.
There are some comments
* Call out TLS into a separate section
* Add details of the TLS protocol itself
* Emphasise that actual TLS session initiation (i.e. the TLS handshake) can
be initiated from either side (as required by the TLS standard I believe
and as actually works in practice)
* Clarify what is a requirem
Am 10.04.2016 um 11:27 schrieb Marwa Hamza:
> hello
> i'm trying to configure qemu on windows so i'm using MinGW and msys
> every time i run the script configure (./configure) an error message
> show about missing packages , i fixed those errors i installed
> pkg-config , zlib packages but the la
On 04/10/2016 04:20 PM, Marcel Apfelbaum wrote:
Hi,
I'll let Markus to continue the review, it brings very valuable
information,
I will only try to answer the questions below.
Several questions on this topic:
1. How to confirm whether a device model has non-MSI variant? AFAICT,
it is these
hello
i'm trying to configure qemu on windows so i'm using MinGW and msys
every time i run the script configure (./configure) an error message show
about missing packages , i fixed those errors i installed pkg-config ,
zlib packages but the last error i couldn't fix it
ERROR: glib-2.12 gthread-2.
Eric,
Thanks. In v7 I've taken all of these, save where indicated
(or as described) below.
>> +If the server receives `NBD_OPT_STARTTLS` it MUST reply with
>
> Worth mentioning 'prior to initiating TLS', since...
> ...the behavior after initiating TLS is required to be different?
As you point o
* Call out TLS into a separate section
* Add details of the TLS protocol itself
* Emphasise that actual TLS session initiation (i.e. the TLS handshake) can
be initiated from either side (as required by the TLS standard I believe
and as actually works in practice)
* Clarify what is a requirem
On 03/28/2016 10:32 AM, Marcel Apfelbaum wrote:
Signed-off-by: Marcel Apfelbaum
Ping.
Thanks,
Marcel
---
hw/pci/pci.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/hw/pci/pci.c b/hw/pci/pci.c
index a1d41aa..da8b0b6 100644
--- a/hw/pci/pci.c
+++ b/hw/pci/pci.c
On 03/28/2016 10:23 AM, Marcel Apfelbaum wrote:
Fix 'error: shift exponent -1 is negative' warning
by adding a corresponding assert.
Ping.
Thanks,
Marcel
Reported-by: Peter Maydell
Signed-off-by: Markus Armbruster
Signed-off-by: Marcel Apfelbaum
---
hw/pci/pci.c | 4
1 file chang
On 04/09/2016 03:19 PM, Cao jin wrote:
Hi
On 04/08/2016 04:44 PM, Markus Armbruster wrote:
diff --git a/hw/ide/ich.c b/hw/ide/ich.c
index 0a13334..db4fdb5 100644
--- a/hw/ide/ich.c
+++ b/hw/ide/ich.c
@@ -146,7 +146,7 @@ static void pci_ich9_ahci_realize(PCIDevice *dev, Error
**errp)
/*
On 04/05/2016 02:26 PM, Cao jin wrote:
All the other devices` .realize function name are xxx_realize, except this one
Signed-off-by: Cao jin
CC: Paolo Bonzini
---
hw/scsi/mptsas.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/hw/scsi/mptsas.c b/hw/scsi/mptsas.c
ind
On 04/05/2016 02:26 PM, Cao jin wrote:
Nobody use its return value, so change the type to void
Signed-off-by: Cao jin
CC: Paolo Bonzini
CC: Dmitry Fleytman
---
hw/scsi/vmw_pvscsi.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/hw/scsi/vmw_pvscsi.c b/hw/scsi/vmw_pvs
On 04/08/2016 10:16 AM, Markus Armbruster wrote:
Please use a more descriptive title. Suggest "megasas: Fix
Cao jin writes:
msi_init returns non-zero value on both failure and success
This is a sentence, should end with a period.
Bug's impact? Here's my guess.
msi_init() either succeeds
71 matches
Mail list logo