Re: [Qemu-devel] [PATCH RFC 0/8] scsi-disk: Active/passive ALUA support

2015-12-13 Thread Hannes Reinecke
On 12/14/2015 08:24 AM, Stefan Hajnoczi wrote: On Thu, Dec 10, 2015 at 10:13:17AM +0100, Hannes Reinecke wrote: On 12/10/2015 09:26 AM, Stefan Hajnoczi wrote: On Fri, Nov 27, 2015 at 03:58:58PM +0100, Hannes Reinecke wrote: here's now an updated version to enable ALUA and simplified active/pas

Re: [Qemu-devel] [PATCH v3 5/7] vmxnet3: The vmxnet3 device is a PCIE endpoint

2015-12-13 Thread Shmulik Ladkani
Thanks Jason, On Mon, 14 Dec 2015 14:24:36 +0800, jasow...@redhat.com wrote: > > +static void vmxnet3_realize(DeviceState *qdev, Error **errp) > > +{ > > +VMXNET3Class *vc = VMXNET3_DEVICE_GET_CLASS(qdev); > > +PCIDevice *pci_dev = PCI_DEVICE(qdev); > > +VMXNET3State *s = VMXNET3(qdev)

Re: [Qemu-devel] Question about nonblocking stderr and lost logs

2015-12-13 Thread Stefan Hajnoczi
On Mon, Dec 14, 2015 at 04:19:50PM +1100, Sam Bobroff wrote: > On Thu, Dec 10, 2015 at 04:37:22PM +0800, Stefan Hajnoczi wrote: > > On Mon, Dec 07, 2015 at 02:22:18PM +1100, Sam Bobroff wrote: > > > On Fri, Dec 04, 2015 at 02:33:01PM +0800, Stefan Hajnoczi wrote: > > > > On Mon, Nov 30, 2015 at 04:

Re: [Qemu-devel] [PATCH RFC 0/8] scsi-disk: Active/passive ALUA support

2015-12-13 Thread Stefan Hajnoczi
On Thu, Dec 10, 2015 at 10:13:17AM +0100, Hannes Reinecke wrote: > On 12/10/2015 09:26 AM, Stefan Hajnoczi wrote: > >On Fri, Nov 27, 2015 at 03:58:58PM +0100, Hannes Reinecke wrote: > >>here's now an updated version to enable ALUA and simplified > >>active/passive multipath support for qemu. > >> >

Re: [Qemu-devel] [RFC PATCH 0/3] x86: Add support for guest DMA dirty page tracking

2015-12-13 Thread Yang Zhang
On 2015/12/14 13:46, Alexander Duyck wrote: On Sun, Dec 13, 2015 at 9:22 PM, Yang Zhang wrote: On 2015/12/14 12:54, Alexander Duyck wrote: On Sun, Dec 13, 2015 at 6:27 PM, Yang Zhang wrote: On 2015/12/14 5:28, Alexander Duyck wrote: This patch set is meant to be the guest side code for

[Qemu-devel] [RFC] qemu-system-arm: cortex-m gdb registers

2015-12-13 Thread Christopher Friedt
* allow overriding the default xml descriptor with gdb_xml_descriptor() * read cortex-m registers using arm_cortexm_gdb_read_register() * write cortex-m registers using arm_cortexm_gdb_write_register() * correct the number of cortex-m core regs to 23 Signed-off-by: Christopher Friedt --- gdbstub

[Qemu-devel] [RFC] qemu-system-arm: cortex-m gdb registers

2015-12-13 Thread Christopher Friedt
At least for Cortex-M3 devices (but also M0, M0+, M4, ...), while JTAG debugging using OpenOCD's built-in GDB server, the general purpose register layout (i.e. `info reg' in GDB) should contain slightly more than the usual ARM core registers. The non-addressable core registers that appear in O

Re: [Qemu-devel] [PATCH v3 6/7] vmxnet3: Introduce 'x-disable-pcie' backword compatability property

2015-12-13 Thread Jason Wang
On 12/12/2015 08:00 PM, Shmulik Ladkani wrote: > Following the previous patch which changed vmxnet3 to be a pci express > device, this patch introduces a boolean property 'x-disable-pcie' whose > default is false. > > Setting 'x-disable-pcie' to 'on' preserves the old 'pci device' (non > express)

Re: [Qemu-devel] [RFC PATCH v0 0/9] Generic cpu-core device

2015-12-13 Thread Bharata B Rao
On Thu, Dec 10, 2015 at 03:25:53PM -0500, Matthew Rosato wrote: > On 12/10/2015 01:15 AM, Bharata B Rao wrote: > > Hi, > > > > This is an attempt to define a generic CPU device that serves as a > > containing device to underlying arch-specific CPU devices. The motivation > > for this is to have an

Re: [Qemu-devel] [PATCH v3 5/7] vmxnet3: The vmxnet3 device is a PCIE endpoint

2015-12-13 Thread Jason Wang
On 12/12/2015 08:00 PM, Shmulik Ladkani wrote: > Report the 'express endpoint' capability if on a PCIE bus. > > Signed-off-by: Shmulik Ladkani > --- > hw/net/vmxnet3.c | 53 - > 1 file changed, 52 insertions(+), 1 deletion(-) > > diff --git a/

Re: [Qemu-devel] [PATCH v3 3/7] vmxnet3: Introduce 'x-old-msi-offsets' backword compatability property

2015-12-13 Thread Jason Wang
On 12/12/2015 08:00 PM, Shmulik Ladkani wrote: > Following the previous patches, where vmxnet3's pci's msi/msix > capability offsets and msix's PBA table offsets have been changed, this > patch introduces a boolean property 'x-old-msi-offsets' to vmxnet3, > whose default is false. > > Setting 'x-

Re: [Qemu-devel] [PATCH v3 0/4] fix debug macro pattern for vmxnet3

2015-12-13 Thread Jason Wang
On 12/08/2015 02:29 PM, Dmitry Fleytman wrote: > > Reviewed-by: Dmitry Fleytman > > >> On 8 Dec 2015, at 07:28 AM, Miao Yan > > wrote: >> >> This patchset fixes debug macro pattern for vmxnet3. The old style uses >> #ifdef...#else...#endif

Re: [Qemu-devel] [RFC PATCH 0/3] x86: Add support for guest DMA dirty page tracking

2015-12-13 Thread Alexander Duyck
On Sun, Dec 13, 2015 at 9:22 PM, Yang Zhang wrote: > On 2015/12/14 12:54, Alexander Duyck wrote: >> >> On Sun, Dec 13, 2015 at 6:27 PM, Yang Zhang >> wrote: >>> >>> On 2015/12/14 5:28, Alexander Duyck wrote: This patch set is meant to be the guest side code for a proof of concept >

Re: [Qemu-devel] [RFC PATCH 0/3] x86: Add support for guest DMA dirty page tracking

2015-12-13 Thread Yang Zhang
On 2015/12/14 12:54, Alexander Duyck wrote: On Sun, Dec 13, 2015 at 6:27 PM, Yang Zhang wrote: On 2015/12/14 5:28, Alexander Duyck wrote: This patch set is meant to be the guest side code for a proof of concept involving leaving pass-through devices in the guest during the warm-up phase of gu

Re: [Qemu-devel] Question about nonblocking stderr and lost logs

2015-12-13 Thread Sam Bobroff
On Thu, Dec 10, 2015 at 04:37:22PM +0800, Stefan Hajnoczi wrote: > On Mon, Dec 07, 2015 at 02:22:18PM +1100, Sam Bobroff wrote: > > On Fri, Dec 04, 2015 at 02:33:01PM +0800, Stefan Hajnoczi wrote: > > > On Mon, Nov 30, 2015 at 04:34:47PM +1100, Sam Bobroff wrote: > > > > Hi QEMU programmers, > > >

Re: [Qemu-devel] HTTP access to QEMU Git repositories

2015-12-13 Thread Stefan Hajnoczi
On Thu, Dec 10, 2015 at 04:58:35PM +0800, Stefan Hajnoczi wrote: > On Wed, Dec 09, 2015 at 06:22:35PM +0100, Paolo Bonzini wrote: > > On 09/12/2015 18:14, Liguori, Anthony wrote: > > > Alex Bennee and Andreas also should have access as owners. I've just > > > sent an invite to add Paolo as an owne

Re: [Qemu-devel] [RFC PATCH 0/3] x86: Add support for guest DMA dirty page tracking

2015-12-13 Thread Alexander Duyck
On Sun, Dec 13, 2015 at 6:27 PM, Yang Zhang wrote: > On 2015/12/14 5:28, Alexander Duyck wrote: >> >> This patch set is meant to be the guest side code for a proof of concept >> involving leaving pass-through devices in the guest during the warm-up >> phase of guest live migration. In order to ac

Re: [Qemu-devel] [RFC PATCH 0/3] x86: Add support for guest DMA dirty page tracking

2015-12-13 Thread Yang Zhang
On 2015/12/14 5:28, Alexander Duyck wrote: This patch set is meant to be the guest side code for a proof of concept involving leaving pass-through devices in the guest during the warm-up phase of guest live migration. In order to accomplish this I have added a new function called dma_mark_dirty

Re: [Qemu-devel] [PATCH 06/11] pseries: Improve error handling in find_unknown_sysbus_device()

2015-12-13 Thread David Gibson
On Fri, Dec 11, 2015 at 10:49:40AM +0100, Thomas Huth wrote: > On 11/12/15 01:11, David Gibson wrote: > > Use error_setg() to return an error instead of using an explicit exit(). > > > > Signed-off-by: David Gibson > > --- > > hw/ppc/spapr.c | 9 + > > 1 file changed, 5 insertions(+), 4

Re: [Qemu-devel] [PATCH 01/11] ppc: Cleanup error handling in ppc_set_compat()

2015-12-13 Thread David Gibson
On Fri, Dec 11, 2015 at 06:58:12AM -0700, Eric Blake wrote: > On 12/10/2015 05:11 PM, David Gibson wrote: > > Current ppc_set_compat() returns -1 for errors, and also (unconditionally) > > reports an error message. The caller in h_client_architecture_support() > > may then report it again using an

Re: [Qemu-devel] [PATCH 07/11] pseries: Cleanup error handling in spapr_kvm_type()

2015-12-13 Thread David Gibson
On Fri, Dec 11, 2015 at 11:01:37AM +0100, Thomas Huth wrote: > On 11/12/15 01:11, David Gibson wrote: > > Use error_setg() and &error_fatal instead of an explicit exit(). > > > > Signed-off-by: David Gibson > > --- > > hw/ppc/spapr.c | 4 ++-- > > 1 file changed, 2 insertions(+), 2 deletions(-)

Re: [Qemu-devel] [PATCH 09/11] pseries: Clean up error handling in xics_system_init()

2015-12-13 Thread David Gibson
On Fri, Dec 11, 2015 at 11:08:59AM +0100, Thomas Huth wrote: > On 11/12/15 01:11, David Gibson wrote: > > Use the error handling infrastructure to pass an error out from > > try_create_xics() instead of assuming &error_abort - the caller is in a > > better position to decide on error handling polic

Re: [Qemu-devel] [PATCH 02/11] pseries: Cleanup error handling of spapr_cpu_init()

2015-12-13 Thread David Gibson
On Fri, Dec 11, 2015 at 07:54:48AM -0700, Eric Blake wrote: > On 12/10/2015 05:11 PM, David Gibson wrote: > > Currently spapr_cpu_init() is hardcoded to handle any errors as fatal. > > That works for now, since it's only called from initial setup where an > > error here means we really can't procee

Re: [Qemu-devel] [PATCH 05/11] pseries: Cleanup error handling in spapr_vga_init()

2015-12-13 Thread David Gibson
On Fri, Dec 11, 2015 at 10:35:58AM +0100, Thomas Huth wrote: > On 11/12/15 01:11, David Gibson wrote: > > Use error_setg() to return an error rather than an explicit exit(). > > Previously it was an exit(0) instead of a non-zero exit code, which was > > simply a bug. > > > > Also improve the error

Re: [Qemu-devel] [PATCH 06/11] pseries: Improve error handling in find_unknown_sysbus_device()

2015-12-13 Thread David Gibson
On Fri, Dec 11, 2015 at 08:15:39AM -0700, Eric Blake wrote: > On 12/10/2015 05:11 PM, David Gibson wrote: > > Use error_setg() to return an error instead of using an explicit exit(). > > > > Signed-off-by: David Gibson > > --- > > hw/ppc/spapr.c | 9 + > > 1 file changed, 5 insertions(+)

Re: [Qemu-devel] [PATCH 11/11] pseries: Clean up error reporting in htab migration functions

2015-12-13 Thread David Gibson
On Fri, Dec 11, 2015 at 08:22:59AM -0700, Eric Blake wrote: > On 12/10/2015 05:11 PM, David Gibson wrote: > > The functions for migrating the hash page table on pseries machine type > > (htab_save_setup() and htab_load()) can report some errors with an > > explicit fprintf() before returning an app

Re: [Qemu-devel] [PATCH 02/11] pseries: Cleanup error handling of spapr_cpu_init()

2015-12-13 Thread David Gibson
On Fri, Dec 11, 2015 at 02:15:38PM +0530, Bharata B Rao wrote: > On Fri, Dec 11, 2015 at 5:41 AM, David Gibson > wrote: > > Currently spapr_cpu_init() is hardcoded to handle any errors as fatal. > > That works for now, since it's only called from initial setup where an > > error here means we real

Re: [Qemu-devel] [PATCH 03/11] pseries: Clean up hash page table allocation error handling

2015-12-13 Thread David Gibson
On Fri, Dec 11, 2015 at 08:01:39AM -0700, Eric Blake wrote: > On 12/10/2015 05:11 PM, David Gibson wrote: > > The spapr_alloc_htab() and spapr_reset_htab() functions currently handle > > all errors with error_setg(&error_abort, ...). That's correct for > > spapr_reset_htab() - if anything goes wro

Re: [Qemu-devel] [PATCH 03/11] pseries: Clean up hash page table allocation error handling

2015-12-13 Thread David Gibson
On Fri, Dec 11, 2015 at 02:10:40PM +0530, Bharata B Rao wrote: > On Fri, Dec 11, 2015 at 5:41 AM, David Gibson > wrote: > > The spapr_alloc_htab() and spapr_reset_htab() functions currently handle > > all errors with error_setg(&error_abort, ...). That's correct for > > spapr_reset_htab() - if an

Re: [Qemu-devel] [PATCH 06/11] ppc: cleanup logging

2015-12-13 Thread David Gibson
On Sat, Dec 12, 2015 at 11:36:22AM +0100, Paolo Bonzini wrote: > Avoid "naked" qemu_log, bring documentation for DEBUG #defines > up to date. > > Cc: David Gibson > Signed-off-by: Paolo Bonzini Reviewed-by: David Gibson -- David Gibson| I'll have my music baroque, and my c

Re: [Qemu-devel] live migration vs device assignment (motivation)

2015-12-13 Thread Alexander Duyck
On Sun, Dec 13, 2015 at 7:47 AM, Lan, Tianyu wrote: > > > On 12/11/2015 1:16 AM, Alexander Duyck wrote: >> >> On Thu, Dec 10, 2015 at 6:38 AM, Lan, Tianyu wrote: >>> >>> >>> >>> On 12/10/2015 7:41 PM, Dr. David Alan Gilbert wrote: > > > Ideally, it is able to leave guest driver unmodi

[Qemu-devel] [Bug 1525682] Re: configure: fix POSIX compatibility issue

2015-12-13 Thread Dmitrij D. Czarkoff
Sorry, wrong patch. ** Patch added: "0001-configure-fix-POSIX-compatibility-issue.patch" https://bugs.launchpad.net/qemu/+bug/1525682/+attachment/4534158/+files/0001-configure-fix-POSIX-compatibility-issue.patch ** Patch removed: "0001-configure-fix-POSIX-compatibility-issue.patch" https:

[Qemu-devel] [Bug 1525682] [NEW] configure: fix POSIX compatibility issue

2015-12-13 Thread Dmitrij D. Czarkoff
Public bug reported: When running configure script from 2.5.0-rc4 on OpenBSD-current (amd64), I get the following error: ./configure[4756]: ${nettle:+($nettle_version)}": bad substitution *** Error 1 in . (/usr/ports/infrastructure/mk/bsd.port.mk:2747 '/usr/ports/pobj/qemu-2.5.0rc4/.configur

Re: [Qemu-devel] live migration vs device assignment (motivation)

2015-12-13 Thread Lan, Tianyu
On 12/11/2015 1:16 AM, Alexander Duyck wrote: On Thu, Dec 10, 2015 at 6:38 AM, Lan, Tianyu wrote: On 12/10/2015 7:41 PM, Dr. David Alan Gilbert wrote: Ideally, it is able to leave guest driver unmodified but it requires the hypervisor or qemu to aware the device which means we may need a

Re: [Qemu-devel] [PATCH 00/74] pc: acpi: convert DSDT to AML API and drop ASL templates support

2015-12-13 Thread Marcel Apfelbaum
On 12/10/2015 06:31 PM, Igor Mammedov wrote: On Thu, 10 Dec 2015 17:53:31 +0200 Marcel Apfelbaum wrote: [...] Hi Igor, Please consider splinting this series... Maybe ACPI new constructs first, then memhp/cpu, piix/q35. (only a suggestion) In this you will have some "sane" 20 something patches

Re: [Qemu-devel] [PATCH v2 58/74] pc: acpi: piix4: move PCI0._PRT() into SSDT

2015-12-13 Thread Marcel Apfelbaum
On 12/10/2015 06:17 PM, Igor Mammedov wrote: Signed-off-by: Igor Mammedov --- v2: - adapt build_prt() for using for PCI0._PRT(), reduces code duplication, Suggested-by: Marcel Apfelbaum pc: acpi: piix4: adapt build_prt() for using for PCI0._PRT() Signed-off-by: Igor Mammedov --- hw/i

Re: [Qemu-devel] net: vmxnet3: memory leakage issue

2015-12-13 Thread Dmitry Fleytman
Hello Prasad, On 9 Dec 2015, at 17:28 PM, P J P wrote: > > Hello Jason, Dmitry, > > +-- On Tue, 8 Dec 2015, P J P wrote --+ > | |1) VMXNET3_CMD_QUIESCE_DEV > | > | IIUC, it is used to pause the device when the receiver end is unable to > | keee-up with the incoming flow. After a brief per

Re: [Qemu-devel] net: vmxnet3: memory leakage issue

2015-12-13 Thread Dmitry Fleytman
> On 11 Dec 2015, at 12:04 PM, P J P wrote: > > Hello Jason, > > +-- On Fri, 11 Dec 2015, Jason Wang wrote --+ > | I think it's possible for attacker. Better wait for Dmitry's answer for > | this. > > Okay. > > | > +/* Verify if device is active */ > | > +if (s->device_active) { > |

Re: [Qemu-devel] [PATCH v2 0/6] pvscsi: Fine-tune device capabilities

2015-12-13 Thread Dmitry Fleytman
Acked-by: Dmitry Fleytman mailto:dmi...@daynix.com>> > On 13 Dec 2015, at 10:08 AM, Shmulik Ladkani > wrote: > > Various fixes to what the vmw_pvscsi device reports in its PCI > configuration space, to better align with VMware virtual hardware > as exposed by ESXi/Workstation. > > Since v1: Ad

[Qemu-devel] [PATCH v2 6/6] vmw_pvscsi: Introduce 'x-disable-pcie' backword compatability property

2015-12-13 Thread Shmulik Ladkani
Following the previous patch which changed pvscsi to be a pci express device, this patch introduces a boolean property 'x-disable-pcie'. Its default value is false, exposing pvscsi as a pcie device. Setting 'x-disable-pcie' to 'on' preserves the old 'pci device' (non express) behavior. This allow

[Qemu-devel] [PATCH v2 2/6] vmw_pvscsi: Change offset of msi pci capability

2015-12-13 Thread Shmulik Ladkani
Place device reported MSI capability at the same offset as placed by the VMware virtual hardware - at offset 0x7c. Signed-off-by: Shmulik Ladkani --- hw/scsi/vmw_pvscsi.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/hw/scsi/vmw_pvscsi.c b/hw/scsi/vmw_pvscsi.c index ce

[Qemu-devel] [PATCH v2 4/6] vmw_pvscsi: coding: Introduce PVSCSIClass

2015-12-13 Thread Shmulik Ladkani
Introduce a class type for pvscsi, and the usual DEVICE_CLASS/DEVICE_GET_CLASS macros. No semantic change. Signed-off-by: Shmulik Ladkani --- hw/scsi/vmw_pvscsi.c | 10 ++ 1 file changed, 10 insertions(+) diff --git a/hw/scsi/vmw_pvscsi.c b/hw/scsi/vmw_pvscsi.c index e785b8b..00d6900 1

[Qemu-devel] [PATCH v2 5/6] vmw_pvscsi: The pvscsi device is a PCIE endpoint

2015-12-13 Thread Shmulik Ladkani
Report the 'express endpoint' capability if on a PCIE bus. Signed-off-by: Shmulik Ladkani --- hw/scsi/vmw_pvscsi.c | 54 +++- 1 file changed, 53 insertions(+), 1 deletion(-) diff --git a/hw/scsi/vmw_pvscsi.c b/hw/scsi/vmw_pvscsi.c index 00d6900..f

[Qemu-devel] [PATCH v2 3/6] vmw_pvscsi: Introduce 'x-old-pci-configuration' backword compatability property

2015-12-13 Thread Shmulik Ladkani
Following the previous patches, which introduced various changes in pvscsi's pci configuration space (device subsystem id and revision, msi offset), this patch introduces a boolean property 'x-old-pci-configuration' to pvscsi. Its default value is false, exposing the above changes in the pci confi

[Qemu-devel] [PATCH v2 1/6] vmw_pvscsi: Set device subsystem and revision

2015-12-13 Thread Shmulik Ladkani
To be VMware PVSCSI SCSI Controller, rev 02. As reported by the VMware virtual hardware. Signed-off-by: Shmulik Ladkani --- hw/scsi/vmw_pvscsi.c | 23 --- 1 file changed, 20 insertions(+), 3 deletions(-) diff --git a/hw/scsi/vmw_pvscsi.c b/hw/scsi/vmw_pvscsi.c index 9c71f31.

[Qemu-devel] [PATCH v2 0/6] pvscsi: Fine-tune device capabilities

2015-12-13 Thread Shmulik Ladkani
Various fixes to what the vmw_pvscsi device reports in its PCI configuration space, to better align with VMware virtual hardware as exposed by ESXi/Workstation. Since v1: Added compatability properties for migration Shmulik Ladkani (6): vmw_pvscsi: Set device subsystem and revision vmw_pvscsi