On Fr, 2015-01-16 at 14:08 -0500, Don Koch wrote:
> Signed-off-by: Don Koch
> +trace_do_mouse_set(mon, index);
First, I think we should have a better name for that one, maybe
"input_mouse_set" ?
Second I'm wondering what the use case is. The place is a bit strange
(tracing management not g
On Mo, 2015-01-19 at 11:42 +0800, arei.gong...@huawei.com wrote:
> It's important to match g_malloc() with g_free(), plain
> malloc() with free(). Otherwise bad things can happen,
> since these allocators may use different memory pools.
added to usb queue.
thanks,
Gerd
When add a qdev device to bus, bus_add_child will be called.
But in this function, the new device is inserted to the head
of the list. That means the sequence will be reversed.
For example, if there are three virtio-scsi devices with
lun 0 to 2 in the same controller, in the Guest, device with
lu
On 2015-01-17 19:55:16, Peter Maydell wrote:
>On 17 January 2015 at 11:52, Peter Maydell wrote:
> > On 17 January 2015 at 06:48, Zhang Haoyu wrote:
> >> G_IO_OUT|G_IO_HUP are passed from all of the callers
> >> of chr_add_watch hooker, the assert condition MUST be
> >> changed.
>>
> > "All the c
On Tue, Dec 23, 2014 at 06:30:26AM -0600, Michael Roth wrote:
> This option enables/disables PCI hotplug for a particular PHB.
>
> Also add machine compatibility code to disable it by default for machine
> types prior to pseries-2.3.
>
> Signed-off-by: Michael Roth
Reviewed-by: David Gibson
-
On Tue, Dec 23, 2014 at 06:30:30AM -0600, Michael Roth wrote:
> This enables hotplug for PHB bridges. Upon hotplug we generate the
> OF-nodes required by PAPR specification and IEEE 1275-1994
> "PCI Bus Binding to Open Firmware" for the device.
>
> We associate the corresponding FDT for these node
On Tue, Dec 23, 2014 at 06:30:29AM -0600, Michael Roth wrote:
You need a commit message with a rationale for this.
> Signed-off-by: Michael Roth
> ---
> hw/pci/pci.c | 2 +-
> include/hw/pci/pci.h | 1 +
> 2 files changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/hw/pci/pci.c b/
On Tue, Dec 23, 2014 at 06:30:24AM -0600, Michael Roth wrote:
> This function handles generation of ibm,drc-* array device tree
> properties to describe DRC topology to guests. This will by used
> by the guest to direct RTAS calls to manage any dynamic resources
> we associate with a particular DR
On Tue, Dec 23, 2014 at 06:30:31AM -0600, Michael Roth wrote:
> From: Tyrel Datwyler
>
> This uses extension of existing EPOW interrupt/event mechanism
> to notify userspace tools like librtas/drmgr to handle
> in-guest configuration/cleanup operations in response to
> device_add/device_del.
>
>
On Tue, Dec 23, 2014 at 06:30:27AM -0600, Michael Roth wrote:
> These will be used to support hotplug/unplug of PCI devices to the PCI
> bus associated with a particular PHB.
>
> Signed-off-by: Michael Roth
Reviewed-by: David Gibson
--
David Gibson| I'll have my music baro
On Tue, Dec 23, 2014 at 06:30:28AM -0600, Michael Roth wrote:
> Reserve 32 entries of type PCI in each PHB's initial FDT. This
> advertises to guests that each PHB is DR-capable device with
> physical hotpluggable slots. This is necessary for allowing
> hotplugging of devices to it later via bus re
On Tue, Dec 23, 2014 at 06:30:25AM -0600, Michael Roth wrote:
> And make it the default. This is identical to pseries-2.2 for now,
> but subsequent commits will use it to enable pseries-2.3+ features.
>
> Signed-off-by: Michael Roth
Reviewed-by: David Gibson
I think this should go in immediate
On Tue, Dec 23, 2014 at 06:30:23AM -0600, Michael Roth wrote:
> From: Tyrel Datwyler
>
> We don't actually rely on this interface to surface hotplug events, and
> instead rely on the similar-but-interrupt-driven check-exception RTAS
> interface used for EPOW events. However, the existence of this
On Tue, Dec 23, 2014 at 06:30:22AM -0600, Michael Roth wrote:
> From: Nathan Fontenot
>
> This extends the data structures currently used to report EPOW events to
> gets via the check-exception RTAS interfaces to also include event types
> for hotplug/unplug events.
>
> This is currently undocum
From: Gonglei
Signed-off-by: Gonglei
---
hw/core/fw-path-provider.c | 2 +-
hw/ppc/spapr.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/hw/core/fw-path-provider.c b/hw/core/fw-path-provider.c
index 1290c3e..7442d32 100644
--- a/hw/core/fw-path-provider.c
++
On Tue, Dec 23, 2014 at 06:30:21AM -0600, Michael Roth wrote:
This really wants a commit message explaining in outline what
configure_connector does.
> Signed-off-by: Michael Roth
> ---
> hw/ppc/spapr_rtas.c | 81
> +
> 1 file changed, 81 ins
On Tue, Dec 23, 2014 at 06:30:20AM -0600, Michael Roth wrote:
> This is similar to the existing rtas_st_buffer(), but for case where
> the guest is not expecting a length-encoded byte array. Namely,
> for calls where an "work area" buffer is used to pass around
> arbitrary fields/data.
>
> Signed-
From: Gonglei
It's important to match g_malloc() with g_free(), plain
malloc() with free(). Otherwise bad things can happen,
since these allocators may use different memory pools.
Signed-off-by: Gonglei
---
hw/usb/desc-msos.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/
Hi,
At present, vhost-scsi device do not boot in Qemu, but some clients/users have
requirements for that in some scenarios. Of course if we want complete the
aim we should make some changes both Qemu and kernel (vhost-scsi driver
module, it need to add an IOCTL interface to get target_id/lun_id et
On Fri, 01/16 13:22, John Snow wrote:
>
>
> On 01/13/2015 04:24 AM, Fam Zheng wrote:
> >On Mon, 01/12 11:31, John Snow wrote:
> >>A bitmap successor is an anonymous BdrvDirtyBitmap that is intended to
> >>be created just prior to a sensitive operation (e.g. Incremental Backup)
> >>that can either
Excuse me, gmail is broken in China, during these days, I can only login
in gmail web site via my Mac book Safari (which can not send pure text
mail), so I have to use my another mail address to send patch.
Thanks.
On 1/19/15 00:22, Chen Gang S wrote:
> For tcg_target_ulong (include TCGArg), it
On 02/01/15 17:30, Peter Maydell wrote:
> On 2 January 2015 at 13:57, Mark Cave-Ayland
> wrote:
>> On 23/12/14 22:11, Peter Maydell wrote:
>>> These patches fix warnings generated by clang. Patches 1-3
>>> have been onlist before (and reviewed by RTH) but didn't get
>>> applied I think because of
> On 12/29/2014 03:38 PM, Roy Vardi wrote:
> >
> >
> >
> >
> >
> > > -Original Message-
> >
> > > From: Jason Wang [mailto:jasow...@redhat.com]
> >
> > > Sent: Tuesday, December 23, 2014 11:13 AM
> >
> > > To: Roy Vardi
> >
> > > Cc: qemu-devel@nongnu.org; stefa...@redhat.com; Noam Camus;
>
23 matches
Mail list logo