01.04.2014 03:05, Hani Benhabiles wrote:
> Also convert nearby monitor_printf() call to error_report().
Applied to -trivial, thank you!
/mjt
26.03.2014 15:45, Paolo Bonzini wrote:
> This is the model file that is being used for the QEMU project's scans
> on scan.coverity.com. It fixed about 30 false positives (10% of the
> total) and exposed about 60 new memory leaks.
>
> The file is not automatically used; changes to it must be propa
04.04.2014 19:25, Amos Kong пишет:
> We mixed the use of "guest time", "system time", "hardware time",
> "RTC" in documentation, it's unclear.
>
> This patch just added two remarks of RTC and replace two "guest time"
> by "guest's system time".
Applied to -trivial, thank you!
/mjt
31.03.2014 22:51, Peter Maydell wrote:
> The help text for the --enable-debug-info and --disable-debug-info
> command line options was misindented: delete the stray extra space
> and bring it in to line with everything else.
Applied to -trivial, thanks!
/mjt
04.04.2014 13:39, Chen Gang wrote:
> When you ask for an accelerator not supported for your target, you get
> a bogus "accelerator does not exist" message:
>
> $ qemu-system-arm -machine none,accel=kvm
> KVM not supported for this target
> "kvm" accelerator does not exist.
> No accelerator
06.04.2014 04:52, Fam Zheng wrote:
> On Sat, 04/05 18:29, Michael Tokarev wrote:
>> A quick (hopefully) question.
>>
>> Why build-as-modules only enabled for a few optional modules only,
>> why not build as modules everything, to reduce common executable
>> size? Or is it not a concern anymore at
This patch fixed the following bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1084302 .
path_combine can not calculate the correct full path name for backing_file.
Such as:
create a snapshot chain:
sn2->sn1->$BASE_IMG
backing file is : /home/wookpecker/img.qcow2
sn1 : /home/woodpecker/tmp/sn1
sn2
There are 3 different variants of the decrementor for BookE and BookS.
The BookE variant sets TSR[DIS] to 1 when the DEC value becomes 1 or 0. TSR[DIS]
is then the indicator whether the decrementor interrupt line is asserted or not.
The old BookS variant treats DEC as an edge interrupt that gets
On Sat, 04/05 18:29, Michael Tokarev wrote:
> A quick (hopefully) question.
>
> Why build-as-modules only enabled for a few optional modules only,
> why not build as modules everything, to reduce common executable
> size? Or is it not a concern anymore at our disk sizes? :)
>
The original deman
On 5 April 2014 21:50, Hervé Poussineau wrote:
> Le sam. 05 avril 2014 22:34:38 CEST, Alexander Graf a écrit :
>> It means "default endianness of the guest cpu" so that accesses coming
>> from the CPU get passed in the value they had in the CPU registers :).
>
>
> In that case, behaviour should be
Le sam. 05 avril 2014 22:34:38 CEST, Alexander Graf a écrit :
On 05.04.2014, at 22:26, Hervé Poussineau wrote:
Hi Andreas,
Le sam. 05 avril 2014 17:41:43 CEST, Andreas Färber a écrit :
Hi Hervé,
Am 20.03.2014 00:36, schrieb Andreas Färber:
From: Hervé Poussineau
Remove now duplicated co
On 05.04.2014, at 22:26, Hervé Poussineau wrote:
> Hi Andreas,
>
> Le sam. 05 avril 2014 17:41:43 CEST, Andreas Färber a écrit :
>> Hi Hervé,
>>
>> Am 20.03.2014 00:36, schrieb Andreas Färber:
>>> From: Hervé Poussineau
>>>
>>> Remove now duplicated code from prep board.
>>>
>>> Signed-off-
Hi Andreas,
Le sam. 05 avril 2014 17:41:43 CEST, Andreas Färber a écrit :
Hi Hervé,
Am 20.03.2014 00:36, schrieb Andreas Färber:
From: Hervé Poussineau
Remove now duplicated code from prep board.
Signed-off-by: Hervé Poussineau
Signed-off-by: Andreas Färber
---
hw/pci-host/prep.c | 85 +
This patch fixed the following bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1084302 .
path_combine can not calculate the correct full path name for backing_file.
Such as:
create a snapshot chain:
sn2->sn1->$BASE_IMG
backing file is : /home/wookpecker/img.qcow2
sn1 : /home/woodpecker/tmp/sn1
sn2
Alex Williamson writes:
> On Fri, 2014-04-04 at 18:49 -0400, Bandan Das wrote:
>> commit 4b9430294ed added an option in vfio to blacklist
>> roms that are known to be unstable. Add a similar mechanism
>> for pci-assign as well. The default behavior is to disable
>> loading but can be overriden by
Hi Hervé,
Am 20.03.2014 00:36, schrieb Andreas Färber:
> From: Hervé Poussineau
>
> Remove now duplicated code from prep board.
>
> Signed-off-by: Hervé Poussineau
> Signed-off-by: Andreas Färber
> ---
> hw/pci-host/prep.c | 85
> hw/ppc/prep.
On 05.04.2014, at 17:01, Tom Musta wrote:
> On 4/5/2014 9:39 AM, Alexander Graf wrote:
>>
>> On 05.04.14 16:31, Andreas Färber wrote:
>>> Am 04.04.2014 19:56, schrieb Peter Maydell:
On 4 April 2014 17:18, Tom Musta wrote:
> Alex, Peter:
>
> Is it too late to get this into 2.0
On 4/5/2014 9:39 AM, Alexander Graf wrote:
>
> On 05.04.14 16:31, Andreas Färber wrote:
>> Am 04.04.2014 19:56, schrieb Peter Maydell:
>>> On 4 April 2014 17:18, Tom Musta wrote:
Alex, Peter:
Is it too late to get this into 2.0?
>>> Alex's call (though my personal feeling would be
On 05.04.14 16:51, Andreas Färber wrote:
Am 04.04.2014 22:23, schrieb Thomas Falcon:
This patch allows registers to be properly read from and written to
when using the gdbstub to debug a ppc guest running in little
endian mode. It accomplishes this goal by byte swapping the values of
any regis
Am 04.04.2014 22:23, schrieb Thomas Falcon:
> This patch allows registers to be properly read from and written to
> when using the gdbstub to debug a ppc guest running in little
> endian mode. It accomplishes this goal by byte swapping the values of
> any registers if the MSR:LE value is set.
>
>
On 05.04.14 16:31, Andreas Färber wrote:
Am 04.04.2014 19:56, schrieb Peter Maydell:
On 4 April 2014 17:18, Tom Musta wrote:
Alex, Peter:
Is it too late to get this into 2.0?
Alex's call (though my personal feeling would be to
classify it as too late). It's very very late, but
this will onl
Am 04.04.2014 19:56, schrieb Peter Maydell:
> On 4 April 2014 17:18, Tom Musta wrote:
>> Alex, Peter:
>>
>> Is it too late to get this into 2.0?
>
> Alex's call (though my personal feeling would be to
> classify it as too late). It's very very late, but
> this will only affect PPC targets, at lea
A quick (hopefully) question.
Why build-as-modules only enabled for a few optional modules only,
why not build as modules everything, to reduce common executable
size? Or is it not a concern anymore at our disk sizes? :)
Thanks,
/mjt
When installing modules (when --enable-modules is specified for
./configure), Makefile uses the following construct to replace all
slashes with dashes in module name:
${s//\//-}
This is a bash-specific substitution mechanism. POSIX does not
have it, and some operating systems (for example Debia
When playing with W7 OEM activation again, I noticed that qemu
builds ACPI tables twice to feed seabios.
Here are the 2 stack traces from gdb taken at
hw/i386/acpi-build.c:build_header() when called to build RSDT:
#0 build_header (linker=0x562afcc0, table_data=0x562afc90,
h=0x563
On 2 April 2014 16:38, Michael S. Tsirkin wrote:
> On Wed, Apr 02, 2014 at 05:33:02PM +0200, Paolo Bonzini wrote:
>> The subsection already exists in one well-known enterprise Linux
>> distribution, but for some strange reason the fields were swapped
>> when forward-porting the patch to upstream.
On 4 April 2014 20:27, Kevin Wolf wrote:
> The following changes since commit 5913815a17387a5e9825c734ccab760588471ee5:
>
> Update version for v2.0.0-rc1 release (2014-04-03 15:51:01 +0100)
>
> are available in the git repository at:
>
> git://repo.or.cz/qemu/kevin.git tags/for-upstream
>
> fo
27 matches
Mail list logo