Hi,
as the subject states, I have some problems with 1G hugepages with
qemu(-vfio-git) on Linux 3.12-rc3.
I start qemu like this, for example:
"/usr/bin/qemu-system-x86_64 -enable-kvm -m 1024 -mem-path /dev/hugepages
-drive file=/files/vm/arch.img,if=virtio,media=disk -monitor stdio"
where /dev
Am 06.10.2013 00:18, schrieb Gabriel Kerneis:
> On Sun, Oct 06, 2013 at 12:54:08AM +0900, Peter Maydell wrote:
>> So this sed script appears to convert literal newlines in the input
>> Is that what's intended?
> Yes.
>
>> It doesn't seem very useful because if you cut-n-paste (or pipe)
>> 'hello\nw
On Sun, Oct 06, 2013 at 12:54:08AM +0900, Peter Maydell wrote:
> So this sed script appears to convert literal newlines in the input
> Is that what's intended?
Yes.
> It doesn't seem very useful because if you cut-n-paste (or pipe)
> 'hello\nworld' into a shell you get an actual backslash-n, not
On Sat, Oct 05, 2013 at 08:06:22PM +0200, Stefan Weil wrote:
> Am 05.10.2013 19:54, schrieb Juergen Lock:
> > On Fri, Oct 04, 2013 at 09:15:37AM +0200, Jan Kiszka wrote:
> >> On 2013-10-03 18:05, Peter Maydell wrote:
> >>> On 3 October 2013 23:09, Juergen Lock wrote:
> Local variable CPUClass
Am 05.10.2013 19:54, schrieb Juergen Lock:
> On Fri, Oct 04, 2013 at 09:15:37AM +0200, Jan Kiszka wrote:
>> On 2013-10-03 18:05, Peter Maydell wrote:
>>> On 3 October 2013 23:09, Juergen Lock wrote:
Local variable CPUClass *cc needs to be reloaded after return from longjmp
too. (This fi
On Fri, Oct 04, 2013 at 09:15:37AM +0200, Jan Kiszka wrote:
> On 2013-10-03 18:05, Peter Maydell wrote:
> > On 3 October 2013 23:09, Juergen Lock wrote:
> >> Local variable CPUClass *cc needs to be reloaded after return from longjmp
> >> too. (This fixes the mips-softmmu crash observed on FreeBSD
On 5 October 2013 23:41, Gabriel Kerneis wrote:
> Escape single quotes and newlines when writing configure arguments
> to config-host.mak. This is necessary to allow correct regeneration
> by re-executing configure in a shell when config-host.mak becomes
> out-of-date.
>
> Signed-off-by: Gabriel K
Quoting Michael Tokarev (m...@tls.msk.ru):
> 06.06.2013 12:48, David Gibson wrote:
> >pci-hotplug.c and the CONFIG_PCI_HOTPLUG variable which controls its
> >compilation are misnamed. They're not about PCI hotplug in general, but
> >rather about the pci_add/pci_del interface which are now deprecat
Escape single quotes and newlines when writing configure arguments
to config-host.mak. This is necessary to allow correct regeneration
by re-executing configure in a shell when config-host.mak becomes
out-of-date.
Signed-off-by: Gabriel Kerneis
---
configure | 6 +-
1 file changed, 5 inserti
From: "Corey J. Boyle"
Use target address rather than host address when performing
non-GOT relocations
Signed-off-by: Corey J. Boyle
---
linux-user/flatload.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/linux-user/flatload.c b/linux-user/flatload.c
index 58f679e..ceb
On Sat, Oct 5, 2013 at 4:04 AM, Peter Maydell wrote:
> On 5 October 2013 07:50, Corey J. Boyle wrote:
> > From: "Corey J. Boyle"
> >
> > Use target address rather than host address when performing
> > non-GOT relocations
> >
> > Signed-off-by: Corey J. Boyle
> > ---
> > linux-user/flatload.c |
Am 05.10.2013 11:19, schrieb Michael Tokarev:
>
> Author: Michael Tokarev
> Date: Sat Oct 5 13:18:28 2013 +0400
>
> migration: Fix compiler warning ('caps' may be used uninitialized)
>
> Signed-off-by: Michael Tokarev
>
> diff --git a/migration.c b/migration.c
> index b4f8462..2b1ab20 1
Am 05.10.2013 11:10, schrieb Michael Tokarev:
> 03.10.2013 00:40, Stefan Weil wrote:
>> While dirent->d_type is 8 bit for most systems, it is 32 bit for MinGW.
>> Reducing it to 8 bit results in a compiler warning because the macro
>> is_dir_maybe compares that 8 bit value with 32 bit constants.
>>
05.10.2013 13:15, Michael Tokarev пишет:
Okay. This takes just too long and too many people
are affected. I'll just set the variable in question
(caps) to NULL at entry for now, -- it is not a critical
path and the current code is correct anyway. This is
becoming ridiculous, when there are so
Okay. This takes just too long and too many people
are affected. I'll just set the variable in question
(caps) to NULL at entry for now, -- it is not a critical
path and the current code is correct anyway. This is
becoming ridiculous, when there are so many different
opinions about such a trivi
03.10.2013 00:40, Stefan Weil wrote:
While dirent->d_type is 8 bit for most systems, it is 32 bit for MinGW.
Reducing it to 8 bit results in a compiler warning because the macro
is_dir_maybe compares that 8 bit value with 32 bit constants.
Using 'unsigned' instead of 'unsigned char' matches the
On 5 October 2013 07:50, Corey J. Boyle wrote:
> From: "Corey J. Boyle"
>
> Use target address rather than host address when performing
> non-GOT relocations
>
> Signed-off-by: Corey J. Boyle
> ---
> linux-user/flatload.c |4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff -
From: "Corey J. Boyle"
Use target address rather than host address when performing
non-GOT relocations
Signed-off-by: Corey J. Boyle
---
linux-user/flatload.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/linux-user/flatload.c b/linux-user/flatload.c
index 58f679e.
On 10/04/2013 02:15 PM, Claudio Fontana wrote:
> At first glance I think we should add X4 to the list of restrictions in
> function `target_parse_constraint':
No, we've consumed all of the inputs at this point. We only
need list those registers we're going to clobber before the
inputs are consum
19 matches
Mail list logo