On Sat, May 29, 2010 at 09:21:14PM +, Blue Swirl wrote:
> On Sat, May 29, 2010 at 4:37 PM, Gleb Natapov wrote:
> > On Sat, May 29, 2010 at 04:13:22PM +, Blue Swirl wrote:
> >> On Sat, May 29, 2010 at 2:46 PM, Gleb Natapov wrote:
> >> > On Sat, May 29, 2010 at 09:35:30AM +, Blue Swirl
On Sat, May 29, 2010 at 08:52:34PM +, Blue Swirl wrote:
> On Sat, May 29, 2010 at 4:32 PM, Gleb Natapov wrote:
> > On Sat, May 29, 2010 at 04:03:22PM +, Blue Swirl wrote:
> >> 2010/5/29 Gleb Natapov :
> >> > On Sat, May 29, 2010 at 09:15:11AM +, Blue Swirl wrote:
> >> >> >> There is no
On Tue, 2010-05-18 at 04:18 -0700, Nicholas A. Bellinger wrote:
> On Tue, 2010-05-18 at 11:43 +0200, Hannes Reinecke wrote:
> > Nicholas A. Bellinger wrote:
> > > On Fri, 2010-05-14 at 02:42 -0700, Nicholas A. Bellinger wrote:
> > > Greetings Hannes,
> > >
> > > So I spent some more time with XP g
I'm trying to get arm big endian support to work. I patched the 2.6.33 kernel
to pretend that good old versatilepb can have a big endian CPU plugged into it
(attached), and then I built a kernel with the attached .config, and qemu went
"boing":
$ qemu-system-arm -M versatilepb -nographic -no-r
> On Fri, May 28, 2010 at 7:34 PM, Paul Brook wrote:
> >> Use a qemu_irq to request CPU exit.
> >
> > Needing to request a CPU exit at all is just wrong. See previous
> > discussions about how any use of qemu_bh_schedule_idle is fundamentally
> > broken.
>
> I agree for the device case. Is the a
2010/5/29 Blue Swirl :
> Robert Reif did some improvements to SuperSparc emulation, but the
> work was not finished. That should be a good starting point.
Do you mean the last patch he sent to us or are there some earlier
unapplied patches?
The last patch _seems_ to be mainly refactoring and disa
Thanks, applied.
On Sat, May 29, 2010 at 8:48 PM, Artyom Tarasenko
wrote:
> SuperSPARC MMU Breakpoint Action register is used by OBP at boot
>
> The patch allows booting Solaris and some other OS with
> SPARCStation-20 OBP.
>
> Signed-off-by: Artyom Tarasenko
> ---
> target-sparc/op_helper.c |
On Sat, May 29, 2010 at 4:37 PM, Gleb Natapov wrote:
> On Sat, May 29, 2010 at 04:13:22PM +, Blue Swirl wrote:
>> On Sat, May 29, 2010 at 2:46 PM, Gleb Natapov wrote:
>> > On Sat, May 29, 2010 at 09:35:30AM +, Blue Swirl wrote:
>> >> > I still don't see how the alternative is supposed to
** Attachment added: "Test image (iso, gzipped)"
http://launchpadlibrarian.net/49329042/bootable.iso.gz
--
gfxmenu from GRUB or GRUB4DOS hang qemu.
https://bugs.launchpad.net/bugs/587344
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU
Public bug reported:
When you run the graphical menu GRUB (gfxmenu, any theme) execution stops.
Test image (iso, as an attachment):
http://www.multiupload.com/AAI7MGMOLE
Image make options:
mkisofs -R -b grldr -no-emul-boot -boot-load-seg 0x1000 -o bootable.iso
image_root/
With options and GF
On Sat, May 29, 2010 at 4:32 PM, Gleb Natapov wrote:
> On Sat, May 29, 2010 at 04:03:22PM +, Blue Swirl wrote:
>> 2010/5/29 Gleb Natapov :
>> > On Sat, May 29, 2010 at 09:15:11AM +, Blue Swirl wrote:
>> >> >> There is no code, because we're still at architecture design stage.
>> >> >>
>> >
SuperSPARC MMU Breakpoint Action register is used by OBP at boot
The patch allows booting Solaris and some other OS with
SPARCStation-20 OBP.
Signed-off-by: Artyom Tarasenko
---
target-sparc/op_helper.c |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/target-sparc/op_hel
Both bdrv_can_snapshot() and bdrv_has_snapshot() does not work as advertized.
First issue: Their names implies different porpouses, but they do the same thing
and have exactly the same code. Maybe copied and pasted and forgotten?
bdrv_has_snapshot() is called in various places for actually checkin
On Sat, May 29, 2010 at 8:51 PM, Aurelien Jarno wrote:
> On Sat, May 29, 2010 at 08:42:52PM +0200, Lars Munch wrote:
>> On Fri, May 28, 2010 at 9:24 PM, Aurelien Jarno wrote:
>> > On Sat, May 08, 2010 at 10:43:35PM +0200, Lars Munch wrote:
>> >> Booting an arm kernel has been broken a while when
On Sat, May 29, 2010 at 3:06 AM, Markus Armbruster wrote:
>
>> I seem to remember that we came to the conclusion that
>> bdrv_has_snapshot() isn't needed at all and should be dropped. Any user
>> should be using bdrv_can_snapshot() instead as this is what they really
>> want.
>
> Our reasoning ada
On Sat, May 29, 2010 at 08:42:52PM +0200, Lars Munch wrote:
> On Fri, May 28, 2010 at 9:24 PM, Aurelien Jarno wrote:
> > On Sat, May 08, 2010 at 10:43:35PM +0200, Lars Munch wrote:
> >> Booting an arm kernel has been broken a while when booting from non zero
> >> start
> >> address. This is due t
On Fri, May 28, 2010 at 9:24 PM, Aurelien Jarno wrote:
> On Sat, May 08, 2010 at 10:43:35PM +0200, Lars Munch wrote:
>> Booting an arm kernel has been broken a while when booting from non zero
>> start
>> address. This is due to the order of events: board init loads the kernel and
>> sets registe
On Sat, May 29, 2010 at 04:13:22PM +, Blue Swirl wrote:
> On Sat, May 29, 2010 at 2:46 PM, Gleb Natapov wrote:
> > On Sat, May 29, 2010 at 09:35:30AM +, Blue Swirl wrote:
> >> > I still don't see how the alternative is supposed to simplify our life
> >> > or improve the efficiency of the d
On Fri, May 28, 2010 at 05:24:47PM +0200, Jes Sorensen wrote:
> We were looking at the dmidecode output from qemu-kvm pre-seabios and
> current qemu-kvm and noticed some of the strings have changed.
[...]
> I wanted to check with the lists if there are any strong feelings about
> this, and whether
Artyom Tarasenko wrote:
> 2010/5/28 Blue Swirl :
>
>> On Fri, May 28, 2010 at 7:54 AM, Bob Breuer wrote:
>>
>>> Artyom Tarasenko wrote:
>>>
2010/5/27 Bob Breuer :
> Artyom Tarasenko wrote:
>
>
>> Was going to put some more empty slo
Kevin Wolf writes:
> Am 28.05.2010 20:18, schrieb Miguel Di Ciurcio Filho:
>> Both bdrv_can_snapshot() and bdrv_has_snapshot() does not work as advertized.
>>
>> First issue: Their names implies different porpouses, but they do the same
>> thing
>> and have exactly the same code. Maybe copied a
[cc: kraxel]
Jan Kiszka writes:
> From: Jan Kiszka
>
> As long as we allow /dev.1 as shortcut for /dev1/bus1, we also have to
> make sure that /dev1/dev2 works for /dev1/bus1/dev2/bus2 - as long as
> there is only one child bus per device.
We auto-root a path not starting with '/' via conventi
>From pthread man:
These functions manipulate the calling thread's stack of
thread-cancellation clean-up handlers. A clean-up handler is
a function that is automatically executed when a thread is canceled
[...] it might, for example, unlock a mutex so that it becomes
available to other t
Blue Swirl wrote:
> On Sat, May 29, 2010 at 10:16 AM, Jan Kiszka wrote:
>> Blue Swirl wrote:
>> This is - according to my current understanding - the proposed
>> alternative architecture:
>>
>> .---.
>>
Thanks, applied.
On Fri, May 28, 2010 at 9:05 PM, Igor V. Kovalenko
wrote:
> From: Igor V. Kovalenko
>
> - change 128-bit atomic loads to reference nucleus context
> v0->v1: dropped disassembler change
> Signed-off-by: Igor V. Kovalenko
> ---
> target-sparc/op_helper.c | 10 +-
> 1 f
Jan Kiszka writes:
> From: Jan Kiszka
>
> Extend qbus_find_dev to allow addressing of devices without an unique id
> via an optional per-bus instance number. The new formats are
> 'driver.instance' and 'alias.instance'.
>
> Signed-off-by: Jan Kiszka
> ---
> docs/qdev-device-use.txt | 12
Jan Kiszka writes:
> From: Jan Kiszka
>
> As the user may specify ambiguous device IDs, let's search for their
> official names first before considering the user-supplied identifiers.
>
> Signed-off-by: Jan Kiszka
The problem is letting the user specify ambiguous device IDs in the
first place!
Add some missing functions in qemu-thread. Currently qemu-thread
is only used for io-thread but it will used by the vnc server soon
and we need those functions instead of calling pthread directly.
Signed-off-by: Corentin Chary
---
qemu-thread.c | 22 ++
qemu-thread.h |4
On Sat, May 29, 2010 at 2:46 PM, Gleb Natapov wrote:
> On Sat, May 29, 2010 at 09:35:30AM +, Blue Swirl wrote:
>> > I still don't see how the alternative is supposed to simplify our life
>> > or improve the efficiency of the de-coalescing workaround. It's rather
>> > problematic like Gleb poin
Jan Kiszka writes:
> Markus Armbruster wrote:
>> Jan Kiszka writes:
>>
>>> Luiz Capitulino wrote:
On Sun, 23 May 2010 12:59:19 +0200
Jan Kiszka wrote:
> From: Jan Kiszka
>
> Allow to specify the device to be removed via device_del not only by ID
> but also by it
On Sat, May 29, 2010 at 04:03:22PM +, Blue Swirl wrote:
> 2010/5/29 Gleb Natapov :
> > On Sat, May 29, 2010 at 09:15:11AM +, Blue Swirl wrote:
> >> >> There is no code, because we're still at architecture design stage.
> >> >>
> >> > Try to write test code to understand the problem better.
Markus Armbruster wrote:
> Jan Kiszka writes:
>
>> Markus Armbruster wrote:
>>> Jan Kiszka writes:
>>>
Luiz Capitulino wrote:
> On Sun, 23 May 2010 12:59:19 +0200
> Jan Kiszka wrote:
>
>> From: Jan Kiszka
>>
>> Allow to specify the device to be removed via device_d
Jan Kiszka writes:
> From: Jan Kiszka
>
> This simply forwards the result of the internal vsnprintf to the callers
> of monitor_printf and monitor_vprintf. When invoked over a QMP session
> or in absence of an active monitor, -1 is returned.
>
> Signed-off-by: Jan Kiszka
Appreciated! Opens th
Markus Armbruster wrote:
> Luiz Capitulino writes:
>
>> On Sun, 23 May 2010 12:59:26 +0200
>> Jan Kiszka wrote:
>>
>>> From: Jan Kiszka
>>>
>>> Ported commands that are marked 'user_only' will not be considered for
>>> QMP monitor sessions. This allows to implement new commands that do not
>>>
2010/5/29 Gleb Natapov :
> On Sat, May 29, 2010 at 09:15:11AM +, Blue Swirl wrote:
>> >> There is no code, because we're still at architecture design stage.
>> >>
>> > Try to write test code to understand the problem better.
>>
>> I will.
>>
> Please do ASAP. This discussion shows that you don'
Markus Armbruster wrote:
> Jan Kiszka writes:
>
>> From: Jan Kiszka
>>
>> Extend qbus_find_dev to allow addressing of devices without an unique id
>> via an optional per-bus instance number. The new formats are
>> 'driver.instance' and 'alias.instance'.
>>
>> Signed-off-by: Jan Kiszka
>> ---
>>
Markus Armbruster wrote:
> Avi Kivity writes:
>
>> On 05/23/2010 10:57 AM, Jan Kiszka wrote:
>>> Avi Kivity wrote:
>>>
On 05/22/2010 11:18 AM, Jan Kiszka wrote:
> From: Jan Kiszka
>
> This introduces device_show, a monitor command that saves the vmstate of
> a
2010/5/28 Gleb Natapov :
> On Fri, May 28, 2010 at 08:06:45PM +, Blue Swirl wrote:
>> 2010/5/28 Gleb Natapov :
>> > On Thu, May 27, 2010 at 06:37:10PM +, Blue Swirl wrote:
>> >> 2010/5/27 Gleb Natapov :
>> >> > On Wed, May 26, 2010 at 08:35:00PM +, Blue Swirl wrote:
>> >> >> On Wed, May
Luiz Capitulino wrote:
> This new version moves the documentation to qemu-monitor.hx and now
> QMP/qmp-commands.txt is generated from there (thanks Jan!).
>
> I hope I've addressed all review comments in this version and now it should
> describe reality.
>
> Next step is to fix glitches (after th
Luiz Capitulino writes:
> On Sun, 23 May 2010 12:59:26 +0200
> Jan Kiszka wrote:
>
>> From: Jan Kiszka
>>
>> Ported commands that are marked 'user_only' will not be considered for
>> QMP monitor sessions. This allows to implement new commands that do not
>> (yet) provide a sufficiently stable
On Sat, May 29, 2010 at 5:15 AM, Bob Breuer wrote:
> Artyom Tarasenko wrote:
>> 2010/5/28 Blue Swirl :
>>
>>> On Fri, May 28, 2010 at 7:54 AM, Bob Breuer wrote:
>>>
Artyom Tarasenko wrote:
> 2010/5/27 Bob Breuer :
>
>
>> Artyom Tarasenko wrote:
>>
>>
>>> Was
On Fri, May 28, 2010 at 08:15:04PM +0200, Kevin Wolf wrote:
> The truncate and getlength commands passed a negative error number to
> strerror.
> They also happen to be the two functions that are lacking a newline at the end
> of their error message.
>
> Signed-off-by: Kevin Wolf
Ok,
Reviewed
Paul Brook writes:
>> The system emulators for each arch are using inconsistent
>> naming for the default PCI bus "pci" vs "pci.0". Since it
>> is conceivable we'll have multiple PCI buses in the future
>> standardize on "pci.0" for all architectures. This ensures
>> mgmt apps can rely on a name
2010/5/29 Jan Kiszka :
> Gleb Natapov wrote:
>> On Fri, May 28, 2010 at 08:06:45PM +, Blue Swirl wrote:
>>> 2010/5/28 Gleb Natapov :
On Thu, May 27, 2010 at 06:37:10PM +, Blue Swirl wrote:
> 2010/5/27 Gleb Natapov :
>> On Wed, May 26, 2010 at 08:35:00PM +, Blue Swirl wrote:
Blue Swirl wrote:
>>> On the contrary, APIC is actually the only source of the IRQ ack
>>> information. RTC hack would not work without APIC (or the
>>> bidirectional IRQ) passing this info to RTC.
>>>
>>> What APIC doesn't have now is the timer frequency or period info. This
>>> is known by RTC an
Implement a threaded VNC server using the producer-consumer model.
The main thread will push encoding jobs (a list a rectangles to update)
in a queue, and the VNC worker thread will consume that queue and send
framebuffer updates to the output buffer.
There is three levels of locking:
- jobs queue
On Sat, May 29, 2010 at 9:45 AM, Jan Kiszka wrote:
> Blue Swirl wrote:
>> 2010/5/29 Jan Kiszka :
>>> Gleb Natapov wrote:
On Fri, May 28, 2010 at 08:06:45PM +, Blue Swirl wrote:
> 2010/5/28 Gleb Natapov :
>> On Thu, May 27, 2010 at 06:37:10PM +, Blue Swirl wrote:
>>> 2010/5
Markus Armbruster wrote:
> [cc: kraxel]
>
> Jan Kiszka writes:
>
>> From: Jan Kiszka
>>
>> As long as we allow /dev.1 as shortcut for /dev1/bus1, we also have to
>> make sure that /dev1/dev2 works for /dev1/bus1/dev2/bus2 - as long as
>> there is only one child bus per device.
>
> We auto-root
Blue Swirl wrote:
> 2010/5/29 Jan Kiszka :
>> Gleb Natapov wrote:
>>> On Fri, May 28, 2010 at 08:06:45PM +, Blue Swirl wrote:
2010/5/28 Gleb Natapov :
> On Thu, May 27, 2010 at 06:37:10PM +, Blue Swirl wrote:
>> 2010/5/27 Gleb Natapov :
>>> On Wed, May 26, 2010 at 08:35:00P
Hi,
This series add a threaded VNC server and should be applied on top on my
previous patch set (adding tight encoding).
The first two patchs add some functions to qemu-thread. The last is the
threaded VNC server and the changelog
explains how it works.
refs:
http://xf.iksaif.net/blog/index.php
Gleb Natapov wrote:
> On Fri, May 28, 2010 at 08:06:45PM +, Blue Swirl wrote:
>> 2010/5/28 Gleb Natapov :
>>> On Thu, May 27, 2010 at 06:37:10PM +, Blue Swirl wrote:
2010/5/27 Gleb Natapov :
> On Wed, May 26, 2010 at 08:35:00PM +, Blue Swirl wrote:
>> On Wed, May 26, 2010 a
Blue Swirl wrote:
This is - according to my current understanding - the proposed
alternative architecture:
.---.
| de-coalescing |
|
On Fri, May 28, 2010 at 7:34 PM, Paul Brook wrote:
>> Use a qemu_irq to request CPU exit.
>
> Needing to request a CPU exit at all is just wrong. See previous discussions
> about how any use of qemu_bh_schedule_idle is fundamentally broken.
I agree for the device case. Is the attached patch then
2010/5/29 Bob Breuer :
> Artyom Tarasenko wrote:
>> 2010/5/28 Blue Swirl :
>>
>>> On Fri, May 28, 2010 at 7:54 AM, Bob Breuer wrote:
>>>
Artyom Tarasenko wrote:
> 2010/5/27 Bob Breuer :
>
>
>> Artyom Tarasenko wrote:
>>
>>
>>> Was going to put some more empty
On Sat, May 29, 2010 at 10:16 AM, Jan Kiszka wrote:
> Blue Swirl wrote:
> This is - according to my current understanding - the proposed
> alternative architecture:
>
> .---.
> | de-co
Avi Kivity writes:
> On 05/23/2010 10:57 AM, Jan Kiszka wrote:
>> Avi Kivity wrote:
>>
>>> On 05/22/2010 11:18 AM, Jan Kiszka wrote:
>>>
From: Jan Kiszka
This introduces device_show, a monitor command that saves the vmstate of
a qdev device and visualizes it. QMP is
On Fri, May 28, 2010 at 9:53 PM, Artyom Tarasenko
wrote:
>> 32m: 0x12fff394
>> 64m: 0x14fff394
>> 192m:0x1cfff394
>> 256m:0x20fff394
>>
>> Memory probing? It would be strange that OS would do it itself. The OS
>> could just
>> ask OBP how much does it have. Here is the listing where it happens:
>>
>>qemu-system-m68k -cpu ?
Sorry . Where to find executable 'qemu-system-m68k.exe" ?
Thank you
Am 28.05.2010 um 21:00 schrieb Thomas Monjalon:
From: Thomas Monjalon
This line was a bit clear.
The next lines set or reset this bit (LE) depending of another bit
(ILE).
So the first line is useless.
Signed-off-by: Thomas Monjalon
---
target-ppc/helper.c |1 -
1 files changed, 0 inser
Jes Sorensen wrote:
Hi,
We were looking at the dmidecode output from qemu-kvm pre-seabios and
current qemu-kvm and noticed some of the strings have changed.
The main problem with this is that certain OSes are quite sensitive to
system changes and avoiding to change things unnecessarily would
pr
Alexander Graf wrote:
> Anthony Liguori wrote:
> > I'd prefer to stick to bug fixes for stable releases. Performance
> > improvements are a good motivation for people to upgrade to 0.13 :-)
>
> In general I agree, but this one looks like a really simple one.
Besides, there are too many reported
On Sat, May 29, 2010 at 09:35:30AM +, Blue Swirl wrote:
> > I still don't see how the alternative is supposed to simplify our life
> > or improve the efficiency of the de-coalescing workaround. It's rather
> > problematic like Gleb pointed out: The de-coalescing logic needs to be
> > informed a
On Sat, May 29, 2010 at 09:15:11AM +, Blue Swirl wrote:
> >> There is no code, because we're still at architecture design stage.
> >>
> > Try to write test code to understand the problem better.
>
> I will.
>
Please do ASAP. This discussion shows that you don't understand what is the
problem
Signed-off-by: cmchao
---
Makefile.target |2 +-
hw/omap.h |2 +
hw/omap2.c | 323 ---
hw/omap_spi.c | 346 +++
4 files changed, 349 insertions(+), 324 deletions(-)
create
Signed-off-by: cmchao
---
Makefile.target |3 +-
hw/omap1.c | 170
hw/omap_uart.c | 194 +++
3 files changed, 196 insertions(+), 171 deletions(-)
create mode 100644 hw/omap_uart.c
d
65 matches
Mail list logo