On Fri, 08 Jan 2010 16:54:30 -0600
Anthony Liguori wrote:
> On 01/08/2010 12:16 PM, Luiz Capitulino wrote:
> > Hi there,
> >
> > Today's master full build is broken to me on x86_64 and i386:
> >
> > """
> >GEN config-target.h
> > make[1]: *** No rule to make target `feature_to_c.sh', ne
On 01/08/2010 12:16 PM, Luiz Capitulino wrote:
Hi there,
Today's master full build is broken to me on x86_64 and i386:
"""
GEN config-target.h
make[1]: *** No rule to make target `feature_to_c.sh', needed by
`gdbstub-xml.c'. Stop.
make[1]: *** Waiting for unfinished jobs
make: **
It's emitted everytime a VNC client connects to QEMU,
client's information such as port and IP address is provided.
Note that if any kind of authentication is enabled, this
event is only emitted when the client successfully
authenticates.
For example:
{ "event": "VNC_CONNECT",
"timestamp": {
It's emitted everytime a VNC client disconnects from QEMU,
client's information such as port and IP address is provided.
Note that if any kind of authentication is enabled, this
event is only emitted if the disconnection happens after
the client has been authenticated.
For example:
{ "event": "V
When a disconnection happens the client's socket on QEMU
side may become invalid, this way it won't be possible
to query it to get client information, which is going to
be needed by the future VNC disconnect QMP event.
To always have this information available we query the
socket at connection tim
It contains the socket adress family name, like "ipv4" or
"ipv6".
This is useful for clients so that they can interpret the
'host' key reliably.
Signed-off-by: Luiz Capitulino
---
vnc.c | 24 +++-
1 files changed, 23 insertions(+), 1 deletions(-)
diff --git a/vnc.c b/vnc.
It's the SASL username, so it's better to call it 'sasl_username'
to be consistent.
Note that this change wouldn't be allowed if QMP were stable.
Signed-off-by: Luiz Capitulino
---
vnc.c |9 +
1 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/vnc.c b/vnc.c
index a1ef8fc
There is no reason to have it as optional and the code
in the server and client gets slightly simpler if the
key is mandatory.
While there also do some cleanup on how the server info is
collected.
Signed-off-by: Luiz Capitulino
---
vnc.c | 26 ++
1 files changed, 14 in
Currently the 'status' key is a string whose value can be
"disabled" or "enabled", change it to the QMP's standard
'enabled' key, which is a bool.
Note that 'status' in being dropped and this wouldn't be
allowed if QMP were stable.
Signed-off-by: Luiz Capitulino
---
vnc.c | 10 +-
1 f
Hi there,
This series contains two related changes. First a small cleanup is done in
the current 'query-vnc' command, then two new QMP asynchronous events are
introduced: VNC connect and disconnect.
That's, everytime a VNC client connects or disconnects from QEMU, the
QMP client will get full
On Fri, 8 Jan 2010, Juergen Lock wrote:
> On Fri, Jan 08, 2010 at 11:27:13AM +0300, malc wrote:
> > On Thu, 7 Jan 2010, Juergen Lock wrote:
> >
> > > In this case it was missing on FreeBSD <= 6.x (Which also doesn't have
> > > SNDCTL_DSP_POLICY yet so the version doesn't get used anyway.)
> >
>
On Fri, Jan 08, 2010 at 11:27:13AM +0300, malc wrote:
> On Thu, 7 Jan 2010, Juergen Lock wrote:
>
> > In this case it was missing on FreeBSD <= 6.x (Which also doesn't have
> > SNDCTL_DSP_POLICY yet so the version doesn't get used anyway.)
>
> I've commited slightly different fix for the issue,
The monitor_protocol_event() function will free the
event's data, this is wrong as 'data' management is up
to the caller.
Signed-off-by: Luiz Capitulino
---
monitor.c |4 +++-
1 files changed, 3 insertions(+), 1 deletions(-)
diff --git a/monitor.c b/monitor.c
index 3af1d5c..2403a97 100644
This commit completes the do_pci_info() conversion to
QObject by adding support to PCI bridge devices.
This is done by recursively adding devices in the
"pci_bridge" key.
IMPORTANT: This code is being added separately because I could
NOT test it properly. According to Michael Tsirkin, it depends
This commit adds the "pci_bridge" key to the PCI device QDict,
it also adds support for printing it in the user protocol.
IMPORTANT: This code is being added separately because I could
NOT test it properly. According to Michael Tsirkin, it depends
on ultrasparc and it would take time to do the pro
The returned QObject is a QList of all buses. Each bus is
represented by a QDict, which has a key with a QList of all
PCI devices attached to it. Each device is represented by
a QDict.
IMPORTANT: support for printing PCI bridge information and
its devices is NOT part of this commit, it's going to
A helper to retrieve a QDict from a QDict.
Signed-off-by: Luiz Capitulino
---
qdict.c | 13 +
qdict.h |1 +
2 files changed, 14 insertions(+), 0 deletions(-)
diff --git a/qdict.c b/qdict.c
index ba8eef0..c6a5a42 100644
--- a/qdict.c
+++ b/qdict.c
@@ -216,6 +216,19 @@ QList *qd
Iterate over QList entries, it's needed to call qlist_entry_obj()
to retrieve the stored QObject.
I'm not sure if it's ok to have this, because it's not as easy as
qlist_iter() and the QListEntry data type is now exposed to the
users, which means we have one more struct to be maintained when
we ha
Hi,
This is a new version of the pci_info() conversion.
changelog
-
V0 -> V1
- Coding style fixes
- Make 'BAR' and 'IRQ' keys lowercase
- Add 'irq' key to the documentation
Thanks.
On 08.01.2010, at 19:29, Blue Swirl wrote:
> On Fri, Jan 8, 2010 at 6:27 PM, Alexander Graf wrote:
>>
>> On 08.01.2010, at 19:22, Blue Swirl wrote:
>>
>>> On Fri, Jan 8, 2010 at 6:07 PM, Alexander Graf wrote:
On 08.01.2010, at 19:04, Blue Swirl wrote:
> On Fri, Jan 8, 201
On Fri, Jan 8, 2010 at 6:27 PM, Alexander Graf wrote:
>
> On 08.01.2010, at 19:22, Blue Swirl wrote:
>
>> On Fri, Jan 8, 2010 at 6:07 PM, Alexander Graf wrote:
>>>
>>> On 08.01.2010, at 19:04, Blue Swirl wrote:
>>>
On Fri, Jan 8, 2010 at 5:43 PM, Alexander Graf wrote:
> Our guest system
On 08.01.2010, at 19:22, Blue Swirl wrote:
> On Fri, Jan 8, 2010 at 6:07 PM, Alexander Graf wrote:
>>
>> On 08.01.2010, at 19:04, Blue Swirl wrote:
>>
>>> On Fri, Jan 8, 2010 at 5:43 PM, Alexander Graf wrote:
Our guest systems need to know by how much the timebase increases every
s
Thanks, applied all except 9/9.
On Thu, Jan 7, 2010 at 8:27 PM, Igor V. Kovalenko
wrote:
> The following series is a cleanup over previous one.
>
> v0 -> v1: post-review changes
> - dropped patch "clear exception_index with -1 val" (applied)
> - new patch "change_pstate should have 32bit argument
On Fri, Jan 8, 2010 at 6:07 PM, Alexander Graf wrote:
>
> On 08.01.2010, at 19:04, Blue Swirl wrote:
>
>> On Fri, Jan 8, 2010 at 5:43 PM, Alexander Graf wrote:
>>> Our guest systems need to know by how much the timebase increases every
>>> second,
>>> so there usually is a "timebase-frequency" p
Hi there,
Today's master full build is broken to me on x86_64 and i386:
"""
GEN config-target.h
make[1]: *** No rule to make target `feature_to_c.sh', needed by
`gdbstub-xml.c'. Stop.
make[1]: *** Waiting for unfinished jobs
make: *** [subdir-arm-linux-user] Error 2
make: *** Waiting
On 08.01.2010, at 19:04, Blue Swirl wrote:
> On Fri, Jan 8, 2010 at 5:43 PM, Alexander Graf wrote:
>> Our guest systems need to know by how much the timebase increases every
>> second,
>> so there usually is a "timebase-frequency" property in the cpu leaf of the
>> device tree.
>>
>> This prop
On Fri, Jan 8, 2010 at 5:43 PM, Alexander Graf wrote:
> Our guest systems need to know by how much the timebase increases every
> second,
> so there usually is a "timebase-frequency" property in the cpu leaf of the
> device tree.
>
> This property is missing in OpenBIOS, as is the "clock-frequenc
On Fri, Jan 8, 2010 at 10:26 AM, Paolo Bonzini wrote:
>> This will wreak havoc on the tree since these are built by default and
>> they are replacing files in revision control.
> ... the next question is why are they (linuxboot.bin and multiboot.bin)
> in revision control since the
Our guest systems need to know by how much the timebase increases every second,
so there usually is a "timebase-frequency" property in the cpu leaf of the
device tree.
This property is missing in OpenBIOS, as is the "clock-frequency" property that
tells the guest how fast the CPU is. FWIW that one
On Fri, 08 Jan 2010 11:01:31 -0600
Adam Litke wrote:
> On Thu, 2010-01-07 at 16:30 -0200, Luiz Capitulino wrote:
> > On Thu, 7 Jan 2010 15:58:30 -0200
> > Luiz Capitulino wrote:
> >
> > > I like Daniel's idea too. In practice 'refresh-balloon' is going to
> > > be Anthony's idea #1 for the QMP
On Thu, 2010-01-07 at 16:30 -0200, Luiz Capitulino wrote:
> On Thu, 7 Jan 2010 15:58:30 -0200
> Luiz Capitulino wrote:
>
> > I like Daniel's idea too. In practice 'refresh-balloon' is going to
> > be Anthony's idea #1 for the QMP case, which seems the right way to
> > do it with QMP.
>
> Hm, s
On Fri, 08 Jan 2010 10:31:28 -0600
Anthony Liguori wrote:
> On 01/07/2010 12:30 PM, Luiz Capitulino wrote:
> > On Thu, 7 Jan 2010 15:58:30 -0200
> > Luiz Capitulino wrote:
> >
> >
> >> I like Daniel's idea too. In practice 'refresh-balloon' is going to
> >> be Anthony's idea #1 for the QMP
On 01/04/2010 07:45 PM, TeLeMan wrote:
Before calling chardev_init_func(), socket_init() should be called on win32.
Needs a Signed-off-by
Regards,
Anthony Liguori
---
vl.c |8
1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/vl.c b/vl.c
index 0f59142..3b39c
On 12/24/2009 07:38 AM, Avi Kivity wrote:
The gdt address calculation in linuxboot.bin is broken in two ways: first
it loads %cs into %eax, but that instruction leaves the high bits of %eax
undefined and we did not clear them. Secondly, we completely ignore the
incorrect %eax, and use the undefi
On 12/29/2009 03:51 PM, H. Peter Anvin wrote:
Add generic support for debugging consoles (simple I/O ports which
when written to cause debugging output to be written to a target.)
The current implementation matches Bochs' port 0xe9, allowing the same
debugging code to be used for both Bochs and Q
On 12/26/2009 07:13 AM, Adam Lackorzynski wrote:
Signed-off-by: Adam Lackorzynski
Applied. Thanks.
Regards,
Anthony Liguori
---
hw/pc.c | 268 +++
1 files changed, 167 insertions(+), 101 deletions(-)
diff --git a/hw/pc.c b
On 12/24/2009 06:46 AM, Michael S. Tsirkin wrote:
When vhost is bound to a backend device, we need to stop polling it when
vhost is started, and restart polling when vhost is stopped.
Add an API for that for use by vhost, and implement in tap backend.
Signed-off-by: Michael S. Tsirkin
Appl
On 12/21/2009 03:06 AM, Paolo Bonzini wrote:
The vpath directive has two advantages over the VPATH variable:
1) it allows to skip searching of .o files; 2) the default semantics
are to append to the vpath, so there is no confusion between "VPATH=xyz"
and "VPATH+=xyz".
Since "vpath %.c %.h PATH"
On 12/20/2009 08:39 AM, Stefan Weil wrote:
This makes rebuilds after source updates easier
for most users (who don't edit config-devices.mak).
Signed-off-by: Stefan Weil\
Applied. Thanks.
Regards,
Anthony Liguori
---
Makefile | 20 +++-
1 files changed, 15 insertio
On 12/21/2009 09:09 PM, Luiz Capitulino wrote:
Some commands return a QList of QDicts, which is valid,
but will trig the assert().
Just drop it.
Reported-by: Nathan Baum
Signed-off-by: Luiz Capitulino
Applied. Thanks.
Regards,
Anthony Liguori
---
monitor.c |1 -
1 files change
On 01/07/2010 12:30 PM, Luiz Capitulino wrote:
On Thu, 7 Jan 2010 15:58:30 -0200
Luiz Capitulino wrote:
I like Daniel's idea too. In practice 'refresh-balloon' is going to
be Anthony's idea #1 for the QMP case, which seems the right way to
do it with QMP.
Hm, something that has
On 01/08/2010 07:35 AM, Jamie Lokier wrote:
Sometimes it looks like TCP is maintaining write boundaries, but it is
just an artifact of its behaviour on many systems, and is not reliable
even on those systems where it seems to happen most of the time. Even
when connecting to localhost, you cannot
On Tue, Jan 05, 2010 at 08:16:15PM +, Jamie Lokier wrote:
> It would be good if virtio relayed the backing device's basic topology
> hints, so:
>
> - If the backing dev is a real disk with 512-byte sectors,
> virtio should indicate 512-byte blocks to the guest.
>
> - If the back
This patch adds a pci bus property 'rombar' which specifies whenever
the pci rom should be loaded via pci rom bar (default) or via fw_cfg.
The later can be used for compatibility with older qemu versions where
no pci rom bar is present.
Signed-off-by: Gerd Hoffmann
---
hw/pci.c | 15 ++
Changes:
- make dir argument mandatory, we allways have one anyway
(vgaroms or genroms).
- check for duplicates, skip loading if found.
Signed-off-by: Gerd Hoffmann
---
hw/fw_cfg.c | 18 +++---
1 files changed, 11 insertions(+), 7 deletions(-)
diff --git a/hw/fw_cfg.c b/hw/fw
So '-M pc-0.10' and '-M pc-0.11' will use the fw_cfg rom load method
by default.
Signed-off-by: Gerd Hoffmann
---
hw/pc.c |8
1 files changed, 8 insertions(+), 0 deletions(-)
diff --git a/hw/pc.c b/hw/pc.c
index 3ed43f5..825501c 100644
--- a/hw/pc.c
+++ b/hw/pc.c
@@ -1315,6 +1315,1
Add a new machine type for qemu 0.12.
Also fixup the 0.11 machine type: msi for virtio-blk-pci was enabled
after the 0.11 release, so turn it off in the 0.11 machine type.
Signed-off-by: Gerd Hoffmann
---
hw/pc.c | 18 +-
1 files changed, 17 insertions(+), 1 deletions(-)
diff
Changes:
- Drop extra file argument from rom_add_file().
- Drop fw_dir check in do_info_roms, we allways have a dir name.
- code style fixes.
Signed-off-by: Gerd Hoffmann
---
hw/loader.c | 38 +++---
hw/loader.h |5 +++--
2 files changed, 26 insertions
Hi,
Here is a patch series trying to address 0.11 compatibility issues.
First, there is a patch which adds a 0.12 machine type for the new
release and fixes up the 0.11 one. Unlike the version posted yesterday
as single patch it actually compiles ...
The following patches allow to load pci ro
This patch changes the way rom loading via fw_cfg is handled.
Instead of having pc_init1() call a function which passed all
roms to the firmware config we simply pass a pointer to fw_cfg
to the rom loader.
Advantage: loading roms via firmware works also for devices which
are initialized after pc_i
Amit Shah wrote:
> On (Fri) Jan 08 2010 [01:12:31], Jamie Lokier wrote:
> > Amit Shah wrote:
> > > Guests send us one buffer at a time. Current guests send buffers sized
> > > 4K bytes. If guest userspace applications sent out > 4K bytes in one
> > > write() syscall, the write request actually send
On 01/08/2010 01:31 AM, Paolo Bonzini wrote:
On 01/07/2010 09:03 PM, Anthony Liguori wrote:
This will wreak havoc on the tree since these are built by default and
they are replacing files in revision control.
... the next question is why are they (linuxboot.bin and
multiboot.bin) in revision
> This will wreak havoc on the tree since these are built by default and
> they are replacing files in revision control.
... the next question is why are they (linuxboot.bin and multiboot.bin)
in revision control since they do not require any strange tool to be built.
>>> They req
Paolo Bonzini a écrit :
> On 01/08/2010 08:57 AM, Aurelien Jarno wrote:
>> Paolo Bonzini a écrit :
>>> On 01/07/2010 09:03 PM, Anthony Liguori wrote:
This will wreak havoc on the tree since these are built by default and
they are replacing files in revision control.
>>> ... the next quest
On Thu, 7 Jan 2010, Juergen Lock wrote:
> In this case it was missing on FreeBSD <= 6.x (Which also doesn't have
> SNDCTL_DSP_POLICY yet so the version doesn't get used anyway.)
I've commited slightly different fix for the issue, thanks.
--
mailto:av1...@comtv.ru
On 01/08/2010 08:57 AM, Aurelien Jarno wrote:
Paolo Bonzini a écrit :
On 01/07/2010 09:03 PM, Anthony Liguori wrote:
This will wreak havoc on the tree since these are built by default and
they are replacing files in revision control.
... the next question is why are they (linuxboot.bin and mu
56 matches
Mail list logo