Re: trailing underscores naming convention_

2014-05-09 Thread Steven D'Aprano
On Fri, 09 May 2014 10:35:09 -0600, Michael Torrie wrote: > On 05/08/2014 11:49 PM, Metallicow wrote: >> I guess to be more clear here is a small code snippet that shows what >> is happening more readably. Hence the underscores question. > > In a case like this I'd probably prefer to number the m

Re: trailing underscores naming convention_

2014-05-09 Thread Michael Torrie
On 05/08/2014 11:49 PM, Metallicow wrote: > I guess to be more clear here is a small code snippet that shows what > is happening more readably. Hence the underscores question. In a case like this I'd probably prefer to number the methods rather than add underscores to the end of the names. My cur

Re: trailing underscores naming convention_

2014-05-09 Thread Albert Visser
On Fri, 09 May 2014 12:22:56 +0200, Metallicow wrote: On Friday, May 9, 2014 3:10:26 AM UTC-6, Peter Otten wrote: Metallicow wrote: > I guess to be more clear here is a small code snippet that shows what is > happening more readably. Hence the underscores question. Working with multiple

Re: trailing underscores naming convention_

2014-05-09 Thread Peter Otten
Metallicow wrote: > On Friday, May 9, 2014 3:10:26 AM UTC-6, Peter Otten wrote: >> Metallicow wrote: >> >> > I guess to be more clear here is a small code snippet that shows what >> > is happening more readably. Hence the underscores question. >> >> Working with multiple names with small differe

Re: trailing underscores naming convention_

2014-05-09 Thread Metallicow
On Friday, May 9, 2014 3:10:26 AM UTC-6, Peter Otten wrote: > Metallicow wrote: > > > I guess to be more clear here is a small code snippet that shows what is > > happening more readably. Hence the underscores question. > > Working with multiple names with small differences is error-prone. > You

Re: trailing underscores naming convention_

2014-05-09 Thread Peter Otten
Metallicow wrote: > I guess to be more clear here is a small code snippet that shows what is > happening more readably. Hence the underscores question. Working with multiple names with small differences is error-prone. You should give a method a name that describes what it does rather than when

Re: trailing underscores naming convention_

2014-05-08 Thread Metallicow
I guess to be more clear here is a small code snippet that shows what is happening more readably. Hence the underscores question. class MainAuiManager(aui.AuiManager): def __init__(self, managed_window=None, agwFlags=0) aui.AuiManager.__init__(self, managed_window, agwFlags)

Re: trailing underscores naming convention_

2014-05-08 Thread Metallicow
On Thursday, May 8, 2014 10:24:00 PM UTC-6, Ian wrote: > On Thu, May 8, 2014 at 9:28 PM, Metallicow wrote: > > I seem to be comfortable with all the information out around the net dealing > > with python naming conventions. Occasionally I have to remind myself on some > > of this stuff. The PEP8 do

Re: trailing underscores naming convention_

2014-05-08 Thread Ian Kelly
On Thu, May 8, 2014 at 9:28 PM, Metallicow wrote: > I seem to be comfortable with all the information out around the net dealing > with python naming conventions. Occasionally I have to remind myself on some > of this stuff. The PEP8 does a good job for most of it, but I am having a bit > of troub

trailing underscores naming convention_

2014-05-08 Thread Metallicow
I seem to be comfortable with all the information out around the net dealing with python naming conventions. Occasionally I have to remind myself on some of this stuff. The PEP8 does a good job for most of it, but I am having a bit of trouble finding some more detailed information on the trailing h