On Mon, 20 Aug 2018 08:19:12 +1000
Cameron Simpson wrote:
[sorry for late reply]
> Someone else has descibed zip tersely: it pairs it the elements of 2
> lists. In fact it joins up matching elements of an arbitrary number
> of iterables. Here is a 3 iterable example:
>
> >>> zip( (1,2,3), (
On 19Aug2018 15:09, richard lucassen wrote:
On Sun, 19 Aug 2018 19:53:04 +1000
Cameron Simpson wrote:
Although I do not understand what zip is doing exactly here (I presume
I switch to use pointers instead of the values),
Someone else has descibed zip tersely: it pairs it the elements of 2 li
On Mon, Aug 20, 2018 at 7:55 AM, Cameron Simpson wrote:
> Draw little boxes with arrows. It helps. - Michael J. Eager
Draw good boxes. - DeviCat
ChrisA
--
https://mail.python.org/mailman/listinfo/python-list
On 19Aug2018 18:10, richard lucassen wrote:
On Sun, 19 Aug 2018 10:11:08 -0400
Joel Goldstick wrote:
Your allusion to pointers is misguided. Python is not like C or
assembler. You don't, and don't need to know where objects are
stored. Names are assigned to reference data objects
I'll hav
On Sun, 19 Aug 2018 12:37:18 -0400
Joel Goldstick wrote:
> > I'll have another look at it, I was just searching for a clear
> > explanation, but the page I found was not clear enough for me. I'll
> > have to take some time for it...
>
> try python.org tutorial, and search for terms like names, o
On Sun, Aug 19, 2018 at 12:16 PM Richard Lucassen
wrote:
>
> On Sun, 19 Aug 2018 10:11:08 -0400
> Joel Goldstick wrote:
>
> > > Well, apparently there were quite a lot of things that makes the
> > > code more readable I'd say. And even better. But it was indeed not
> > > very unPythony. OTOH, I'm
On Sun, 19 Aug 2018 10:11:08 -0400
Joel Goldstick wrote:
> > Well, apparently there were quite a lot of things that makes the
> > code more readable I'd say. And even better. But it was indeed not
> > very unPythony. OTOH, I'm not a programmer, otherwise I would have
> > written this in C ;-)
>
On Sun, 19 Aug 2018 19:53:04 +1000
Cameron Simpson wrote:
> There are always unPythonic bits. Even after you've cleaned them all
> up, since people will disagree about the finer points of Pythonicism
> there will be bits both over and under cleaned.
Although I do not understand what zip is doing
On Sun, Aug 19, 2018 at 9:56 AM richard lucassen
wrote:
>
> On Sun, 19 Aug 2018 12:02:51 +0300
> Marko Rauhamaa wrote:
>
> > richard lucassen :
> > > As I'm new to Python, just this question: are there any unPythony
> > > things in this code?
> >
> > Your code looks neat.
>
> Well, apparently the
On Sun, 19 Aug 2018 12:02:51 +0300
Marko Rauhamaa wrote:
> richard lucassen :
> > As I'm new to Python, just this question: are there any unPythony
> > things in this code?
>
> Your code looks neat.
Well, apparently there were quite a lot of things that makes the code
more readable I'd say. And
On Sun, 19 Aug 2018 19:53:04 +1000
Cameron Simpson wrote:
[Oops, apparently you set the Reply-To to python-list@python.org,
normally that's no problem, but I did something wrong somewhere]
> There are always unPythonic bits. Even after you've cleaned them all
> up, since people will disagree abo
On 19Aug2018 09:32, richard lucassen wrote:
This is a working script I made. It initializes the I/O expanders, then
it waits for an INT from these I/O expanders on GPIO23, reads the
contents and sends which bit on which chip went up or down to a fifo
(and stdout for logging)
As I'm new to Pytho
richard lucassen :
> As I'm new to Python, just this question: are there any unPythony
> things in this code?
Your code looks neat.
> except IOError:
> print ("[ALERT] I/O problem device 0x%x" % list_pcf[i])
Just double check that simply printing the alert is the correct recovery
f
On Fri, 17 Aug 2018 08:31:22 +1000
Cameron Simpson wrote:
> Just looking at your loop I would be inclined to just call flush once
> at the bottom, _before_ the sleep() call:
>
> sys.stdout.flush()
>
> Your call; the performance difference will be small, so it tends to
> come down to keeping y
On Fri, 17 Aug 2018 08:31:22 +1000
Cameron Simpson wrote:
> This isn't specific to Python, you'll find it with most programmes.
> (The shell's builtin "echo" command is an exception.)
[buffer explanation]
I already suspectec a buffered output and to check if it was the
buffer, I created a lot o
On 16Aug2018 22:37, richard lucassen wrote:
I can run a shell script from the commandline as root in which I start
a python script as user "ha". The output to stdout and stderr
generated by the python script is visible in an xterm:
#!/bin/dash
exec 2>&1
chpst -u ha:ha:i2c -U ha /usr/local/ha/in
I can run a shell script from the commandline as root in which I start
a python script as user "ha". The output to stdout and stderr
generated by the python script is visible in an xterm:
#!/bin/dash
exec 2>&1
chpst -u ha:ha:i2c -U ha /usr/local/ha/init.sh
exec chpst -u ha:ha:i2c:gpio /usr/local/h
> or like this:
>
> print '\r'+str(percent),
>
> Then make sure it gets sent out, like this:
>
> sys.stdout.flush()
Hey!
Thanks very much, that did the trick!
Thanks to everyone that replied, I discovered converting to str was
crutial to actually print anything. :)
Cheers,
Daniel.
--
http:/
Chris Rebert wrote:
On Sun, Mar 8, 2009 at 1:37 AM, Daniel Dalton wrote:
Hi,
I've got a program here that prints out a percentage of it's
completion. Currently with my implimentation it prints like this:
0%
1%
2%
3%
4%
etc taking up lots and lots of lines of output... So, how can I make it
wr
"Daniel Dalton" wrote:
> I've got a program here that prints out a percentage of it's
> completion. Currently with my implimentation it prints like this:
> 0%
> 1%
> 2%
> 3%
> 4%
>
> etc taking up lots and lots of lines of output... So, how can I make it
> write the percentage on the same line e
On Sun, 8 Mar 2009 01:59:03 -0800
Chris Rebert wrote:
> > etc taking up lots and lots of lines of output... So, how can I make it
> > write the percentage on the same line eg.
> Use the carriage return character to overwrite the line (you'll need
> to forego `print`):
Why do you say that?
> from
On Sun, Mar 8, 2009 at 1:37 AM, Daniel Dalton wrote:
> Hi,
>
> I've got a program here that prints out a percentage of it's
> completion. Currently with my implimentation it prints like this:
> 0%
> 1%
> 2%
> 3%
> 4%
>
> etc taking up lots and lots of lines of output... So, how can I make it
> wri
Hi,
I've got a program here that prints out a percentage of it's
completion. Currently with my implimentation it prints like this:
0%
1%
2%
3%
4%
etc taking up lots and lots of lines of output... So, how can I make it
write the percentage on the same line eg.
while working:
print percent
every
23 matches
Mail list logo