On 2016-07-19 22:21, alister wrote:
On Tue, 19 Jul 2016 13:06:39 +1000, Steven D'Aprano wrote:
On Tue, 19 Jul 2016 06:20 am, alister wrote:
I suggest next time you stay awake during lessons.
That's an uncalled for nasty comment. You don't know the O.P's issues or
why he is having difficulty
On Tue, 19 Jul 2016 13:06:39 +1000, Steven D'Aprano wrote:
> On Tue, 19 Jul 2016 06:20 am, alister wrote:
>
>> I suggest next time you stay awake during lessons.
>
> That's an uncalled for nasty comment. You don't know the O.P's issues or
> why he is having difficulty.
because he has failed to
On Mon, 18 Jul 2016 07:50 pm, Eric kago wrote:
> Hi Pythoners
>
> I need help in understanding hoe to put up the code to the following
> command
Hi Eric,
You might find that the "Tutor" mailing list is better for simple questions
like this:
https://mail.python.org/mailman/listinfo/tutor
Reme
On Tue, 19 Jul 2016 06:20 am, alister wrote:
> I suggest next time you stay awake during lessons.
That's an uncalled for nasty comment. You don't know the O.P's issues or why
he is having difficulty.
--
Steven
“Cheer up,” they said, “things could be worse.” So I cheered up, and sure
enough, t
On Mon, 18 Jul 2016 12:50:04 +0300, Eric kago wrote:
> Hi Pythoners
>
> I need help in understanding hoe to put up the code to the following
> command
>
>
>- Create a constructor that takes in an integer and assigns this to a
>`balance` property
>
>
>
>
> Regards,
>
> Eric Kago +25
Hi Pythoners
I need help in understanding hoe to put up the code to the following command
- Create a constructor that takes in an integer and assigns this to a
`balance` property
Regards,
Eric Kago
+254(0)714249373
Nairobi
Kenya
--
https://mail.python.org/mailman/listinfo/python-list
On 2/18/2013 2:42 PM, leonardo selmi wrote:
i saved the above program from python shell into a file as "circle.py" .
Which copied too much into the file.
Edit circle.py until it is a proper python program.
My initial guess was that you copied the >>> prompts, but you later
message shows that
leonardo libero.it> writes:
> here is the error message:
> [...]
Okay, now we are on the road to solving this problem.
But first we need to take a slight detour and learn about python packaging,
because no matter what the current error is, naming a module "circle" and then
throwing it naked out
On 02/18/2013 12:14 PM, leonardo wrote:
thanks guys and sorry for my incomplete datas, here is the error message:
Traceback (most recent call last):
File "", line 1, in
import circle
File "circle.py", line 1
Python 2.7.3 (v2.7.3:70274d53c1dd, Apr 9 2012, 20:52:43)
^
Sy
thanks guys and sorry for my incomplete datas, here is the error message:
Traceback (most recent call last):
File "", line 1, in
import circle
File "circle.py", line 1
Python 2.7.3 (v2.7.3:70274d53c1dd, Apr 9 2012, 20:52:43)
^
SyntaxError: invalid syntax
thanks for any hel
Leonardi,
> i saved the above program from python shell into a file as "circle.py" . when
> i type "import circle" i get error..
Next time, please mention what kind of error you're getting.
Was it an indentation error? Because, as you pasted it, your code would lead to
one.
If I fix the ind
On 02/18/2013 11:42 AM, leonardo selmi wrote:
pls i need help:
i have copied the following from a book and tried to make it work:
import math
def area(radius):
return math.pi * radius**2
def circumference(radius):
return 2 * math.pi * radius
i saved the above program from python shell into a
leonardo selmi icloud.com> writes:
> [...]
> i saved the above program from python shell into a file as
> "circle.py" . when i type "import circle" i get error..
Urm... would you be so kind as to copy and paste the error message verbatim? You
have obvious syntax errors in this code due to improp
Is this exactly how it shows in your shell? If so, it seems you need to
indent your methods.
#
import math
def area(radius):
return math.pi * radius**2
def circumference(radius):
return 2 * math.pi * radius
#***
>
> ...where the image data is loaded into a numpy array
> (1600x1200x3)...
One comment: that is a big array, too big for the cache memory. I know
that in these cases it makes a difference how many times the slices of
the array are loaded and unloaded from RAM onto cache. One issue is
that a 2D a
ttest wrote:
>> Reimplement colorsys.rgb_to_hsv() such that it operates on arrays instead of
>> scalars. Only minor modifications are necessary.
>>
>> --
>> Robert Kern
>
> Thanks! I'll try and see if a newcomer like me can get his head
> around the array-centric modifications to colorsys.
If yo
> Reimplement colorsys.rgb_to_hsv() such that it operates on arrays instead of
> scalars. Only minor modifications are necessary.
>
> --
> Robert Kern
Thanks! I'll try and see if a newcomer like me can get his head
around the array-centric modifications to colorsys.
--
http://mail.python.org/mai
ttest wrote:
> Hello,
>
> I'm working on an image processing project using the Python Imaging
> Library along with numpy. Right now, I'm trying to build a speedy
> script for converting whole images between the RGB and the HSV (a.k.a.
> HSB) color spaces. Unfortunately, the code I've made so far
On Monday 13 June 2005 03:59 am, Steven D'Aprano wrote:
> Are there any useful naming conventions for modules, classes and functions?
>
> For instance, should I name functions as verbs and classes as nouns?
Hmm. Okay, here's a few I use:
Classes are generally: Capitalized or CapWords and I use
Steven D'Aprano wrote:
> Are there any useful naming conventions for modules, classes and
> functions?
>
> For instance, should I name functions as verbs and classes as nouns?
>
> eg
> class Transformer():
> pass
>
> def transform():
> do_stuff
>
> What about the module name? transform
www.sourceforge.net
--
http://mail.python.org/mailman/listinfo/python-list
21 matches
Mail list logo