Thanks everybody. There seems to be a lot of resistance to dict unpacking, in
addition to the problem with my proposed shorthand dict() initialization syntax
pointed out by Steven D'Aprano, so I won't be pursuing this.
--
https://mail.python.org/mailman/listinfo/python-list
I'd like to run this idea by the community to see if it's PEP worthy and
hasn't been already rejected.
Background
Just as keyword arguments enhance code readability and diminish the risk of
bugs, so too would named
return values. Currently, we can write
val1, val2, val3 = myfunc()
but we must