Dubslow added the comment:
Note that this follows a bit of discussion on python-ideas, in two threads:
https://mail.python.org/pipermail/python-ideas/2017-November/047920.html
https://mail.python.org/pipermail/python-ideas/2017-November/047989.html
I agree the zip_longest-derived solution is
Dubslow added the comment:
Regarding the current bug more specifically, I think a few comments would go a
long way to helping readers understand the code.
And also, I do think the (1, +1, -1) is less readable, simply because it
doesn't follow the most common usage patterns of range,
Dubslow added the comment:
Perhaps the loop variable could be renamed to "len_minus_1" or some such
something which is more semantic to the algorithm.
--
___
Python tracker
<https://bugs.python.o
Dubslow added the comment:
Er, in my first message, make that "(yield from tup for tup in
zip_longest(*iters, usefill=False))"
--
___
Python tracker
<https://bugs.python.o
New submission from Dubslow :
In sequence comparisons, the enforcement of reflexivity of elements means that
only non-identical elements are actually compared. The docs then note, with
example, that non-reflexive elements thus always "compare" equal inside the
sequence.
Dubslow added the comment:
The PR includes an unrelated one word grammar fix in the same file, that can be
removed (by me or by someone else, IDC).
This is possibly backportable but I wouldn't know, and leave such decisions for
someone who do.
--
type: -> enh
Dubslow added the comment:
I like Terry's suggestion much better. I've closed my GitHub PR in favor of
Terry's change.
My only suggested tweak might be throwing in something like "(e.g." None)",
perhaps e.g. "Instances of an unordered class (e.g. None) beco