Solomon Ucko added the comment:
> It changes the semantics of Python.
When would the return value actually matter? Would it affect the value of the
variable `__hello__`?
--
___
Python tracker
<https://bugs.python.org/issu
Solomon Ucko added the comment:
The byte code could be further optimized (because this is such a speed-critical
module! :)):
1 0 LOAD_CONST 2 (True)
3 STORE_NAME 1 (initialized)
2 6 LOAD_NAME2 (print
New submission from Solomon Ucko :
3 independent but related proposals. (#4 requires #3.) The main issue for #2
and #4 is the readability of a mix of square and round brackets, especially
within nested brackets. This would be less of an issue with [Coconut
support](https://bugs.python.org
New submission from Solomon Ucko :
Any chance we could integrate [Coconut](http://coconut-lang.org/) into Python?
Any sain Python code should work with Coconut and Coconut allows making code
*so* much more readable.
IMO, the reason not many people use Coconut is that they haven't heard
New submission from Solomon Ucko :
The logging module should be changed to use snake_case (as opposed to
camelCase). Also, logger.basicConfig should list keyword arguments and defaults
in the argument list, as opposed to using `**kwargs` and `dict.pop` (for
readability and improved