applied whole series, thanks!
On November 19, 2019 10:28 am, Stefan Reiter wrote:
> Not only did it display two prompts with identical meaning, the second
> was indented to the end of the first in my terminal for some reason.
>
> Signed-off-by: Stefan Reiter
> ---
>
> Series is already based on
On 11/21/19 5:48 PM, Oguz Bektas wrote:
> diff --git a/src/lxc-pve-poststop-hook b/src/lxc-pve-poststop-hook
> index 19d0b52..64fe54d 100755
> --- a/src/lxc-pve-poststop-hook
> +++ b/src/lxc-pve-poststop-hook
> @@ -38,6 +38,14 @@ PVE::LXC::Tools::lxc_hook('post-stop', 'lxc', sub {
> PVE::Netw
Note them in the log, but do not die - the pending changes should be
kept if the did not apply and we do not want to cancel a reboot.
Signed-off-by: Thomas Lamprecht
---
src/lxc-pve-poststop-hook | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/lxc-pve-poststop-hook b/sr
On November 20, 2019 5:43 pm, Stefan Reiter wrote:
> It does some basic sanity checking, warns the user about encryption
> settings and unresolved hostnames, and finally makes sure that all nodes
> have the same links configured (as well as comparing the configured
> links to specified interfaces,
small nit inline
On November 20, 2019 5:43 pm, Stefan Reiter wrote:
> add_corosync_link_properties/extract_corosync_link_args are introduced
> as helpers to avoid hardcoding links in parameters=>properties on
> several occasions, while still providing autocompletion with pvecm by
> being seperate
On 11/5/19 1:44 PM, Wolfgang Link wrote:
>
> These patches are just the acme.sh thin wrapper part for the reuse of the
> dnsapi.
> In this version I use curl instead of wget.
> Curl is already part of PMG, and PVE has libcurl packages dependency.
> This script has additionl an additional on
>
>>applied and pushed the 7.1 tag to the mirror_frr, thanks!
Thanks !
>>as Dietmar said, we have a bit limited resources for such a core
>>thematic like SDN, which needs a good experience with Networks and
>>PVE developing, and those people having that here are currently working
>>on other stuff..
On November 13, 2019 10:15 am, Dominik Csapak wrote:
> the code returns undef in case there is no 'tos', and the code
> calling this api call handles a non-existing tos already, but
> fails in that case becasue of the failing return value verification
>
> Signed-off-by: Dominik Csapak
> ---
> PV
hi,
On Fri, Nov 22, 2019 at 09:18:34AM +0100, Thomas Lamprecht wrote:
> On 11/21/19 5:48 PM, Oguz Bektas wrote:
> > diff --git a/src/lxc-pve-poststop-hook b/src/lxc-pve-poststop-hook
> > index 19d0b52..64fe54d 100755
> > --- a/src/lxc-pve-poststop-hook
> > +++ b/src/lxc-pve-poststop-hook
> > @@ -3
hi,
will this get applied?
On Thu, Oct 24, 2019 at 01:53:09PM +0200, Oguz Bektas wrote:
> or any other variant of the word 'pending'.
>
> note that we can actually allow this snapshot after PVE 7.0, since
> pending section and snapshots will be properly namespaced.
> ([pve:pending] and [snap:$s
On 11/22/19 12:32 PM, Oguz Bektas wrote:
> hi,
>
> On Fri, Nov 22, 2019 at 09:18:34AM +0100, Thomas Lamprecht wrote:
>> On 11/21/19 5:48 PM, Oguz Bektas wrote:
>>> diff --git a/src/lxc-pve-poststop-hook b/src/lxc-pve-poststop-hook
>>> index 19d0b52..64fe54d 100755
>>> --- a/src/lxc-pve-poststop-ho
On 11/19/19 12:23 PM, Stefan Reiter wrote:
> ...PVE::QemuServer::Machine.
>
> qemu_machine_feature_enabled is exported since it has a *lot* of users
> in PVE::QemuServer and a long enough name as it is.
>
> Signed-off-by: Stefan Reiter
> ---
>
> I left the code exporting qemu_machine_feature_en
Some hints from my side inline.
Rephrasing some passages trying to make it easier to read and understand.
Did some sentence splitting an smaller corrections as well.
Please check if the rephrased sections are still correct from a
technical POV.
On 11/15/19 9:51 AM, Wolfgang Link wrote:
Imp
Signed-off-by: Thomas Lamprecht
---
PVE/Storage/RBDPlugin.pm | 35 +--
1 file changed, 17 insertions(+), 18 deletions(-)
diff --git a/PVE/Storage/RBDPlugin.pm b/PVE/Storage/RBDPlugin.pm
index 214b732..d78a785 100644
--- a/PVE/Storage/RBDPlugin.pm
+++ b/PVE/Storage
'pvecm create' fails since the subroutine doesn't exist in PVE::Cluster
but in PVE::Corosync
Signed-off-by: Oguz Bektas
---
data/PVE/Corosync.pm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/data/PVE/Corosync.pm b/data/PVE/Corosync.pm
index 1b92ea3..7fb52e6 100644
--- a
On 11/22/19 4:13 PM, Oguz Bektas wrote:
> 'pvecm create' fails since the subroutine doesn't exist in PVE::Cluster
> but in PVE::Corosync
>
first, great catch! But...
> Signed-off-by: Oguz Bektas
> ---
> data/PVE/Corosync.pm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff
On Fri, Nov 22, 2019 at 04:15:30PM +0100, Thomas Lamprecht wrote:
> On 11/22/19 4:13 PM, Oguz Bektas wrote:
> > 'pvecm create' fails since the subroutine doesn't exist in PVE::Cluster
> > but in PVE::Corosync
> >
>
> first, great catch! But...
>
> > Signed-off-by: Oguz Bektas
> > ---
> > data/
'pvecm create' fails since the subroutine doesn't exist in PVE::Cluster
but in PVE::Corosync
Signed-off-by: Oguz Bektas
---
v1->v2:
* PVE::Corosync is redundant since we're already in that module
data/PVE/Corosync.pm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/data/
On 11/22/19 4:21 PM, Oguz Bektas wrote:
> 'pvecm create' fails since the subroutine doesn't exist in PVE::Cluster
> but in PVE::Corosync
>
> Signed-off-by: Oguz Bektas
> ---
>
> v1->v2:
> * PVE::Corosync is redundant since we're already in that module
>
> data/PVE/Corosync.pm | 4 ++--
> 1 fil
This was forgotten to add/update when the package was refactored ...
Signed-off-by: Thomas Lamprecht
---
Makefile | 12 +++-
1 file changed, 7 insertions(+), 5 deletions(-)
diff --git a/Makefile b/Makefile
index 6adbdb4..527edb5 100644
--- a/Makefile
+++ b/Makefile
@@ -6,6 +6,8 @@ PACKA
Hi,
>> my $krbd_feature_blacklist = ['deep-flatten', 'fast-diff', 'object-map',
>> 'exclusive-lock'];
since kernel 5.3, all theses features are supported now :) (it was missing
fast-diff && object-map before).
- Mail original -
De: "Thomas Lamprecht"
À: "pve-devel"
Envoyé: V
On 11/22/19 5:12 PM, Alexandre DERUMIER wrote:
> Hi,
>
>>> my $krbd_feature_blacklist = ['deep-flatten', 'fast-diff',
>>> 'object-map', 'exclusive-lock'];
>
>
> since kernel 5.3, all theses features are supported now :) (it was missing
> fast-diff && object-map before).
Yeah, that's why
When validating the parameters (or return values) of an API call against the
schema we run the parameter hash through Devel::Cycle::find_cycle.
find_cycle has no handler for GLOB types (e.g. filehandles).
Recently we introduced passing a filehandle as return attribute in
PMG::API2::Quarantine::dow
On 11/22/19 6:21 PM, Stoiko Ivanov wrote:
> When validating the parameters (or return values) of an API call against the
> schema we run the parameter hash through Devel::Cycle::find_cycle.
>
> find_cycle has no handler for GLOB types (e.g. filehandles).
> Recently we introduced passing a filehand
On 11/22/19 7:03 PM, Thomas Lamprecht wrote:
> On 11/22/19 6:21 PM, Stoiko Ivanov wrote:
>> When validating the parameters (or return values) of an API call against the
>> schema we run the parameter hash through Devel::Cycle::find_cycle.
>>
>> find_cycle has no handler for GLOB types (e.g. filehan
On Fri, 22 Nov 2019 19:05:44 +0100
Thomas Lamprecht wrote:
> On 11/22/19 7:03 PM, Thomas Lamprecht wrote:
> > On 11/22/19 6:21 PM, Stoiko Ivanov wrote:
> >> When validating the parameters (or return values) of an API call against
> >> the
> >> schema we run the parameter hash through Devel::Cy
This is costly and only really required during package build.
Signed-off-by: Thomas Lamprecht
---
whipped up a patch, works fine here, did a build and manual force check by
adding big fat warn "..." below the early-return.
src/PVE/JSONSchema.pm | 14 ++
1 file changed, 10 insertio
Do not check for cycles or for self-validation if not in a build
environment.
The slight drawback is that we also avoid this cycle checks when we
do (development) testing through the API and don't remeber to set the
PROXMOX_FORCE_SCHEMA_VALIDATION environment variable.
But honestyl, I never had a
On Fri, 22 Nov 2019 19:37:20 +0100
Thomas Lamprecht wrote:
> Do not check for cycles or for self-validation if not in a build
> environment.
>
> The slight drawback is that we also avoid this cycle checks when we
> do (development) testing through the API and don't remeber to set the
> PROXMOX_F
29 matches
Mail list logo