since there is nowhere to migrate to and we hide the regular migrate
buttons/options too.
Signed-off-by: Dominik Csapak
---
changes from v1:
* use new 'isStandaloneNode()' from Utils
www/manager6/node/CmdMenu.js | 4
www/manager6/node/Config.js | 1 +
2 files changed, 5 insertions(+)
dif
into Utils and use it where we manually checked that
Signed-off-by: Dominik Csapak
---
I put it into utils since i did not find a better place. Could have put it
in the ResourceStore, but coupling those things seemed wrong to me.
www/manager6/Utils.js | 4
www/manager6/
On November 10, 2023 2:07 pm, Fiona Ebner wrote:
> I'd rather go with your current approach than a new endpoint. Having
> said that, another issue is that custom naming is not a first-class
> feature currently, e.g. live-migration of a local disk or moving a disk
> to a different storage or restori
don't try to add|del ip from ipam here
Signed-off-by: Alexandre Derumier
---
src/PVE/Network/SDN/Dhcp.pm | 75 +
1 file changed, 18 insertions(+), 57 deletions(-)
diff --git a/src/PVE/Network/SDN/Dhcp.pm b/src/PVE/Network/SDN/Dhcp.pm
index e4c4078..1c32fec 10
Here my current work, based on wip2 Stefan Hanreich
Changes:
I have removed dhcp.cfg extra file, and now we can simply define dhcptype in
the zone
So, we'll have 1 dhcp server for each zone, could be in different vrf with same
subnet reuse.
/etc/pve/sdn/zones.cfg
simple: simpve
dhcp
Signed-off-by: Alexandre Derumier
---
vm-network-scripts/pve-bridge | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/vm-network-scripts/pve-bridge b/vm-network-scripts/pve-bridge
index c6b3ea8..24efaad 100755
--- a/vm-network-scripts/pve-bridge
+++ b/vm-network-scripts/pve-b
use to cache mac-ip list association.
can be use by external ipam, firewall,etc for fast lookup
Signed-off-by: Alexandre Derumier
---
src/PVE/Cluster.pm | 1 +
src/pmxcfs/status.c | 1 +
2 files changed, 2 insertions(+)
diff --git a/src/PVE/Cluster.pm b/src/PVE/Cluster.pm
index cfa2583..80c4b
Signed-off-by: Alexandre Derumier
---
src/PVE/Network/SDN/Ipams/PVEPlugin.pm | 32 --
1 file changed, 32 deletions(-)
diff --git a/src/PVE/Network/SDN/Ipams/PVEPlugin.pm
b/src/PVE/Network/SDN/Ipams/PVEPlugin.pm
index 0bc2b65..776eff8 100644
--- a/src/PVE/Network/SDN/Ipam
Signed-off-by: Alexandre Derumier
---
vm-network-scripts/pve-bridgedown | 19 ---
1 file changed, 19 deletions(-)
diff --git a/vm-network-scripts/pve-bridgedown
b/vm-network-scripts/pve-bridgedown
index a220660..d18d88f 100755
--- a/vm-network-scripts/pve-bridgedown
+++ b/vm-net
First look ip mac.db cache
if not, lookup in ipam , and cache result in mac.db
Signed-off-by: Alexandre Derumier
---
src/PVE/Network/SDN/Dhcp.pm| 8 ++
src/PVE/Network/SDN/Ipams.pm | 19 +++--
src/PVE/Network/SDN/Ipams/NetboxPlugin.pm | 25
Signed-off-by: Alexandre Derumier
---
src/PVE/Network/SDN/Ipams/NetboxPlugin.pm | 36
src/PVE/Network/SDN/Ipams/PVEPlugin.pm| 12 +++
src/PVE/Network/SDN/Ipams/Plugin.pm | 7
src/PVE/Network/SDN/Subnets.pm| 21 +---
src/PVE/Network/SDN/
simple: zone1
ipam pve
dhcp dnsmasq
simple: zone2
ipam pve
dhcp dnsmasq
This generate 1 dhcp by zone/vrf.
Don't use dhcp.cfg anymore
It's reuse node filtering from zone.
same subnets in 2 differents zones can't use
same dhcp server
Signed-off-by: Alexandre Derum
Signed-off-by: Alexandre Derumier
---
PVE/QemuServer.pm | 19 +++
1 file changed, 19 insertions(+)
diff --git a/PVE/QemuServer.pm b/PVE/QemuServer.pm
index 511f644..e4cc80d 100644
--- a/PVE/QemuServer.pm
+++ b/PVE/QemuServer.pm
@@ -2339,6 +2339,9 @@ sub destroy_vm {
});
Signed-off-by: Alexandre Derumier
---
PVE/API2/Qemu.pm | 6 ++
PVE/QemuServer.pm | 15 +++
2 files changed, 21 insertions(+)
diff --git a/PVE/API2/Qemu.pm b/PVE/API2/Qemu.pm
index 38bdaab..a0f8243 100644
--- a/PVE/API2/Qemu.pm
+++ b/PVE/API2/Qemu.pm
@@ -991,6 +991,8 @@ __PACKAG
Signed-off-by: Alexandre Derumier
---
src/PVE/Network/SDN/Ipams.pm | 61 +-
src/PVE/Network/SDN/Ipams/PVEPlugin.pm | 4 +-
src/PVE/Network/SDN/Subnets.pm | 8 +++-
src/test/run_test_subnets.pl | 6 +++
4 files changed, 75 insertions(+), 4 del
Signed-off-by: Alexandre Derumier
---
src/PVE/Network/SDN/Subnets.pm | 4 +---
src/PVE/Network/SDN/Vnets.pm | 27 ---
2 files changed, 13 insertions(+), 18 deletions(-)
diff --git a/src/PVE/Network/SDN/Subnets.pm b/src/PVE/Network/SDN/Subnets.pm
index b2125a1..905ec77
Signed-off-by: Alexandre Derumier
---
PVE/QemuServer.pm | 38 +++
vm-network-scripts/pve-bridge | 2 +-
2 files changed, 39 insertions(+), 1 deletion(-)
diff --git a/PVE/QemuServer.pm b/PVE/QemuServer.pm
index 31e3919..5c109b1 100644
--- a/PVE/QemuSer
Signed-off-by: Alexandre Derumier
---
src/PVE/Network/SDN/Dhcp/Dnsmasq.pm | 18 +++---
1 file changed, 15 insertions(+), 3 deletions(-)
diff --git a/src/PVE/Network/SDN/Dhcp/Dnsmasq.pm
b/src/PVE/Network/SDN/Dhcp/Dnsmasq.pm
index 64895ef..21a6ddd 100644
--- a/src/PVE/Network/SDN/Dhcp
Signed-off-by: Alexandre Derumier
---
src/PVE/Network/SDN/Subnets.pm | 4 ++--
src/PVE/Network/SDN/Vnets.pm | 12 ++--
2 files changed, 12 insertions(+), 4 deletions(-)
diff --git a/src/PVE/Network/SDN/Subnets.pm b/src/PVE/Network/SDN/Subnets.pm
index 905ec77..2bd1ec8 100644
--- a/src
Am 13/11/2023 um 10:38 schrieb Fabian Grünbichler:
> On November 10, 2023 2:07 pm, Fiona Ebner wrote:
>> I'd rather go with your current approach than a new endpoint. Having
>> said that, another issue is that custom naming is not a first-class
>> feature currently, e.g. live-migration of a local d
Am 13/11/2023 um 09:59 schrieb Dominik Csapak:
> into Utils and use it where we manually checked that
>
> Signed-off-by: Dominik Csapak
> ---
> I put it into utils since i did not find a better place. Could have put it
> in the ResourceStore, but coupling those things seemed wrong to me.
>
> ww
Signed-off-by: Hannes Laimer
---
PVE/API2/Nodes.pm | 124 ++
1 file changed, 124 insertions(+)
diff --git a/PVE/API2/Nodes.pm b/PVE/API2/Nodes.pm
index a73fca3f..0956eb0a 100644
--- a/PVE/API2/Nodes.pm
+++ b/PVE/API2/Nodes.pm
@@ -289,6 +289,7 @@ __PACK
Adds support for bulk suspending VMs as it already exists for stop.
v2, thanks @Thomas:
* api: skip CTs + fix permission checks
* ui: disable `suspendall` button if user isn;t allowed to use it
* ui: use new bulk action filtering
Hannes Laimer (2):
api: add suspendall endpoint
ui: add bulk su
Signed-off-by: Hannes Laimer
---
www/manager6/Utils.js | 1 +
www/manager6/node/CmdMenu.js | 15 +++
www/manager6/node/Config.js | 14 ++
www/manager6/window/BulkAction.js | 5 +++--
4 files changed, 33 insertions(+), 2 deletions(-)
diff --git a/w
Add a dev[n] argument to the container config to pass devices through to
a container. A device can be passed by its path. Additionally the access
mode, uid and gid can be specified through their respective properties.
Signed-off-by: Filip Schauer
---
src/PVE/LXC.pm| 57 ++
Signed-off-by: Filip Schauer
---
src/PVE/Syscall.pm | 1 +
src/PVE/Tools.pm | 5 +
2 files changed, 6 insertions(+)
diff --git a/src/PVE/Syscall.pm b/src/PVE/Syscall.pm
index 4c0b9cf..2a423e8 100644
--- a/src/PVE/Syscall.pm
+++ b/src/PVE/Syscall.pm
@@ -16,6 +16,7 @@ BEGIN {
openat
Changes since v1:
* mknod the devices in /var/lib/lxc/$vmid/passthrough and setup proper
permissions instead of bind mounting the devices from /dev directly
* Add support for USB mapping
* Add foreach_passthrough_device helper function
Changes since v2:
* Remove support for USB mapping
* Add mkn
Signed-off-by: Filip Schauer
---
src/PVE/Tools.pm | 31 +++
1 file changed, 31 insertions(+)
diff --git a/src/PVE/Tools.pm b/src/PVE/Tools.pm
index fbb6773..b3af2c6 100644
--- a/src/PVE/Tools.pm
+++ b/src/PVE/Tools.pm
@@ -62,6 +62,20 @@ CLONE_NEWIPC
CLONE_NEWUSER
CL
Patch v4 available:
https://lists.proxmox.com/pipermail/pve-devel/2023-November/060022.html
On 10/11/2023 11:44, Wolfgang Bumiller wrote:
On Tue, Nov 07, 2023 at 02:46:42PM +0100, Filip Schauer wrote:
Add a dev[n] argument to the container config to pass devices through to
a container. A devic
On 11/13/23 11:04, Alexandre Derumier wrote:
> I have splitted the ipam add|del , from the dhcp lease reservation.
>
> The ipam add|del ip is done when creating|deleting vm, or add|del a vm nic
>
> The dhcp reservation is done at vm start.
>
> The delete of dhcp reservation is done at vm destr
--- Begin Message ---
> But I do have another suggestion too: Should we rather automatically
> preserve the current volume name (just replacing the VM ID) if there is
> no other volume with that name and choose a new name if there is? For
> offline storage migration, we also do it like that (sans r
Am 31/10/2023 um 10:05 schrieb Folke Gleumes:
> The ToS endpoint ignored data that is needed to detect if EAB needs to
> be used. Instead of adding a new endpoint that does the same request,
> the tos endpoint is deprecated and replaced by the meta endpoint,
> that returns all information returned
Am 31/10/2023 um 10:05 schrieb Folke Gleumes:
> Changes since v2:
> * reverted the new_account abi to be non breaking
>
> Changes since v1:
> * fixed nit's
> * expanded meta endpoint by all return values defined in the rfc
> * expanded new_account signature by field for eab credentials
> * al
On 11/3/23 11:39, Fiona Ebner wrote:
[...]
This essentially duplicates most of the same function in the parent
plugin, i.e. LVMPlugin. What you can do to avoid it, is introduce new
helper functions for the parts that are different, call those in
LVMPlugin's implementation and overwrite the help
Am 13/11/2023 um 11:14 schrieb Moayad Almalat:
> update Arabic translation
>
> Signed-off-by: Moayad Almalat
>
> ---
> ar.po | 961 +++---
> 1 file changed, 380 insertions(+), 581 deletions(-)
>
>
applied, thanks!
_
Am 13/11/2023 um 11:20 schrieb Hannes Laimer:
> Adds support for bulk suspending VMs as it already exists for stop.
>
> v2, thanks @Thomas:
> * api: skip CTs + fix permission checks
> * ui: disable `suspendall` button if user isn;t allowed to use it
> * ui: use new bulk action filtering
>
> Hanne
Am 13.11.23 um 14:13 schrieb Hannes Dürr:
>
> On 11/3/23 11:39, Fiona Ebner wrote:
>> 1. check if base
>> 2. check if already exists/rename allowed
>> 3. call parent plugin's volume_import function passing along
>> vm-XYZ-disk-N (or undef if it should be renamed) instead of
>> base-XYZ-disk-N
>> 4
caaIdentities was mistakenly labled as a string in a previous patch and
not as an array of strings, as it is defined in the rfc [0].
[0] https://datatracker.ietf.org/doc/html/rfc8555#section-7.1.1
Signed-off-by: Folke Gleumes
---
This is a followup to Thomas correction, regarding the metadata s
Am 13/11/2023 um 11:30 schrieb Filip Schauer:
> Signed-off-by: Filip Schauer
> ---
> src/PVE/Syscall.pm | 1 +
> src/PVE/Tools.pm | 5 +
> 2 files changed, 6 insertions(+)
>
>
applied this one already, thanks!
___
pve-devel mailing list
pve-de
Am 13/11/2023 um 11:30 schrieb Filip Schauer:
> Signed-off-by: Filip Schauer
> ---
> src/PVE/Tools.pm | 31 +++
> 1 file changed, 31 insertions(+)
>
>
applied this one already too, thanks!
Albeit I'm not too happy with having those constants in PVE::Tools
in the fir
Am 13/11/2023 um 15:11 schrieb Folke Gleumes:
> caaIdentities was mistakenly labled as a string in a previous patch and
> not as an array of strings, as it is defined in the rfc [0].
>
> [0] https://datatracker.ietf.org/doc/html/rfc8555#section-7.1.1
>
> Signed-off-by: Folke Gleumes
> ---
>
> T
a few high level ui things
(i did not look too deeply in the code, but i'll send
probably some comments there too)
that probably was already there, but i find the all/any + invert combination
confusing (i had to think about it for a bit before getting a grasp on it)
i would propose we can write
Am 13/11/2023 um 15:34 schrieb Dominik Csapak:
> (also is the change from and/or to all/any not a breaking change?,
> did we expose this in the api yet ?)
there's lots of breaking change, it was applied a bit to early (reviewer
"fault", not dev one) but only ever exposed on pvetest, so Lukas got m
Hi, thanks for your input.
On 11/13/23 15:34, Dominik Csapak wrote:
a few high level ui things
(i did not look too deeply in the code, but i'll send
probably some comments there too)
Just as a warning, the tree code/data binding is definitely not as clean
as it could be right now, a cleanup pa
Try to homogenize style and format
Title case naming conventions for configuration options
Simplify examples
Re-phrase descriptions
Signed-off-by: Stefan Lendl
---
Notes:
Used single line heading style
The multi line heading format just does not work with syntax
highlighting in
in generaly my biggest issue with this patch is that
the various functions/formulas/handler are way to far
away from the place they live/get used/etc.
in generaly i'd try to use the 'controller+viewmodel' consistently
so have a controller (where the logic (methods+handlers) live, the
view where t
Am 23/06/2023 um 11:45 schrieb Alexandre Derumier:
> Like ceph mgr dashboard, we need a warning state.
>
> - set degraded as warning instead working
> - set undersized as warning instead error
> - rename error as critical
> - add "working" (info-blue) color for working state
> - use warning (orang
Am 10/11/2023 um 09:47 schrieb Lukas Wagner:
> I don't have any strong preference for any form, I just think
> that some consistency with the API would be nice - and changing
> the API routes would be much more work ;)
hehe OK, as said, it doesn't matters that much so I'm fine with whatever
you pr
Hi Stefan !
On 11/13/23 11:04, Alexandre Derumier wrote:
> I have splitted the ipam add|del , from the dhcp lease reservation.
>
> The ipam add|del ip is done when creating|deleting vm, or add|del a
> vm nic
>
> The dhcp reservation is done at vm start.
>
> The delete of dhcp reservation is don
Am 19/10/2023 um 11:13 schrieb Dominik Csapak:
> to be able to download 'tar.zst' archives
>
> Signed-off-by: Dominik Csapak
> ---
> src/PVE/API2/Storage/FileRestore.pm | 9 -
> 1 file changed, 8 insertions(+), 1 deletion(-)
>
>
applied, thanks!
__
Am 19/10/2023 um 11:13 schrieb Dominik Csapak:
> all endpoints now can handle the 'tar' parameter, so add it for all
>
> Signed-off-by: Dominik Csapak
> ---
> src/window/FileBrowser.js | 6 +-
> 1 file changed, 1 insertion(+), 5 deletions(-)
>
>
applied, thanks!
_
Am 19/10/2023 um 11:13 schrieb Dominik Csapak:
> diff --git a/src/window/FileBrowser.js b/src/window/FileBrowser.js
> index 4e4c639..e036d9f 100644
> --- a/src/window/FileBrowser.js
> +++ b/src/window/FileBrowser.js
> @@ -61,10 +61,6 @@ Ext.define("Proxmox.window.FileBrowser", {
> 'd': tr
On 11/13/23 16:46, Thomas Lamprecht wrote:
Am 19/10/2023 um 11:13 schrieb Dominik Csapak:
diff --git a/src/window/FileBrowser.js b/src/window/FileBrowser.js
index 4e4c639..e036d9f 100644
--- a/src/window/FileBrowser.js
+++ b/src/window/FileBrowser.js
@@ -61,10 +61,6 @@ Ext.define("Proxmox.window
On 11/13/23 16:44, DERUMIER, Alexandre wrote:
> I think it also need api to add dhcp-range in subnet, as for external
> ipam like netbox, It need to call netbox api to add the ip range.
>
> So, maybe a button in subnet panel :"add dhcp-range", allowing to add
> multiple range.
Yes, that's wha
On 11/13/23 11:04, Alexandre Derumier wrote:
> if ($have_sdn) {
> -PVE::Network::SDN::Dhcp::add_mapping($vmid, $net->{bridge},
> $net->{macaddr});
> +PVE::Network::SDN::Dhcp::add_mapping($net->{bridge}, $net->{macaddr});
>
> PVE::Network::SDN::Zones::tap_create($iface, $net->{br
Am 22/08/2023 um 11:04 schrieb Aaron Lauterer:
> It is possible to have multiple OSD daemons on a single disk. This is
> useful if fast NVME drives are used to utilize their full potential.
>
> For these situations we want to list all OSD daemons that are located on
> the disk in the disk panel of
When using PCI(e) passthrough, enabling ballooning for a VM (as in, setting a
"minimum memory" amount that is smaller than "memory") does not have any
effect, which may be surprising to users [0].
Patch #1 adds a note about this incompatibility to the PCI(e) passthrough and
ballooning sections of
When using PCI(e) passthrough, setting a minimum amount of memory does
not have any effect, which may be surprising to users [0]. Add a note
to the PCI(e) passthrough section, and reference it in the ballooning
section.
[0] https://forum.proxmox.com/threads/134202/
Signed-off-by: Friedrich Weber
If a VM uses PCI(e) passthrough, ballooning does not work as expected:
The QEMU process will always consume the full memory amount given in
`memory`, even if `balloon` is set to a smaller (non-zero) amount. The
reason is that the PCI device might use DMA, so QEMU needs to map the
complete guest mem
Am 04/07/2023 um 11:45 schrieb Fabian Grünbichler:
> it's not returned anymore by the corresponding backends, since fetching
> changelogs is now fully delegated to `apt`.
>
> Signed-off-by: Fabian Grünbichler
> ---
>
> Notes:
> could benefit from a Breaks on old versions of pve-manager/pmg-a
On November 13, 2023 6:18 pm, Thomas Lamprecht wrote:
> Am 04/07/2023 um 11:45 schrieb Fabian Grünbichler:
>> it's not returned anymore by the corresponding backends, since fetching
>> changelogs is now fully delegated to `apt`.
>>
>> Signed-off-by: Fabian Grünbichler
>> ---
>>
>> Notes:
>>
61 matches
Mail list logo