[pve-devel] [PATCH manager] vzdump: getlock: return lock file handle and let the caller close it

2021-04-12 Thread Fabian Ebner
so it doesn't get out of scope too early. Regression introduced by a06e0311de595e19f6312a12d07c6767365d7a2c as pointed out by Fabian Grünbichler. Reported in the community forum: https://forum.proxmox.com/threads/limit-simultaneous-backup-jobs.87489 Suggested-by: Thomas Lamprecht Signed-off-by:

[pve-devel] [PATCH] Add API for VM import

2021-04-12 Thread Dominic Jäger
Extend qm importdisk/importovf functionality to the API. Co-authored-by: Fabian Grünbichler Signed-off-by: Dominic Jäger --- v8: - Fabian moved the import functions into the existing create_vm / update_vm_api - Dropped the separate API endpoints & import lock PVE/API2/Qemu.pm | 175 +

[pve-devel] [PATCH] Add GUI to import disk & VM

2021-04-12 Thread Dominic Jäger
Add GUI wizard to import whole VMs and a window to import single disks in Hardware View. Signed-off-by: Dominic Jäger --- v8: - Adapt to new API - Some small fixes - Much renaming PVE/API2/Nodes.pm | 7 + www/manager6/Makefile | 2 + www/manager6/Work

[pve-devel] [PATCH guest-common 2/3] partially fix 3111: snapshot rollback: fix removing replication snapshots

2021-04-12 Thread Fabian Ebner
Get the replicatable volumes from the snapshot config rather than the current config. And filter those volumes further to those that will actually be rolled back. Previously, a volume that only had replication snapshots (e.g. because it was added after the non-replication snapshot was taken, or th

[pve-devel] [RFC guest-common 3/3] fix 3111: replicate guest on rollback if there are replication jobs for it

2021-04-12 Thread Fabian Ebner
so that there will be a valid replication snapshot again. Otherwise, replication will be broken after a rollback if the last (non-replication) snapshot is removed before replication can run once. Signed-off-by: Fabian Ebner --- Not a huge fan of this, but the alternatives I could come up with d

[pve-devel] [PATCH storage 1/3] volume export/import: allow uppercase letters

2021-04-12 Thread Fabian Ebner
Bug reported in the community forum[0]. Currently, it's possible to break replication by: 1. have an existing snapshot whose name contains an uppercase letter 2. set up a replication job and run it 3. rollback to the existing snapshot 4. replicate again -> fails The failure occurs, because after

[pve-devel] applied: [PATCH manager] vzdump: getlock: return lock file handle and let the caller close it

2021-04-12 Thread Thomas Lamprecht
On 12.04.21 10:47, Fabian Ebner wrote: > so it doesn't get out of scope too early. > > Regression introduced by a06e0311de595e19f6312a12d07c6767365d7a2c as pointed > out by Fabian Grünbichler. > > Reported in the community forum: > https://forum.proxmox.com/threads/limit-simultaneous-backup-jobs.

[pve-devel] applied: [PATCH storage] zfs: fix #3345 restore container volume to ZFS with size 0

2021-04-12 Thread Thomas Lamprecht
On 09.04.21 17:10, Aaron Lauterer wrote: > A restore to ZFS for a container which has a volume (rootfs / mount > point) of size 0 failed because the refquota property does not accept > '0k' but wants 'none' in that situation. > > Signed-off-by: Aaron Lauterer > --- > PVE/Storage/ZFSPoolPlugin.pm

[pve-devel] applied: [PATCH v2 storage 1/3] rbd: centralize rbd path concatenation

2021-04-12 Thread Thomas Lamprecht
On 07.04.21 16:22, Aaron Lauterer wrote: > The / paths are needed in quite a lot of places. Having one > single place where they are created helps to reduce duplicate code and > makes it easier to introduce new features. > > The 'add_pool_to_disk' sub was already doing that but the name was not >

[pve-devel] applied: [PATCH v2 storage 2/3] rbd: fix #3286 add namespace support

2021-04-12 Thread Thomas Lamprecht
On 07.04.21 16:22, Aaron Lauterer wrote: > This patch introduces support for Cephs RBD namespaces. > > A new storage config parameter 'namespace' defines the namespace to be > used for the RBD storage. > > The namespace must already exist in the Ceph cluster as it is not > automatically created.

[pve-devel] applied: [PATCH v2 storage 3/3] rbd: add integration test for namespace handling

2021-04-12 Thread Thomas Lamprecht
On 07.04.21 16:22, Aaron Lauterer wrote: > This test is intended to be run on a hyperconverged PVE cluster to test > the most common operations of VMs using a namespaced Ceph RBD pool. > > Signed-off-by: Aaron Lauterer > --- > v1 -> v2: > reworked the test from the feedback I got [0]. > > * test

[pve-devel] applied: [PATCH storage 1/3] volume export/import: allow uppercase letters

2021-04-12 Thread Thomas Lamprecht
On 12.04.21 13:37, Fabian Ebner wrote: > Bug reported in the community forum[0]. > > Currently, it's possible to break replication by: > 1. have an existing snapshot whose name contains an uppercase letter > 2. set up a replication job and run it > 3. rollback to the existing snapshot > 4. replica

[pve-devel] [PATCH widget-toolkit 1/2] ui: network: add columns for vlan-id and vlan-raw-device

2021-04-12 Thread Aaron Lauterer
Signed-off-by: Aaron Lauterer --- There are probably a few opinions if these columns should be hidden by default and where they should be placed. src/node/NetworkView.js | 14 ++ 1 file changed, 14 insertions(+) diff --git a/src/node/NetworkView.js b/src/node/NetworkView.js index a

[pve-devel] [RFC series 0/2] Show more vlan infos

2021-04-12 Thread Aaron Lauterer
The main motivation here is to make the VLAN tags configured for an interface better visible. The approach taken in this RFC is to use the already existing vlan-id and vlan-raw-device values. These were only present if the vlan device was configured with those explicit options, available with ifupd

[pve-devel] [PATCH common 2/2] inotify: read_interfaces: add vlan-id and vlan-raw-device on dot notation vlan interfaces

2021-04-12 Thread Aaron Lauterer
Setting the vlan-id and vlan-raw-device value for vlan devices that follow the dot notaton (interface.vlan) aligns how dot notation vlan devices and vlan devices that use the explicit vlan-id and vlan-raw-device options, available with ifupdown2, are represented in API return values. Previously th

[pve-devel] applied: [PATCH pve-docs] fix 3372: fix typos, and impove pve-gui docs

2021-04-12 Thread Thomas Lamprecht
On 09.04.21 15:20, Dylan Whyte wrote: > This reformulates quite a bit of the gui section and corrects small > typos elsewhere. > > Signed-off-by: Dylan Whyte > --- > ha-manager.adoc | 4 +- > local-zfs.adoc| 14 ++-- > pve-firewall.adoc | 8 +- > pve-gui.adoc | 18

[pve-devel] [PATCH installer] highlight focused button with dark orange

2021-04-12 Thread Oguz Bektas
idea was from community forum [0] arbitrary css can be used to style the installer, for now just add the highlight feature. [0]: https://forum.proxmox.com/threads/proxmox-installation-eye-catching-color.87440 Signed-off-by: Oguz Bektas --- proxinstall | 7 +++ 1 file changed, 7 insertions(

[pve-devel] [PATCH proxmox-widget-toolkit 1/2] FileBrowser: allow downloading root folder and simplify code

2021-04-12 Thread Stefan Reiter
Signed-off-by: Stefan Reiter --- Smoke tested by downloading an entire container archive as zip, extracting and checking the files. If there was a reason for this to be disabled let me know. Based on my previous series to move the FileBrowser to the widget toolkit: https://lists.proxmox.com/pipe

[pve-devel] [PATCH proxmox-backup 2/2] api/datastore: allow pxar file download of entire archive

2021-04-12 Thread Stefan Reiter
Treat filepaths like "/root.pxar.didx" without a trailing slash as wanting to download the entire archive content instead of erroring. The zip-creation code already works fine for this scenario. Signed-off-by: Stefan Reiter --- src/api2/admin/datastore.rs | 2 +- 1 file changed, 1 insertion(+),

[pve-devel] applied: [pbs-devel] [PATCH proxmox-widget-toolkit 2/3] FileBrowser: remove PBS dependencies

2021-04-12 Thread Thomas Lamprecht
On 01.04.21 17:34, Stefan Reiter wrote: > Don't construct any URLs locally, instead have them (and their static > parameters) be passed in. This removes the need to have the datastore. > > Signed-off-by: Stefan Reiter > --- > src/window/FileBrowser.js | 52 ++-

[pve-devel] applied: [pbs-devel] [PATCH proxmox-widget-toolkit 1/3] window: add FileBrowser

2021-04-12 Thread Thomas Lamprecht
On 01.04.21 17:34, Stefan Reiter wrote: > from proxmox-backup, only names changed > > Signed-off-by: Stefan Reiter > --- > src/Makefile | 1 + > src/window/FileBrowser.js | 248 ++ > 2 files changed, 249 insertions(+) > create mode 100644 src/w

[pve-devel] applied: [pbs-devel] [PATCH proxmox-backup 2/2] api/datastore: allow pxar file download of entire archive

2021-04-12 Thread Thomas Lamprecht
On 12.04.21 17:32, Stefan Reiter wrote: > Treat filepaths like "/root.pxar.didx" without a trailing slash as > wanting to download the entire archive content instead of erroring. The > zip-creation code already works fine for this scenario. > > Signed-off-by: Stefan Reiter > --- > src/api2/admin