Re: [PHP] Which is better coding style...

2001-04-20 Thread Geir Eivind Mork
On Thursday 19 April 2001 21:48, Steve Lawson wrote: > Personally, I hate trailing {'s Personally, I hate having the {'s on the next line. I always trail them in others code when they have them on the next line :) and there are thousand of ways that the people here displays textblocks. some

Re: [PHP] Which is better coding style...

2001-04-20 Thread Christian Reiniger
On Thursday 19 April 2001 22:31, you wrote: > Definitely the second style :) > > (If we were talking about C(++) then the first would have even been > forbidden by my companies coding standard as well as several coding > standards of other companies I worked for.) Urgh That's a rule back from ye

RE: [PHP] Which is better coding style...

2001-04-19 Thread Joe Sheble \(Wizaerd\)
> -Original Message- > From: ..s.c.o.t.t.. [gts] [mailto:[EMAIL PROTECTED]] > Sent: Thursday, April 19, 2001 2:05 PM > To: Php-General > Subject: RE: [PHP] Which is better coding style... > > > OOooo... > > it drives me nuts when i see beginning brackets > on s

Re: [PHP] Which is better coding style...

2001-04-19 Thread Szii
hat I mean, Vern?";} -Szii - Original Message - From: Chris Lee <[EMAIL PROTECTED]> To: <[EMAIL PROTECTED]> Sent: Thursday, April 19, 2001 3:51 PM Subject: Re: [PHP] Which is better coding style... > I would like to see an editor with a built in code beutifie

Re: [PHP] Which is better coding style...

2001-04-19 Thread Chris Lee
I would like to see an editor with a built in code beutifier and un-beutifier. I like the if (true) { } else { } method, but pear standards are if (true) { } else { } it would be nice to see ultra edit convert it to the first format for me and save it as the second for pear. -- Chri

Re: [PHP] Which is better coding style...

2001-04-19 Thread Chris Lee
;other"; break; } return $retval; } > -Original Message- > From: ..s.c.o.t.t.. [gts] [mailto:[EMAIL PROTECTED]] > Sent: 19 April 2001 21:31 > To: Php-General > Subject: RE: [PHP] Which is better coding style... > > > i say the first styl

Re: [PHP] Which is better coding style...

2001-04-19 Thread Chris Lee
I preffer the first. -- Chris Lee [EMAIL PROTECTED] ""Boget, Chris"" <[EMAIL PROTECTED]> wrote in message [EMAIL PROTECTED]">news:[EMAIL PROTECTED]... Which is better? function blah() { switch( $bob ) { case 1: return "this"; case 2: return "that"; default:

Re: [PHP] Which is better coding style...

2001-04-19 Thread Plutarck
> if (...) { > } > else { > } > > (it drives me nuts to see "} else {" also) > > > > -Original Message- > > From: Sander Pilon [mailto:[EMAIL PROTECTED]] > > Sent: Thursday, April 19, 2001 4:32 PM > > To: 'Php-General' > &

Re: [PHP] Which is better coding style...

2001-04-19 Thread David Bouw
Your coding style is not the most used.. But I must be honest and tell you that I also find the clearest way... I also use it on all my own code.. It has got the advantage that you always see all brackets (no need to scroll to the right to find a bracket) and if you go down on the same horizontal

Re: [PHP] Which is better coding style...

2001-04-19 Thread Chris Adams
On 19 Apr 2001 14:08:13 -0700, ..s.c.o.t.t.. [gts] <[EMAIL PROTECTED]> wrote: >OOooo... > >it drives me nuts when i see beginning brackets >on seperate lines ;) > >i like to start brackets on the same line as the >statement and finish them on a line of their own. Very strong agreement here. I thi

RE: [PHP] Which is better coding style...

2001-04-19 Thread Philip Olson
coding style? here's what pear has to say : http://www.php.net/manual/en/pear.standards.php http://www.php.net/manual/en/pear.standards.control.php [ example ] switch (condition) { case 1: action1; break; case 2: action2; break; default: defaultac

Re: [PHP] Which is better coding style...

2001-04-19 Thread Norbert Pfeiffer
Hi, This participates the clearest for me, but unfortunately not usual. if (...) {...commands... switch(...) {case commands... case commands... case commands... } while(...) {...commands... } } else {...commands...

RE: [PHP] Which is better coding style...

2001-04-19 Thread ..s.c.o.t.t.. [gts]
gt; From: Sander Pilon [mailto:[EMAIL PROTECTED]] > Sent: Thursday, April 19, 2001 4:32 PM > To: 'Php-General' > Subject: RE: [PHP] Which is better coding style... > > > Definitely the second style :) > > (If we were talking about C(++) then the first would have eve

Re: [PHP] Which is better coding style...

2001-04-19 Thread Martín Marqués
On Jue 19 Abr 2001 23:35, Miles Thompson wrote: > Amen! For both elimination of trailing {'s , and a good clear break. > > I don't know how trailing {'s came about, but I find the blocks are harder > to follow. I consider them HIDDEN rather than trailing, but I cut my teeth > on Pascal, and FoxPro

Re: [PHP] Which is better coding style...

2001-04-19 Thread Miles Thompson
Amen! For both elimination of trailing {'s , and a good clear break. I don't know how trailing {'s came about, but I find the blocks are harder to follow. I consider them HIDDEN rather than trailing, but I cut my teeth on Pascal, and FoxPro. While we're at it, how about plain old carriage retu

RE: [PHP] Which is better coding style...

2001-04-19 Thread Sander Pilon
etval = "other"; break; } return $retval; } > -Original Message- > From: ..s.c.o.t.t.. [gts] [mailto:[EMAIL PROTECTED]] > Sent: 19 April 2001 21:31 > To: Php-General > Subject: RE: [PHP] Which is better coding style... > > > i say the first style.

Re: [PHP] Which is better coding style...

2001-04-19 Thread Steve Lawson
Personally, I hate trailing {'s I think this function blah() { switch( $bob ) { case 1: $var = "whatever"; break; } } Is much easier to read and follow. As for the exiting question... The "proper" way is to use the breaks. "They" say that multiple returns in any

RE: [PHP] Which is better coding style...

2001-04-19 Thread ..s.c.o.t.t.. [gts]
i say the first style. unneeded variables and other thingies just obscure things and make it harder to maintain. > -Original Message- > From: Boget, Chris [mailto:[EMAIL PROTECTED]] > Subject: [PHP] Which is better coding style... > > Which is better? > > function blah() { > switch(

Re: [PHP] Which is better coding style...

2001-04-19 Thread Christian Reiniger
On Thursday 19 April 2001 19:57, you wrote: > Which is better? > > function blah() { > switch( $bob ) { > case 1: >return "this"; > function blah() { > $retval = ""; > > switch( $bob ) { > case 1: >$retval = "this"; >break; > In other words, is it good pra