Re: [PHP] php-fpm does'nt work

2011-01-13 Thread Sharl
check your nginx configuration. mufenggu 编写: >hi, i just install nginx-0.8.54, php-5.3.5, mysql-5.5.8 >in nginx.conf i pass .php file to php-fpm(127.0.0.1:9000) >i can get static file like index.html, but i got a blank page from >simple test.php file, there only one command: > > > >and no errors

[PHP] php-fpm does'nt work

2011-01-13 Thread mufenggu
hi, i just install nginx-0.8.54, php-5.3.5, mysql-5.5.8 in nginx.conf i pass .php file to php-fpm(127.0.0.1:9000) i can get static file like index.html, but i got a blank page from simple test.php file, there only one command: and no errors print out, i set all display_errors=on, and it doesn't

Re: [PHP] Re: query strings and other delights

2011-01-13 Thread David Robley
kbai...@howlermonkey.net wrote: > ...Holy cow... nothing to extract the query string, it's automatically > part of the environment. So I just do work with the $_GET string, it's > in there already... yikes. > > You might find phpinfo() particularly useful as an indicator of how php is configure

Re: [PHP] A bad design decision or pure genius?

2011-01-13 Thread li...@pruimphotography.com
On Jan 13, 2011, at 8:53 PM, Daevid Vincent wrote: -Original Message- From: li...@pruimphotography.com [mailto:li...@pruimphotography.com] Sent: Thursday, January 13, 2011 4:50 PM To: php-general@lists.php.net Subject: [PHP] A bad design decision or pure genius? Hey Everyone, I have a

RE: [PHP] A bad design decision or pure genius?

2011-01-13 Thread Daevid Vincent
> -Original Message- > From: li...@pruimphotography.com [mailto:li...@pruimphotography.com] > Sent: Thursday, January 13, 2011 4:50 PM > To: php-general@lists.php.net > Subject: [PHP] A bad design decision or pure genius? > > Hey Everyone, > > I have a question about php & javascript...

Re: [PHP] A bad design decision or pure genius?

2011-01-13 Thread li...@pruimphotography.com
On Jan 13, 2011, at 7:54 PM, Joshua Kehn wrote: On Jan 13, 2011, at 7:49 PM, li...@pruimphotography.com wrote: Hey Everyone, I have a question about php & javascript... Yes I know this forum is for php BUT I needed an opinion on where to look for stuff... I have a application that I'm wo

Re: [PHP] A bad design decision or pure genius?

2011-01-13 Thread Joshua Kehn
On Jan 13, 2011, at 7:49 PM, li...@pruimphotography.com wrote: > Hey Everyone, > > I have a question about php & javascript... Yes I know this forum is for php > BUT I needed an opinion on where to look for stuff... > > I have a application that I'm working on that uses google maps to display

[PHP] A bad design decision or pure genius?

2011-01-13 Thread li...@pruimphotography.com
Hey Everyone, I have a question about php & javascript... Yes I know this forum is for php BUT I needed an opinion on where to look for stuff... I have a application that I'm working on that uses google maps to display interactive maps (using javascript) on the website. I now have the nee

Re: [Fwd: Re: [PHP] Re: Rewriting string]

2011-01-13 Thread Daniel Brown
On Thu, Jan 13, 2011 at 16:31, Nathan Rixham wrote: > Dan, you misread, I fwd'd the email, that was Richards reply to me. > > You should know I don't reply to people in such a manner by now :) Thought it was a bit odd, but in Gmail, it didn't show forwarding, only a reply - seemingly written

Re: [PHP] Re: Rewriting string

2011-01-13 Thread Nathan Rixham
Nathan Rixham wrote: Admin wrote: $categorys = array('home', 'services', 'gallery', 'about_us', 'contact_us', 'testimonials'); If(in_array($_GET['page'], $categories)) { echo ''.str_replace("_"," ",$_GET['page']).''; }else{ echo ''.str_replace("_"," ",$_GET['page']).''; } I normally never wr

Re: [PHP] Re: Rewriting string

2011-01-13 Thread Nathan Rixham
Admin wrote: $categorys = array('home', 'services', 'gallery', 'about_us', 'contact_us', 'testimonials'); If(in_array($_GET['page'], $categories)) { echo ''.str_replace("_"," ",$_GET['page']).''; }else{ echo ''.str_replace("_"," ",$_GET['page']).''; } I normally never write someones code for t

Re: [PHP] Re: Rewriting string

2011-01-13 Thread Admin
> $categorys = array('home', 'services', 'gallery', 'about_us', 'contact_us', > 'testimonials'); If(in_array($_GET['page'], $categories)) { echo ''.str_replace("_"," ",$_GET['page']).''; }else{ echo ''.str_replace("_"," ",$_GET['page']).''; } I normally never write someones code for them but you

Re: [PHP] Closure and $this

2011-01-13 Thread David Harkness
On Wed, Jan 12, 2011 at 10:57 PM, Larry Garfield wrote: > I believe this is the relevant RFC: > > http://wiki.php.net/rfc/closures/object-extension > That was a good bedtime read last night, Larry. I prefer method A which is nearly identical to Java's inner classes where $this would remain tied t

Re: [PHP] Array Symbol Suggestion

2011-01-13 Thread David Harkness
On Thu, Jan 13, 2011 at 10:07 AM, David Hutto wrote: > On Thu, Jan 13, 2011 at 12:59 PM, David Harkness > > I learned it early on as well, and I never really liked it. Instead of > > $iFish I would prefer a more descriptive name such as $fishCount. > > What info did you get on hook for the client

Re: [PHP] Re: query strings and other delights

2011-01-13 Thread kbailey
Cool. SO, now it's in a string, I can chop, slice, dice, make gazillions of steak fries, and drive on. So, now we can munch a webpage with a query string as a KEY to unlock access to it, and use DIE to stop the process if it is not there, or is the correct key, so far making sense? Quot

[PHP] Re: query strings and other delights

2011-01-13 Thread Nathan Rixham
kbai...@howlermonkey.net wrote: Your turn! :-D just in case I totally misunderstood, and you simply have the string and want to rip out the component parts of the query string, then: Or similar, watch out for parse_str though as it'll swap out spaces and . for _ - which is nice. -- PHP

Re: [PHP] Array Symbol Suggestion

2011-01-13 Thread David Hutto
On Thu, Jan 13, 2011 at 12:59 PM, David Harkness wrote: > On Thu, Jan 13, 2011 at 2:23 AM, Richard Quadling wrote: > >> The Hungarian Notation [1] was what I was taught all those years ago >> when I learnt standard C programming. > > > I learned it early on as well, and I never really liked it. In

Re: [PHP] Re: query strings and other delights

2011-01-13 Thread Nathan Rixham
kbai...@howlermonkey.net wrote: ...Holy cow... nothing to extract the query string, it's automatically part of the environment. So I just do work with the $_GET string, it's in there already... yikes. yup OK, so $_GET is an array keyed to keywords; plug in the key, out comes the value. What

Re: [PHP] Array Symbol Suggestion

2011-01-13 Thread David Harkness
On Thu, Jan 13, 2011 at 2:23 AM, Richard Quadling wrote: > The Hungarian Notation [1] was what I was taught all those years ago > when I learnt standard C programming. I learned it early on as well, and I never really liked it. Instead of $iFish I would prefer a more descriptive name such as $fi

Re: [PHP] Re: query strings and other delights

2011-01-13 Thread kbailey
...Holy cow... nothing to extract the query string, it's automatically part of the environment. So I just do work with the $_GET string, it's in there already... yikes. Quoting Nathan Rixham : kbai...@howlermonkey.net wrote: Your turn! :-D $_GET and if you do post.. (can you guess?)

[PHP] Re: Rewriting string

2011-01-13 Thread Nathan Rixham
David McGlone wrote: Hi everyone, I think the subject is right, or somewhere close. Anyway I am trying to perform a little trickery here with links. In the following code you can see where I am trying to replace the link on the current page so it's not a link when on that page. I think I got

[PHP] Re: query strings and other delights

2011-01-13 Thread Nathan Rixham
kbai...@howlermonkey.net wrote: Your turn! :-D $_GET and if you do post.. (can you guess?) $_POST usage: http://www.foo.org/item1/delivery.php?item=name&code=DATA http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php

Re: [PHP] query strings and other delights

2011-01-13 Thread Marc Guay
Give parse_str() a go. http://ca.php.net/manual/en/function.parse-str.php -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php

[PHP] query strings and other delights

2011-01-13 Thread kbailey
I have circumstances which cause me to investigate get strings and such, and wish to start a thread discussing such matters. This relates to a cluster of functions iin php such as public array HttpQueryString::toArray ( void ) and it's bretherin and sisterin and otherin. Being new to php,

Re: [PHP] Closure and $this

2011-01-13 Thread Raymond Irving
Many thanks Larry. I like the Closure::bind() method proposal. Best regards __ Raymond Do more with less - http://raxanpdi.com --- On Thu, 1/13/11, Larry Garfield wrote: From: Larry Garfield Subject: Re: [PHP] Closure and $this To: php-general@lists.php.net Date: Thursday, January 13, 2011,

Re: [PHP] Rewriting string

2011-01-13 Thread Admin
Try this. After you create the array If(in_array($_GET['page'],$categorys)){ }else{ } Sent from my iPhone On Jan 13, 2011, at 5:09 AM, David McGlone wrote: > Hi everyone, > > I think the subject is right, or somewhere close. Anyway I am trying to > perform a little trickery here with li

Re: [PHP] Array Symbol Suggestion

2011-01-13 Thread Richard Quadling
On 12 January 2011 20:23, wrote: > Thanks for all the responses to my suggestion.  I realize this would be a > major change, so that's why I also mentioned it as an addition to the > language. > > I'm sure it's just what you're used to, but still being new to all this, it > just makes sense (t

[PHP] Rewriting string

2011-01-13 Thread David McGlone
Hi everyone, I think the subject is right, or somewhere close. Anyway I am trying to perform a little trickery here with links. In the following code you can see where I am trying to replace the link on the current page so it's not a link when on that page. I think I got the general idea of wha

Re: [PHP] HTML errors

2011-01-13 Thread Pete Ford
On 12/01/11 14:13, Richard Quadling wrote: On 12 January 2011 14:07, Steve Staples wrote: On Wed, 2011-01-12 at 13:40 +, Richard Quadling wrote: On 12 January 2011 13:20, Steve Staples wrote: Jim, Not to be a smart ass like Danial was (which was brilliantly written though), but you hav