Hi Peter,
I would just fill in the configuration and have it give me the correct
client which uses the configuration instance.
=
| client |
client := TwitterConfiguration new
username: 'stuff';
password: 'password1';
port: '1234';
useHttps;
client.
TwitterCo
> Am 11.02.2018 um 21:34 schrieb Stephane Ducasse :
>
> Arghh no magic please.
> I got burned by too much DNU override.
+ magic number
Norbert
>
>
> On Sun, Feb 11, 2018 at 8:17 PM, Christian Caldeiro
> wrote:
>> Maybe using directly TwitterClient, but using #doesNotUnderstand: to
>> de
> On 11 Feb 2018, at 22:02, Richard Sargent
> wrote:
>
> Beautiful, Sven!
>
> I have a publicity suggestion. Make a larger png of that and share it on
> Twitter and LinkedIn.
> (And if you do, I would also suggest cascading the message sends to the
> camera.)
>
> I would love to share that
There are two use cases that come immediately to mind. They may be the two
most important.
"As a Compiler, I need to be able to resolve a Symbol to a known Object."
"As a Browser, I need to be able to identify the possible resolutions of a
String to known Objects."
I can elaborate on those, but
2018-02-11 21:08 GMT+01:00 Stephane Ducasse :
> Denis
>
> we should introduce classNamed: now we can have traits and globals too :(
>
Yes, we need to think about it.
> Idea? may be can still classNamed:
>
> Stef
>
>
> On Sun, Feb 11, 2018 at 8:55 PM, Denis Kudriashov
> wrote:
> >
> >
> > 2018-
Arghh no magic please.
I got burned by too much DNU override.
On Sun, Feb 11, 2018 at 8:17 PM, Christian Caldeiro
wrote:
> Maybe using directly TwitterClient, but using #doesNotUnderstand: to
> delegate there message sends to the configuration object(kind of a proxy
> pattern). That way the
2018-02-11 16:55 GMT-03:00 Denis Kudriashov :
>
>
> 2018-02-11 20:36 GMT+01:00 Hernán Morales Durand :
>>
>> 2018-02-11 16:10 GMT-03:00 Denis Kudriashov :
>> > Hi Hernan.
>> >
>> > 2018-02-11 19:57 GMT+01:00 Hernán Morales Durand
>> > :
>> >>
>> >> Hi Denis
>> >>
>> >> 2018-02-10 15:18 GMT-03:00 De
Denis
we should introduce classNamed: now we can have traits and globals too :(
Idea? may be can still classNamed:
Stef
On Sun, Feb 11, 2018 at 8:55 PM, Denis Kudriashov wrote:
>
>
> 2018-02-11 20:36 GMT+01:00 Hernán Morales Durand :
>>
>> 2018-02-11 16:10 GMT-03:00 Denis Kudriashov :
>> > Hi
2018-02-11 20:36 GMT+01:00 Hernán Morales Durand :
> 2018-02-11 16:10 GMT-03:00 Denis Kudriashov :
> > Hi Hernan.
> >
> > 2018-02-11 19:57 GMT+01:00 Hernán Morales Durand <
> hernan.mora...@gmail.com>:
> >>
> >> Hi Denis
> >>
> >> 2018-02-10 15:18 GMT-03:00 Denis Kudriashov :
> >> >
> >> > 2018-02
2018-02-11 16:10 GMT-03:00 Denis Kudriashov :
> Hi Hernan.
>
> 2018-02-11 19:57 GMT+01:00 Hernán Morales Durand :
>>
>> Hi Denis
>>
>> 2018-02-10 15:18 GMT-03:00 Denis Kudriashov :
>> >
>> > 2018-02-10 20:59 GMT+03:00 Stephane Ducasse :
>> >>
>> >> Please to not use an unary on Symbol
>> >> Dispatc
Maybe using directly TwitterClient, but using #doesNotUnderstand: to
delegate there message sends to the configuration object(kind of a proxy
pattern). That way the TwitterClient class doesn't became so heavy.
Christian
On Sun, Feb 11, 2018 at 1:35 PM, Sven Van Caekenberghe wrote:
> Why not d
Hi Hernan.
2018-02-11 19:57 GMT+01:00 Hernán Morales Durand :
> Hi Denis
>
> 2018-02-10 15:18 GMT-03:00 Denis Kudriashov :
> >
> > 2018-02-10 20:59 GMT+03:00 Stephane Ducasse :
> >>
> >> Please to not use an unary on Symbol
> >> Dispatch on something.
> >>
> >> self class environment at: #Array
>
Hi Denis
2018-02-10 15:18 GMT-03:00 Denis Kudriashov :
>
> 2018-02-10 20:59 GMT+03:00 Stephane Ducasse :
>>
>> Please to not use an unary on Symbol
>> Dispatch on something.
>>
>> self class environment at: #Array
>> is the best
>
>
> We should not use collection API for reflection calls. It makes
Why not directly on TwitterClient ? That would be easiest for the user, then
they do not need to know about TwitterConfiguration. Anyway, that is how I do
it most often. The disadvantage is that TwitterClient might become a bit heavy,
API wise, but you can delegate internally.
> On 11 Feb 2018,
Hi,
are there any best practices/idioms in regards to object
configuration/building?
Let's say I want to configure a TwitterClient that requires a username and
a password that is stored in a separate object TwitterConfiguration
a) the basic approach (either separate sends or via cascade, that is
15 matches
Mail list logo