On Wed, Feb 26, 2014 at 12:29 PM, Andres Freund wrote:
> On 2014-02-24 17:06:53 -0500, Robert Haas wrote:
>> - heap_page_prune_opt(scan->rs_rd, buffer, RecentGlobalXmin);
>> + if (IsSystemRelation(scan->rs_rd)
>> + || RelationIsAccessibleInLogicalDecoding(scan->rs_rd))
>>
Andres Freund escribió:
> On 2014-02-26 15:30:55 -0300, Alvaro Herrera wrote:
> > Andres Freund escribió:
> >
> > > I am wondering about the related situation of GetOldestXmin()
> > > callers. There's a fair bit of duplicated logic in the callers, before
> > > but especially after this patchset. W
On 2014-02-26 15:30:55 -0300, Alvaro Herrera wrote:
> Andres Freund escribió:
>
> > I am wondering about the related situation of GetOldestXmin()
> > callers. There's a fair bit of duplicated logic in the callers, before
> > but especially after this patchset. What about adding 'Relation rel'
> >
Andres Freund escribió:
> I am wondering about the related situation of GetOldestXmin()
> callers. There's a fair bit of duplicated logic in the callers, before
> but especially after this patchset. What about adding 'Relation rel'
> parameter instead of `allDbs' and `systable'? That keeps the log
On 2014-02-24 17:06:53 -0500, Robert Haas wrote:
> - heap_page_prune_opt(scan->rs_rd, buffer, RecentGlobalXmin);
> + if (IsSystemRelation(scan->rs_rd)
> + || RelationIsAccessibleInLogicalDecoding(scan->rs_rd))
> + heap_page_prune_opt(scan->rs_rd, buffer, Rece
Hi,
On 2014-02-25 13:47:49 -0500, Robert Haas wrote:
> On Mon, Feb 24, 2014 at 6:16 PM, Andres Freund wrote:
> > I actually thought they'd be too ugly to live and we'd remove them
> > pre-commit.
>
> Might be getting to be about that time, then.
I want to leave them in until the slot semantics
On Mon, Feb 24, 2014 at 6:16 PM, Andres Freund wrote:
> I actually thought they'd be too ugly to live and we'd remove them
> pre-commit.
Might be getting to be about that time, then.
>> - if (nrels > 0 || nmsgs > 0 || RelcacheInitFileInval ||
>> forceSyncCommit)
>> +
Hi,
On 2014-02-24 17:06:53 -0500, Robert Haas wrote:
> I still think pg_create_logical_replication_slot should be in slotfuncs.c.
Ok, I don't feel too strongly, so I can change it. I wanted to keep
logical/ stuff out of slotfuncs.c, but there's not really a strong
reason for that.
> I don't thin
On Mon, Feb 24, 2014 at 10:11 AM, Andres Freund wrote:
> Changes in this version include:
> * changed slot error handling log by introducing "ephermal" slots which
> get dropped on errors. This is the biggest change.
> * added quoting in the test_decoding output plugin
> * closing of a tight rac