Thanks for the suggestion, Peter. It looks like pg_comparator is for comparing
the contents of two different servers. I need to compare the contents of two
dump files from the same server separated by time and busy developers.
Regards,
Bob Lunney
--- On Thu, 4/15/10, Peter Eisentraut wrote:
the 8.4.3 binary tarball for solaris sparc
64bit on postgresql.com was shipped with the 32bit includes and the
Makefile fragments from 8.4-community/lib/64/pgxs/src/
I'm specifically hitting this contradition:
$ grep FLOAT8 include/server/pg_config.h
#define FLOAT8PASSBYVAL false
and
Robert Haas wrote:
> On Thu, Apr 8, 2010 at 3:22 PM, Oleg Bartunov wrote:
> >> On general thought I've had is that it would be nice if the first
> >> attempt to SELECT against a table with no statistics would trigger an
> >> automatic ANALYZE by the backend on which the query was executed.
> >> It
Peter Eisentraut wrote:
> Apparently, pgindent replaces multiple spaces in comments by a tab
> (possibly subject to additional logic). An example among thousands:
>
> http://git.postgresql.org/gitweb?p=postgresql.git;a=blobdiff_plain;f=src/backend/access/gin/ginentrypage.c;h=c23415c0075b5ec52f08e
Peter Eisentraut wrote:
On tor, 2010-04-15 at 10:48 -0700, Bob Lunney wrote:
I needed a way to run diffs on two
database dumps to see what data developers put in their
local databases versus the initial database load.
Maybe pg_comparator would help you?
Or DBIx::Compare if you li
On Thu, Apr 15, 2010 at 2:54 AM, Heikki Linnakangas
wrote:
> Robert Haas wrote:
>> I've realized another problem with this patch. standby_keep_segments
>> only controls the number of segments that we keep around for purposes
>> of streaming: it doesn't affect archiving at all. And of course, a
>
"Kevin Grittner" writes:
> What's up with the sort of _accrged7200 (in the slower plan) taking
> in 3.5 million rows and putting out 1 row? There's something there
> I'm not understanding.
It's under a merge join, so what probably happened is that the first
row from that side had a larger key th
Tom Lane wrote:
> I'm not sure how much it would help to increase the statistics
> targets, but that would be worth trying.
I notice that the scan rowcount estimates are very accurate, there's
that one hash join result that's way off, though.
What's up with the sort of _accrged7200 (in the s
Greg Smith wrote:
> Bruce Momjian wrote:
> >> http://wiki.postgresql.org/wiki/User:Simon
> > Well, unless Simon wants to keep it for some reason, it should be
> > removed, and if kept, renamed. Simon?
> >
>
> I already retitled the copy left on the personal page and deleted the
> one that was
Oleg Bartunov writes:
> below is an example of interesting query and two plans - the bad plan, which
> uses merge join and big sorting, took 216 sec, and good plan with merge join
> disabled took
> 8 sec.
The "good" plan seems to be fast mainly because of heavily cached inner
indexscans. If t
On Thu, 15 Apr 2010, Pavel Stehule wrote:
Hello
there is significant problem in statistics I think,
Ah, you're right !
Regards
Pavel Stehule
2010/4/15 Oleg Bartunov :
On Thu, 15 Apr 2010, Kevin Grittner wrote:
Oleg Bartunov wrote:
Sorry for odd names, they were generated by popular
Hello
there is significant problem in statistics I think,
Regards
Pavel Stehule
2010/4/15 Oleg Bartunov :
> On Thu, 15 Apr 2010, Kevin Grittner wrote:
>
>> Oleg Bartunov wrote:
>>
>>> Sorry for odd names, they were generated by popular accounting
>>> engine in Russia.
>>
>> How much of that can
Apparently, pgindent replaces multiple spaces in comments by a tab
(possibly subject to additional logic). An example among thousands:
http://git.postgresql.org/gitweb?p=postgresql.git;a=blobdiff_plain;f=src/backend/access/gin/ginentrypage.c;h=c23415c0075b5ec52f08e8ef698f7b7ec2f97b19;hp=5cbbc7455
On tor, 2010-04-15 at 10:48 -0700, Bob Lunney wrote:
> I needed a way to run diffs on two
> database dumps to see what data developers put in their
> local databases versus the initial database load.
Maybe pg_comparator would help you?
--
Sent via pgsql-hackers mailing list (pgsql-hackers@postg
On Thu, 15 Apr 2010, Kevin Grittner wrote:
Oleg Bartunov wrote:
Sorry for odd names, they were generated by popular accounting
engine in Russia.
How much of that can you trim out and still see the problem?
It's difficult, since I don't know semantics of data. I reduced query, though.
que
I needed a way to run diffs on two
database dumps to see what data developers put in their
local databases versus the initial database load. The
pg_dump utility with --inserts works well for this, but
since the order in which the data is returned of the server
is not guaranteed I hacked this patch
Oleg Bartunov wrote:
> Sorry for odd names, they were generated by popular accounting
> engine in Russia.
How much of that can you trim out and still see the problem?
-Kevin
--
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://w
Hi there,
below is an example of interesting query and two plans - the bad plan, which
uses merge join and big sorting, took 216 sec, and good plan with merge join disabled took
8 sec. Sorry for odd names, they were generated by popular accounting
engine in Russia. 8.4.3 and HEAD show the same
Erik Rijkers wrote:
> Btw, typo alert: documentation 18.5.4, subhead 'standby_keep_segments',
> says: 'replciation' for 'replication'.
>
> http://developer.postgresql.org/pgdocs/postgres/runtime-config-wal.html#RUNTIME-CONFIG-REPLICATION
Thanks, fixed.
--
Heikki Linnakangas
EnterpriseDB
On Wed, Apr 14, 2010 at 08:37:18PM -0400, Robert Haas wrote:
> On Wed, Apr 14, 2010 at 8:31 PM, Bruce Momjian wrote:
> > Tom Lane wrote:
> >> Robert Haas writes:
> >> > What's wrong with something like "connection not permitted" or
> >> > "connection not authorized"?
> >>
> >> The case that we're
Robert Haas escribió:
> In the department of minor nits, I also don't like the fact that the
> GUC is called standby_keep_segments and the variable is called
> StandbySegments. If we really have to capitalize them differently, we
> should at least make it StandbyKeepSegments, but personally I thi
On Wed, Apr 14, 2010 at 11:13 PM, Fujii Masao wrote:
> On Wed, Apr 14, 2010 at 11:15 PM, Magnus Hagander wrote:
>>> http://archives.postgresql.org/pgsql-hackers/2010-04/msg00077.php
As for the code itself, don't we need a CHECK_FOR_INTERRUPTS in there
for it to be actually useful?
>>>
>
On Wed, April 14, 2010 08:23, Heikki Linnakangas wrote:
> Erik Rijkers wrote:
>> This replication test that was working well earlier (it ran daily), stopped
>> working
>
> This is probably because of this change:
>
>> date: 2010/04/12 09:52:29; author: heikki; state: Exp; lines: +71 -23
>> Chan
Stephen Frost writes:
> * Simon Riggs (si...@2ndquadrant.com) wrote:
>> So instead of the typical "reject" instruction we also add a
>> "rejectverbose" instruction that has a more verbose message.
> Erm, so we'd add an option for this? That strikes me as pretty
> excessive.
I think Simon's poin
Simon,
* Simon Riggs (si...@2ndquadrant.com) wrote:
> So instead of the typical "reject" instruction we also add a
> "rejectverbose" instruction that has a more verbose message. Docs would
> describe it as an additional instruction to assist with debugging a
> complex pg_hba.conf, with warning tha
On Tue, Apr 13, 2010 at 7:55 PM, Tom Lane wrote:
> Alvaro Herrera writes:
>> Magnus Hagander wrote:
>>> This script should probably live in CVS, and be run when Microsoft
>>> releases new timezone data. Where should I put it - src/timezone or
>>> somewhere in src/tools? (it does read pgtz.c in th
On Thu, Apr 15, 2010 at 3:48 AM, Tom Lane wrote:
> Magnus Hagander writes:
>> On Wed, Apr 7, 2010 at 21:01, Tom Lane wrote:
>>> ... lack either the note about defaulting to GMT or the hint. I guess
>>> we should add both of those to the failure cases in the Windows version
>>> of identify_syste
On Thu, Apr 15, 2010 at 2:54 AM, Tom Lane wrote:
> [ back to this... ]
>
> Magnus Hagander writes:
>> On Wed, Apr 7, 2010 at 21:06, Tom Lane wrote:
>>> I suppose we had a reason for doing it the first way but I can't see
>>> what. "GMT" seems a fairly English-centric way of referring to UTC
>>>
On Thu, Apr 15, 2010 at 5:13 AM, Fujii Masao wrote:
> On Wed, Apr 14, 2010 at 11:15 PM, Magnus Hagander wrote:
The patch also seems confused about whether it's intending to be a
general-purpose solution or not. You can maybe take some shortcuts
if it's only going to be for walrece
On Thu, Apr 15, 2010 at 4:17 AM, Tom Lane wrote:
> Magnus Hagander writes:
>> Looking at the call-sites, there are bugs now - if PQexec() returns
>> NULL, we don't deal with it. It also doesn't always free the result
>> properly. I've added checks for that.
>
> I think you're just adding useless
On Thu, 2010-04-15 at 00:24 -0400, Tom Lane wrote:
> Robert Haas writes:
> > So you'd prefer a message that is sometimes flat-out wrong over a
> > message that is correct but less informative in the common case? I
> > guess that could be right call, but it's not what I'd pick.
>
> Well, as I sai
On Wed, 2010-04-14 at 23:28 -0400, Bruce Momjian wrote:
> Greg Smith wrote:
> > Bruce Momjian wrote:
> > > What is "Prioritised" Todo? It looks like a copy of the TODO list that
> > > was created on March 23, 2010, and only you and Simon have modified it:
> > >
> > >
> > > http://wiki.postgresq
32 matches
Mail list logo