>I don't see the need for a new keyword. An attribute should be fine
>
> sub foo : coroutine { }
>
>Would do quite well. It would fit with the :method attribute, and
>a possible :lvalue attribute.
That would be fine.
>Anyway, isn't what you are proposing more of a generator/sink rather
>th
>[I think this belongs on the language list, FWIW, Cc'd there]
>
>I like this, but I'd like to see this, inter-thread queues, and events
all
>use the same communication method. Overload filehandles to pass events
>around instead, so:
I'm proposing that events and threads be dropped in lieu of c