Re: RFC: Rename local() operator

2000-08-07 Thread Glenn Linderman
Bart Lateur wrote: > >The C operator of Perl5 and earlier does not do what it claims > >to and should be renamed. > > How about: > > override > > meaning: ignore the value you've seen so far, for now, you'll use my > value. This is the sort of thing I was looking for when I proposed "red

Re: RFC: Rename local() operator

2000-08-07 Thread Nathan Wiger
> > As for the "need a verb" argument, my() and our() aren't verbs either. > > They're also lexical rather than dynamic. Dynamic things need action > words (verbs) IMHO. A valid distinction. Though, "now" has an action-like ring to it, even though it's not truly a verb. "NOW this var is this v

Re: RFC: Rename local() operator

2000-08-07 Thread Jonathan Scott Duff
On Mon, Aug 07, 2000 at 09:26:04AM -0700, Nathan Wiger wrote: > As for the "need a verb" argument, my() and our() aren't verbs either. They're also lexical rather than dynamic. Dynamic things need action words (verbs) IMHO. -Scott -- Jonathan Scott Duff [EMAIL PROTECTED]

Re: RFC: Rename local() operator

2000-08-07 Thread Bart Lateur
On 07 Aug 2000 17:26:14 +0100, Piers Cawley wrote: >$/ = "\n" now; $/ = "\n" for now; Very English-like. OTOH, now() sounds like a synonym for the built-in time(). -- Bart.

Re: RFC: Rename local() operator

2000-08-07 Thread Piers Cawley
Nathan Wiger <[EMAIL PROTECTED]> writes: > > > But it isn't "here" that's the problem. If we just wanted to change > > > the value "here", we could use my(). The problem is that local() > > > changes the value for somewhere else as well as here. > > > > Well, as has been pointed out, special^W

Re: RFC: Rename local() operator

2000-08-07 Thread Nathan Wiger
> > But it isn't "here" that's the problem. If we just wanted to change > > the value "here", we could use my(). The problem is that local() > > changes the value for somewhere else as well as here. > > Well, as has been pointed out, special^Wlocalized variables are > scoped in time, not space,

Re: RFC: Rename local() operator

2000-08-07 Thread Bart Lateur
>The C operator of Perl5 and earlier does not do what it claims >to and should be renamed. How about: override meaning: ignore the value you've seen so far, for now, you'll use my value. I can't say that any of the proposed new names actually "clicks". But "hide" and "save" are to much

Re: RFC: Rename local() operator

2000-08-07 Thread John Porter
Nick Ing-Simmons wrote: > > > In PostScript, [gsave] allows you to save the current state of > > the graphics output device, on a stack, but it doesn't modify it. > > Neither does local - it is the = "\n" that does the modifying. Oh, not really. Because you get modification *regardless* of wh

Re: RFC: Rename local() operator

2000-08-07 Thread John Porter
Buddha Buck wrote: > > But it isn't "here" that's the problem. If we just wanted to change > the value "here", we could use my(). The problem is that local() > changes the value for somewhere else as well as here. Well, as has been pointed out, special^Wlocalized variables are scoped in ti

Re: RFC: Rename local() operator

2000-08-07 Thread Ariel Scolnicov
Buddha Buck <[EMAIL PROTECTED]> writes: > > > What about C ? > > > > Here's yet another one - how about "here"? > > > >{ > > here $/ = "\n"; # what it is in here > > > >} > > > > Not really any confusion on this - $/ is "\n" 'in here', but maybe > > something else outside. > >

Re: RFC: Rename local() operator

2000-08-06 Thread Peter Scott
At 12:50 AM 8/7/00 -0500, Jonathan Scott Duff wrote: >On Sun, Aug 06, 2000 at 08:03:51PM -0700, Nathan Wiger wrote: > > > What about C ? > > > > Here's yet another one - how about "here"? Doesn't this have a list of its own yet? >Well, "here" isn't a verb and I think we need a verb er ... here.

Re: RFC: Rename local() operator

2000-08-06 Thread Jonathan Scott Duff
On Sun, Aug 06, 2000 at 08:03:51PM -0700, Nathan Wiger wrote: > > What about C ? > > Here's yet another one - how about "here"? Well, "here" isn't a verb and I think we need a verb er ... here. Granted, "local" isn't a verb either, but that's probably part of it's problem. -Scott -- Jonathan S

Re: RFC: Rename local() operator

2000-08-06 Thread Nathan Wiger
> >{ > > here $/ = "\n"; # what it is in here > >} > > But it isn't "here" that's the problem. If we just wanted to change > the value "here", we could use my(). The problem is that local() > changes the value for somewhere else as well as here. Other names > suggested (like "sh

Re: RFC: Rename local() operator

2000-08-06 Thread Buddha Buck
> > What about C ? > > Here's yet another one - how about "here"? > >{ > here $/ = "\n"; # what it is in here > >} > > Not really any confusion on this - $/ is "\n" 'in here', but maybe > something else outside. > > Unlike "hide" or others, this doesn't connote it's necessaril

Re: RFC: Rename local() operator

2000-08-06 Thread Nathan Wiger
> What about C ? Here's yet another one - how about "here"? { here $/ = "\n"; # what it is in here } Not really any confusion on this - $/ is "\n" 'in here', but maybe something else outside. Unlike "hide" or others, this doesn't connote it's necessarily any different from somew

Re: RFC: Rename local() operator

2000-08-06 Thread Nathan Wiger
> shadow $/ = "\n"; > > seems to have the right implications to me. Personally, I like this by far out of all the suggestions I've heard. "save" seems to say "save THIS value" (the one you're setting, not the global one you can't see). "hide" is a little too general (hide what in what?). But

Re: RFC: Rename local() operator

2000-08-05 Thread Chaim Frenkel
guard protect Hmm, 'guard' is just as long as 'local'. > "JSD" == Jonathan Scott Duff <[EMAIL PROTECTED]> writes: JSD> More words: JSD>store() # put away for the duration of the scope JSD>tuck() # Now I lay me down to sleep JSD>hide()

Re: RFC: Rename local() operator

2000-08-05 Thread Russ Allbery
Nick Ing-Simmons <[EMAIL PROTECTED]> writes: > What about C ? > I think C or C has merit - "while I am out contact ...". > But I still think C is the essence of what it does. I like either C or C too, but just to throw out the other idea that occurred to me, what's being done here is in other

Re: RFC: Rename local() operator

2000-08-05 Thread Nick Ing-Simmons
Bart Lateur <[EMAIL PROTECTED]> writes: >>> C >> >>If I had my druthers, save() would be it. > >I'm against it. Why? Because it suggests that all it does is save the >value for later retrieval. It does not: the value is cleared as well. It >masks the previous global value, as if it didn't exist be

Re: RFC: Rename local() operator

2000-08-05 Thread Jonathan Scott Duff
On Sat, Aug 05, 2000 at 12:04:30PM +0200, Bart Lateur wrote: > On Fri, 4 Aug 2000 10:54:16 -0500, Jonathan Scott Duff wrote: > > >> C > > > >If I had my druthers, save() would be it. > > I'm against it. Why? Because it suggests that all it does is save the > value for later retrieval. It does no

Re: RFC: Rename local() operator

2000-08-05 Thread Bart Lateur
On Fri, 4 Aug 2000 10:54:16 -0500, Jonathan Scott Duff wrote: >> C > >If I had my druthers, save() would be it. I'm against it. Why? Because it suggests that all it does is save the value for later retrieval. It does not: the value is cleared as well. It masks the previous global value, as if it

Re: RFC: Rename local() operator

2000-08-04 Thread Jonathan Scott Duff
On Fri, Aug 04, 2000 at 01:37:09AM -0500, J. David Blackstone wrote: > =head1 IMPLEMENTATION > > C If I had my druthers, save() would be it. -Scott -- Jonathan Scott Duff [EMAIL PROTECTED]

Re: RFC: Rename local() operator

2000-08-04 Thread skud
Please do not send your RFCs to both perl6-rfc and perl6-$working_group. The RFC librarian will automatically forward your RFC with a number on it, which is kinda neater. K. -- Kirrily Robert -- <[EMAIL PROTECTED]> -- http://netizen.com.au/ Open Source development, consulting and solutions Leve

RFC: Rename local() operator

2000-08-03 Thread J. David Blackstone
Since no one else has taken this up, I'll start an initial draft. =head1 TITLE Rename the C operator =head1 VERSION Maintainer: J. David Blackstone <[EMAIL PROTECTED]> Date: 4 Aug 2000 Version: 1 Mailing List: [EMAIL PROTECTED] Number: not yet assigned =head1 ABSTRACT The C opera