RE: L2R/R2L syntax (was Re: Everything is an object.)

2003-01-08 Thread HellyerP
>Atriel: >> Damian: >> Can I suggest that an alternative solution might be the following: >> >> Suppose Perl 6 had two new very low precedence operators: ~> and <~ >> (a.k.a. "bind rightwards" and "bind leftwards") >> >> @out = @a ~> grep {...} ~> map {...} ~> sort; >> >> @ou

RE: seperate() and/or Array.cull

2002-12-05 Thread HellyerP
Angel Faus: > Maybe the solution is to make it hash-wise: > > %hash = @array.sep { > when /^[A-Z]*$/ {'uppercase'} > when /^[a-z]*$/ {'lowercase'} > default {'mixedcase'} > } I agree that general partitioning is 'better' than a fixed binary proposal, but what is ga

RE: seperate() and/or Array.cull

2002-12-05 Thread HellyerP
Aaron Crane: > However, I don't think it should be called 'seperate'. I also don't think > it should be called 'separate', because that word seems to be commonly > misspelled... That seems like an excellent argument for calling it 'separate'. Perhaps it will be the first of many spelling-improvi

prebinding questions

2002-08-30 Thread HellyerP
[apologies to anyone who received this twice... the bonehead at the keyboard left the subject blank. ] > This week I was fortunate enough to hear Damian speak twice, once on > everything and once on Perl6. Damian, it was tremendous of you to come > and speak to us in London - thank-you very muc

RE: Loop controls

2002-04-29 Thread HellyerP
On Monday, April 29, 2002 3:10 PM, Aaron Sherman wrote: > On Fri, 2002-04-26 at 19:06, Allison Randal wrote: > > On Fri, Apr 26, 2002 at 05:24:13PM -0400, Aaron Sherman wrote: > > > Of course it brings other less wholesome things to mind like "elsfor" > > > and "elsloop" and "if ... elsfor" and "f

RE: the handiness of undef becoming NaN (when you want that)

2001-10-22 Thread HellyerP
> Aaron Sherman <[EMAIL PROTECTED]> wrote: > while(<>) { > $count++; > $total += substr($_,22,2); > } > printf "Average: %.2f\n", $total/$count; > >Right now, if my expected numeric column has garbage in it on the >400,000th line, I treat it as zero a

RE: More on operators

2001-10-10 Thread HellyerP
> :Alberto Manuel Brandao Simoes <[EMAIL PROTECTED]> writes: > : > :>If we are in the mood of changing operators, && can be /\ > :> and || can be \/. At least, mathematicians will like it! > : > :You are, of course, joking. > : > :-- > :Piers > Given Damian's sigma operator in E3,