On 8/16/06, Darren Duncan <[EMAIL PROTECTED]> wrote:
Both the === and eqv operators test the actual values of 2
containers, but that their semantics differ in regards to mutable
containers. Given an immutable container/type, such as a number or
Str or Seq, both will always return true if the val
At 11:42 AM +0300 8/16/06, Markus Laire wrote:
On 8/16/06, Darren Duncan <[EMAIL PROTECTED]> wrote:
The difference between === and eqv is that, if you have 2 symbols, $a
and $b, and $a === $b returns true, then that result is guaranteed to
be eternal if you don't assign to either symbol afterwar
"Markus Laire" schreef:
> my $x = 'Just Another';
> my $y := $x;
> $y = 'Perl Hacker';
>
> After this, both $x and $y contain the string "Perl Hacker", since
> they are really just two different names for the same variable.
>
So "$x === Sy" stil holds.
--
Affijn, Ruud
"Gewoon is e
On 8/16/06, Dr.Ruud <[EMAIL PROTECTED]> wrote:
"Markus Laire" schreef:
> my $x = 'Just Another';
> my $y := $x;
> $y = 'Perl Hacker';
>
> After this, both $x and $y contain the string "Perl Hacker", since
> they are really just two different names for the same variable.
>
So "$x ==
On 8/16/06, Darren Duncan <[EMAIL PROTECTED]> wrote:
At 11:42 AM +0300 8/16/06, Markus Laire wrote:
>On 8/16/06, Darren Duncan <[EMAIL PROTECTED]> wrote:
>>The difference between === and eqv is that, if you have 2 symbols, $a
>>and $b, and $a === $b returns true, then that result is guaranteed to
On 8/10/06, Larry Wall <[EMAIL PROTECTED]> wrote:
Yes, it's a design smell. The point of core is to huffman code common
things, so something in core with _ should normally either be shorter
or out of the core.
Would it be adequate to say "think hard about keeping core names
concise, but pref
On 8/16/06, Darren Duncan <[EMAIL PROTECTED]> wrote:
I'll try saying what I meant differently here:
The difference between === and eqv is that, if you have 2 symbols, $a
and $b, and $a === $b returns true, then that result is guaranteed to
be eternal if you don't assign to either symbol [or othe
"Markus Laire" schreef:
> Dr.Ruud:
>> Markus Laire:
>>> my $x = 'Just Another';
>>> my $y := $x;
>>> $y = 'Perl Hacker';
>>>
>>> After this, both $x and $y contain the string "Perl Hacker", since
>>> they are really just two different names for the same variable.
>>>
>>
>> So "$x ===
Author: creiss
Date: Wed Aug 16 08:53:17 2006
New Revision: 14131
Modified:
trunk/docs/pdds/clip/pdd10_embedding.pod
trunk/docs/pdds/pdd23_exceptions.pod
Changes in other areas also in this revision:
Added:
trunk/config/auto/cpu/
- copied from r14128, /branches/stm/config/auto/cpu/
On 8/15/06, chromatic <[EMAIL PROTECTED]> wrote:
Here's a proposed patch that seems to work okay for me on Linux. It's not
great or beautiful, mostly because of the Makefile hackery. It's a starting
point though. I suspect Windows might complain.
i'll happily test, but i can't apply it, as i
On Wednesday 16 August 2006 08:57, jerry gay wrote:
> i'll happily test, but i can't apply it, as it seems not to be in the
> format my patch util expects. did you use C? i don't see the
> familiar "Index: " headers.
It's a standard svk diff. That's really weird. Is this any better?
-- c
--- M
On 8/16/06, chromatic <[EMAIL PROTECTED]> wrote:
On Wednesday 16 August 2006 08:57, jerry gay wrote:
> i'll happily test, but i can't apply it, as it seems not to be in the
> format my patch util expects. did you use C? i don't see the
> familiar "Index: " headers.
It's a standard svk diff. Th
On 8/15/06, chromatic <[EMAIL PROTECTED]> wrote:
Here's a proposed patch that seems to work okay for me on Linux. It's not
great or beautiful, mostly because of the Makefile hackery. It's a starting
point though. I suspect Windows might complain.
windows indeed complains. not only about miss
On Wed, Aug 16, 2006 at 04:25:13PM +0200, Dr.Ruud wrote:
: Comparing strings in Perl5, using NFKD:
:
: perl5 -MUnicode::Normalize -we '
: ($\, $,) = ("\n", "\t") ;
: $x = qq{Henry IV} ;
: $y = qq{Henry \x{2163}} ;
: print qq{<$x>}, qq{<$y>}, length $x, length $y, $x eq $y ? 1 : 0 ;
: # $x
On 8/16/06, Dr.Ruud wrote:
I also wondered why a "simple" array (for example containing only value
type objects) whould not C<===> its copy.
But with .SKID that must be easy to handle.
That's what I was wondering that started off this thread. I
understand (more or less, I think), why it *does
On 8/16/06, Charles Bailey wrote:
This is where the "eternal" part starts to confuse me (not picking on
your wording, but on the semantics).
I'll pick on the wording (wording should always be picked on -- not
to be pedantic (OK, I like to be pedantic, but that's not the *only*
reason!), but b
Author: creiss
Date: Wed Aug 16 09:48:09 2006
New Revision: 14139
Modified:
trunk/docs/pdds/pdd23_exceptions.pod
Log:
Undo accidental reversion.
Modified: trunk/docs/pdds/pdd23_exceptions.pod
==
--- trunk/docs/pdds/p
...which I would have thought was a faq; maybe I just haven't found
the right faq list...
Where can I find a pod2html that groks the p6 version of POD? I want
to format my fresh-from-svn copies of the doc...
--
Mark J. Reed <[EMAIL PROTECTED]>
Author: larry
Date: Wed Aug 16 14:57:15 2006
New Revision: 11047
Modified:
doc/trunk/design/syn/S05.pod
Log:
Clarification of intented use of the word "regex", suggested by dduncan++.
Modified: doc/trunk/design/syn/S05.pod
=
Larry Wall schreef:
> Dr.Ruud:
>> Comparing strings in Perl5, using NFKD:
>>
>> perl5 -MUnicode::Normalize -we '
>> ($\, $,) = ("\n", "\t") ;
>> $x = qq{Henry IV} ;
>> $y = qq{Henry \x{2163}} ;
>> print qq{<$x>}, qq{<$y>}, length $x, length $y, $x eq $y ? 1 : 0 ;
>> # $x = NFKD $x ;
>> $
Is a NEXT clause called before or after the update portion of a general loop
statement? For instance, consider the following code:
loop $n = 0; $n < 5; ++$n {
NEXT {print $n;}
}
Is the output 01234 or 12345?
Joe Gottman
On Wed, Aug 16, 2006 at 08:21:29PM -0400, Joe Gottman wrote:
: Is a NEXT clause called before or after the update portion of a general loop
: statement? For instance, consider the following code:
:
:
:
: loop $n = 0; $n < 5; ++$n {
:
: NEXT {print $n;}
:
: }
:
:
:
: Is the output 012
In Perl6/Spec/Operator.pod
"Trinary" should be "Ternary".
Mark
Author: larry
Date: Wed Aug 16 20:39:30 2006
New Revision: 11065
Modified:
doc/trunk/design/syn/S03.pod
Log:
Removed contentious "Trinary".
Modified: doc/trunk/design/syn/S03.pod
==
--- doc/trunk/design/syn/S03.pod
On 8/17/06, Mark J. Reed <[EMAIL PROTECTED]> wrote:
Where can I find a pod2html that groks the p6 version of POD? I want
to format my fresh-from-svn copies of the doc...
If you mean the POD files of perl 6 synopses, then pod2html only lacks
the support for the "=encoding" directive.
On my (
On 8/15/06, Darren Duncan wrote:
At 2:51 PM -0600 8/15/06, David Green wrote:
[...]
You are right, but we have both Seq and Array types, so depending
which one you use, you want either the === or eqv operators to do
what you want. There is no reason that === should say 2 Array are
equal; we
On 8/16/06, David Green wrote:
$a=[1, 2, [EMAIL PROTECTED];
$c=[1, 2, [EMAIL PROTECTED];
$d=[1, 2, [EMAIL PROTECTED];
$a =:= $c; #false, different variables
$a === $c; #true, same elements make up $a and $c
$a eqv $c; #true, same elements therefore
# New Ticket Created by Matt Diephouse
# Please include the string: [perl #40151]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org/rt3/Ticket/Display.html?id=40151 >
So sayeth array.pmc:
void set_pmc(PMC *other)
Currently, an alias to C. Expec
# New Ticket Created by Will Coleda
# Please include the string: [perl #40153]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org/rt3/Ticket/Display.html?id=40153 >
Anything referring to TEST_PROG should probably be renamed to
"parrot" or "executable"
# New Ticket Created by Matt Diephouse
# Please include the string: [perl #40156]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org/rt3/Ticket/Display.html?id=40156 >
I don't know how to write a test for this off the top of my head, but
Iterator and D
# New Ticket Created by Matt Diephouse
# Please include the string: [perl #40158]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org/rt3/Ticket/Display.html?id=40158 >
I don't know how to write a test for this off the top of my head, but
Iterator and D
# New Ticket Created by Matt Diephouse
# Please include the string: [perl #40171]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org/rt3/Ticket/Display.html?id=40171 >
I don't know how to write a test for this off the top of my head, but
Iterator and D
# New Ticket Created by Chip Salzenberg
# Please include the string: [perl #40178]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org/rt3/Ticket/Display.html?id=40178 >
The None class serves no useful (portable) purpose and it should be removed,
especial
# New Ticket Created by Chip Salzenberg
# Please include the string: [perl #40179]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org/rt3/Ticket/Display.html?id=40179 >
The None class serves no useful (portable) purpose and it should be removed,
especial
# New Ticket Created by Will Coleda
# Please include the string: [perl #40182]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org/rt3/Ticket/Display.html?id=40182 >
<@pmichaud> CodeString is one of those that I think could give a nice
perfor
35 matches
Mail list logo