Parrot 0.4.5 in Tru64 5.1B:
$ perl Configure.pl
...
Determining if your platform supports readline.yes.
Determining if your platform supports gdbm..no.
Testing snprintf...resolve_symbols: loader error: dlopen:
libreadline.so.4: symbol "tgetnum"
Bin packing looks better because I don't think SSA has been implemented yet. Linear Search looks perfect for SSA code, but Bin Packing would be better for Parrot. (Bin Packing views allocation as a bin packing problem and solves it heuristically.) On Jun 29, 2006, at 11:20 PM, Vishal Soni wrote:Hi
# New Ticket Created by chromatic
# Please include the string: [perl #39669]
# in the subject line of all future correspondence about this issue.
# https://rt.perl.org/rt3/Ticket/Display.html?id=39669 >
I've been playing with embedding Parrot and trying to pass arbitrary PIR code
to the embe
Hi,
The .end seems to be replaced by an implicit end.
-Vishal
On 6/29/06, Will Coleda via RT <[EMAIL PROTECTED]> wrote:
Hey, Vishal:
> [vsoni - Tue Jun 27 05:48:27 2006]:
>
> Hi,
>
> This was a straight forward fix. The line number was being decremented
> at the start of a 'sub' token imcc.
On Jun 29, 2006, at 18:48, Jarkko Hietaniemi wrote:
Any way to add verbosity to e.g. see which commands are being run?
perl Configure.pl --verbose-step=snprintf
leo
On Jun 30, 2006, at 17:06, chromatic (via RT) wrote:
Unfortunately, it appears that there is no PIR compiler available to
embedded
Parrot.
The PIR compiler is registered within imcc_init(), which should
probably called automagically during Parrot init sequence. See also
compilers/imcc/ma
What is supposed to happen if one says:
class Dog {
has $:tail handles 'wag';
meth wag { # something else than $:tail.wag
}
}
Is it a compilation error? Or one of the definitions prevail (with a
warning or something)?
Adriano Ferreira.
On Friday 30 June 2006 09:35, Leopold Toetsch wrote:
> The PIR compiler is registered within imcc_init(), which should
> probably called automagically during Parrot init sequence. See also
> compilers/imcc/main.c.
Okay, here's the patch I checked in as #13066. The IMCC headers need some
cleanup
Author: larry
Date: Fri Jun 30 11:57:00 2006
New Revision: 9725
Modified:
doc/trunk/design/syn/S02.pod
doc/trunk/design/syn/S03.pod
doc/trunk/design/syn/S04.pod
doc/trunk/design/syn/S05.pod
doc/trunk/design/syn/S06.pod
Log:
Change "env" variables to "context" variables.
Modified:
Author: larry
Date: Fri Jun 30 12:07:05 2006
New Revision: 9726
Modified:
doc/trunk/design/syn/S02.pod
doc/trunk/design/syn/S03.pod
doc/trunk/design/syn/S04.pod
doc/trunk/design/syn/S05.pod
doc/trunk/design/syn/S06.pod
Log:
Forgot to update versions and dates...
Modified: doc/tru
Author: chip
Date: Fri Jun 30 13:10:33 2006
New Revision: 13070
Modified:
trunk/docs/pdds/clip/pdd23_exceptions.pod
Log:
Overhaul.
Take _that_, Coke!
Modified: trunk/docs/pdds/clip/pdd23_exceptions.pod
==
--- trunk/do
Author: chip
Date: Fri Jun 30 13:12:26 2006
New Revision: 13071
Added:
trunk/docs/pdds/pdd23_exceptions.pod
- copied unchanged from r13070, /trunk/docs/pdds/clip/pdd23_exceptions.pod
Removed:
trunk/docs/pdds/clip/pdd23_exceptions.pod
Log:
Rename pdd23 into docs/pdds.
I've got a complete (if not battle-tested) version of the exceptions
pdd is now committed and renamed into docs/pdd. Share & Enjoy!
--
Chip Salzenberg <[EMAIL PROTECTED]>
Author: larry
Date: Fri Jun 30 15:17:55 2006
New Revision: 9727
Modified:
doc/trunk/design/syn/S02.pod
Log:
Revised quote declarator.
Modified: doc/trunk/design/syn/S02.pod
==
--- doc/trunk/design/syn/S02.pod
This version of Test::Harness has the straps return a newly-created
Test::Harness::Results object.
Next release: Overloadable strap classes.
xoxo,
Andy
Begin forwarded message:
From: PAUSE <[EMAIL PROTECTED]>
Date: June 30, 2006 5:07:02 PM CDT
To: "Andy Lester" <[EMAIL PROTECTED]>
Subject
Author: larry
Date: Fri Jun 30 15:31:34 2006
New Revision: 9728
Modified:
doc/trunk/design/syn/S03.pod
doc/trunk/design/syn/S05.pod
Log:
<( and )> no longer need to balance.
<< and >> are now directional word boundaries, along with « and ».
is generic replacement for \b, for \B
Clarified
On Jun 30, 2006, at 22:10, [EMAIL PROTECTED] wrote:
Log:
Overhaul.
Take _that_, Coke!
I'd really appreciate more verbose log messages, the more that we might
somewhen autogen ChangeLog.
Thanks (to all),
leo
Author: pmichaud
Date: Fri Jun 30 15:53:39 2006
New Revision: 9729
Modified:
doc/trunk/design/syn/S05.pod
Log:
describe below -> described below
Modified: doc/trunk/design/syn/S05.pod
==
--- doc/trunk/design/syn/S05.
> +This hides any qX rule that might be defined in the gramma. Note
s/gramma/grammar/ if you please. I prefer the new quoting behaviour and
I like << and >> as word boundaries. (Sometimes I miss Vim regexes' \<
and \>.) Are << and >> zero-width?
--
"The rules of programming are transitory;
On Sat, Jul 01, 2006 at 12:22:05AM +0200, Leopold Toetsch wrote:
> I'd really appreciate more verbose log messages, the more that we might
> somewhen autogen ChangeLog.
I actually believe in good change entries, but "overhauled" is a pretty good
description in this case, as it leads to interested
> > +This hides any qX rule that might be defined in the gramma. Note
> s/gramma/grammar/ if you please.
Erm, credit TreyHarris on this one, as he seems to have spotted it
first on #perl6.
--
"Of all things, good sense is the most fairly distributed: everyone
thinks he is so well supplie
Author: larry
Date: Fri Jun 30 16:40:05 2006
New Revision: 9730
Modified:
doc/trunk/design/syn/S05.pod
Log:
Typo spotted by TreyHarris++
Modified: doc/trunk/design/syn/S05.pod
==
--- doc/trunk/design/syn/S05.pod
Here's an even newer Test::Harness with overloadable straps.
Begin forwarded message:
From: PAUSE <[EMAIL PROTECTED]>
Date: June 30, 2006 6:43:58 PM CDT
To: "Andy Lester" <[EMAIL PROTECTED]>
Subject: CPAN Upload: P/PE/PETDANCE/Test-Harness-2.63_02.tar.gz
Reply-To: cpan-testers@perl.org
The up
Just before I committed pdd23 as it currently is, I asked Audrey whether it
was better to make handlers continuations or closures. She said it was not
important, and to choose whichever is faster. However, I think I erred in
choosing continuations.
In the continuation model (as in pdd23 at prese
This patch fixes the branch reorganization failing for tail recursion.Previously.---$ ./parrot -Oc ack.pir 3Ack(3, 3) = 61
$ /parrot -Oc1 ack.pir 3maximum recursion depth exceeded (According to Leo)But on Linux I was getting a segfault.After--$ ./parrot -Oc ./examples/shootout/ack.pi
On Wed, Jun 28, 2006 at 11:40:28PM -0700, Matt Diephouse wrote:
> The get_namespace opcode gets namespaces from the root namespace.
> Should it get namespaces from the HLL namespace instead? The PDD isn't
> explicit either way [...]
It is, actually:
=head2 Namespace Opcodes
Note that all n
On Friday 30 June 2006 20:43, Vishal Soni wrote:
> This patch fixes the branch reorganization failing for tail recursion.
Thanks, applied as #13084.
-- c
# New Ticket Created by chromatic
# Please include the string: [perl #39672]
# in the subject line of all future correspondence about this issue.
# https://rt.perl.org/rt3/Ticket/Display.html?id=39672 >
On Friday 30 June 2006 20:43, Vishal Soni wrote:
> This patch fixes the branch reorganiza
Chip Salzenberg <[EMAIL PROTECTED]> wrote:
On Wed, Jun 28, 2006 at 11:40:28PM -0700, Matt Diephouse wrote:
> The get_namespace opcode gets namespaces from the root namespace.
> Should it get namespaces from the HLL namespace instead? The PDD isn't
> explicit either way [...]
It is, actually:
On Fri, Jun 30, 2006 at 10:50:58PM -0700, Matt Diephouse wrote:
> Chip Salzenberg <[EMAIL PROTECTED]> wrote:
> >On Wed, Jun 28, 2006 at 11:40:28PM -0700, Matt Diephouse wrote:
> >> Tcl uses C< .namespace [''] > to refer to the root namespace (correctly,
> >> I think) and I can't think of any langua
30 matches
Mail list logo