[perl #37655] [PATCH] uninitialized variable warning from t/perl/manifest

2005-11-11 Thread via RT
# New Ticket Created by Allison Randal # Please include the string: [perl #37655] # in the subject line of all future correspondence about this issue. # https://rt.perl.org/rt3/Ticket/Display.html?id=37655 > On my box, this warning pops up in the middle of t/perl/manifest at 2/5: Use of unin

[perl #28995] 'make test' failures

2005-11-11 Thread Jerry Gay via RT
i have a sneaking suspicion that this test no longer fails, but there are no smoke reports for ppc-linux for me to verify. is there someone with that cpu/arch combo who can produce a test result to either prove or disprove my claim? ~jerry

Legal names for PMCs

2005-11-11 Thread Roger Browne
Is it documented anywhere what are the legal names for a PMC? I tried to use the name "AMBER::BOOLEAN" but pmc2c objects with: bad block open: ::BOOLEAN ... at /home/install/parrot/svn/build_tools/pmc2c.pl line 355, <$fh> line 1. It works if I follow the Python/TCL/Perl pattern and use

What's the latest on Iterators?

2005-11-11 Thread Joe Gottman
The various synopses contain many mentions of Iterators. These are used, for instance, to implement lazy lists so the expression 1..1_000_000 does not have to allocate a million element array. But as far as I can tell the term is never defined anywhere in the synopses. Is Iterator a role, and

Re: Legal names for PMCs

2005-11-11 Thread Leopold Toetsch
Roger Browne wrote: Is it documented anywhere what are the legal names for a PMC? I tried to use the name "AMBER::BOOLEAN" but pmc2c objects with: bad block open: ::BOOLEAN ... at /home/install/parrot/svn/build_tools/pmc2c.pl line 355, To me it seems that the created C code is the limit

Re: Legal names for PMCs

2005-11-11 Thread Roger Browne
I wrote: > > Is it documented anywhere what are the legal names for a PMC? Leo replied: > To me it seems that the created C code is the limiting thing here > ... a PMC name has to follow rules of a C identifier. That makes sense. Also, it seems that two PMC names should not differ only by letter

Re: What's the latest on Iterators?

2005-11-11 Thread Rob Kinyon
On 11/11/05, Joe Gottman <[EMAIL PROTECTED]> wrote: >The various synopses contain many mentions of Iterators. These are used, > for instance, to implement lazy lists so the expression 1..1_000_000 does > not have to allocate a million element array. But as far as I can tell the > term is neve

Re: Test Case: Complex Numbers

2005-11-11 Thread Larry Wall
On Fri, Nov 11, 2005 at 06:21:53AM +, Luke Palmer wrote: : Just some initial thoughts and syntax issues. I'll come back to it on : the conceptual side a little later. : : On 11/10/05, Jonathan Lang <[EMAIL PROTECTED]> wrote: : > : > class complexRectilinear { : > has $.x, $.y; : : Hmm, tha

Re: What's the latest on Iterators?

2005-11-11 Thread Larry Wall
On Fri, Nov 11, 2005 at 08:42:44AM -0500, Joe Gottman wrote: : Do functions like map and grep, which in Perl5 return lists, return : Iterators in Perl6? A list may contain iterators. Lists don't eagerly flatten in Perl 6. : Can an Iterator be passed to a function (like map and grep again) : that

Re: proposal: rename 'subtype' declarator to 'set'

2005-11-11 Thread Larry Wall
On Wed, Nov 09, 2005 at 01:45:21PM +0100, TSa wrote: : So, why not call the thing what it is---a set *type* declarator! : : set SmallInt of Int where { abs < 10 }; : : set SomeNums of Num = (3.14, 4, 89, 23.42); : : set Bit of Int = (0,1); Interesting idea. I expect a bit of interference

Re: [perl #28995] 'make test' failures

2005-11-11 Thread chromatic
On Thu, 2005-11-10 at 20:51 -0800, Jerry Gay via RT wrote: > i have a sneaking suspicion that this test no longer fails, but there > are no smoke reports for ppc-linux for me to verify. is there someone > with that cpu/arch combo who can produce a test result to either prove > or disprove my claim

[perl #37622] [TODO] Unicode implementation of downcase opcode

2005-11-11 Thread Matt Diephouse via RT
Leo has been kind enough to implement this, any many other unicode functions, enabling Tcl to once again pass 100% of its tests (with just a little cheating). leo++ -- matt diephouse

Re: reconfiguring configure

2005-11-11 Thread Joshua Hoblitt
On Thu, Nov 10, 2005 at 10:16:14AM +, Simon Wistow wrote: > On Wed, Nov 09, 2005 at 05:57:22PM -1000, Joshua Hoblitt said: > > I've taken a look at using Module::Pluggable to register configure > > steps. The simplest way to do this is to let Module::Pluggable search > > through the ./config d

Re: reconfiguring configure

2005-11-11 Thread Joshua Hoblitt
On Thu, Nov 10, 2005 at 11:51:44AM +0100, Leopold Toetsch wrote: > Joshua Hoblitt wrote: > >I've taken a look at using Module::Pluggable to register configure > >steps. The simplest way to do this is to let Module::Pluggable search > >through the ./config directory. This requires renaming all of

Re: reconfiguring configure

2005-11-11 Thread Will Coleda
On Nov 11, 2005, at 5:15 PM, Joshua Hoblitt wrote: On Thu, Nov 10, 2005 at 11:51:44AM +0100, Leopold Toetsch wrote: Joshua Hoblitt wrote: I've taken a look at using Module::Pluggable to register configure steps. The simplest way to do this is to let Module::Pluggable search through the ./c

Re: reconfiguring configure

2005-11-11 Thread jerry gay
On 11/11/05, Joshua Hoblitt <[EMAIL PROTECTED]> wrote: > I think it makes sense to rename the files to be .pm anyways as they're > already more of a module then a script and will only become more so. > please rename them, as we discussed on #parrot. they can't be run as standalone scripts, so the .

Re: reconfiguring configure

2005-11-11 Thread Joshua Hoblitt
On Fri, Nov 11, 2005 at 05:17:30PM -0500, Will Coleda wrote: > > On Nov 11, 2005, at 5:15 PM, Joshua Hoblitt wrote: > > > >As in my original proposal, Configure.pl would have to set the order > >that the steps run in. Longer term it'd be nice to build a dependency > >tree between the steps and ex

Re: reconfiguring configure

2005-11-11 Thread Joshua Hoblitt
On Fri, Nov 11, 2005 at 02:26:13PM -0800, jerry gay wrote: > On 11/11/05, Joshua Hoblitt <[EMAIL PROTECTED]> wrote: > > I think it makes sense to rename the files to be .pm anyways as they're > > already more of a module then a script and will only become more so. > > > please rename them, as we di

[perl #31181] [TODO] Strings - character class & properties testing

2005-11-11 Thread Jerry Gay via RT
has this been addressed, even partially? it seems that it has, but this ticket, nor the related email thread (http://www.nntp.perl.org/group/perl.perl6.internals/29394) has been updated since may 2005. ~jerry

[perl #35391] [TODO] filepath manipulations

2005-11-11 Thread Jerry Gay via RT
forgot to copy p6i > [particle - Fri Nov 11 11:41:28 2005]: > > > [leo - Tue May 10 05:13:47 2005]: > [above code snipped] > > As a starter an equivalent of File::Spec::catfile() would suffice to be > > able to rewrite above code. > > > File::Spec::catdir() has been implemented for win32. catfi

Re: proposal: rename 'subtype' declarator to 'set'

2005-11-11 Thread Stuart Cook
On 12/11/05, Larry Wall <[EMAIL PROTECTED]> wrote: > On Wed, Nov 09, 2005 at 01:45:21PM +0100, TSa wrote: > : So, why not call the thing what it is---a set *type* declarator! > : > : set SmallInt of Int where { abs < 10 }; > : > : set SomeNums of Num = (3.14, 4, 89, 23.42); > : > : set Bit of

[svn ci] better errors for missing / invalid ops

2005-11-11 Thread jerry gay
i removed a stray line of imcc code which accidentally converted an op's full name back to it's short name (e.g. branch_p => branch). this should make errors for missing ops or bad arguments easier to understand, as the op full name, short name, and arg count is now reported in the error message.

Re: Thoughs on Theory.pm

2005-11-11 Thread Rob Kinyon
On 10/13/05, Dave Whipp <[EMAIL PROTECTED]> wrote: > (ref: http://svn.openfoundry.org/pugs/docs/notes/theory.pod) > > >theory Ring{::R} { > >multi infix:<+> (R, R --> R) {...} > >multi prefix:<-> (R --> R){...} > >multi infix:<-> (R $x, R $y --> R) { $x + (-

Re: Test Case: Complex Numbers

2005-11-11 Thread Jonathan Lang
Luke Palmer wrote: > Just some initial thoughts and syntax issues. I'll come back to it on > the conceptual side a little later. I'm looking forward to it. > Jonathan Lang wrote: > > method coerce:complexPolar () returns complexPolar { > > return new complexPolar ($.x * $.x + $.y * $.y, at

Re: proposal: rename 'subtype' declarator to 'set'

2005-11-11 Thread Eric
> > I think 'subset' might be a nicer colour for this bikeshed. For an > extra three characters you lose the confusion with "to set", and it > highlights the fact that you're (usually) declaring a *constrained* > subset of the original type. > > > Stuart > Ehh. By that definition arn't all sets s