HaloO,
Yuval Kogman wrote:
Today on #perl6 I complained about the fact that this is always
inelegant:
if ($condition) { pre }
unconditional midsection;
if ($condition) { post }
I'm not sure if you would considered closure traits as equally
inelegant but what are PRE
On Tue, Sep 20, 2005 at 14:47:33 -0400, Austin Frank wrote:
> Would the named adverbs for gather work in other contexts as well?
> Would you suggest this mechanism for specifying the buffering
> behavior for IO operations?
See scook's email below... I think that yes. Here is a reference
implementa
On Tue, Sep 20, 2005 at 21:09:09 +0200, Juerd wrote:
> Mark Reed skribis 2005-09-20 14:31 (-0400):
> This has so little redundancy that it makes very little sense to want to
> avoid repeating that very short encode_entities($item->label).
The fine line is when the midsection is slightly more than
David Landgren wrote:
Thomas Klausner wrote:
[...]
The cpants analysis fails to recognise this as valid. What is it
looking for and/or could it be taught to look for this? I thought
that it was only looking for a string eval of "use Test::Pod".
It does, but the qq{} you're using isn't reco
I'm pretty sure all the stuff i added (plus more) is now there thanks
to someone else. They may have started from my code, they may not
have. Haven't really looked at the project since.
Peter
On 21/09/2005, at 2:20 PM, Joshua Hoblitt via RT wrote:
[EMAIL PROTECTED] - Tue May 06 06:39:11 20
demerphq wrote:
On 9/15/05, David Landgren <[EMAIL PROTECTED]> wrote:
As I was downloading the newest version of Devel::Cover this morning, I
pondered on the concept of 1 Kwalitee point for coverage >= 80% ...
I have to wonder about how you handle modules that have code that is
Perl version de
David Cantrell wrote:
demerphq wrote:
On 9/15/05, David Landgren <[EMAIL PROTECTED]> wrote:
As I was downloading the newest version of Devel::Cover this morning, I
pondered on the concept of 1 Kwalitee point for coverage >= 80% ...
I have to wonder about how you handle modules that have cod
"Joshua Hoblitt via RT" <[EMAIL PROTECTED]> wrote:
[jhoblitt - Mon Sep 19 22:28:00 2005]:
> [EMAIL PROTECTED] - Sun Sep 22 07:13:56 2002]:
>
> The point of having a validifiable magic number at the start
> of a bytecode file is to avoid this sort of thing:
>
> % ../../parrot -j mops.pasm
> Pack
Hi,
Since my last post about pbc_merge, I've also checked in some tests plus
hunted down and fixed a problem that prevented the tool from working in the
leo-ctx5 branch. I think this ticket can now be closed (I don't have RT
privs to do stuff like this).
Thanks,
Jonathan
Jonathan Worthington wrote:
> FORMAT PROPOSAL...
Great! Anything that brings parrot closer to being able to report the
HLL filename and line numbers is a good thing!
> SOURCE SEGMENTS
> ... the idea would seem to be
> that this segment can contain source code. I suspect the intention of it
>
HaloO Larry,
you wrote:
On Mon, Aug 22, 2005 at 10:51:53PM +0200, Ingo Blechschmidt wrote:
: If we go with these changes, this functionality (starting place for a
: search) would be available by using
:
: Foo::Bar<$symbol_to_lookup>; # right?
Presumably, though Foo::Bar differs from OUT
simon:
> >> > If you're going to check the magic after the wordsize and bytecode, you
> >> > might as well get rid of it altogether.
...
Jonathan:
> ...Change the packfile format, or code around the current way
If you do tweak the signature for the packfile format, I suggest you
take a leaf out of
Hi!
On Wed, Sep 21, 2005 at 11:58:36AM +0200, David Landgren wrote:
> To me, this is a mark of Quality. It would be good to have it as a
> Kwalitee metric, but I see no easy way. The simplest way I can see would
> be to have a META.yml key that contains a URI to the HTML D::C report. I
> would
HaloO Yuval,
you wrote:
On Mon, Aug 29, 2005 at 14:07:51 +0200, TSa wrote:
role Object does Compare[Object, =:=]
role Numdoes Compare[Num, ==]
role Strdoes Compare[Str, eq]
What is the implication of from the perspective of the person using
Object, Num and Str?
Do they have on
Selon Thomas Klausner <[EMAIL PROTECTED]>:
> Hi!
>
> On Wed, Sep 21, 2005 at 11:58:36AM +0200, David Landgren wrote:
>
> > To me, this is a mark of Quality. It would be good to have it as a
> > Kwalitee metric, but I see no easy way. The simplest way I can see would
> > be to have a META.yml key t
On 2005-09-21 03:53, "Yuval Kogman" <[EMAIL PROTECTED]> wrote:
> On Tue, Sep 20, 2005 at 21:09:09 +0200, Juerd wrote:
>> Mark Reed skribis 2005-09-20 14:31 (-0400):
>> This has so little redundancy that it makes very little sense to want to
>> avoid repeating that very short encode_entities($it
On Tue, Sep 20, 2005 at 08:16:23PM -0400, Stevan Little wrote:
> http://svn.openfoundry.org/pugs/perl5/Perl6-MetaModel2.0/docs/
> p6_role_model.jpg
>
> I am planning on making Roles self-bootstrapping, so the class(Role)
> will actually be the first Role in the system. From there, Class will
On 9/21/05, David Landgren <[EMAIL PROTECTED]> wrote:
> I know I had my eyes opened by Devel::Cover. I thought I had pretty good
> coverage in Regexp::Assemble. In fact I had about 60%. I lifted it up to
> 100% statement coverage (some branching and conditional paths are never
> taken, but they are
Every time I've desired a feature for Perl6 it has turned out that either
it was already planned to be there or I have been given good resons why it
would have been better not be there.
Now in Perl(5) {forum,newsgroup}s you can often see people doing stuff
like
my @files=grep !/^\.{1,2}/,
HaloO,
Nathan Gray wrote:
The order that a class does roles is significant, because if two roles
define the same method, only the first one is catalogued by the class
instance.
Ups, this contradicts the concept of class composition which in the
above case should raise an error instead of relyi
On 9/21/05, Michele Dondi <[EMAIL PROTECTED]> wrote:
>
> Letting aside the fact that in the 99% of times they're plainly
> reinventing the wheel of glob() a.k.a. File::Glob, there are indeed
> situations in which one may have stuff like
>
> for (@foo) {
> next if $_ eq 'boo';
> # do something usefu
Hi,
quick questions:
my $pair = (a => 42);
say ~$pair; # "a\t42"? "a\t42\n"? "a 42"?
say +$pair; # 0 (pairs aren't numbers)?
# 42?
# 0 ("a" is not a number)?
# 0 (~$pair can't be used as a number)?
say ?$pair; # true (because 4
Ingo Blechschmidt skribis 2005-09-21 14:47 (+):
> my $pair = (a => 42);
> say ~$pair; # "a\t42"? "a\t42\n"? "a 42"?
> say +$pair; # 0 (pairs aren't numbers)?
> # 42?
> # 0 ("a" is not a number)?
> # 0 (~$pair can't be used as a nu
Nathan,
On Sep 21, 2005, at 9:02 AM, Nathan Gray wrote:
On Tue, Sep 20, 2005 at 08:16:23PM -0400, Stevan Little wrote:
http://svn.openfoundry.org/pugs/perl5/Perl6-MetaModel2.0/docs/
p6_role_model.jpg
I am planning on making Roles self-bootstrapping, so the class(Role)
will actually be the fir
Hi,
(sorry for the long delay.)
Juerd convolution.nl> writes:
> Ingo Blechschmidt skribis 2005-09-19 14:21 (+):
> > \(1,2,3);# Reference to a list promoted to an array (!)
> > \(((1,2,3)));# same
>
> Except that it has to be a reference to a reference, because (1,2)
> (i
demerphq wrote:
On 9/21/05, David Landgren <[EMAIL PROTECTED]> wrote:
I know I had my eyes opened by Devel::Cover. I thought I had pretty good
coverage in Regexp::Assemble. In fact I had about 60%. I lifted it up to
100% statement coverage (some branching and conditional paths are never
taken,
Ingo~
On 9/21/05, Ingo Blechschmidt <[EMAIL PROTECTED]> wrote:
>
> foo(1,2,3); # &infix:<,> *not* called
> foo (1,2,3); # same as
> foo( (1,2,3) ); # &infix:<,> called
Do you mean this to read?
foo(1,2,3); # &infix:<,> *not* called
foo .(1,2,3);# &infix:<,>
Hi,
Matt Fowles wrote:
> On 9/21/05, Ingo Blechschmidt <[EMAIL PROTECTED]> wrote:
>> foo(1,2,3); # &infix:<,> *not* called
>> foo (1,2,3); # same as
>> foo( (1,2,3) ); # &infix:<,> called
>
> Do you mean this to read?
>
> foo(1,2,3); # &infix:<,> *not* called
>
I've just closed the ticket. Thanks.
Ingo Blechschmidt skribis 2005-09-21 17:24 (+0200):
> multi prefix:<\> (Item $item) {...}
> multi prefix:<\> (@array) {...}
> multi prefix:<\> (%hash) {...}
I keep forgetting. What's the rule for determining that the (Item $item)
is used, rather than (@array), when one uses \$
On Wed, 2005-09-21 at 11:44 +0100, Jonathan Worthington wrote:
> >> but I can cause a segfault from random input on x86.
> >>
> >> --
> >> $ ./parrot -j docs/running.pod
> >> Segmentation fault
> This is a Bad Thing and needs fixing. I'll see what I can find - I don't
> even see a segfault or a
On Wed, Sep 21, 2005 at 09:54:33 -0400, Mark Reed wrote:
> Watch the attributions, please. I didn't write the above text - Juerd did.
Sorry, I must have gotten confused when I was snipping
--
() Yuval Kogman <[EMAIL PROTECTED]> 0xEBD27418 perl hacker &
/\ kung foo master: /me supports the
Hi,
Juerd wrote:
> Ingo Blechschmidt skribis 2005-09-21 17:24 (+0200):
>> multi prefix:<\> (Item $item) {...}
>> multi prefix:<\> (@array) {...}
>> multi prefix:<\> (%hash) {...}
>
> I keep forgetting. What's the rule for determining that the (Item
> $item) is used, rather th
On Wed, 21 Sep 2005, Joshua Hoblitt via RT wrote:
[EMAIL PROTECTED] - Tue May 27 19:30:39 2003]:
Currently, if you're in the debugger, and do anything that causes an
internal_exception call within the interpreter, you get a segfault.
[Backtrace snipped]
...etc
I think what's happen
On Wed, 21 Sep 2005, Joshua Hoblitt via RT wrote:
[EMAIL PROTECTED] - Fri Oct 31 12:58:45 2003]:
An attempt to build Parrot with PIO_OS_STDIO defined (as is the case
when you're trying to build miniparrot) dies in core_ops.c with the error
message:
ops/io.ops: In function `Parrot_sockad
Hey,
Since you wouldn't expect an object to stringify or numify why expect pairs
to? I'm not sure i see any value in thatm, $pair.perl.say would be the best
way to output one anyway.
my $pair1 = (a => 2);
my $pari2 = (b => 3);
say $pair1 + $par2; # Error: illegal stringification of pair.?
I kno
Eric skribis 2005-09-21 16:46 (-0600):
> Since you wouldn't expect an object to stringify or numify [...]
Oh? I would in fact expect many objects to stringify or numify to useful
values. Just like I expect an array reference to stringify as if it was
an array, I expect an HTTP header object to str
On 22/09/05, Juerd <[EMAIL PROTECTED]> wrote:
> By the way, is it really this simple?
>
> class HTTP::Header is Pair {
> foo {
> "{.key}: {.value ~~ s/\n/\n /g}"
> }
> }
>
> Where "foo" is whatever is needed to override stringification.
Something along the lines
On 22/09/05, Juerd <[EMAIL PROTECTED]> wrote:
> I don't think +(~$pair) makes any sense, though. It's basically the same
> as +(~$pair.key). It's probably wise to avoid that $pair can be confused
> for its key or value. A good alternative is hard to find, though. I tend
> to prefer 1 at this moment
Eric wrote:
Hey,
Since you wouldn't expect an object to stringify or numify why expect pairs
to? I'm not sure i see any value in thatm, $pair.perl.say would be the best
way to output one anyway.
my $pair1 = (a => 2);
my $pari2 = (b => 3);
say $pair1 + $par2; # Error: illegal stringification of
David Landgren wrote:
demerphq wrote:
You miss my point. Whether the code be cross-platform or cross-version,
you need to aggregate the coverage results from all the environments
your code is designed to run on.
How is this done?
hcchien raised the following question on #perl6[1]:
If I want to loop through a nine-element array three elements at a time, I do
my @a = 1..9;
for @a -> $x, $y, $z { say $x }
But what if I don't care about the elements 1,4,7? Would the following
be a sane syntax?
my @a = 1..9;
for @a -> undef,
42 matches
Mail list logo