> > and I saw good descriptions at
> > perlmonks site.
> >
>
> Ok. I had found nothing helpful at perlmonks about this, other than
> "use vcvars", which I seem to be.
I meant http://perlmonks.org/?node_id=387070
Although I replied that those are low quality, those were improved, yet
advices are
# New Ticket Created by Will Coleda
# Please include the string: [perl #37545]
# in the subject line of all future correspondence about this issue.
# https://rt.perl.org/rt3/Ticket/Display.html?id=37545 >
Given these two files:
$ cat foo.pir
.HLL 'Tcl', 'tcl_group'
.sub main :main
$P1 =
On Thu, 2005-10-20 at 17:12 -0700, Nate Wiger wrote:
> If Perl 6 is going to be successful, this means it must change the
> fewest key things with the most benefits.
I think there's an assumption here that not only do I not hold but I do
not even understand.
Suppose that I am a game developer wi
On 10/26/05, Rob Kinyon <[EMAIL PROTECTED]> wrote:
> What about:
>
> class Foo is also {
> method foo() { ... }
> }
>
> Where the second foo() is no longer what the first foo() did.
Just overwrite the vtable.
> Furthermore, let's say you have:
>
> class Bar isa Foo {
>
On Oct 26, 2005, at 11:44 PM, Will Coleda wrote:
I tried running with ActiveState Perl, and it all seems fine. one
small glitch in the Configure step
Whoops, which I forgot to mention:
Running CPU specific stuff..Can't spawn ".\test.exe": Bad file
descriptor at
lib/Parrot/Configu
On Oct 25, 2005, at 5:11 AM, Konovalov, Vadim wrote:
I have a copy of XP Pro: I just installed ActiveState Perl, Visual C+
+ Toolkit 2003, the MS SDK and the .NET SDK (On my Virtual PC
installation on my mac, btw. Only took about 10 hours, on and
off =-)
trying to build parrot using the toolkit
On Wed, Oct 26, 2005 at 07:35:05PM -0700, chromatic wrote:
: On Wed, 2005-10-26 at 21:58 -0400, Rob Kinyon wrote:
:
: > Plus, the argument is a straw man. Instead of:
: >
: > class Some::Class is also {
: > }
: >
: > you would do:
: >
: > class My::Version {
: > does Some::C
On Wed, 2005-10-26 at 21:58 -0400, Rob Kinyon wrote:
> Plus, the argument is a straw man. Instead of:
>
> class Some::Class is also {
> }
>
> you would do:
>
> class My::Version {
> does Some::Class;
> }
>
> Problem solved.
Don't forget the fun of modifying all existin
On Wed, 2005-10-26 at 14:52 -0400, Uri Guttman wrote:
> > "LW" == Larry Wall <[EMAIL PROTECTED]> writes:
> LW> One wants to coin a word like "Qlass". Unfortunately "qlass" is
> LW> too easy to misread as "glass". Oy veh, I'm getting notions of
> LW> "the qlass is half empty" for a par
On 10/26/05, Luke Palmer <[EMAIL PROTECTED]> wrote:
[snip]
> Okay, an open class means you can add methods to it, right? So, let's
> say you have this class:
>
> class Foo {
> method foo() {...}
> method bar() {...}
> }
>
> And this code:
>
> my Foo $x = Foo.new;
>
On Wed, 2005-10-26 at 19:22 -0600, Luke Palmer wrote:
> But we find that many programmers make decisions that trade
> readability and extensibility for an extra 1% of speed, even when they
> are writing a command-line frontend to MPlayer[1]. If those people
> are module writers, then we have a bu
On Wed, Oct 26, 2005 at 06:34:48PM -0700, Larry Wall wrote:
: On Wed, Oct 26, 2005 at 04:56:23PM -0600, Luke Palmer wrote:
: : > Then ^T $x binds T to the kind of $x. And $x.kind == $y.kind asks
: : > if two objects are of the same type,
: :
: : Don't you mean $x.kind eqv $y.kind?
: :
: : Ugh.
:
On Wed, Oct 26, 2005 at 04:56:23PM -0600, Luke Palmer wrote:
: > Then ^T $x binds T to the kind of $x. And $x.kind == $y.kind asks
: > if two objects are of the same type,
:
: Don't you mean $x.kind eqv $y.kind?
:
: Ugh.
Now that infix:<::> has come available, maybe I mean:
$x.kind :: $y.k
On Wed, Oct 26, 2005 at 08:48:12PM -0400, Rob Kinyon wrote:
: If a role is an immutable class, that means that its internals cannot
: be changed. Hence, the compiler can trust that it will be the same at
: the end as at the beginning. Which means it's optimized. Which means
: my objects run faster
On 10/26/05, Rob Kinyon <[EMAIL PROTECTED]> wrote:
> On 10/26/05, chromatic <[EMAIL PROTECTED]> wrote:
> > On Wed, 2005-10-26 at 20:29 -0400, Rob Kinyon wrote:
> >
> > > I would prefer to use roles as they're closed by default, leaving
> > > "class" to be my powertool, if I need the power.
> >
> >
On 10/26/05, chromatic <[EMAIL PROTECTED]> wrote:
> On Wed, 2005-10-26 at 20:29 -0400, Rob Kinyon wrote:
>
> > I would prefer to use roles as they're closed by default, leaving
> > "class" to be my powertool, if I need the power.
>
> I don't understand this desire; can you explain your reasoning?
On Wed, 2005-10-26 at 20:29 -0400, Rob Kinyon wrote:
> I would prefer to use roles as they're closed by default, leaving
> "class" to be my powertool, if I need the power.
I don't understand this desire; can you explain your reasoning?
(NB: "closed" here, as I use it, still *does not* correspond
> : 3) Aren't classes mutable and roles immutable by default only? Or has
> : this changed?
>
> Of course. To change the default for a role, call it a class, and
> to change the default for a class, call it a role. :-)
Does this mean that roles are the recommended way to create immutable
classes
On 10/26/05, Larry Wall <[EMAIL PROTECTED]> wrote:
> So maybe we can define our terms like this:
>
> type: a completely generic metaterm for any of the following,
> and then some.
>
> class: a mutable interface object that manages instances in the
> "classical" way, with covariant d
On Wed, Oct 26, 2005 at 03:54:35PM -0400, Rob Kinyon wrote:
: > So maybe we can define our terms like this:
: >
: > type: a completely generic metaterm for any of the following,
: > and then some.
: >
: > class: a mutable interface object that manages instances in the
: > "classical
On 10/26/05, via RT Allison Randal <[EMAIL PROTECTED]> wrote:
> I've attached a patch with a more verbose error message. Even more
> helpful would be listing the types that were passed in.
>
thanks, applied as revision 9579.
~jerry
On Wed, Oct 26, 2005 at 09:54:10AM -0700, Fran??ois PERRAD via RT wrote:
> At 03:02 19/10/2005 -0700, you wrote:
> ># New Ticket Created by Joshua Hoblitt
> ># Please include the string: [perl #37477]
> ># in the subject line of all future correspondence about this issue.
> ># https://rt.perl.org
> So maybe we can define our terms like this:
>
> type: a completely generic metaterm for any of the following,
> and then some.
>
> class: a mutable interface object that manages instances in the
> "classical" way, with covariant derivational properties.
>
> role: an immutable
# New Ticket Created by Allison Randal
# Please include the string: [perl #37541]
# in the subject line of all future correspondence about this issue.
# https://rt.perl.org/rt3/Ticket/Display.html?id=37541 >
Currently the error message when a particular opcode isn't found
gives the name of
> "LW" == Larry Wall <[EMAIL PROTECTED]> writes:
LW> One wants to coin a word like "Qlass". Unfortunately "qlass" is
LW> too easy to misread as "glass". Oy veh, I'm getting notions of
LW> "the qlass is half empty" for a partially instantiated object.
[EMAIL PROTECTED],
i think you ne
via RT jerry gay <[EMAIL PROTECTED]> wrote:
> there have been questions lately about the use of the 'new_pad' op.
> will coleda provided a failing example, which i've included below.
> upon investigating, i found no tests for new_pad. furthermore, i found
> no documentation for new_pad in order to
On Wed, Oct 26, 2005 at 12:36:57PM -0400, Stevan Little wrote:
: This is a very rough and high level view, and ignores little details
: like macros, BEGIN blocks, etc.
Yes, Perl 5 is conceptually a 3-pass compiler, but the passes have to
be interwoven to do the "literate compilation" thing that
On Wed, Oct 26, 2005 at 07:06:15PM +0200, TSa wrote:
: HaloO,
:
: Larry Wall wrote:
: >On Wed, Oct 26, 2005 at 04:59:04PM +0200, Juerd wrote:
: >: Larry Wall skribis 2005-10-26 7:31 (-0700):
: >: > One slightly serious ramification of the : switch is that the space
: >: > is required after the co
On Wed, Oct 26, 2005 at 12:22:07PM -0400, Stevan Little wrote:
:
: On Oct 26, 2005, at 12:05 PM, Larry Wall wrote:
: >Of course, there are other words that are somewhat synonymous with
: >"class", Unfortunately "sort" is already hosed. Maybe "kind".
:
: Actually "kind" is used in the "Core Calcu
HaloO,
Austin Frank wrote:
Which (sort of) takes us back to TSa's (non)sign-off note from 10/5,
wherein he suggested:
I just can't help it, I love the good work done on this list!
And thanks for spelling the acronym correctly.
The Kindly One of a class beeing the representative like
the Presi
Larry Wall <[EMAIL PROTECTED]> wrote:
> Of course, there are other words that are somewhat synonymous with
> "class", Unfortunately "sort" is already hosed. Maybe "kind".
> Then evolutionists could make jokes about the K(T) boundary, and
> creationists could make jokes about "reproducing after the
# New Ticket Created by jerry gay
# Please include the string: [perl #37540]
# in the subject line of all future correspondence about this issue.
# https://rt.perl.org/rt3/Ticket/Display.html?id=37540 >
there have been questions lately about the use of the 'new_pad' op.
will coleda provided a
HaloO,
Larry Wall wrote:
On Wed, Oct 26, 2005 at 04:59:04PM +0200, Juerd wrote:
: Larry Wall skribis 2005-10-26 7:31 (-0700):
: > One slightly serious ramification of the : switch is that the space
: > is required after the colon indicating a null invocant.
What is an invocantless method othe
At 03:02 19/10/2005 -0700, you wrote:
# New Ticket Created by Joshua Hoblitt
# Please include the string: [perl #37477]
# in the subject line of all future correspondence about this issue.
# https://rt.perl.org/rt3/Ticket/Display.html?id=37477 >
Any objections?
$ cat config_lib.pasm
# Genera
Stevan Little:
> They present an rather interesting view on things, that the
> definition of the instance creating portion of a "class" should be
> seperated from the "class" or "kind" portion of the class.
Its quality. Its character. Its features. Its face.
--
Grtz, Ruud
On 10/26/05, Stevan Little <[EMAIL PROTECTED]> wrote:
>
> On Oct 26, 2005, at 12:05 PM, Larry Wall wrote:
> > Of course, there are other words that are somewhat synonymous with
> > "class", Unfortunately "sort" is already hosed. Maybe "kind".
>
> Actually "kind" is used in the "Core Calculus for M
Larry Wall:
> But perhaps it wouldn't be kind.
'caste' wouldn't either.
For inspiraton: type sort class variety brand category breed manner
style nature form hue caste set background stage setting milieu locale
range assortment selection mixture strain suite scenery rank grade
division status ge
Hello all, just unwarnocking myself here :)
These are some notes to add re: a short discussion with autrijus on
#perl6
The idea is that the interpreter/compiler is split into 3 parts.
- The first part parses the code, deals with flow control and syntax
stuff.
- The second part is the typ
On Wed, Oct 26, 2005 at 09:05:22AM -0700, Larry Wall wrote:
> Of course, there are other words that are somewhat synonymous with
> "class", Unfortunately "sort" is already hosed. Maybe "kind".
Maybe we could go with something Linnaean like "family" or "genus"
even though their relation to "class"
On Oct 26, 2005, at 12:05 PM, Larry Wall wrote:
Of course, there are other words that are somewhat synonymous with
"class", Unfortunately "sort" is already hosed. Maybe "kind".
Actually "kind" is used in the "Core Calculus for Metaclasses" paper
which I brought to the hackathon (not sure if
Larry Wall wrote:
Of course, there are other words that are somewhat synonymous with
"class", Unfortunately "sort" is already hosed. Maybe "kind".
Then evolutionists could make jokes about the K(T) boundary, and
creationists could make jokes about "reproducing after their kind".
Some of us coul
On Wed, Oct 26, 2005 at 11:31:28AM -0400, Rob Kinyon wrote:
: > That's just self.meta.add_method($label, $method) by my lights.
: > A .meta already implies/ignores the .class coercion. If we are to
: > support prototype-based programming $x.meta *must not care* whether
: > it has been given a clas
Larry Wall skribis 2005-10-26 8:29 (-0700):
> I think a . would be too lightweight visually within the signature.
> Plus . is a postfix prefix syntactically, not a delimiter.
If weight is the issue, @#@ should do ;)
This aside, you could of course just double the colon. Or use a
semicolon.
I ju
> That's just self.meta.add_method($label, $method) by my lights.
> A .meta already implies/ignores the .class coercion. If we are to
> support prototype-based programming $x.meta *must not care* whether
> it has been given a class or an instance or something in between.
> What I am calling a "cla
On Wed, Oct 26, 2005 at 04:59:04PM +0200, Juerd wrote:
: Larry Wall skribis 2005-10-26 7:31 (-0700):
: > One slightly serious ramification of the : switch is that the space
: > is required after the colon indicating a null invocant.
: > method doit (: $a, $b, $c)
:
: Or, we could separate it
On Tue, Oct 25, 2005 at 05:17:40PM -0400, Stevan Little wrote:
: Larry,
:
: On Oct 25, 2005, at 4:37 PM, Larry Wall wrote:
: >On Mon, Oct 24, 2005 at 06:33:20AM -0700, Ashley Winters wrote:
: >: # behavior through prototype -- guessing realistic syntax
: >: Base.meta.add_method(
: >: do_it =>
Larry Wall skribis 2005-10-26 7:31 (-0700):
> One slightly serious ramification of the : switch is that the space
> is required after the colon indicating a null invocant.
> method doit (: $a, $b, $c)
Or, we could separate it with a . instead of a :, perhaps?
This is already more or less ver
On 10/26/05, Larry Wall <[EMAIL PROTECTED]> wrote:
> A mandatory named parameter is now marked +:$nonoptionaloption.
Woo! :)
-John
It also means you could write a prototype that looks like
:(!, !, !, ?, ?)
We don't need no stinkin' "_". There's more than one way to not care.
(I guess that means that in addition to supporting interesting values
of undef, we also support interesting values of not caring...)
But does that
"Will Coleda via RT" <[EMAIL PROTECTED]> wrote:
This was a very old TODO from the TODO file:
Is this now covered with the recent changes?
[coke - Sun Aug 15 13:27:07 2004]:
Bytecode
Metadata (source line number info, symbol table)
Hard to say; depends if it's talking about HLL
On Wed, Oct 26, 2005 at 04:02:06PM +0200, Juerd wrote:
: Larry Wall skribis 2005-10-26 6:44 (-0700):
: > I should point out that one of the major changes in the most recent
: > S6 is that named arguments are now marked by : rather than +, with
: > :foo($bar) being the way to declare parameter $bar
On Wed, Oct 26, 2005 at 10:06:25AM -0400, Matt Fowles wrote:
: Larry~
:
: On 10/26/05, Larry Wall <[EMAIL PROTECTED]> wrote:
: > So we'd get:
: >
: > :@array[42] 42 => @array[1]
:
: Do you mean C< :@array[42] 42 => @array[42] >?
Yes. I was changing it because 42 : 1 :: foo : a, but I flubbe
On Tue, Oct 25, 2005 at 10:25:48PM -0600, Luke Palmer wrote:
: Yeah, I didn't really follow his argument on that one. I, too, think
: that the one() junction in general is silly, especially for types.
Well, I think it's silly too. I'm just trying to see if we need to
reserve the syntax in case s
Larry~
On 10/26/05, Larry Wall <[EMAIL PROTECTED]> wrote:
> So we'd get:
>
> :@array[42] 42 => @array[1]
Do you mean C< :@array[42] 42 => @array[42] >?
> The last three forms are more arguable than the first three, especially
> since they probably aren't valid formal parameters. We kind of
Larry Wall skribis 2005-10-26 6:44 (-0700):
> I should point out that one of the major changes in the most recent
> S6 is that named arguments are now marked by : rather than +, with
> :foo($bar) being the way to declare parameter $bar but give it the
> external name of "foo". A + is now reserved
> And in fact, its very existence defies another implicit principle of
> mine, that is, the "principle of partial definition": Defining a new
> type or instance can only break a previously typechecking program by
> making it ambiguous. The idea behind that is that at some time you
> may realize t
I should point out that one of the major changes in the most recent
S6 is that named arguments are now marked by : rather than +, with
:foo($bar) being the way to declare parameter $bar but give it the
external name of "foo". A + is now reserved to mark mandatory
parameters, though it's redundant
Nick~
On 10/26/05, Nick Glencross <[EMAIL PROTECTED]> wrote:
> Guy,
>
> As a follow-up to a discussion a few days ago about binding parrot to
> C++ functions, is making it possible to compile parrot with a C++
> compiler a 'Bad Thing'?
I like the idea, but I tend to like C++ more than reason woul
--- Larry Wall wrote:
> On Tue, Oct 25, 2005 at 05:24:52PM +0200, Michele Dondi wrote:
> : But maybe that's just me. Whatever, I guess that the {casual,average}
> : programmer may be scared by its richness and complexity.
>
> But we're trying to design the OO features (indeed, all of Perl 6)
> su
On Wed, Oct 26, 2005 at 09:36:48AM +0200, Michele Dondi wrote:
: On Tue, 25 Oct 2005, Larry Wall wrote:
:
: >But we're trying to design the OO features (indeed, all of Perl 6)
: >such that you can usefully cargo cult those aspects that are of
: >immediate interest without being forced to learn the
This was a very old TODO from the TODO file:
Is this now covered with the recent changes?
> [coke - Sun Aug 15 13:27:07 2004]:
>
> Bytecode
>
> Metadata (source line number info, symbol table)
Guy,
As a follow-up to a discussion a few days ago about binding parrot to
C++ functions, is making it possible to compile parrot with a C++
compiler a 'Bad Thing'?
If anything, it should strengthen the code base. I had a dabble a few
weeks ago to see how big a job it would be, and quickly c
# New Ticket Created by Patrick R. Michaud
# Please include the string: [perl #37537]
# in the subject line of all future correspondence about this issue.
# https://rt.perl.org/rt3/Ticket/Display.html?id=37537 >
---
osname= linux
osvers= 2.4.21-27.0.2.elsmp
arch= i386-linux-thread-multi
cc=
> [coke - Sat Jul 23 14:25:11 2005]:
>
> PGE's match objects should be compatible with Data::Dumper.
>
> (probably a simple rename of the "dump" sub will resolve this.)
>
>
Done (r9573). The old dump format is still available as before (since
PGE's tests currently rely on it), but I added a C
On Tue, 25 Oct 2005, Larry Wall wrote:
But we're trying to design the OO features (indeed, all of Perl 6)
such that you can usefully cargo cult those aspects that are of
immediate interest without being forced to learn the whole thing.
It's not the number one design goal, but it's right up there
65 matches
Mail list logo