Should the compilation sub for p6g3 be in the root namespace as it is currently, or moved to, say, a "p6ge" namespace?
# New Ticket Created by Will Coleda
# Please include the string: [perl #32549]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org:80/rt3/Ticket/Display.html?id=32549 >
The PIR:
.sub main @MAIN
$P1 = new PerlInt
$P1 = 1
$P2 = new Integer
$P2 =
http://mungus.schwern.org/svn/
svn co http://mungus.schwern.org/svn/CPAN//trunk
Anonymous accesses to the ExtUtils::MakeMaker and Test::More repositories
both as web pages and SVN.
I'm moving from CVS repositories located on my laptop to SVN repositories
on a more publicly available server. I'l
Was an RT ticket ever created for the underlying parrot issue here?
Will Coleda (via RT) wrote:
# New Ticket Created by Will Coleda
# Please include the string: [perl #32547]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org:80/rt3/Ticket/Display.html?id=
# New Ticket Created by Will Coleda
# Please include the string: [perl #32547]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org:80/rt3/Ticket/Display.html?id=32547 >
Need unicode support for \u escapes, and for "string wordend",
"string wordstart", "st
# New Ticket Created by Will Coleda
# Please include the string: [perl #32546]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org:80/rt3/Ticket/Display.html?id=32546 >
# New Ticket Created by Will Coleda
# Please include the string: [perl #32545]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org:80/rt3/Ticket/Display.html?id=32545 >
The split opcode currently uses a PerlArray to house its result. It should use
a non-
# New Ticket Created by Will Coleda
# Please include the string: [perl #32544]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org:80/rt3/Ticket/Display.html?id=32544 >
>From the documentation for the split opcode:
split(out PMC, in STR, in STR)
On Sat, Nov 20, 2004 at 08:06:33PM -0500, William Coleda wrote:
> Is there a reason why we have "find_type", but "loadlib"; "eq_str" but
> "isnull" ?
I was just reading something blasting PHP for not being consistent about
core naming conventions particularly about "this_that" vs "thisthat".
FWIW
On Sun, 2004-11-21 at 11:21 +0100, Leopold Toetsch wrote:
> Chromatic <[EMAIL PROTECTED]> wrote:
>
> > Apparently the AIX and Darwin JIT fixes have broken the Linux PPC
> > build, which doesn't pick up the appropriate hints file. I tried a
> > couple of ways to force it to do so to no avail. So
At 9:47 PM + 11/21/04, Tim Bunce wrote:
What steps are being taken to ensure that patches/code donations to Parrot
are free from potential intellectual property concerns?
At the moment we're relying on the integrity of the people submitting
patches, with the assumption that people submitting u
Finally added in rudimentary list support in tcl (using dynclasses/tcllist.pmc)
So the following tcl:
set a [list a b c]
lappend a d e f
puts [llength $a]
will now print 6. More list stuff to come soon, shortly after the exception-related test failures go away. =-)
I switched to local exception handler blocks, and am still getting the same
failure mode.
Of course, it works fine in a simple, single file example.
I've checked everything back in so you can take a look. Once you build tcl,
from the top level directory, try:
oolong:~/research/parrot_8075 coke$ c
At 9:59 AM +0100 11/19/04, Leopold Toetsch wrote:
Dan Sugalski <[EMAIL PROTECTED]> wrote:
The 'invoke the current return continuation' op apparently got lost
in the blowup. That needs to go in.
Its in and named C since yesterday "return with current
continuation".
Hrm. The name's not right, since
William Coleda <[EMAIL PROTECTED]> wrote:
> I just noticed some test failures in the tcl suite.
exception syntax will change slightly.
> set P4, P5["_invoke_cc"]
especially these constructs (resumable handling).
Please use currently a local handler:
newsub ignore, .Exception_Handler, catc
William Coleda <[EMAIL PROTECTED]> wrote:
> Data::Escape is probably your best bet.
> .sub _main
> load_bytecode "runtime/parrot/library/Data/Escape.pbc"
^^^
Just drop that prefix - "library/foo" ought to do it.
leo
Is there some opcode or function built into the standard parrot
distribution that will print a string with appropriate escapes
around special characters (i.e., display newlines as '\n',
returns as '\r', non-printable characters as '\xnn' or '\nnn', etc.)?
I can certainly write a function to do t
On Sun, 21 Nov 2004 10:09:06 +0100, Leopold Toetsch <[EMAIL PROTECTED]> wrote:
> Gabe Schaffer <[EMAIL PROTECTED]> wrote:
> Currently we have COND only for the task queues. But if we need
> conditions in other places, QUEUE_CONDITION is misleading.
> So the current set of macros for existing stuff
I just noticed some test failures in the tcl suite.
Looks like the following code:
print "HERE?\n"
set_eh ignore
find_lex lexical, -1, var
clear_eh
Does the following at runtime:
3713 print "HERE?\n"
HERE?
3715 set_eh P20 - P20=Exception_Handler=PMC(0xf8eb30)
3717 find_lex P18, -1,
I just got my OS 10.2 installation working today, and wanted to get a
parrot on it, but when compiling, I get this error:
Badly balanced at classes/pmc2c2.pl line 316.
make: *** [classes/default.dump] Error 255
The source is a fresh checkout. I also tried the latest.tar.gz, but the
problem stays
# New Ticket Created by Stephane Peiry
# Please include the string: [perl #32535]
# in the subject line of all future correspondence about this issue.
# http://rt.perl.org:80/rt3/Ticket/Display.html?id=32535 >
This patch implements (some) jitted vtables for the sun4/sparc platform.
That is a
Sam Ruby <[EMAIL PROTECTED]> wrote:
> Ever since this commit, I've been seeing the following:
> imcc/t/imcpasm/opt0.t2 512 62 33.33% 3 6
> imcc/t/imcpasm/optc.t1 256 61 16.67% 1
Ah, yes. My local parrot has already some of the next changes. So it
does already emit
Sam Ruby <[EMAIL PROTECTED]> wrote:
> Leopold Toetsch wrote:
>>
>> There are likely some more inconsistencies, which should be fixed rather
>> sooner then later.
> One that I noticed:
> =item B(out PMC, in PMC, in STR)
> =item B(out PMC, in STR, in PMC)
Yeah, and get_repr, get_addr. Same with se
I've now some better timing result, with less loop overhead.
MMD add PerlInt PerlInt 0.698083
MMD add PerlInt INTVAL 0.601620
MMD sub PerlInt PerlInt 0.513797
MMD sub PerlInt INTVAL 0.457096
PIR add PerlInt PerlInt 7.789893
PIR sub PerlInt PerlInt 4.448320
These are 5 million add or sub instructi
Leopold Toetsch wrote:
cvsuser 04/11/19 08:28:06
Modified:imcc/t/imcpasm opt0.t optc.t pcc.t
imcc/t/syn bsr.t
Log:
replace invoke P1 in imcc tests
Revision ChangesPath
1.7 +2 -2 parrot/imcc/t/imcpasm/opt0.t
[snip]
- invoke P1/
+ returncc/
Ev
Leopold Toetsch wrote:
There are likely some more inconsistencies, which should be fixed rather
sooner then later.
One that I noticed:
=item B(out PMC, in PMC, in STR)
=item B(out PMC, in STR, in PMC)
- Sam Ruby
Joshua Gatcomb <[EMAIL PROTECTED]> wrote:
> All:
> oo1-prop.pasm and oo2-prop.pasm are both broken.
Yep. First WRT calling conventions and - that's a bigger problem - again
WRT DOD/GC. The latter is permanently reocurring and needs fixing.
1) The main source of troubles in hash code are the movin
Chromatic <[EMAIL PROTECTED]> wrote:
> Apparently the AIX and Darwin JIT fixes have broken the Linux PPC
> build, which doesn't pick up the appropriate hints file. I tried a
> couple of ways to force it to do so to no avail. Someone who knows
> what he's doing will have to do it.
> jitosnam
I know, I've asked this question some time ago, and implemented
MMD_ADD_INT and friends. But I can't reproduce the full rationale WRT
dispatching of these methods.
add Px, Py, Iz
can clearly use only the left hand operand Py. So it's not a real MMD,
the right hand operand is always a plain in
William Coleda <[EMAIL PROTECTED]> wrote:
> Is there a reason why we have "find_type", but "loadlib"; "eq_str" but
> "isnull" ?
In ancient days the perl5-based assembler tools had troubles with
underscores in opcode names, as the operands (for the fullnames) are
encoded like:
add_p_p_p # add
Gabe Schaffer <[EMAIL PROTECTED]> wrote:
> I think that maybe what we need is a MUTEX, a CONDITION, and a
> QUEUE_CONDITION. The QUEUE_CONDITION would always contain a mutex and
> a condition, while the CONDITION would have a c,m for POSIX and just c
> for Win32.
Currently we have COND only for t
31 matches
Mail list logo