2020-11-21 오전 12:31에 Fernando Frediani 이(가) 쓴 글:
Yes, exactly it is only an issue when someone have to access the web
interface via wifi. In a home environment that is a small issue. In a
more corporate environment there are two options: 1) access is done
via wired network or 2) enable HTTPS, wh
Signed-off-by: DENG Qingfang
---
package/firmware/ath10k-ct-firmware/Makefile | 68 ++--
1 file changed, 34 insertions(+), 34 deletions(-)
diff --git a/package/firmware/ath10k-ct-firmware/Makefile
b/package/firmware/ath10k-ct-firmware/Makefile
index cdfd3fb940..1733f53a5b 100644
Added PKG_INSTALL to avoid using an explicit define Build/Compile
Added PKG_BUILD_PARALLEL for faster compilation.
Removed TARGET_CLAFGS. They are no longer necessary.
fPIC is default now. So is gnu99. -DUSE_DOS is a hack to include old
and mostly unused conversions.
Signed-off-by: Rosen Penev
Fixes compilation with musl 1.2.x.
Signed-off-by: Rosen Penev
---
package/devel/binutils/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index 9f7a0724f4..23f1ea9c25 100644
--- a/package/devel/binu
Without this, cmake will use whatever CC/CXX is set to, which could be
clang. In that case, at least libjson-c/host will fail to compile.
Signed-off-by: Rosen Penev
---
include/cmake.mk | 2 ++
1 file changed, 2 insertions(+)
diff --git a/include/cmake.mk b/include/cmake.mk
index fec6da22ef..2c
Airtime policy configuration is extremely useful in multiple BSS scenarios.
Since nowadays most people configure both private and guest networks (at
least), it makes sense to enable it by default, except for the most limited
of the variants.
Size of the hostapd-basic-openssl binary (mipsel 24Kc -O
On Tue, Nov 24, 2020 at 12:08 PM Georgi Valkov wrote:
>
> Thank you, Philip!
> Here it is the patch:
Please post this on https://github.com/openwrt/packages/pulls . This
patch does not apply locally.
>
>
> From a5c62c0dd2b4dabf72571239f08266b348dad5a2 Mon Sep 17 00:00:00 2001
> From: Georgi Valkov
Hi Bjørn,
Just some thoughts in addition to what was already mentioned about the
property names.
On Wed, 2020-11-25 at 12:45 +0100, Bjørn Mork wrote:
> This ended up a bit more invasive than I imagined, but here goes..
>
> I wanted to add a couple of new rtl83xx devices. They both use
> standar
Drop our local sstrip copy and use the current ELFKickers upstream version.
Patch the original makefile in order to avoid building elftoc, since it fails
with musl's elf.h. This is fine, since we only need sstrip anyway.
Finally, add the possibility to pass additional arguments to sstrip and pass
Drop our local sstrip copy and use the current ELFKickers upstream version.
Patch the original makefile in order to avoid building elftoc, since it fails
with musl's elf.h. This is fine, since we only need sstrip anyway.
Finally, add the possibility to pass additional arguments to sstrip and pass
On Wed, Nov 25, 2020 at 08:23:08PM +0100, Hans Dedecker wrote:
> This is fixed in netifd by commit
> https://git.openwrt.org/?p=project/netifd.git;a=commitdiff;h=645ceed0ed706b073edd6a0d5a2eb936208b48c9
Cool I didn't see that. Thanks!
I'm a bit bummed you didn't just include the more detailed exp
Hi,
On Wed, Nov 25, 2020 at 6:36 PM Daniel Gröber wrote:
>
> When a proto registers a prefix with an address which has bits outside the
> netmask set this confuses the prefix-assignment code further down the line.
>
> For example if we have an interface with
>
> option ip6prefix fdff::fff
Currently when assigning IPv6 addresses with large prefixes to a wireguard
interface, like
config interface 'wg'
option proto 'wireguard'
list addresses 'fd::/48'
and having, say, a LAN interface such as
config interface 'lan'
option proto 'static'
Hi,
> > This should not land in the final commit message. To make sure of that, and
> have it in patchwork anyway, please add a line with only "---" after your
> Signed-off-by and then add anything like that after that line.
>
> Are you mainly talking about the message-id bit or about the entire
On Wed Nov 25, 2020 at 4:11 AM HST, Petr Štetiar wrote:
> Baptiste Jonglez [2020-11-25 12:41:18]:
>
> Hi,
>
> > For the imagebuilder, it increases the *total* build time (not just
> > download time!) by +50%:
> >
> > http://lists.openwrt.org/pipermail/openwrt-devel/2020-September/031406.html
>
>
On Wed, Nov 25, 2020 at 07:28:25PM +0100, Adrian Schmutzler wrote:
> > Note that the addresses configured here usually include a non-zero host part
> > but currently netifd handles this poorly when more than one interface
> > should receive a sub-prefix.
> >
> > The required fix can be found in "[
On Wed, Nov 25, 2020 at 03:11:24PM +0100, Petr Štetiar wrote:
> Baptiste Jonglez [2020-11-25 12:41:18]:
>> For the imagebuilder, it increases the *total* build time (not just
>> download time!) by +50%:
>>
>> http://lists.openwrt.org/pipermail/openwrt-devel/2020-September/031406.html
>
> I don't
Hi,
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
> On Behalf Of Daniel Gröber
> Sent: Mittwoch, 25. November 2020 18:47
> To: openwrt-devel@lists.openwrt.org
> Subject: [PATCH v2] wireguard: Make IPv6 addrs available for automatic
> prefix ass
Hi,
> -Original Message-
> From: Paul Spooren [mailto:m...@aparcar.org]
> Sent: Mittwoch, 25. November 2020 19:21
> To: Rui Salvaterra ; openwrt-
> de...@lists.openwrt.org
> Cc: freif...@adrianschmutzler.de
> Subject: Re: [PATCH v2] tools/sstrip: update to latest version
>
> On Wed Nov 25
On Wed Nov 25, 2020 at 6:48 AM HST, Rui Salvaterra wrote:
> Drop our local sstrip copy and use the current ELFKickers upstream
> version.
>
> Patch the original makefile in order to avoid building elftoc, since it
> fails
> with musl's elf.h. This is fine, since we only need sstrip anyway.
>
> Fina
Currently when assigning IPv6 addresses with large prefixes to a wireguard
interface, like
config interface 'wg'
option proto 'wireguard'
list addresses 'fd::/48'
and having, say, a LAN interface such as
config interface 'lan'
option proto 'static'
Hi,
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
> On Behalf Of Tomasz Maciej Nowak
> Sent: Mittwoch, 25. November 2020 17:34
> To: openwrt-devel@lists.openwrt.org
> Subject: [PATCH 7/8] tegra: sysupgrade: use get_image_dd wrapper
>
> This fu
When a proto registers a prefix with an address which has bits outside the
netmask set this confuses the prefix-assignment code further down the line.
For example if we have an interface with
option ip6prefix fdff:::::1/48
and a couple with
option ip6assign 64
then all thes
Hi,
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
> On Behalf Of Tomasz Maciej Nowak
> Sent: Mittwoch, 25. November 2020 17:34
> To: openwrt-devel@lists.openwrt.org
> Subject: [PATCH 6/8] tegra: sysupgrade: use v function for writing logs
>
>
Hi,
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
> On Behalf Of Tomasz Maciej Nowak
> Sent: Mittwoch, 25. November 2020 17:34
> To: openwrt-devel@lists.openwrt.org
> Subject: [PATCH 2/8] mvebu: sysupgrade: use v function for writing logs
>
>
With board revision 1.3, SolidRun moved the power LED to the middle of
the board. In old place of power LED a GPIO controllable heartbeat LED
was added. This commit touches only Single Shot variant, because all
have revision 1.3. Some boards could be placed in an enclosure, therefore
the LED0 is en
Drop our local sstrip copy and use the current ELFKickers upstream version.
Patch the original makefile in order to avoid building elftoc, since it fails
with musl's elf.h. This is fine, since we only need sstrip anyway.
Finally, add the possibility to pass additional arguments to sstrip and pass
Signed-off-by: Tomasz Maciej Nowak
---
target/linux/mvebu/base-files/lib/upgrade/sdcard.sh | 12 ++--
.../mvebu/cortexa9/base-files/lib/upgrade/linksys.sh | 2 +-
2 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/target/linux/mvebu/base-files/lib/upgrade/sdcard.sh
b/target
This function eliminates false-positive erros emited by dd.
Signed-off-by: Tomasz Maciej Nowak
---
target/linux/mvebu/base-files/lib/upgrade/sdcard.sh | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/target/linux/mvebu/base-files/lib/upgrade/sdcard.sh
b/target/li
Recently (a47279154e08..c02096361c67) there have been changes to
sysupgrade, baeutifying its output. Mimic the changes done in x86 target
to get consistent output across targets. The same could be probably done
in others, but I don't have devices to test these changes.
Tomasz Maciej Nowak (8):
m
This will explain what is actually occuring on dd invocations.
Signed-off-by: Tomasz Maciej Nowak
---
target/linux/tegra/base-files/lib/upgrade/platform.sh | 7 +++
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/target/linux/tegra/base-files/lib/upgrade/platform.sh
b/target/l
This function eliminates false-positive erros emited by dd. Also remove
check for number of arguments, as that's not needed anymore.
Signed-off-by: Tomasz Maciej Nowak
---
.../linux/tegra/base-files/lib/upgrade/platform.sh | 14 ++
1 file changed, 6 insertions(+), 8 deletions(-)
dif
This will explain what is actually occuring on dd invocations.
Signed-off-by: Tomasz Maciej Nowak
---
target/linux/mvebu/base-files/lib/upgrade/sdcard.sh | 7 +++
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/target/linux/mvebu/base-files/lib/upgrade/sdcard.sh
b/target/linux
This is already done by get_partitions.
Signed-off-by: Tomasz Maciej Nowak
---
.../linux/tegra/base-files/lib/upgrade/platform.sh | 13 -
1 file changed, 13 deletions(-)
diff --git a/target/linux/tegra/base-files/lib/upgrade/platform.sh
b/target/linux/tegra/base-files/lib/upgrade/
This is already done by get_partitions.
Signed-off-by: Tomasz Maciej Nowak
---
target/linux/mvebu/base-files/lib/upgrade/sdcard.sh | 12
1 file changed, 12 deletions(-)
diff --git a/target/linux/mvebu/base-files/lib/upgrade/sdcard.sh
b/target/linux/mvebu/base-files/lib/upgrade/sdc
Signed-off-by: Tomasz Maciej Nowak
---
.../linux/tegra/base-files/lib/upgrade/platform.sh | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/target/linux/tegra/base-files/lib/upgrade/platform.sh
b/target/linux/tegra/base-files/lib/upgrade/platform.sh
index 05b48cd
This fixes error when host GCC >= 10.
/usr/bin/ld: scripts/dtc/dtc-parser.tab.o:(.bss+0x10): multiple definition of
`yylloc'; scripts/dtc/dtc-lexer.lex.o:(.bss+0x0): first defined here
collect2: error: ld returned 1 exit status
Signed-off-by: Tomasz Maciej Nowak
---
package/boot/uboot-tegra/Ma
'bootz' expects gziped kernel image anyway, so hard-code it to zImage,
and remove root path from 'load' commands, by default the files are
searched in root directory.
This will make the bootscript static, so the command which modified it
when image was created can now be removed.
Signed-off-by: T
Don't hard-code the PTUUID, use U-Boot commands to determine it, as some
partitioning tools could rewrite PTUUID when modifying partitions.
Signed-off-by: Tomasz Maciej Nowak
---
target/linux/tegra/image/Makefile | 5 +
target/linux/tegra/image/generic-bootscript | 4 +++-
2 files
Hi,
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
> On Behalf Of Bjørn Mork
> Sent: Mittwoch, 25. November 2020 12:45
> To: openwrt-devel@lists.openwrt.org
> Cc: Bjørn Mork
> Subject: [PATCH 0/8] kernel: mtdsplit_uimage: use device tree proper
Hi.
W dniu 24.11.2020 o 15:42, Adrian Schmutzler pisze:
> Hi,
>
>> -Original Message-
>> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
>> On Behalf Of Tomasz Maciej Nowak
>> Sent: Freitag, 20. November 2020 19:47
>> To: openwrt-devel@lists.openwrt.org
>> Subject: [P
Bjørn Mork [2020-11-25 12:45:03]:
Hi,
> Still not sure that was a good idea.
140 insertions(+), 377 deletions(-)
nice numbers, I like it, thanks.
Cheers,
Petr
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.or
Baptiste Jonglez [2020-11-25 12:41:18]:
Hi,
> For the imagebuilder, it increases the *total* build time (not just
> download time!) by +50%:
>
> http://lists.openwrt.org/pipermail/openwrt-devel/2020-September/031406.html
I don't consider 10 seconds dramatic increase of time, but it of course
d
Convert users of the "fonfxc" and "sge" parsers to the generic
"denx,uimage", using device specific "extralen" DT properties.
Signed-off-by: Bjørn Mork
---
.../drivers/mtd/mtdsplit/mtdsplit_uimage.c| 93 ++-
.../linux/ramips/dts/mt7620a_fon_fon2601.dts | 3 +-
.../ramips/dt
The "edimax,uimage" format places the uimage header at an offset
and has an additional magic where the header normally would be.
Extend the generic parser with two device tree properties and
use this instead.
Signed-off-by: Bjørn Mork
---
.../drivers/mtd/mtdsplit/mtdsplit_uimage.c| 159 +
The "netgear,uimage" parser can be replaced by the generic
parser using device specific ih-magic and ih-type properties.
Device tree properties for the following devices have not
been set, as they have been dropped from OpenWrt with the
removal of the ar71xx target:
FW_MAGIC_WNR2000V1 0x3230
Many devices use uimages with non-standard magic values. Let
device tree override the default magic.
Signed-off-by: Bjørn Mork
---
.../drivers/mtd/mtdsplit/mtdsplit_uimage.c| 40 ++-
1 file changed, 22 insertions(+), 18 deletions(-)
diff --git a/target/linux/generic/files/dr
This ended up a bit more invasive than I imagined, but here goes..
I wanted to add a couple of new rtl83xx devices. They both use
standard uimages, but with device specific magic values. Like
most devices in this target, it seems.
The easy route would be to just add another magic to one of the
The only difference between the "openwrt,okli" and the generic
parser is the magic. Set this in device tree for all affected
devices and remove the "openwrt,okli" parser.
Signed-off-by: Bjørn Mork
---
.../ath79/dts/ar7240_engenius_enh202-v1.dts | 3 +-
.../dts/ar9341_engenius_ens202ext-v1.d
Convert users to the generic "denx,uimage" using device specific
"ih-magic" DT properties, and remove "allnet,uimage".
Signed-off-by: Bjørn Mork
---
.../drivers/mtd/mtdsplit/mtdsplit_uimage.c| 49 ---
.../dts/rtl8382_allnet_all-sg8208m.dts| 3 +-
2 files changed, 2 i
Some devices use uimage headers with a non-default ih_type. Add
support for overriding this in device tree.
Signed-off-by: Bjørn Mork
---
.../drivers/mtd/mtdsplit/mtdsplit_uimage.c| 24 +++
1 file changed, 14 insertions(+), 10 deletions(-)
diff --git a/target/linux/generic/f
An "extralen" property in device tree can replace two device
specific parsers.
Signed-off-by: Bjørn Mork
---
.../files/drivers/mtd/mtdsplit/mtdsplit_uimage.c | 14 --
1 file changed, 12 insertions(+), 2 deletions(-)
diff --git a/target/linux/generic/files/drivers/mtd/mtdsplit/mtds
Hi,
On 25-11-20, Petr Štetiar wrote:
> Paul Spooren [2020-11-24 22:29:00]:
>
> Hi,
>
> > Using HTTPS for opkg dramatically slows down download of packages and reload
> > of indexes.
>
> do you've such dramatic numbers handy?
For the imagebuilder, it increases the *total* build time (not just
Paul Spooren [2020-11-24 22:29:00]:
Hi,
> Using HTTPS for opkg dramatically slows down download of packages and reload
> of indexes.
do you've such dramatic numbers handy?
> This was mostly introduced to secure the ImageBuilder. However with the
> usign signature checking ability added to Imag
Paul Spooren [2020-11-24 22:27:58]:
> Trivial cosmetic cleanup. This also helps for script that parse for
> options in Config files.
>
> Signed-off-by: Paul Spooren
> ---
> config/Config-build.in | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/config/Config-build.
Move features common to all subtargets to the parent target, where applicable.
Signed-off-by: Rui Salvaterra
---
After cleaning up ath79, I noticed other targets had the same issue. I think I
cleaned up all the remaning ones, but I may have missed something.
target/linux/apm821xx/Makefile
This reverts commit c1875d1ebbd4c4bad45d7c93cf012317f8ce1810.
Using HTTPS for opkg dramatically slows down download of packages and
reload of indexes. This was mostly introduced to secure the
ImageBuilder. However with the usign signature checking ability added to
ImageBuilders, this becomes obsol
Trivial cosmetic cleanup. This also helps for script that parse for
options in Config files.
Signed-off-by: Paul Spooren
---
config/Config-build.in | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/config/Config-build.in b/config/Config-build.in
index 4148180cd5..bf0ea7d828
58 matches
Mail list logo