m...@adrianschmutzler.de [2020-01-21 00:26:41]:
Hi,
> Note that I changed somewhat between 100 and 150 devices when reorganizing
> board names in ramips between master and 19.07.
and I thank you for that, it names makes more sense now.
> So, unless you have a specific reason to deal with this
Ok, I think I've got it:
The "sk_wmem_alloc" is decremented in sock_wfree() which is called
by kfree_skb.
But in ptm_hard_start_xmit() of the ifxmips_ptm_vdsl.c, the skb
only gets freed immediately, if the skb_headroom is to small or
the skb is cloned. In this case the skb is copied to a new one
Hi Adrian, David, Chuanhong,
On 07.09.2019 12:15, m...@adrianschmutzler.de wrote:
Hi,
> However, this will obviously swap eth0/eth1 on EVERY upgrade, not just
when coming from ar71xx.
> So, does anyone have an idea how to limit this to run only when updated
from ar71xx?
I was thinking about t
Hi Petr,
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
> On Behalf Of Petr Štetiar
> Sent: Montag, 20. Januar 2020 20:40
> To: openwrt-devel@lists.openwrt.org
> Cc: Petr Štetiar
> Subject: [OpenWrt-Devel] [PATCH 19.07] ramips: mt7621: ubnt-erx
ondrej.vot...@cvut.cz [2020-01-20 10:53:05]:
Ahoj,
this comment(if it's really needed and I doubt that) should go into commit
description, self-explaining code is prefered, everybody knows how to use man
pages already or knows how to use `git blame`.
> + /*
> + According to man waitpid(
Adapt Netgear WNDR3700v2 device identification string to ath79 naming
scheme by changing from 'wndr3700v2' to 'wndr3700-v2' (affects config,
makefile, init scripts and device tree definition).
Signed-off-by: Michal Cieslakiewicz
---
...etgear_wndr3700v2.dts => ar7161_netgear_wndr3700-v2.dts} | 4
Add Netgear WNDR3700v2 to the list of supported boards.
Signed-off-by: Michal Cieslakiewicz
---
package/boot/uboot-envtools/files/ath79 | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/package/boot/uboot-envtools/files/ath79
b/package/boot/uboot-envtools/files/ath79
index a
This patch changes device string to 'wndr3700-v2' (adds dash before
variant) making it compatible with naming convention for ath79 target.
Then board, under its new name, is added to uboot-envtools.
Changes v1->v2:
* SUPPORTED_DEVICES fixed to allow sysupgrading from older ath79 builds
Patch lis
Kernel partition increase to 4 MiBs for Netgear WNDR3700v4 and WNDR4300
routers breaks sysupgrade image compatibility with ar71xx builds.
Therefore, SUPPORTED_DEVICES variable has to be removed for both devices
from target makefile.
Signed-off-by: Michal Cieslakiewicz
---
target/linux/ath79/imag
dnsmasq sometimes does not listen for DHCP at bootup on lan (see bug FS#1765).
This occurs because netifd can incorrectly indicate carrier down on an
interface through devstatus after issuing a carrier up hotplug event.
This patch ignores carrier status for bridge interfaces, as this does not
ref
Hello,
I have checked v2 of the patch, and can confirm that it fixes the out
of bounds reads.
I have also fuzzed blobmsg_parse and blobmsg_parse_array for an hour
with LibFuzzer, to check that there are no more similar shallow issues
and no new crashes were found.
Thank you for the help!
Regard
>
> What is the motivation for this?
>
> The router was originally marketed as "WNDR3700v2" and that is both
> in the packaging and also in the printed label in the router itself.
> The "v2" is not a typical separate version number like many 6.1, 3.21
> type of revisions next to the serial number
Currently it's not possible to downgrade from master:
Device ubiquiti,edgerouterx not supported by this image
Supported devices: ubnt-erx
So fix it by adding a DTS based device name from master into
SUPPORTED_DEVICES list.
Signed-off-by: Petr Štetiar
---
target/linux/ramips/image/mt7621.mk |
On Sun, 19 Jan 2020 16:42:12 +0100
wrote:
> Hi,
>
> > - SUPPORTED_DEVICES += wndr3700
> > + SUPPORTED_DEVICES += wndr3700 wndr3700v2
>
> That would have to be
>
> SUPPORTED_DEVICES += wndr3700 netgear,wndr3700v2
>
> Best
>
> Adrian
Thanks! I'll issue v2 soon with that one fixed.
Best
Op maandag 20 januari 2020 om 20:00 schreef Adrian Schmutzler
:
Hi,
-Original Message-
From: openwrt-devel
[mailto:openwrt-devel-boun...@lists.openwrt.org] On
Behalf Of Stijn Segers
Sent: Montag, 20. Januar 2020 19:50
To: openwrt-devel@lists.openwrt.org
Subject: [OpenWrt-Dev
Hi,
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org] On
> Behalf Of Stijn Segers
> Sent: Montag, 20. Januar 2020 19:50
> To: openwrt-devel@lists.openwrt.org
> Subject: [OpenWrt-Devel] [PATCH] [19.07] ramips: add kmod-mt7615e module to
> Netgear R6
MT7615E support wasn't present in OpenWrt's mt76 version prior to 19.07
release, but it is now, so add the module to the image.
Signed-off-by: Stijn Segers
---
target/linux/ramips/image/mt7621.mk | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/target/linux/ramips/image/mt762
c888e17e06 ("hostapd: manage instances via procd instead of pidfile")
added procd support for managing hostapd and wpa_supplicant daemons
but at the same time limited wiphy names to 'phy*'.
This brings back initial behaviour (introduced in 60fb4c92b6 ("hostapd:
add ubus reload") and makes procd ma
Hi,
can you comment on/take care of
https://github.com/openwrt/openwrt/commit/4e6af8b9efcfc51e217d793239487dd8af1f410e#commitcomment-36881083
Best
Adrian
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org] On
> Behalf Of Michal Cieslakiewicz
> Sen
Fixes: 641a93f0f226 ("ath10k-firmware: update wave 1 firmware to
10.2.4-1.0-00047")
Signed-off-by: DENG Qingfang
---
package/firmware/ath10k-firmware/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/package/firmware/ath10k-firmware/Makefile
b/package/firmware/ath10k-
Hi,
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org] On
> Behalf Of Tomasz Maciej Nowak
> Sent: Montag, 20. Januar 2020 16:08
> To: Adrian Schmutzler ; openwrt-
> de...@lists.openwrt.org
> Subject: Re: [OpenWrt-Devel] [PATCH 2/2] mvebu: use SOC to
Hi Paul,
Hi Martin,
On Sun, Jan 12, 2020 at 10:13:42PM -1000, Paul Spooren wrote:
> Hi,
>
> On 1/12/20 1:05 PM, Martin Blumenstingl wrote:
> > Hi Paul,
> >
> > On Sun, Jan 12, 2020 at 10:47 PM Paul Spooren wrote:
> > > Hi all,
> > >
> > > some time ago I created a (now outdated) device overvie
W dniu 18.01.2020 o 02:21, Adrian Schmutzler pisze:
> This introduces the SOC variable to mvebu target to derive some of
> the DEVICE_DTS variables based on the SOC prefix and the device
> definition name.
>
> Since DTS names and compatible are inconsistent also in the kernel
> for this target, th
W dniu 18.01.2020 o 02:21, Adrian Schmutzler pisze:
> For the mvebu target in particular, there is a lot of files in
> base-files that are only relevant for one subtarget. Improve
> overview and reduce size per subtarget by moving/splitting
> base-files depending on the subtarget they belong to.
>
W dniu 18.01.2020 o 02:21, Adrian Schmutzler pisze:
> This moves the if conditions for choosing which image Makefiles
> are used to the parent image/Makefile. It seems more convenient
> to have "codeflow" in the parent while the subtarget-specific
> files only contain the definitions.
>
> Signed-o
The SUBDIRS variable has been removed in kernel 5.4, and was deprecated
since the beginnig of kernel git history in favour of M or KBUILD_EXTMOD.
Signed-off-by: Tomasz Maciej Nowak
---
v1 -> v2
fix commit title
package/kernel/acx-mac80211/Makefile| 2 +-
package/kernel/ath10k-ct/Makefi
The SUBDIRS variable has been removed in kernel 5.4, and was deprecated
since the beginnig of kernel git history in favour of M or KBUILD_EXTMOD.
Signed-off-by: Tomasz Maciej Nowak
---
package/kernel/acx-mac80211/Makefile| 2 +-
package/kernel/ath10k-ct/Makefile | 2 +-
package
Update:
I've found out now that the ENOBUFS is set by __ip_append_data,
because sk_wmem_alloc "overflows".
Martin
On 2020-01-20 07:09, Martin Schiller wrote:
Hi!
I have discovered the following problem:
If you have established a PPPoE session via VDSL / PTM connection incl.
VLAN tagging and
Hi all,
I looked a bit into parsing the DeviceTree files but it's a bit of a
pain. Tools like dts2yaml and dtc exists, however the output is not
really useful: A lot of auto detection prevents the parser from knowing
flash & storage sizes or number of USB ports.
Therefore I decided to create
Juraj Vijtiuk [2020-01-14 22:11:18]:
Hi,
I just sent v2 for review[2], can you check it please?
> > > @@ -191,7 +197,11 @@ int blobmsg_parse(const struct blobmsg_policy
> > > *policy, int policy_len,
> > > }
> > >
> > > __blob_for_each_attr(attr, data, len) {
> > > + if (len
From: Juraj Vijtiuk
Fix out of bounds read in blobmsg_parse and blobmsg_check_name. The
out of bounds read happens because blob_attr and blobmsg_hdr have
flexible array members, whose size is 0 in the corresponding sizeofs.
For example the __blob_for_each_attr macro checks whether rem >=
sizeof(s
From: Ondřej Votava
Adds feature to show process's exit code when
ubus service list is called.
Signed-off-by: Ondřej Votava
---
service/instance.c | 12
service/instance.h | 1 +
2 files changed, 13 insertions(+)
diff --git a/service/instance.c b/service/instance.c
index abd1f34
On 20/01/20 10:01, Petr Štetiar wrote:
Hauke Mehrtens [2020-01-19 18:17:10]:
Hi,
Does someone else other than jow know how to setup built bot for a new
branch? Is this documented somewhere?
It should be documented and at least 3 persons should be able (and willing) to
do that.
There is d
Hauke Mehrtens [2020-01-19 18:17:10]:
Hi,
> Someone has to take care of the release and this person would then
> announce that he wants to tag and build the next RC some days before so
> that people can prepare. The person can change in the release process.
Ok, fine with me, it should be writte
34 matches
Mail list logo