Re: [Openvpn-devel] [PATCH 2/7] Use functions to access key_state instead direct member access

2021-04-27 Thread Antonio Quartulli
Hi, On 27/04/2021 12:21, Arne Schwabe wrote: > >> >>> @@ -369,7 +369,7 @@ bool >>> send_auth_pending_messages(struct tls_multi *tls_multi, const char *extra, >>> unsigned int timeout) >>> { >>> -struct key_state *ks = &tls_multi->session[TM_ACTIVE].key[KS_PRIMA

Re: [Openvpn-devel] [openvpn-devel] Feature request - Include daemon_pid in --tls-crypt-v2-verify env - V2

2021-04-27 Thread tincantech via Openvpn-devel
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Hi, no complaints yet ? Sent with ProtonMail Secure Email. ProtonMail, as crap as googlemail. ‐‐‐ Original Message ‐‐‐ On Friday, 23 April 2021 22:16, tincantech via Openvpn-devel wrote: > Hi, > > I am requesting that daemon_pid be adde

[Openvpn-devel] [PATCH v5] Add documentation on EVENT_READ/EVENT_WRITE constants

2021-04-27 Thread Antonio Quartulli
From: Antonio Quartulli Changes from v4: - get rid of the overly complex EVENT_SHIFT() macro Changes from v3: - re-introduce READ/WRITE_SHIFT because they are different from EVENT_READ/WRITE - define also EVENT_READ/WRITE using READ/WRITE_SHIFT Changes from v2: - moved event definitions to even

Re: [Openvpn-devel] [PATCH 4/4] Implement deferred auth for scripts

2021-04-27 Thread Gert Doering
Hi, On Thu, Apr 08, 2021 at 04:02:29PM +0200, Arne Schwabe wrote: > This patch also refactors the if condition that checks the result of > the authentication since that has become quite unreadable. It renames > s1/s2 and extracts some parts of the condition into individual variables > to make the

[Openvpn-devel] [PATCH applied] Re: rewrite parse_hash_fingerprint()

2021-04-27 Thread Gert Doering
Patch has been applied to the master branch. .. and I still have no test setup for this... "next FOOM!"... commit 925f0180318033f9ea7885b40b4b8200b35abbca (master) Author: Gert Doering Date: Tue Apr 27 13:03:00 2021 +0200 rewrite parse_hash_fingerprint() Signed-off-by: Gert Doering

Re: [Openvpn-devel] [PATCH v2] rewrite parse_hash_fingerprint()

2021-04-27 Thread Antonio Quartulli
Hi, On 27/04/2021 13:03, Gert Doering wrote: > The existing code was doing far too much work for too little > gain - copying the string segment for scanf(), checking extra > for spaces, making the result quite unreadable. > > Verify each segment with (short-circuited) isxdigit() checks, > then fe

[Openvpn-devel] [PATCH applied] Re: Change options->data_channel_use_ekm to flags

2021-04-27 Thread Gert Doering
Lightly stared at code and ran client-side tests that actually used EKM... which meant "upgrading the server the t_client tests talk to" (and all passes). Your patch has been applied to the master branch. commit 9c625f4a6633de05d030884cac779cb41a5060e1 Author: Arne Schwabe Date: Thu Apr 8 16:02

[Openvpn-devel] [PATCH applied] Re: Allow all GCM ciphers

2021-04-27 Thread Gert Doering
Looks good to me, and passes regular client side tests :-) - I have not actually tested the ARIA ciphers, but "they now show up in --show-cipher mode". Seems I'll need to add this to one of the server test cases and see what explodes... WolfSSL folks, please fix the incompatibility Antonio found

[Openvpn-devel] [PATCH v2] rewrite parse_hash_fingerprint()

2021-04-27 Thread Gert Doering
The existing code was doing far too much work for too little gain - copying the string segment for scanf(), checking extra for spaces, making the result quite unreadable. Verify each segment with (short-circuited) isxdigit() checks, then feed directly to scanf(), which will stop parsing on ':' or

Re: [Openvpn-devel] [PATCH] rewrite parse_hash_fingerprint()

2021-04-27 Thread Gert Doering
Hi, On Mon, Apr 26, 2021 at 09:58:38PM +0200, Antonio Quartulli wrote: > > Rewrite error message to differenciate "hash too short" (including > differenciate -> differenTiate fixed. > > -int i; > > +int i=0; > > spaces around the '=' fixed. > > -if (strlen(cp) < 2) > > +

[Openvpn-devel] [PATCH applied] Re: Move tls_select_primary_key into its own function

2021-04-27 Thread Gert Doering
As Antonio says, "just moving around code" (and cleaning up a messy if() statement - so besides this, it's really trivial to see in diff) Your patch has been applied to the master branch. commit 26e40c48b89478cb53d6c2733b346e6dbdc7480b Author: Arne Schwabe Date: Thu Apr 22 17:17:18 2021 +0200

Re: [Openvpn-devel] [PATCH 2/7] Use functions to access key_state instead direct member access

2021-04-27 Thread Arne Schwabe
> >> @@ -369,7 +369,7 @@ bool >> send_auth_pending_messages(struct tls_multi *tls_multi, const char *extra, >> unsigned int timeout) >> { >> -struct key_state *ks = &tls_multi->session[TM_ACTIVE].key[KS_PRIMARY]; >> +struct key_state *ks = get_key_scan(tls_

Re: [Openvpn-devel] [PATCH 2/7] Use functions to access key_state instead direct member access

2021-04-27 Thread Antonio Quartulli
Hi, On 22/04/2021 17:17, Arne Schwabe wrote: > This uses get_key_scan and get_primary key instead the directly > accessing the members of the struct to improve readiability of > the code. > > Signed-off-by: Arne Schwabe > --- > src/openvpn/multi.c | 3 +-- > src/openvpn/push.c | 9

Re: [Openvpn-devel] [PATCH 1/7] Move tls_select_primary_key into its own function

2021-04-27 Thread Antonio Quartulli
Hi, On 22/04/2021 17:17, Arne Schwabe wrote: > tls_pre_encrypt mainly performs the task of selecting the primary > encryption key but also performs other minor tasks. To allow only > querying for the key that should be used for encryption extract this > part of the function into its own function.