[Openocd-development] [PATCH 2/2] Add directory/file completion with tab.

2010-01-02 Thread Dean Glazeski
Lists available completions when a user presses tab from a telnet client. If there is only one completion, it automatically does it. This supports commands, sub-commands, files, and directories. This also introduces a change to the command helpers that allows external files to check if a command

[Openocd-development] [PATCH 0/2] Telnet user experience update

2010-01-02 Thread Dean Glazeski
Hey all, I got tired of not having file and command completion, so I took a whack at implementing it. I was also missing the ability to use my home and end keys. At any rate, this patch series introduces this capability. I'm not sure on the memory leaks (since I'm doing tons of mallocs), but v

[Openocd-development] [PATCH 1/2] Add home and end support to telnet.

2010-01-02 Thread Dean Glazeski
Adds support for the control sequences for home and end on a keyboard to the telnet server interface. --- src/server/telnet_server.c | 20 +++- 1 files changed, 19 insertions(+), 1 deletions(-) diff --git a/src/server/telnet_server.c b/src/server/telnet_server.c index 92e7480..f

[Openocd-development] [patch 5/5] ARM: ADIv5 JTAG symbol cleanup

2010-01-02 Thread David Brownell
Rename DAP_IR_* as JTAG_DP_* since those symbols are specifically for JTAG-DP (or SWJ-DP in JTAG mode), and won't work with SWD. Define the JTAG ABORT and IDCODE instructions for completeness; add a comment about where to (someday) use ABORT. Fix messaging which assumes everything is an SWJ-DP; sa

[Openocd-development] [patch 4/5] ARM: dap info fix + tweaks

2010-01-02 Thread David Brownell
Fix: don't print the BASE address except if it's a MEM-AP; that's an unlikely error, but there's no point getting it wrong. Tweaks: comments, capitalization. --- src/target/arm_adi_v5.c | 27 +-- 1 file changed, 17 insertions(+), 10 deletions(-) --- a/src/target/arm_adi_

[Openocd-development] [patch 3/5] ARM: ADIv5 export cleanup

2010-01-02 Thread David Brownell
Make some private functions "static". Remove their public declarations, and what is now an obviously unused function. Shrinks this object's size (about 5% on x86_64) while making the code's scope easier to understand. Shrink the affected lines. --- src/target/arm_adi_v5.c | 46

[Openocd-development] [patch 1/5] Cortex-M3: minor breakpoint cleanup

2010-01-02 Thread David Brownell
Shrink some lines, add some comments, simplify some tests. During debug startup, log the core revision level too. --- src/target/cortex_m3.c | 37 + 1 file changed, 25 insertions(+), 12 deletions(-) --- a/src/target/cortex_m3.c +++ b/src/target/cortex_m3.c @@

[Openocd-development] [patch 2/5] ARM: ADIv5 symbol docs

2010-01-02 Thread David Brownell
Instead of magic numbers, use their AP_REG_* constants. Rename the ROM address symbol as BASE to match ARM's documentation. Comment various other symbols in the header; add some missing ones. Remove an unused struct. Add some doxygen for the DAP structure and DAP initialization. --- src/target/

[Openocd-development] [patch 0/5] various bits of ARM code cleanup

2010-01-02 Thread David Brownell
These patches don't fix bugs, but we're not yet at the point where only fixes for serious bugs get merged ... so I expect to merge these, unless a significant objection crops up soon. - Cortex-M3, minor breakpoint cleanup. - ARM ADIv5 symbol cleanup, notably use AP_REG_* symbols instead of m

[Openocd-development] [PATCH] streamline and document helptext mode displays

2010-01-02 Thread David Brownell
Most commands are usable only at runtime; so don't bother saying that, it's noise. Moreover, tokens like EXEC are cryptic. Be more clear: highlight only the commands which may (also) be used during the config stage, thus matching the docs more closely. There are - Configuration commands (per doc

Re: [Openocd-development] [PATCH] Added ST FlashLINK interface config file.

2010-01-02 Thread David Brownell
On Thursday 31 December 2009, Antonio Borneo wrote: > in attachment patch to add interface config file for ST FlashLINK JTAG > adapter. > The relevant code is already in OpenOCD. Merged. At some point, someone should audit all the configs for various JTAG adapters against the code, and make sure

Re: [Openocd-development] Add current command to the command invocation structure

2010-01-02 Thread David Brownell
On Friday 01 January 2010, Dean Glazeski wrote: > This patch makes it so the command invocation structure has the current > command set before passing the structure on. merged... ___ Openocd-development mailing list Openocd-development@lists.berlios.de

Re: [Openocd-development] Extra and invalid error messages

2010-01-02 Thread David Brownell
On Friday 01 January 2010, Dean Glazeski wrote: > Yep, it's a memory leak.  I suppose I was a bit hasty on posting it.  Here's > a new version that also checks the success or failure of the alloc_printf > functions.  I'm trying to think of a good way to determine if no matches are > found for the g