Re: [Openocd-development] Error: The 'init' command must be used before 'init'.

2009-12-05 Thread David Brownell
On Friday 04 December 2009, Zach Welch wrote: > On Fri, 2009-12-04 at 02:31 -0800, David Brownell wrote: > > On Friday 04 December 2009, Øyvind Harboe wrote: > > > That's better. > > > > It's an ugly hack that's papering over some real bug. > > > > Why was the JTAG initialization bypassed? The s

Re: [Openocd-development] [PATCH 1/4] improve command_done() API and docs

2009-12-05 Thread Zach Welch
On Sat, 2009-12-05 at 13:26 -0800, David Brownell wrote: > On Sunday 29 November 2009, Zachary T Welch wrote: > > Note: this audit revealed some potential bugs with the command context > > implementation. There was a reason that commands were added at the > > end of the list. Shallow copying of c

Re: [Openocd-development] svn code review part 2

2009-12-05 Thread David Brownell
On Thursday 03 September 2009, David Brownell wrote: > Anyone feeling like addressing the rest of these? > > It's code cleanup, by and large... except that "test > floats for equality" bug. The answer was evidently "no". :( I just merged the following patch. == From: David

Re: [Openocd-development] [PATCH 1/4] improve command_done() API and docs

2009-12-05 Thread David Brownell
On Sunday 29 November 2009, Zachary T Welch wrote: > Note: this audit revealed some potential bugs with the command context > implementation.  There was a reason that commands were added at the > end of the list.  Shallow copying of command_context means that > the list is shared between them. Whe

Re: [Openocd-development] [PATCH 4/4] - add dsp563xx support

2009-12-05 Thread David Brownell
How similar are the OnCE implementations for various FreeScale chips? I get the impression that the answer is "not very". But if that's not true, then I wonder how much OnCE stuff could be shared between drivers for different chips. Once a few more OnCE-equipped chips merge into the tree, that c

Re: [Openocd-development] [PATCH 1/4] - add 29LV400BC flash device

2009-12-05 Thread David Brownell
On Saturday 05 December 2009, Mathias K. wrote: >  src/flash/non_cfi.c |   20 >  1 files changed, 20 insertions(+), 0 deletions(-) committed this, less the needless blank lines. ___ Openocd-development mailing list Openocd-developme

Re: [Openocd-development] [PATCH 2/4] - add dsp563xx support

2009-12-05 Thread David Brownell
On Saturday 05 December 2009, Mathias K. wrote: >  src/target/Makefile.am |    8 ++-- >  1 files changed, 6 insertions(+), 2 deletions(-) This is out-of-order ... commit it, and the tree won't build any more until #4 merges! Ditto #3. Best to just have one patch adding this new CPU's driver

Re: [Openocd-development] [PATCH 4/4] - add dsp563xx support

2009-12-05 Thread David Brownell
On Saturday 05 December 2009, Mathias K. wrote: > + *   Copyright (C) 2009 by Mathias Kuester                                 * > + *   mkd...@users.sourceforge.net                                          * If you want all the attributions to be "Mathias Kuester", stick a "From: Mathias Kuester "

[Openocd-development] [PATCH 3/4] - add dsp563xx support

2009-12-05 Thread Mathias K.
--- src/target/target.c |2 ++ 1 files changed, 2 insertions(+), 0 deletions(-) diff --git a/src/target/target.c b/src/target/target.c index 88931b5..3fafbb1 100644 --- a/src/target/target.c +++ b/src/target/target.c @@ -63,6 +63,7 @@ extern struct target_type cortexa8_target; extern struct

[Openocd-development] [PATCH 2/4] - add dsp563xx support

2009-12-05 Thread Mathias K.
--- src/target/Makefile.am |8 ++-- 1 files changed, 6 insertions(+), 2 deletions(-) diff --git a/src/target/Makefile.am b/src/target/Makefile.am index d00b0e4..a07de17 100644 --- a/src/target/Makefile.am +++ b/src/target/Makefile.am @@ -34,8 +34,10 @@ libtarget_la_SOURCES = \ $(A

[Openocd-development] [PATCH 1/4] - add 29LV400BC flash device

2009-12-05 Thread Mathias K.
--- src/flash/non_cfi.c | 20 1 files changed, 20 insertions(+), 0 deletions(-) diff --git a/src/flash/non_cfi.c b/src/flash/non_cfi.c index f98b108..5169c53 100644 --- a/src/flash/non_cfi.c +++ b/src/flash/non_cfi.c @@ -280,6 +280,26 @@ static struct non_cfi non_cfi_flashe

[Openocd-development] [PATCH 4/4] - add dsp563xx support

2009-12-05 Thread Mathias K.
This patch adds Freescale DSP563xx and DSP563xx-ONCE (one chip emulation) support. --- src/target/dsp563xx.c | 875 src/target/dsp563xx.h | 73 src/target/dsp563xx_once.c | 116 ++ src/target/dsp563xx_once.h | 71 4 files

[Openocd-development] [RFC] common flash work (generic objects)

2009-12-05 Thread Zach Welch
Hi all, The master branch on my repo.or.cz mirror has a couple of patches that begin to unify the flash tree, which will eventually lead to the elimination of a bit more duplicated code. It's using the container_of macro first used by the target module. The first patch introduces the basic scaff

Re: [Openocd-development] [PATCH] minidriver: allow jtag_add_dr_out() to be inlined into inner loops

2009-12-05 Thread Zach Welch
On Sat, 2009-12-05 at 11:14 +0100, Øyvind Harboe wrote: > On Sat, Dec 5, 2009 at 8:45 AM, Zach Welch wrote: > > On Sat, 2009-12-05 at 08:35 +0100, Øyvind Harboe wrote: > >> The approach seems to work fine, but requires that some other > >> issues are sorted out first with include dirs. > >> > >> >

Re: [Openocd-development] [PATCH] minidriver: allow jtag_add_dr_out() to be inlined into inner loops

2009-12-05 Thread Øyvind Harboe
On Sat, Dec 5, 2009 at 8:45 AM, Zach Welch wrote: > On Sat, 2009-12-05 at 08:35 +0100, Øyvind Harboe wrote: >> The approach seems to work fine, but requires that some other >> issues are sorted out first with include dirs. >> >> >From error message above, there are two "strange" -I additions: >> >

Re: [Openocd-development] RC1 in a couple weeks ...

2009-12-05 Thread Øyvind Harboe
On Sat, Dec 5, 2009 at 9:48 AM, David Brownell wrote: > On Friday 04 December 2009, Ųyvind Harboe wrote: >> How about shooting for a release candidate in beginning of >> january? > > I'm sure there will be another one by then.  :) > > >> There are some general "factory shutdowns" coming up, were >

Re: [Openocd-development] libopenocd... again

2009-12-05 Thread Øyvind Harboe
On Sat, Dec 5, 2009 at 8:43 AM, Zach Welch wrote: > On Fri, 2009-12-04 at 23:31 -0800, David Brownell wrote: >> On Tuesday 01 December 2009, Zach Welch wrote: >> > We should approach this problem as though we intend to eventually >> > decouple Jim from the core functionality and switch to a differ

Re: [Openocd-development] libopenocd... again

2009-12-05 Thread Zach Welch
On Sat, 2009-12-05 at 00:51 -0800, David Brownell wrote: > On Friday 04 December 2009, Zach Welch wrote: > > > > > That's a useful statement of the extreme, but note that it's in > > > two parts: decouple ... and switch. > > > > > > Decoupling is one of those things that's not fully understandab

Re: [Openocd-development] libopenocd... again

2009-12-05 Thread David Brownell
On Friday 04 December 2009, Zach Welch wrote: > > > That's a useful statement of the extreme, but note that it's in > > two parts:  decouple ... and switch. > > > > Decoupling is one of those things that's not fully understandable > > except in the context of concrete options.  Without seeing a f

Re: [Openocd-development] RC1 in a couple weeks ...

2009-12-05 Thread David Brownell
On Friday 04 December 2009, Øyvind Harboe wrote: > How about shooting for a release candidate in beginning of > january? I'm sure there will be another one by then. :) > There are some general "factory shutdowns" coming up, were > we couldn't really expect any serious testing; a good time > to

Re: [Openocd-development] [PATCH] minidriver: allow jtag_add_dr_out() to be inlined into inner loops

2009-12-05 Thread Zach Welch
On Sat, 2009-12-05 at 08:25 +0100, Øyvind Harboe wrote: > This worked pretty well, but there are lots of (to me) inexplicable > -I's on the command line still and none of them point to the right > place in the build tree. I'm testing minidummy build != src dir. > > oharboe/fixminidriver2 > > ../o