ping
On 10/30/2015 03:50 PM, Chen Qi wrote:
Use immediate expansion for the assignment to avoid other classes modifying
variables like HOST_ARCH which changes the result. This happens in the
meta-environment recipe. It inherits cross-canadian which changes HOST_ARCH
from TARGET_ARCH to SDK_ARCH,
For now, `systemctl stop dhcpd' cannot stop dhcpd correctly, the SIGTERM
signal would time out, causing a SIGKILL signal sent to dhcpd.
Patch site.h to enable gentle shutdown to so that dhcpd could be stopped
by SIGTERM.
Signed-off-by: Chen Qi
---
.../dhcp/0001-site.h-enable-gentle-shutdown.pat
Changes since V1:
Rebased against latest master.
The following changes since commit 300f858ba07c938427ccd05a3d7220027a03d461:
local.conf.sample: Disable prelink by default (2016-03-13 22:08:55 +)
are available in the git repository at:
git://git.openembedded.org/openembedded-core-contri
On 03/14/2016 02:51 PM, Robert Yang wrote:
The following changes since commit 1a51bb69b7600cbe6da7928d46e0ea058a14ccde:
base: check for existing prefix when expanding names in PACKAGECONFIG
(2016-03-11 23:15:01 +)
are available in the git repository at:
git://git.openembedded.org/
Sorry for the late response, I put it to jethro-next just now.
git://git.openembedded.org/openembedded-core-contrib rbt/jethro-next
// Robert
On 03/14/2016 03:38 PM, Mittal, AnujX wrote:
Hi Robert,
Subject: [meta-intel][master][jethro][PATCH 1/1] tune-corei7.inc: Fix
PACKAGE_EXTRA_ARCHS f
Yes, I am nagging.
On the Friday after ELC in San Diego (Yocto Project Dev Day is
Thursday), we will have a developer meeting near the conference venue
Jefro has arranged for a room at the Marriot next to the conference
venue, sponsored by the Yocto Project.
OpenEmbedded would like to thank the Y
The eudev recipe included the hwdb.d directory by default,
which ended up making the eudev package a lot heavier than
the old udev, this patch splits the eudev-hwdb package to
avoid using unecessary space when required
Signed-off-by: Alejandro Hernandez
---
meta/recipes-core/udev/eudev_3.1.5.bb
The installation on ncurses calls "make install.libs install.includes"
Turns out, install.libs implicitly installs header files as well,
so calling install.includes is redundant.
The description in INSTALL explicitly says:
...
'make install.includes' installs the headers.
'make install.libs'
As "install.libs" also installs header files, it is
redundant to also call "install.includes".
In fact, doing so can lead to a race, as both targets could
try to install the header files at the same time if running
parallel make. Obviously, with only calling "install.libs",
there is no race with "i
On 14 March 2016 at 21:23, Otavio Salvador wrote:
> Do you mind to explain to me why?
>
> I would like to try to see your view on this.
>
libsdl is a good example to be honest. Why does your choice of target
distro features decide what libraries the native sdl should use?
Respecting them means
On Mon, Mar 14, 2016 at 6:21 PM, Christopher Larson wrote:
> On Mon, Mar 14, 2016 at 2:04 PM Otavio Salvador
> wrote:
>>
>> On Mon, Mar 14, 2016 at 6:02 PM, Burton, Ross
>> wrote:
>> >
>> > On 14 March 2016 at 20:55, Otavio Salvador
>> > wrote:
>> >>
>> >> I know it however up to now we could k
On Mon, Mar 14, 2016 at 2:04 PM Otavio Salvador <
otavio.salva...@ossystems.com.br> wrote:
> On Mon, Mar 14, 2016 at 6:02 PM, Burton, Ross
> wrote:
> >
> > On 14 March 2016 at 20:55, Otavio Salvador
> > wrote:
> >>
> >> I know it however up to now we could know that native and nativesdk
> >> mig
On Mon, Mar 14, 2016 at 6:02 PM, Burton, Ross wrote:
>
> On 14 March 2016 at 20:55, Otavio Salvador
> wrote:
>>
>> I know it however up to now we could know that native and nativesdk
>> might respect DISTRO_FEATURES and be in sync. Now this is not truth
>> anymore.
>
> It's been like this in mast
On 14 March 2016 at 20:55, Otavio Salvador wrote:
> I know it however up to now we could know that native and nativesdk
> might respect DISTRO_FEATURES and be in sync. Now this is not truth
> anymore.
>
It's been like this in master since December and the world hasn't exploded
just yet :)
Ross
On Mon, Mar 14, 2016 at 5:46 PM, Burton, Ross wrote:
>
> On 14 March 2016 at 20:43, Otavio Salvador
> wrote:
>>
>> Well, with this it is harder to know if what works on native will work
>> on nativesdk. I don't like this behavior.
>
> Again, native and nativesdk *are* different. Just because a n
On 14 March 2016 at 20:43, Otavio Salvador wrote:
> Well, with this it is harder to know if what works on native will work
> on nativesdk. I don't like this behavior.
>
Again, native and nativesdk *are* different. Just because a native recipe
builds doesn't mean a nativesdk one will, and their
From: Markus Lehtonen
Add 'do_kernel_configme' and 'do_kernel_configcheck' to
SRCTREECOVEREDTASKS of kernel packages. These tasks should not be run
because kernel meta in the srctree is not necessarily up-to-date or
even present which causes build failures and/or invalid kernel config.
Especially
On Mon, Mar 14, 2016 at 5:41 PM, Burton, Ross wrote:
>
> On 14 March 2016 at 20:38, Otavio Salvador
> wrote:
>>
>> This makes nativesdk and native feature set to differ. I don't think
>> it is a good move
>
> It's exactly the right move - nativesdk and native are different. You want
> nativesdk
Backport a couple of fixes from master that allow devtool to work
properly on the kernel.
The following changes since commit 9e7d207e207bf0319b09d403d87d37f24e3dfbee:
base: check for existing prefix when expanding names in PACKAGECONFIG
(2016-03-11 23:14:55 +)
are available in the git re
From: Markus Lehtonen
This makes the correct kernel config to be used when building kernel
from srctree (extrernalsrc). If no kernel config is present in the
builddir 'do_configure' task copies .config from the srctree.
(From OE-Core master rev: 3b516332e038a587685f6e0c14a7f04990bdd6cc)
Signed-
On 14 March 2016 at 20:40, Otavio Salvador wrote:
> To be honest, even though this syncs the Jethro and master on this
> regard (and thus is a good change) I think this needs to be considered
> that doing this way libsdl-native will differ. Native and Native SDK
> binaries will provide different
On 14 March 2016 at 20:38, Otavio Salvador wrote:
> This makes nativesdk and native feature set to differ. I don't think
> it is a good move
>
It's exactly the right move - nativesdk and native are different. You want
nativesdk to match target, but native is unrelated to the distro you've
built
On Mon, Mar 14, 2016 at 5:35 PM, Ross Burton wrote:
> The Xorg libraries use REQUIRED_DISTRO_FEATURES to stop building on
> distributions without the x11 feature but this stops people building native
> tooling that uses libX11, such as libsdl-native.
>
> Signed-off-by: Ross Burton
To be honest,
On Mon, Mar 14, 2016 at 5:33 PM, Burton, Ross wrote:
>
> On 14 March 2016 at 19:12, Otavio Salvador
> wrote:
>>
>> Just for completeness, this is only need on Jethro.
>
>
> Wouldn't a better fix be to backport
> 161bb3409edee21827cf594cc011fe88185f1496?
This makes nativesdk and native feature se
On 14 March 2016 at 18:40, Otavio Salvador wrote:
> The native flavour ought to enable X11 ONLY if it is in DISTRO_FEATURES.
>
Backport of the relevant fix - not workaround - submitted.
Ross
--
___
Openembedded-core mailing list
Openembedded-core@lis
The Xorg libraries use REQUIRED_DISTRO_FEATURES to stop building on
distributions without the x11 feature but this stops people building native
tooling that uses libX11, such as libsdl-native.
Signed-off-by: Ross Burton
---
meta/recipes-graphics/xorg-lib/libxcb.inc | 1 +
meta/recipes-g
On 14 March 2016 at 19:12, Otavio Salvador wrote:
> Just for completeness, this is only need on Jethro.
>
Wouldn't a better fix be to
backport 161bb3409edee21827cf594cc011fe88185f1496?
Ross
--
___
Openembedded-core mailing list
Openembedded-core@list
On Mon, Mar 14, 2016 at 3:46 PM, Otavio Salvador
wrote:
> To allow the use of Framebuffer-only distributions we cannot force the
> existence of X11. This fixes:
>
> ,
> | ERROR: Nothing PROVIDES 'virtual/libx11-native' (but
> | virtual:native:.../meta/recipes-graphics/libsdl/libsdl_1.2.15.
Hi,
Can you please tell me what are the video accelerators supported by yocto for
imx6 freescale ?
* VPU-Video Processing Unit
* IPUv3H-Image Processing Unit version 3H (2 IPUs)
* GPU3Dv4-3D Graphics Processing Unit (OpenGL ES 2.0) version 4
* GPU2Dv2-2D Graphics Processing Unit (BitBlt)
* GPUVG
To allow the use of Framebuffer-only distributions we cannot force the
existence of X11. This fixes:
,
| ERROR: Nothing PROVIDES 'virtual/libx11-native' (but
| virtual:native:.../meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
| DEPENDS on or otherwise requires it)
`
Error catch by
Hello folks,
On Fri, Mar 11, 2016 at 11:58 PM, Trevor Woerner wrote:
> On 03/11/16 18:16, Richard Purdie wrote:
>> On Fri, 2016-03-11 at 16:36 -0500, Trevor Woerner wrote:
>>> On 03/11/16 15:49, Burton, Ross wrote:
Can you verify that
cherry-picking 55ca1fb8f0e81ff739b3c46897e43356d1f76
So, long story short, there were some relatively straightforward patches
recently which led to discovering a weird race condition during startup, and
careful debugging of that convinced me to rework the server-spawning code,
and the server startup code, and some other things.
At which point, I thi
From: Humberto Ibarra
Add the options --codedump and --skip-git-check to the yocto-bsp help and
yocto-bsp usage, since they are currently missing.
[YOCTO #8322]
Signed-off-by: Humberto Ibarra
---
scripts/lib/bsp/help.py | 2 ++
1 file changed, 2 insertions(+)
diff --git a/scripts/lib/bsp/hel
On Mon, Mar 14, 2016 at 12:06 PM, Martin Jansa wrote:
> Blacklisting linux-yocto-tiny and linux-yocto-tiny-kexecboot helped
> with random failures in qemux86* builds
>
> == Tested changes (not included in master yet) - bitbake ==
> 0eacf83 world-image: add extra target
>
> == Tested changes (not i
On Fri, 2016-03-11 at 17:41 +, Richard Purdie wrote:
> On Fri, 2016-03-11 at 14:07 +, Joshua Lock wrote:
> >
> > This series removes RPM 4 and code to support it from OE Core.
> > There
> > are
> > several known issues with using RPM 4 and it seems better to
> > acknowledge it's
> > unsupp
On Fri, 2016-03-11 at 08:47 +, mariano.lo...@linux.intel.com wrote:
> From: Mariano Lopez
>
> ISC DHCP allows remote attackers to cause a denial of
> service (application crash) via an invalid length field
> in a UDP IPv4 packet.
Thanks Mariano,
I've queued this in my fido-next branch.
Reg
Blacklisting linux-yocto-tiny and linux-yocto-tiny-kexecboot helped
with random failures in qemux86* builds
== Tested changes (not included in master yet) - bitbake ==
0eacf83 world-image: add extra target
== Tested changes (not included in master yet) - openembedded-core ==
a780836 base.bbclass:
- Le 14 Mar 16, à 11:15, Martin Jansa martin.ja...@gmail.com a écrit :
> On Sun, Mar 13, 2016 at 05:54:08PM -0400, Trevor Woerner wrote:
>> On 03/13/16 16:53, Paul Eggleton wrote:
>> > On Sun, 13 Mar 2016 16:42:41 Trevor Woerner wrote:
>> >> That's the problem I'm trying to solve: how can I
On Sun, Mar 13, 2016 at 05:54:08PM -0400, Trevor Woerner wrote:
> On 03/13/16 16:53, Paul Eggleton wrote:
> > On Sun, 13 Mar 2016 16:42:41 Trevor Woerner wrote:
> >> That's the problem I'm trying to solve: how can I easily keep all the
> >> information required to reproduce this build, exactly. The
We are having issues on decompressing tarball with xz format and rpm
installation on target.
We have this solution implemented to resolve it internally and would like to
enable it in OE-core in order we wouldn't revisit this issue in future.
Do I need to resend the patch with revised commit messa
On Mon, 2016-03-14 at 15:15 +0800, Rebecca Chang wrote:
> From: Anuj Mittal
>
> Enable lzma compression support in rpm.
Your commit message says what the patch does but not why? Presumably
this change increases the size of the rpm install so what is the
benefit?
Cheers,
Richard
--
___
Hi Robert,
> Subject: [meta-intel][master][jethro][PATCH 1/1] tune-corei7.inc: Fix
> PACKAGE_EXTRA_ARCHS for corei7-32
>
> From: Chang Rebecca Swee Fun
>
> Change the name to core2-32 from core2.
>
> There's no AVAILTUNES with the name core2. Make sure that we specify the
> correct
> TUNE nam
From: Anuj Mittal
Enable lzma compression support in rpm.
[YOCTO #9246]
Signed-off-by: Anuj Mittal
Signed-off-by: Chang Rebecca Swee Fun
---
meta/recipes-devtools/rpm/rpm_5.4.16.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.16.bb
b/
I am just aware that another patch was already merged to fix the issue, please
ignore my patch.
Best Regards,
Zhenhua
From: openembedded-core-boun...@lists.openembedded.org
[mailto:openembedded-core-boun...@lists.openembedded.org] On Behalf Of Zhenhua
Luo
Sent: Monday, March 14, 2016 2:12 PM
44 matches
Mail list logo