On Sun, 2012-07-29 at 06:41 +0100, Paul Eggleton wrote:
> If do_package needs to be re-run and packages are removed/renamed as a
> result, we want the corresponding stale pkgdata files to no longer be
> present; for that we need to ensure all of the old pkgdata files are
> cleaned out prior to crea
On 07/27/2012 02:05 PM, Saul Wold wrote:
On 07/27/2012 04:21 AM, Laurentiu Palcu wrote:
Hi,
This patchset adds relocatable SDK functionality. Instead of a
tarball, the
output of "bitbake meta-toolchain/meta-toolchain-sdk" will be a self
extracting
archive.
The user will then execute the .sh sc
we were assigning local variable to an array coming through
positional arguments. local is a non posix contruct thats
also supported by dash luckily but operates differently in this
case it exapnds the array before assignment. so
local pkgs="$@"
turns into pkgs=locale-base-en-us locale-base-en-gb
>
>
> After RPs fix and Paul's root file system rework I am still seeing
>
> temp/run.do_rootfs.25593: 932: local: locale-base-en-gb: bad variable name
>
OK I think my fault is that I am dash'ing and not bash'ing and
meta/classes/package_rpm.bbclass is full of bashism
On Thu, Jul 26, 2012 at 2:47 PM, Mark Hatle wrote:
> On 7/26/12 4:27 PM, Khem Raj wrote:
>>
>> On Thu, Jul 26, 2012 at 1:53 PM, Phil Blundell wrote:
>>>
>>> On Thu, 2012-07-26 at 21:38 +0100, Richard Purdie wrote:
the other alternative which comes to mind would be so set a variable
On Sun, 2012-07-29 at 14:50 +0200, Martin Jansa wrote:
> On Mon, Jul 23, 2012 at 01:18:29PM +0200, Martin Jansa wrote:
> > On Sun, Jul 22, 2012 at 10:43:53AM +, g...@git.openembedded.org wrote:
> > > Module: openembedded-core.git
> > > Branch: master
> > > Commit: 284a65d55f0ffad0f4f7f32d72da0f
On Mon, Jul 23, 2012 at 01:18:29PM +0200, Martin Jansa wrote:
> On Sun, Jul 22, 2012 at 10:43:53AM +, g...@git.openembedded.org wrote:
> > Module: openembedded-core.git
> > Branch: master
> > Commit: 284a65d55f0ffad0f4f7f32d72da0f9410578643
> > URL:
> > http://git.openembedded.org/?p=openem
* recipe from tarball should be default version
Signed-off-by: Martin Jansa
---
meta/recipes-graphics/drm/libdrm_git.bb |2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/meta/recipes-graphics/drm/libdrm_git.bb
b/meta/recipes-graphics/drm/libdrm_git.bb
index 2b3ef47..4f4d
On Thu, 2012-07-26 at 00:03 +0100, Paul Eggleton wrote:
> Fix up handling of "complementary" package installation (dev, dbg, doc,
> etc.) and introduce a staticdev-pkgs IMAGE_FEATURES feature.
>
> Changes since the brown paper bag patchset that was v3:
>
> * Remove bogus clearing of IMAGE_FEATURE
On Fri, 2012-07-27 at 16:15 +0800, rongqing...@windriver.com wrote:
> From: Roy.Li
>
> [YOCTO #2844]
>
> socat has dependency on readline
>
> Signed-off-by: Roy.Li
> ---
> meta/recipes-connectivity/socat/socat_1.7.2.0.bb |4 ++--
> 1 files changed, 2 insertions(+), 2 deletions(-)
Merged
On Thu, 2012-07-26 at 16:55 -0400, Robert P. J. Day wrote:
> "error_promt" -> "error_prompt" changed in both places
> "subfolers" -> "subfolders" since it's not referenced anyway
>
> Signed-off-by: Robert P. J. Day
Merged to master, thanks.
Richard
___
On Thu, 2012-07-26 at 16:34 -0400, Yao Zhao wrote:
> follow Richard's approach, modify bzip2-native recipe to install bzip2 package
> binaries to STAGING_BINDIR_NATIVE/bzip2-native to avoid problems when other
> package is doing upack to reference bzip2. libbz2.so* still installs to
> STAGING_LIBDI
On Thu, 2012-07-26 at 15:34 +0100, Paul Eggleton wrote:
> The following changes since commit 14b70cd222519e5bccaca955334787f123d9fc54:
>
> base/perlnative/pythonnative/gzipnative: Add a new variable to enable
> easier handling of native path issues (2012-07-26 14:55:35 +0100)
>
> are available
On Thu, 2012-07-26 at 11:21 -0500, Matthew McClintock wrote:
> If we are building from sstate-cache it's possible to be building
> from another folder on another machine, therefore the linker requires
> that a proper --sysroot is passed too it so it can find things like
> libgcc.a and avoid errors
On Thu, 2012-07-26 at 18:17 +0200, Andreas Müller wrote:
> see [1] & [2] for discussion of this patch
>
> [1]
> http://lists.linuxtogo.org/pipermail/openembedded-core/2012-July/026606.html
> [2]
> http://lists.linuxtogo.org/pipermail/openembedded-core/2012-July/026611.html
>
> Signed-off-by: An
On Fri, 2012-07-20 at 16:46 -0700, Christopher Larson wrote:
> From: Christopher Larson
>
> The following changes since commit ef637e417ae1c2dff7fc0ad6cb30989e72ac35ab:
>
> grub-efi-native: remove help2man dependency (2012-07-20 12:32:13 +0100)
>
> are available in the git repository at:
>
>
On Fri, 2012-07-27 at 13:07 +0200, Martin Jansa wrote:
> Signed-off-by: Martin Jansa
> ---
> meta/recipes-connectivity/ppp/ppp_2.4.5.bb |2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
Merged to master, thanks.
Richard
___
Openembedded
On Fri, 2012-07-27 at 20:03 +0800, rongqing...@windriver.com wrote:
> From: Roy.Li
>
> [YOCTO #2847]
>
> Before use usbbuslist, we should check if it is valid.
>
> Signed-off-by: Roy.Li
> ---
> .../usbutils/usbutils/Fix-NULL-pointer-crash.patch | 28
>
> meta/recipes-b
On Fri, 2012-07-27 at 12:58 +0100, Ross Burton wrote:
> From: Damien Lespiau
>
> So let's remove the X dependencies from DEPENDS and white list it in
> xorg-lib-common.inc.
>
> Signed-off-by: Damien Lespiau
> Signed-off-by: Ross Burton
> ---
> meta/recipes-graphics/xorg-lib/libpciaccess_0.13.
On Fri, 2012-07-27 at 12:53 +0100, Ross Burton wrote:
> Forwarding some patches to libdrm. More mesa-related changes later.
>
> The following changes since commit fb53d69d9c726e6a663ea276cc440676e20f8326:
>
> documentation/dev-manual/dev-manual-intro.xml: typo fixed. (2012-07-26
> 18:53:04 +0
On Fri, 2012-07-27 at 16:54 -0500, Peter Seebach wrote:
> This update replaces the half-baked --arch logic with the use
> of $CFLAGS to pick compiler flags, on the grounds that it makes
> a lot more sense for the build system to pick flags than for
> pseudo to try to guess what they should be; this
On Sat, 2012-07-28 at 17:31 +0800, song...@windriver.com wrote:
> From: "Song.Li"
>
> In guile meta/Makefile, what install-data-hook do
> must be run after install-binSCRIPTS.so it's a exec hook, not a data hook.
> If keep these exec-hook in data-hook,when we run make with multi-jobbing ,
> insta
On Sat, 2012-07-28 at 13:10 +0200, Martin Jansa wrote:
> From: Martin Jansa
>
> * this patch depends on http://patchwork.openembedded.org/patch/32085/
>
> Signed-off-by: Martin Jansa
>
> ---
> v2: rebased bluez4 PR bump
>
> ---
> meta/recipes-connectivity/bluez/bluez4_4.101.bb|2 +-
>
On Sat, 2012-07-28 at 22:20 +0200, Martin Jansa wrote:
> Signed-off-by: Martin Jansa
> ---
> meta/recipes-devtools/bison/bison_2.5.bb |4 ++--
> 1 files changed, 2 insertions(+), 2 deletions(-)
Merged to master, thanks.
Richard
___
Openembedded
24 matches
Mail list logo