Re: take 2 WAS (RE: [RFC] make qdisc_restart more readable

2007-05-12 Thread jamal
On Sat, 2007-12-05 at 11:46 +0200, Thomas Graf wrote: > > + struct sk_buff *skb = NULL; > > + > > + if (skb = dev->gso_skb) > > This must have caused a warning Possibly (dont recall) - i will move the assignment to the first line. > and you probably want to inline this function. will do.

Re: take 2 WAS (RE: [RFC] make qdisc_restart more readable

2007-05-12 Thread Thomas Graf
* jamal <[EMAIL PROTECTED]> 2007-05-11 15:29 > diff --git a/net/sched/sch_generic.c b/net/sched/sch_generic.c > + netif_schedule(dev); > + return 0; > +} > + > +static struct sk_buff * > +try_get_tx_pkt(struct net_device *dev, struct Qdisc *q) > +{ > + struct sk_buff *skb = NULL; > + >

RE: take 2 WAS (RE: [RFC] make qdisc_restart more readable

2007-05-11 Thread jamal
On Fri, 2007-11-05 at 15:01 -0700, Waskiewicz Jr, Peter P wrote: > The current requeue calls in qdisc_restart() returns a value of 1 to the > upper layer. Which was not meaningful ;-> i.e qdisc run would break as a result. Note, this is still in conformance with net-2.6 based on a change in the

RE: take 2 WAS (RE: [RFC] make qdisc_restart more readable

2007-05-11 Thread Waskiewicz Jr, Peter P
> Ok, booting fine to me; > if you receive this email, it must have worked. OTOH, if you > didnt receive this it probably failed ;-> (as the presenter > said "if you cant hear me in the far corner please raise your hand"). > > clip away ... +static inline int +handle_dev_requeue(struct sk_buff *sk

take 2 WAS (RE: [RFC] make qdisc_restart more readable

2007-05-11 Thread jamal
On Fri, 2007-11-05 at 11:46 -0700, Waskiewicz Jr, Peter P wrote: > Clippers are standing by. :) Nothing as nice as time off to code away;-> Ok, booting fine to me; if you receive this email, it must have worked. OTOH, if you didnt receive this it probably failed ;-> (as the presenter said "if