Re: rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-05 Thread SF Markus Elfring
> Every time you send a set of patches, I suggested some updates for Linux source files since October 2014. > there are legitimate issues which people raise, There was usual feedback. > and every time they are discussed, The discussion results were mixed between acceptance and usual disagree

Re: rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-05 Thread Julian Calaby
Hi Markus, On Tue, Jan 5, 2016 at 7:29 PM, SF Markus Elfring wrote: >> That said, if you figure out some change that produces significant >> reductions in code or binary size on multiple architectures without >> making things more complicated, less readable or making the code or >> binary size la

Re: rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-05 Thread SF Markus Elfring
> That said, if you figure out some change that produces significant > reductions in code or binary size on multiple architectures without > making things more complicated, less readable or making the code or > binary size larger, then by all means propose it. Are you looking also for "a proof" th

Re: rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-04 Thread Julian Calaby
Hi Markus, On Mon, Jan 4, 2016 at 11:33 PM, SF Markus Elfring wrote: >>> May I resend a consistent patch series for the source file >>> "drivers/net/wireless/rsi/rsi_91x_pkt.c" in the near future? >> >> If you were sending checkpatch.pl fixes that would be easier to deal with > > Does this feedba

Re: [PATCH 1/3] rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-04 Thread David Miller
From: Dan Carpenter Date: Mon, 4 Jan 2016 12:28:57 +0300 > Please stop sending cleanup patches, Markus. Just send fixes. +1 -- To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/m

Re: [PATCH 1/3] rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-04 Thread Dan Carpenter
On Mon, Jan 04, 2016 at 02:17:40PM +0100, Bjørn Mork wrote: > Dan Carpenter writes: > > > Please stop sending cleanup patches, Markus. Just send fixes. > > Thanks for your continued but unwarranted belief in AI. > I always tell people that I am very mechanical and you can rely on me to send p

Re: [PATCH 1/3] rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-04 Thread Bjørn Mork
Dan Carpenter writes: > Please stop sending cleanup patches, Markus. Just send fixes. Thanks for your continued but unwarranted belief in AI. Do you mind if I remind you of https://lkml.org/lkml/2014/11/3/162 ? I am sure there are lots and lots of other examples. There is no reason to believe

Re: rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-04 Thread SF Markus Elfring
>> May I resend a consistent patch series for the source file >> "drivers/net/wireless/rsi/rsi_91x_pkt.c" in the near future? > > If you were sending checkpatch.pl fixes that would be easier to deal with Does this feedback mean that you would accept any more suggestions around source code updates

Re: [PATCH 1/3] rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-04 Thread Dan Carpenter
On Mon, Jan 04, 2016 at 11:44:15AM +0100, SF Markus Elfring wrote: > > Please stop sending cleanup patches, Markus. Just send fixes. > > How often will source code clean-up fix something? > > > May I resend a consistent patch series for the source file > "drivers/net/wireless/rsi/rsi_91x_pkt.c"

Re: [PATCH 1/3] rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-04 Thread SF Markus Elfring
> These patches are labour intensive to review because you can't just do > it in the email client. Thanks for your general interest. > Also you were not able to review it properly yourself and introduced > a bug. I admit that it can happen during my software development that I overlook implemen

Re: [PATCH 1/3] rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-04 Thread Dan Carpenter
Btw, GCC misses a lot of uninitialized variable bugs. I have a Smatch check which sometimes catches the bugs that GCC misses but you should not rely on the tools here. These patches need to be reviewed manually. And the "goto err" before the initialization makes everything more complicated (that

Re: [PATCH 1/3] rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-04 Thread Dan Carpenter
These patches are labour intensive to review because you can't just do it in the email client. Also you were not able to review it properly yourself and introduced a bug. I am often remove initializers but it's normally because I am changing something else which makes it worthwhile. This patch i

[PATCH v2 1/3] rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-02 Thread SF Markus Elfring
From: Markus Elfring Date: Sat, 2 Jan 2016 19:22:36 +0100 Omit explicit initialisation at the beginning for four local variables which are redefined before their first use. Signed-off-by: Markus Elfring --- drivers/net/wireless/rsi/rsi_91x_pkt.c | 8 1 file changed, 4 insertions(+), 4

Re: [PATCH 1/3] rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-02 Thread kbuild test robot
Hi Markus, [auto build test WARNING on wireless-drivers-next/master] [also build test WARNING on v4.4-rc7 next-20151231] [if your patch is applied to the wrong git tree, please drop us a note to help improving the system] url: https://github.com/0day-ci/linux/commits/SF-Markus-Elfring/net-rs

[PATCH 1/3] rsi: Delete unnecessary variable initialisations in rsi_send_mgmt_pkt()

2016-01-02 Thread SF Markus Elfring
From: Markus Elfring Date: Sat, 2 Jan 2016 14:54:30 +0100 Omit explicit initialisation at the beginning for five local variables which are redefined before their first use. Signed-off-by: Markus Elfring --- drivers/net/wireless/rsi/rsi_91x_pkt.c | 10 +- 1 file changed, 5 insertions(+)