From: Evgeniy Polyakov <[EMAIL PROTECTED]>
Date: Mon, 21 Aug 2006 17:01:21 +0400
> Actually I completely do not care about define or enums, it is really
> silly dispute, I just do not want to rewrite bunch of code _again_ and
> then _again_ when someone decide that defines are better.
I totally a
On Mon, 2006-08-21 at 17:01 +0400, Evgeniy Polyakov wrote:
[ #define vs enum { } ]
> And, ugh:
>
> (gdb) list
> 1 enum {
> 2 A = 1,
> 3 B = 2,
> 4 };
> 5
> 6 int main()
> 7 {
> 8 printf("%x\n", A | B);
> 9 }
> (gdb) bre 8
> Br
On Mon, 2006-08-21 at 15:13 +0400, Evgeniy Polyakov wrote:
[...]
> And what is the difference between
As others already pointed out in this thread:
These are not seen by the C compiler.
> #define A 1
> #define B 2
> #define C 4
> and
These are known by the C compiler and thus usable/viewable in
On Mon, Aug 21, 2006 at 02:53:25PM +0200, Bernd Petrovitsch ([EMAIL PROTECTED])
wrote:
> On Mon, 2006-08-21 at 15:13 +0400, Evgeniy Polyakov wrote:
> [...]
> > And what is the difference between
>
> As others already pointed out in this thread:
>
> These are not seen by the C compiler.
> > #defi
On Mon, Aug 21, 2006 at 11:56:37AM +0100, Christoph Hellwig ([EMAIL PROTECTED])
wrote:
> On Fri, Aug 18, 2006 at 03:23:36PM +0400, Evgeniy Polyakov wrote:
> > > defines make some sense for userspace-visible ABIs because then people
> > > can test for features with ifdef. It doesn't make any sense
On Fri, Aug 18, 2006 at 03:23:36PM +0400, Evgeniy Polyakov wrote:
> > defines make some sense for userspace-visible ABIs because then people
> > can test for features with ifdef. It doesn't make any sense for constants
> > that are used purely in-kernel. For those enums make more sense because
>
On Fri, Aug 18, 2006 at 11:46:07AM +0100, Christoph Hellwig ([EMAIL PROTECTED])
wrote:
> > > > +#define KEVENT_READY 0x1
> > > > +#define KEVENT_STORAGE 0x2
> > > > +#define KEVENT_USER0x4
> > >
> > > Please use enums here.
> >
> > I used, but I was sugested to use
> > > +#define KEVENT_READY 0x1
> > > +#define KEVENT_STORAGE 0x2
> > > +#define KEVENT_USER 0x4
> >
> > Please use enums here.
>
> I used, but I was sugested to use define in some previous releases :)
defines make some sense for userspace-visible ABIs because
On Wed, Aug 16, 2006 at 12:45:54PM -0700, David Miller ([EMAIL PROTECTED])
wrote:
> > >>> + for (i=0; ikevent_list); ++i)
> > >> for (i = 0; i < ARRAY_SIZE(u->kevent_list); i++)
> > >
> > > Ugh, no. It reduces readability due to exessive number of spaces.
> >
> > Ihavetoverystronglydisagr
From: Zach Brown <[EMAIL PROTECTED]>
Date: Wed, 16 Aug 2006 11:08:41 -0700
> >>> + for (i=0; ikevent_list); ++i)
> >>for (i = 0; i < ARRAY_SIZE(u->kevent_list); i++)
> >
> > Ugh, no. It reduces readability due to exessive number of spaces.
>
> Ihavetoverystronglydisagree.
Metoo. :-)
Spaces
On Wed, Aug 16, 2006 at 11:08:41AM -0700, Zach Brown ([EMAIL PROTECTED]) wrote:
>
> >>> + for (i=0; ikevent_list); ++i)
> >>for (i = 0; i < ARRAY_SIZE(u->kevent_list); i++)
> >
> > Ugh, no. It reduces readability due to exessive number of spaces.
>
> Ihavetoverystronglydisagree.
W e l l , i
>>> + for (i=0; ikevent_list); ++i)
>> for (i = 0; i < ARRAY_SIZE(u->kevent_list); i++)
>
> Ugh, no. It reduces readability due to exessive number of spaces.
Ihavetoverystronglydisagree.
- z
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [
On Wed, Aug 16, 2006 at 02:45:50PM +0100, Christoph Hellwig ([EMAIL PROTECTED])
wrote:
> > diff --git a/include/linux/kevent.h b/include/linux/kevent.h
> > new file mode 100644
> > index 000..03a
> > --- /dev/null
> > +++ b/include/linux/kevent.h
> > @@ -0,0 +1,310 @@
> > +/*
> > + *
> diff --git a/include/linux/kevent.h b/include/linux/kevent.h
> new file mode 100644
> index 000..03a
> --- /dev/null
> +++ b/include/linux/kevent.h
> @@ -0,0 +1,310 @@
> +/*
> + * kevent.h
Please don't put filenames in the top of file block comments. They're
redudant and as history sh
Core files.
This patch includes core kevent files:
- userspace controlling
- kernelspace interfaces
- initialization
- notification state machines
Signed-off-by: Evgeniy Polyakov <[EMAIL PROTECTED]>
diff --git a/arch/i386/kernel/syscall_table.S b/arch/i386/kernel/syscall_table.S
index dd63d
15 matches
Mail list logo