Re: [patch 1/7] net_device list cleanup: core

2006-07-09 Thread Andrey Savochkin
On Sat, Jul 08, 2006 at 01:48:13AM +0900, YOSHIFUJI Hideaki / [EMAIL PROTECTED](B wrote: > In article <[EMAIL PROTECTED]> (at Fri, 7 Jul 2006 11:54:25 +0400), Andrey > Savochkin <[EMAIL PROTECTED]> says: > > > On Fri, Jul 07, 2006 at 01:34:34PM +0900, YOSHIFUJI Hideaki / [EMAIL > > PROTECTED](B

Re: [patch 1/7] net_device list cleanup: core

2006-07-07 Thread YOSHIFUJI Hideaki / 吉藤英明
In article <[EMAIL PROTECTED]> (at Fri, 7 Jul 2006 11:54:25 +0400), Andrey Savochkin <[EMAIL PROTECTED]> says: > On Fri, Jul 07, 2006 at 01:34:34PM +0900, YOSHIFUJI Hideaki / [EMAIL > PROTECTED](B wrote: > > In article <[EMAIL PROTECTED]> (at Mon, 3 Jul 2006 12:18:51 +0400), Andrey > > Savochki

Re: [patch 1/7] net_device list cleanup: core

2006-07-07 Thread Andrey Savochkin
On Fri, Jul 07, 2006 at 01:34:34PM +0900, YOSHIFUJI Hideaki / [EMAIL PROTECTED](B wrote: > In article <[EMAIL PROTECTED]> (at Mon, 3 Jul 2006 12:18:51 +0400), Andrey > Savochkin <[EMAIL PROTECTED]> says: > > > @@ -3271,22 +3277,22 @@ int unregister_netdevice(struct net_devi > > > > /* And

Re: [patch 1/7] net_device list cleanup: core

2006-07-06 Thread YOSHIFUJI Hideaki / 吉藤英明
In article <[EMAIL PROTECTED]> (at Mon, 3 Jul 2006 12:18:51 +0400), Andrey Savochkin <[EMAIL PROTECTED]> says: > @@ -3271,22 +3277,22 @@ int unregister_netdevice(struct net_devi > > /* And unlink it from device chain. */ > for (dp = &dev_base; (d = *dp) != NULL; dp = &d->next) { Wh

Re: [patch 1/7] net_device list cleanup: core

2006-07-05 Thread Andrey Savochkin
On Tue, Jul 04, 2006 at 08:35:37PM +0400, A.N.Kuznetsov wrote: > > > Different modules want different kinds of lookup. > > So, I'm thinking about something like ilookup5. > > > The next question: would people agree to review a patch doing this for > > net_devices? :) > > One not original sug

Re: [patch 1/7] net_device list cleanup: core

2006-07-04 Thread Alexey Kuznetsov
Hello! > Different modules want different kinds of lookup. > So, I'm thinking about something like ilookup5. > The next question: would people agree to review a patch doing this for > net_devices? :) One not original suggestion, which did not sound nevertheless: to implement netdev_iterate_l

Re: [patch 1/7] net_device list cleanup: core

2006-07-04 Thread Andrey Savochkin
On Tue, Jul 04, 2006 at 10:10:03AM +0100, Christoph Hellwig wrote: > On Tue, Jul 04, 2006 at 11:24:05AM +0400, Andrey Savochkin wrote: > > > Yes, it's a little more work as you need to audit all drivers to see what > > > they are doing and find suitable abstractions but it's a must have that > > >

Re: [patch 1/7] net_device list cleanup: core

2006-07-04 Thread Christoph Hellwig
On Tue, Jul 04, 2006 at 11:24:05AM +0400, Andrey Savochkin wrote: > > Yes, it's a little more work as you need to audit all drivers to see what > > they are doing and find suitable abstractions but it's a must have that > > should have been done a lot earlier. > > Hiding dev_base_head can be done

Re: [patch 1/7] net_device list cleanup: core

2006-07-04 Thread Andrey Savochkin
Christoph, On Mon, Jul 03, 2006 at 06:46:50PM +0100, Christoph Hellwig wrote: > On Mon, Jul 03, 2006 at 12:18:51PM +0400, Andrey Savochkin wrote: > > Cleanup of net_device list use in net_dev core and IP. > > The cleanup consists of > > - converting the to list_head, to make the list double-linke

Re: [patch 1/7] net_device list cleanup: core

2006-07-03 Thread Christoph Hellwig
On Mon, Jul 03, 2006 at 12:18:51PM +0400, Andrey Savochkin wrote: > Cleanup of net_device list use in net_dev core and IP. > The cleanup consists of > - converting the to list_head, to make the list double-linked (thus making >remove operation O(1)), and list walks more readable; > - introduc

[patch 1/7] net_device list cleanup: core

2006-07-03 Thread Andrey Savochkin
Cleanup of net_device list use in net_dev core and IP. The cleanup consists of - converting the to list_head, to make the list double-linked (thus making remove operation O(1)), and list walks more readable; - introducing of for_each_netdev wrapper over list_for_each. Signed-off-by: Andrey Sa