> +struct phy_device *find_phy_device(struct fwnode_handle *fwnode)
We should consider the naming convention. All phylib phy functions
start with phy_. We already have phy_find_first(), so maybe
phy_find_by_fwnode() to follow the pattern?
> +{
> + struct fwnode_handle *fwnode_mdio;
> + st
On Wed, Jul 1, 2020 at 9:13 AM Calvin Johnson
wrote:
>
> The PHYs on a mdiobus are probed and registered using mdiobus_register().
> Later, for connecting these PHYs to MAC, the PHYs registered on the
> mdiobus have to be referenced.
>
> For each MAC node, a property "mdio-handle" is used to refer
The PHYs on a mdiobus are probed and registered using mdiobus_register().
Later, for connecting these PHYs to MAC, the PHYs registered on the
mdiobus have to be referenced.
For each MAC node, a property "mdio-handle" is used to reference the
MDIO bus on which the PHYs are registered. On getting ho