Re: [RFC PATCH v2] ethtool: add IPv6 to the NFC API

2016-01-24 Thread Ben Hutchings
On Fri, 2016-01-22 at 10:54 -0800, Alexander Duyck wrote: > On Fri, Jan 22, 2016 at 10:04 AM, Edward Cree wrote: [...] > > +/** > > + * struct ethtool_usrip6_spec - general flow specification for IPv6 > > + * @ip6src: Source host > > + * @ip6dst: Destination host > > + * @l4_4_bytes: First 4 bytes

Re: [RFC PATCH v2] ethtool: add IPv6 to the NFC API

2016-01-24 Thread Ben Hutchings
On Fri, 2016-01-22 at 18:04 +, Edward Cree wrote: [...] >  #define IP_USER_FLOW0x0d/* spec only (usr_ip4_spec) */ > +#define IP6_USER_FLOW 0x0e/* spec only (usr_ip6_spec; nfc only) */ [...] This should be named IPV6_USER_FLOW for consistency with the other NFC type name

Re: [RFC PATCH v2] ethtool: add IPv6 to the NFC API

2016-01-22 Thread Alexander Duyck
On Fri, Jan 22, 2016 at 10:04 AM, Edward Cree wrote: > Signed-off-by: Edward Cree > --- > changes from v1: > * split out separate spec structs for different flow types > * clarified the proto field in usr_ip6_spec > * changed IP6_USER_FLOW to 0x0e as I noticed there's a gap there > > include/uap

[RFC PATCH v2] ethtool: add IPv6 to the NFC API

2016-01-22 Thread Edward Cree
Signed-off-by: Edward Cree --- changes from v1: * split out separate spec structs for different flow types * clarified the proto field in usr_ip6_spec * changed IP6_USER_FLOW to 0x0e as I noticed there's a gap there include/uapi/linux/ethtool.h | 67