On Sat, 2017-04-08 at 11:28 -0400, Jiri Benc wrote:
> Perhaps the structure should be named just "netlink_ext" or so? It
> seems it'll pick up some non-error related usage, such as the cookies
> here or, in the future, flags indicating how the message should be
> parsed.
Fair point, I'll call it n
On Fri, 7 Apr 2017 21:44:02 +0200, Johannes Berg wrote:
> @@ -67,6 +67,8 @@ struct netlink_ext_err {
> u32 ext_code;
> u32 msg_offset;
> u16 attr;
> + const u8 *cookie;
> + u8 cookie_len;
> };
Perhaps the structure should be named just "netlink_ext" or so? It
seems it'l
From: Johannes Berg
This is for Jamal, it allows the subsystem to return an arbitrary
cookie to identify a new object/operation, perhaps to delete or
cancel it later.
This is actually something we use a lot in wifi too, though I'm
not sure how we could do the backport necessary for that (since
w