On 01/13/2017 02:55 AM, David Laight wrote:
> From: Florian Fainelli
>> Sent: 12 January 2017 22:51
>> On 01/12/2017 01:21 PM, David Miller wrote:
>>> From: Florian Fainelli
>>> Date: Wed, 11 Jan 2017 19:41:16 -0800
>>>
Add a helper function to lookup a device reference given a class name.
From: Florian Fainelli
> Sent: 12 January 2017 22:51
> On 01/12/2017 01:21 PM, David Miller wrote:
> > From: Florian Fainelli
> > Date: Wed, 11 Jan 2017 19:41:16 -0800
> >
> >> Add a helper function to lookup a device reference given a class name.
> >> This is a preliminary patch to remove adhoc c
From: Florian Fainelli
Date: Thu, 12 Jan 2017 14:50:39 -0800
> Well, this is really so that we don't need to cast the arguments passed
> to device_find_child(), which takes a void *data as well.
Aha, I didn't catch that, my bad.
On 01/12/2017 01:21 PM, David Miller wrote:
> From: Florian Fainelli
> Date: Wed, 11 Jan 2017 19:41:16 -0800
>
>> Add a helper function to lookup a device reference given a class name.
>> This is a preliminary patch to remove adhoc code from net/dsa/dsa.c and
>> make it more generic.
>>
>> Signed
From: Florian Fainelli
Date: Wed, 11 Jan 2017 19:41:16 -0800
> Add a helper function to lookup a device reference given a class name.
> This is a preliminary patch to remove adhoc code from net/dsa/dsa.c and
> make it more generic.
>
> Signed-off-by: Florian Fainelli
> ---
> drivers/base/core.
Add a helper function to lookup a device reference given a class name.
This is a preliminary patch to remove adhoc code from net/dsa/dsa.c and
make it more generic.
Signed-off-by: Florian Fainelli
---
drivers/base/core.c| 19 +++
include/linux/device.h | 1 +
2 files changed