Re: [PATCH net-next 1/5] net: phy: marvell: refactor HWMON OOP style

2021-04-13 Thread Marek Behún
On Tue, 13 Apr 2021 16:36:35 +0200 Andrew Lunn wrote: > > +static int marvell_hwmon_read(struct device *dev, enum hwmon_sensor_types > > type, > > + u32 attr, int channel, long *temp) > > { > > struct phy_device *phydev = dev_get_drvdata(dev); > > - int err; > > +

Re: [PATCH net-next 1/5] net: phy: marvell: refactor HWMON OOP style

2021-04-13 Thread Andrew Lunn
> +static int marvell_hwmon_read(struct device *dev, enum hwmon_sensor_types > type, > + u32 attr, int channel, long *temp) > { > struct phy_device *phydev = dev_get_drvdata(dev); > - int err; > + const struct marvell_hwmon_ops *ops = to_marvell_hwmon_ops(p

Re: [PATCH net-next 1/5] net: phy: marvell: refactor HWMON OOP style

2021-04-13 Thread kernel test robot
Hi "Marek, Thank you for the patch! Yet something to improve: [auto build test ERROR on net/master] [also build test ERROR on next-20210413] [cannot apply to net-next/master ipvs/master linus/master v5.12-rc7] [If your patch is applied to the wrong git tree, kindly drop us a note. And when submit

[PATCH net-next 1/5] net: phy: marvell: refactor HWMON OOP style

2021-04-13 Thread Marek Behún
Use a structure of Marvell PHY specific HWMON methods to reduce code duplication. Store a pointer to this structure into the PHY driver's driver_data member. Signed-off-by: Marek Behún --- drivers/net/phy/marvell.c | 371 +- 1 file changed, 127 insertions(+),